Problème pour installer texmacs

Diablo42

Membre confirmé
19 Mars 2005
204
4
44
Bonjour. Après installation de texmacs avec Fink, je le lance depuis le terminal. Tout se déroule bien jusqu'à ce que j'ai ce message d'erreur:

Fatal error: I failed to connect to Xserver in 'x_display_rep::x_display_rep'

Depuis j'ai réinstallé l'application mais j'ai toujours le même problème.
Quelqu'un peut-il m'aider svp?
 

FjRond

Membre émérite
16 Février 2004
797
14
63
Vendée
homepage.mac.com
Diablo42 a dit:
Bonjour. Après installation de texmacs avec Fink, je le lance depuis le terminal. Tout se déroule bien jusqu'à ce que j'ai ce message d'erreur:

Fatal error: I failed to connect to Xserver in 'x_display_rep::x_display_rep'
X11 est-il bien installé ?

Diablo42 a dit:
Depuis j'ai réinstallé l'application mais j'ai toujours le même problème.
Quelqu'un peut-il m'aider svp?
Vous voulez dire que vous avez réinstallé fink ? Un selfupdate suivi d'un update-all auraient suffi. Mais après la réinstallation, il faut lancer un selfupdate-cvs ou selfupdate-rsync suivi d'un update-all. La méthode cvs fonctionnait mal depuis les dernières mises à jour de Panther ; rsync était préférable. Je ne sais pas ce qu'il en est à présent, j'utilise rsync qui fonctionne parfaitement.
Un autre point: il arrive qu'on ait affaire à un package récalcitrant. C'est ainsi que l'installation de zsh par fink a échoué un bon nombre de fois chez moi, jusqu'à ce qu'une petite mise à jour ait eu lieu. Je ne sais pas ce qu'il en est de texmacs, n'utilisant qu'Emacs pour LaTeX.
 

Diablo42

Membre confirmé
19 Mars 2005
204
4
44
Bonjour. Non je n'ai pas désinstallé fink mais bien les binaires de texmacs et je les ai ensuite réinstallé mais sans plus de succès. J'ai toujours le même message d'erreur. Quelqu'un peut-il me dire ce qu'il signifie? Je pensais à un problème au niveau de X11 mais j'ai déjà installé via fink des applications et elles tournent sans problème. Une petite mise à jour de fink serait-elle utile?
Je suppose que tu décris la manière de mettre à jour fink. Je peux pas vérifier, je suis sur un pc actuellement.
Parmis les utilisateurs de texmacs, avez-vous eu des difficultés à faire l'installlation? Avez-vous utilisé les binaires ou les sources? Merci d'avance.
 

Diablo42

Membre confirmé
19 Mars 2005
204
4
44
Bonsoir. J'utilise FinkCommander pour installer mes apllications. Je ne sais pas où se trouve display ni de quoi il s'agit. Peux-tu éclairer ma lanterne stp? Merci.
 

Gallenza

Membre confirmé
30 Mars 2003
467
8
DISPLAY est une variable d'environnement, elle est chargée par le shell à son lancement si elle est présente dans le fichier de conf approprié.
Pour les outils sous X11 un peu complexes, pe une installe de Linux est-elel plus adaptée?
 

geoffrey

Membre d’élite
Club MacG
19 Août 2004
3 065
145
44
kwit.fr
Comme l'a dit Galenza, si tu ne positionne pas la variable d'environement DISPLAY avant de lancer ton appli, rien ne se passera. (tu peux essayer, dans le terminal, avant de lancer ton appli : $ export DISPLAY=<nom_de_ta_machine>:0.0).
 

Eymerich

Membre junior
5 Avril 2003
61
3
53
Paris
Pour info: j'ai installé voici un mois texmacs sous tiger via fink (finkcommander) sans soucis,
ouverture de l'appli sans avoir eu à configurer quoiquecesoit.

J'ai juste désinstallé peu de temps après car fink installe par défaut aussi tetex, or je préfère
la distrib par i-installer. Je n'ai pas eu le temps de voir avec system-tetex qui mime l'install d tetex dans sw.

Courage pour Texmacs.

Quelqu'un l'a essayé sur mac en combinaison avec maxima?


Ey.
 

Luitel

Membre junior
22 Janvier 2005
69
4
49
Eymerich a dit:
Quelqu'un l'a essayé sur mac en combinaison avec maxima?


Ey.
Oui, moi, du reste j'ai surtout installé TeXMacs pour ça :avoir une interface graphique à Maxima digne de ce nom (xmaxima : bof), et ça marche assez bien, sauf pour l'aide de Maxima qui coince irrémédiablement avec TeXMacs. Le problème vient en fait de Maxima lui-même, dans la version qu'on trouve sur Fink, la 5.9.0.0.3 si je me rappelle bien. Une version ultérieure a corrigé ce défaut, mais elle n'est pas encore disponible via Fink.