Probleme Safari-Mac

ArnoQc

Membre enregistré
12 Novembre 2008
4
0
Bonjour,

J’ai un problème d’affichage de mon site Web sur Safari -Mac. Le site fonctionne super bien sur Internet Explorer, Firefox (Mac, Windows) et Safari (Windows), Camino mais pas sur Safari Mac, il y a un décalage.
Est-ce que c’est un problème déjà connu? Est-ce que quelqu’un pourrait m’aider ?
Le site web (www.rglab.org) est géré avec WordPress.

Merci

Arnaud.
 

ArnoQc

Membre enregistré
12 Novembre 2008
4
0
Merci,
je suis aussi sur Safari 3.1.2.
Au bas de la page, il y a une decallage des cadres si tu compares avec Firefox.

Merci

Arnaud..
 

ArnoQc

Membre enregistré
12 Novembre 2008
4
0
Merci,

J'ai mis une impression ecran de Safari et de FireFox pour vous montrer le decalage dans le bas du site Web.

Arnaud.
 

momo-fr

Ancien Aveyronnais
Club MacG
4 Octobre 2004
4 725
1 852
Bordeaux (33)
www.momofr.net
Bizarre, je ne vois rien à part des petits soucis de couleurs avec les visuels et le fond de page.

Maintenant en mettant en vis-à-vis la même page avec les 2 navigateurs tu n'as pas de différence en hauteur, le seul truc c'est que Safari te fais ressortir ta construction car on voit la différence de couleur fond de page, visuels du design.

Couleur background du body : #00101D

Couleur des bords des visuels : #001425

A creuser... ;) :cool:
 

newpain

Membre enregistré
6 Octobre 2005
4
0
45
Même combat, j'ai un site ( http:// www.satras.com ) qui fonctionne :
Sous windows ie 6 / 7 , firefox 2/3, safari 3.2 , opera
sous linux firefox 2/3, konqueror
sous emac G3 os10.4, firefox 2/3 mais pas safari 3.2
alors je pige plus, mes clients utilisent pour la plupart osx avec safari, et je comprends pas d'où vients ces erreurs css, pourquoi ces différences entre même version de safari sur les plateformes différentes ?
 
A

Anonyme

Invité
Même combat, j'ai un site ( http:// www.satras.com ) qui fonctionne :
Sous windows ie 6 / 7 , firefox 2/3, safari 3.2 , opera
sous linux firefox 2/3, konqueror
sous emac G3 os10.4, firefox 2/3 mais pas safari 3.2
alors je pige plus, mes clients utilisent pour la plupart osx avec safari, et je comprends pas d'où vients ces erreurs css, pourquoi ces différences entre même version de safari sur les plateformes différentes ?

Il faudrait peut-être refaire le site en laissant tomber la mise en page par tableaux, utiliser un bon doctype, bref tout refaire en respectant les standards, l'accessibilité et la sémantique. :p

Tes visiteurs y gagneront, et l'entreprise aussi car les robots indexeurs auront plus facile à faire leur travail...

Plus d'info. ;)
 

newpain

Membre enregistré
6 Octobre 2005
4
0
45
ok , mon code est tout pourri mais je vois pas pourquoi un site sous safari 3.2 windows fonctionne et pas safari 3.2 sous mac.
Je répète : Comment ce fait il qu'il y ai des différences d'affichage avec un même navigateur estampillé du même numéro de version sur 2 plateformes.
J'ai pourtant opera window et linux
firefox linux win et mac, et des autres navigateur, il n'y a que la version osx mac ppc de safari qui fonctionne pas bien ?

Pour ce qui est du code, y a rien a dire, le tableau c'est un choix pour ce projet, les feuilles de style css c'est pour d'autres projets (plus gros) , il y a du code un peu a la barbare pour une raison très simple, il s'agit d'un seul fichier index.php (lors des modifs de fichiers, j'ai pas a chercher la page, tout est centraliser) faisant appel aux image et flash, il y a un javascript pour les l'aggrandissement des images et quelques détections de navigateur qui affiche soit du gif soit du png .. . et pas de doctype pour le moment en raison de conflit entre les css (affichage 100% dans la hauteur pour les images de fond, et le fond transparent des flash) suivant le navigateur, ( a cause de ie ), je verrait plus tard le code pour ceci.

C'est galère, que ce soit du tableau ou du CSS, il y a toujours un navigateur qui affiche des différences.
 

ArnoQc

Membre enregistré
12 Novembre 2008
4
0
Bonjour,

Merci pour les reponses.
Cependant, mon site web a ete fait par des "professionnels".
En leur signalant cette erreur, ils m'ont dit qu"il ne pouvait rien faire car cela marchait parfaitement sur Safari Windows, Firefox (mac-Windows), IE.
Est-ce que cela vient des tableaux ?

Merci

Arnaud.
 

momo-fr

Ancien Aveyronnais
Club MacG
4 Octobre 2004
4 725
1 852
Bordeaux (33)
www.momofr.net
Est-ce que cela vient des tableaux ?
Non, ça vient du fait que Safari sur Mac affiche avec un gamma différent du PC (c'est un réglage système et tu n'y peux rien), du coup tout est un peu plus clair et les défauts ce voit bien mieux... Il faut impérativement vérifier les valeurs des couleurs, éviter les profils couleur pour rester dans le sRGB... bref ça marche avec quelques règles à suivre de près. :siffle: :cool:
 

fredmac75

Membre expert
Club MacG
14 Juillet 2003
1 416
127
50
Le Mans
www.km-spirit.com
... Cependant, mon site web a ete fait par des "professionnels"...

Si je devais rendre un site comme celui-ci à mes clients, je me ferais souffler dans les bronches, et a raison. On ne peux décemment se dire professionnel et rendre un travail de cette qualité.

A décharge, le budget est souvent en cause. A vouloir du pas cher on obtient du vite fait. C'est ce que l'on appelle le "Fast&Cheap" (vite fait et bon marché).

En leur signalant cette erreur, ils m'ont dit qu"il ne pouvait rien faire car cela marchait parfaitement sur Safari Windows, Firefox (mac-Windows), IE.

Ibidem.


Est-ce que cela vient des tableaux ?
Cela est tout à fait possible, sachant que l'imbrication des tableaux peut faire perdre les pédales à certains navigateurs.
;)
 

obi wan

Membre expert
Club MacG
19 Mars 2003
1 634
86
Non, ça vient du fait que Safari sur Mac affiche avec un gamma différent du PC (c'est un réglage système et tu n'y peux rien), du coup tout est un peu plus clair et les défauts ce voit bien mieux... Il faut impérativement vérifier les valeurs des couleurs, éviter les profils couleur pour rester dans le sRGB... bref ça marche avec quelques règles à suivre de près. :siffle: :cool:

Et quand on est obligé de bosser avec des images qui ont un profil à la base (c'est mon cas alors je le dis hein :D), le seul moyen de régler ces soucis de gamma c'est de convertir en profil colormatch RGB dans photoshop après avoir aplati avant de faire un export pour le web de l'image en question.

fredMac a dit:
Lorsque les bases du codage ne sont pas là, il ne faut pas s'attendre à ce que tous fonctionne.
Hihi, et encore meme quand elles y sont les bases c'est pas toujours gagné :D
 
  • J’aime
Réactions: fredmac75

newpain

Membre enregistré
6 Octobre 2005
4
0
45
je viens de trouver mon problème qui est pour le moins encore une fois lié parce que je voulais optimisé mon site pour internet explorien avec une police geneva par défaut, le mac a bien cette police mais en visuel il y a une minuscule augmentation de taille de cette police sur les navigateurs safari sous osX.
Il y a aussi ces vides & espace   que l'on mets des fois ou sont automatiquement mis par nos logiciels de création web (genre dreamweaver) qui sans cela internet explorer mets en l'air la mise en page et sur les autres navigateurs l'affiche avec la police par default (en geneva en l'occurence qui a ce petit probleme de dimension) et c'est mon probleme qui est lié a mon site et non pas le navigateur safari.

Tout ça pour dire : A mort internet ex...reur
 

fredmac75

Membre expert
Club MacG
14 Juillet 2003
1 416
127
50
Le Mans
www.km-spirit.com
Voici un outil fort sympathique, qu'il m'arrive d'utiliser et qui permet d'apprécier ce genre de problématique (différence de hauteur d'une typo à l'autre et pour un corps identique). Attention cette problématique est à deux dimensions ; hauteur et largeur.

typetester

Cependant, la solution idéale (dans le sens de pérenne) passe par un design extensible à minima (taille de la typo x2 ou x3).
;)
 

obi wan

Membre expert
Club MacG
19 Mars 2003
1 634
86
haaa les typos :D même en verdana, l'interlignage et l'interlettrage diffèrent d'un navigateur à l'autre... même la largeur des lettres est différente.

@newpain >> eclipse m'a jamais mis de   que je ne lui demandais pas :D ;)