Publipostage Word 2011

sativenarey

Membre confirmé
Bonjour,

Je transforme ma collectivité locale, en passant sous Mac, et en abandonnant Windows... je rencontre quelques Bugs, mais celui-ci me laisse perplexe :



J'ai 6 postes, clients Mac OSX (Montain Lion Snow et Leopard) avec Word et XL 2011, qui font des publipostages (lettres) en prenant source dans une BDD de fichiers XL 97-2007 (initialement créés avec windows XP) dans un Mac Mini Snow leopard Server .

Pour mes clients Leopard et Snow Leopard pas de soucis.

Pour 1 clients Mountain Lions, j'utilise Word 2008 pas de soucis

J'ai 4 Nouvelles machine dans mon parc, pour ces 4 clients riches, Mountain Lions sur Imac et Mac Book Pro qui ont les mêmes configuration Word 2001 j'obtiens pour 2 d'entre eux (un Mac book et IMac, un message d'erreur d'interprétation du fichier XL :

C'est à dire :

Ouverture de Word 2011
creation dun document
Outil> gestion de publipostage
Choix > lettre
Choix > source de données

Message-1 "Convertir le fichier, avec une liste de format : texte unicode, word setting (14), classeur XL 3.x ...

Aucun des formats ne permet d'ouvrir le fichiers, pour chaque choix de format, la réponse est le même : "Ce fichier doit être ouvert avec un convertisseur de fichier XL, il contient peut être un virus... ...cliquez sur OK si souhaitez l'ouvrir "
je clique sur OK

Message-1 "le fichier n'a pu être ouvert.

Et dans ma boite de dialogue de source de publi postage publipostage > un fichier vide

Et sur le 2 autres, (un Mac Book et 1 Imac) t < le publipostage fonctionne bien.

Avez-vous déjà eu ce type de problèmes ?

Si vous avez une idée... je suis preneur !

Merci à vous
 

Aliboron

Chercheur de son
Club iGen
1 Janvier 2008
14 693
1 187
Toulouse.cong
faq.office.macintosh.free.fr
peut être en ouvrant le fichier avec excel avant de faire le publipostage ?
Non au contraire, je crois bien qu'il faut impérativement que le classeur soit fermé (ce que semble mettre en évidence le test fait par sativenarey.

Il semblerait plutôt que le cas de figure corresponde à un souci lié à l'installation dans Mountain Lion qui fait une impasse dans la création d'un dossier important. Il semblerait qu'on puisse facilement le résoudre en allant créer soi-même un dossier vide, nommé "Microsoft", dans ~/Bibliothèque/Preferences (attention, pour une raison mystérieuse, Apple a rendu le dossier ~/Bibliothèque invisible dans Lion et Mountain Lion, il faut donc y aller en passant par le menu "Aller" du Finder tout en tenant la touche "Option" enfoncée). Tiens nous au courant...
 

sativenarey

Membre confirmé
Bonjour,

Je suis allé dans bibliothèque, et j'ai fais un dossier vide "Microsoft".

Mais j'ai toujours le même problème

Voici ce que j'éssaie : Comme les sources son des fichier Xl 97-2007 initialement créés sous Vista downgrader XP sur un serveur Windows.

Je vais créé un fichier nouveau dans XL 2011, copier et coller les infos de l'ancien sur le nouveau.
et enregistrer avec un nouveau nom, dans l m^m répertoire, car c'est peut un problème de USERS.


... ça marche pas ...

résumons :

J'ai re-créer une source sur le serveur > marche pas
J'ai recréé une source en local > marche pas
J'ai ré-installer office > marche pas
j'ai testé différents fichiers qui fonctionne sur l'autre client> marche pas


Chaque une fenêtre s'ouvre et me propose un menu de convertisseur de fichier avec une liste de choix.

rtf, texte brut excel 3x, 4x,5x, excel binaire, excel windows, html, etc...

Quelque soit le choix ; le message d'erreur :
"Ce fichier doit être ouvert avec un convertisseur de texte Classeur Excel, ce qui peut constituer un risque de sécurité si le fichier que vous avez ouvert contient un virus. Choisissez OK pour ouvrir uniquement si vous êtes sûr qu'il provient d'une source sécurisé"

Je clique et (wait for it )

Message d'erreur :

"Erreur lors de l'ouverture du fichier". :(


là je dois dire... que je ne comprend rien, mais c'est sans doute tout simple...
 
Dernière édition:

Aliboron

Chercheur de son
Club iGen
1 Janvier 2008
14 693
1 187
Toulouse.cong
faq.office.macintosh.free.fr
Je suis allé dans bibliothèque, et j'ai fais un dossier vide "Microsoft".
Est-ce que c'est bien dans ~/Bibliothèque (c'est à dire celle du compte utilisateur, qu'on atteint en passant par le menu "Aller" du Finder tout en tenant la touche "Option" enfoncée) que tu as créé ce dossier ?

Sinon, je ne vois pas trop et surtout ne peux pas tester, n'ayant pas Mountain Lion. Mais c'est nécessairement un problème quelque part dans ton installation, le publipostage fonctionne sous Mountain Lion.

Dès lors qu'il te demande de choisir un format, c'est que ça cloche, qu'il ne reconnaît pas le classeur Excel. Le message d'alerte n'apporte pas d'information supplémentaire, tu devrais juste avoir un message pour t'informer qu'il passe par le convertisseur...
 

sativenarey

Membre confirmé
Est-ce que c'est bien dans ~/Bibliothèque (c'est à dire celle du compte utilisateur, qu'on atteint en passant par le menu "Aller" du Finder tout en tenant la touche "Option" enfoncée) que tu as créé ce dossier ?


> Oui j'ai vérifié.





Sinon, je ne vois pas trop et surtout ne peux pas tester, n'ayant pas Mountain Lion. Mais c'est nécessairement un problème quelque part dans ton installation, le publipostage fonctionne sous Mountain Lion.


Le pire c'est que sur mes 3 postes en Lion, pour 1 ça fonctionne et pas pour les 3 autres... alors que ce sont les mêmes installations...


Dès lors qu'il te demande de choisir un format, c'est que ça cloche, qu'il ne reconnaît pas le classeur Excel. Le message d'alerte n'apporte pas d'information supplémentaire, tu devrais juste avoir un message pour t'informer qu'il passe par le convertisseur...

bah oui, sur le poste qui fonctionne c'est ça...


Une chance que je sois chauve, ça m'évite de m'arracher les cheveux...

---------- Nouveau message ajouté à 16h37 ---------- Le message précédent a été envoyé à 15h40 ----------

C'est dans Preferences
comptes utilisateurs
options
Rattaché l'utilisateur au réseau > selectionner le domaine.local
autoriser le SSL
et l'utilisateur du poste peut utiliser une source sur le serveur.



Pfff

5 jours de galère pour ça ...
 
Dernière édition:
  • J’aime
Réactions: Aliboron