Rafraichissement pages WEB

paul.s

Nouveau membre
7 Novembre 2013
4
0
31
Bonjour à tous,

j'ai un petit problème de rafraichissement sur safari

j'utilise actuellement MAMP, coda2 et safari comme navigateur ainsi que Postgresql.

Quand je veux afficher mon site, il s'affiche nickel et la connection à ma base de données se fait bien.

Mais quand je change quelque chose dans mon code et que je rafraichis ma page web celle-ci ne se rafraichis pas dessuite. (Parfois si...) Il faut que j'attende quelques minutes et en rafraichissant à ce moment cela marche.

Je pensais que c'étais du au cache mais ce n'est pas cela..

si quelqu'un à une idée pour régler cela je suis preneur ! =)

Merci à tous !
 

Vermilion

Membre confirmé
20 Octobre 2013
190
7
Paris
Hello,

Un hypothèse un peu bête, est-ce que Coda 2 sauvegarde bien le fichier quand tu le lui demandes ? Tu peux faire un test avec un autre éditeur et voir si le problème se pose toujours.

Aussi, comment est-ce que tu appelles ta page modifiée ? Une requête sur localhost avec Safari ?

Pour les problème de cache, ça m'est déjà arrivé d'avoir ce genre de problèmes même après l'avoir vidé (sous Safari). Tu peux essayer avec Chrome ou Firefox, et voir si le problème est toujours d'actualité.

Bref, quelques pistes qui me viennent à l'esprit là comme ça... :up:
 

paul.s

Nouveau membre
7 Novembre 2013
4
0
31
merci de ta réponse !

j'ai déjà tester sous aptana ou autre et toujours le même résultat..

je viens de me rendre compte que quand je code quand html le refresh de la page se passe instantanément mais quand j'intègre du PHP il faut attendre quelques minutes avant d'avoir la modification du code
 

Vermilion

Membre confirmé
20 Octobre 2013
190
7
Paris
je viens de me rendre compte que quand je code quand html le refresh de la page se passe instantanément mais quand j'intègre du PHP il faut attendre quelques minutes avant d'avoir la modification du code

Alors peut être un cache du côté des modules Apache (en rapport avec PHP) ? Regarde dans la liste des modules chargés par Apache :)

Je dis peut être des bêtises, je n'utilise pas les techno MAMP et PHP.
 

paul.s

Nouveau membre
7 Novembre 2013
4
0
31
Le top ton lien !

pour ceux qui recherchent j'ai changé dans Mamp --> Préférences --> PHP --> Passer à la version 5.2.17 !

et la comme par miracle ! le refresh est automatique !

Merci beaucoup pour ton lien Vermilion j'avais eu beau rechercher sur le net j'avais pas trouvé.
 

Vermilion

Membre confirmé
20 Octobre 2013
190
7
Paris
Certes...

paul.s, la meilleure solution à ton problème n'est pas de rétrograder de version mais de désactiver le module lié à la mise en cache de PHP, afin de conserver ta version actuelle.

Changer de version peut t'amener d'autres soucis en rapport avec du code qui ne serait potentiellement plus compatible.

Désactivation de XCache : http://top-frog.com/2011/03/14/beware-mamps-default-caching-settings/
 
Dernière édition: