récupérer partition Bootcamp

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
Je veux récupérer la partition BootCamp qui est sur l'iMac, avec son contenu WIn10 et fichiers, tout ça fonctionne, pour faire une partition Windows 10 sur le MBP. Si j'en fais une image disque depuis l'iMac qui ne pose pas de problème (mais avec une version antérieure de Winclone) et qu'ensuite je la récupère avec Winclone 8, ça doit, être possible, non ?
Ce n'est pas clair, est-ce que ta version de Windows dans cet iMac est vraiment fonctionnelle ? Si oui, alors Winclone pourra en faire la sauvegarde à condition d'utiliser un disque dur USB, car de base ta partition de Windows est de 168 Go. Il te faut donc à minima un disque dur USB de 256 Go.

Eh non, un fichier image depuis macOS ne fonctionnera pas. Le principe de base de Winclone est de faire un clonage sous forme d'un fichier image ayant pour extension .winclone. Sur un autre Mac, il faut impérativement faire une réservation d'un taille strictement égale au moment de la sauvegarde. Dans ton cas de figure 168 Go, mais, mais, par sécurité il faut ajouter 1 Go de plus, soit 169 Go (ce que conseille l'éditeur). Lors de la réservation de Windows, il faudra donc faire un formatage impérativement en MS-DOS (FAT32), puis Winclone lors de la restauration fera à la volée la conversion dans le format NTFS. Attention, en pensant que ça sera la même chose, il ne faut jamais faire une réservation de la partition en NTFS, ce sera un échec cuisant.
 
Dernière édition:

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
Ce n'est pas clair, est-ce que ta version de Windows dans cet iMac est vraiment fonctionnelle ?
oui, aucun problème.
Si oui, alors Winclone pourra en faire la sauvegarde à condition d'utiliser un disque dur USB, car de base ta partition de Windows est de 168 Go. Il te faut donc à minima un disque dur USB de 256 Go.
j'ai installé Winclone 7 sur l'iMac en suivant ton lien #19. la partition Boot Camp sur l'iMac fait 98 Go, j'ai réussi à en faire la sauvegarde sur un HD externe USB.

Eh non, un fichier image depuis macOS ne fonctionnera pas. Le principe de base de Winclone est de faire un clonage sous forme d'un fichier image ayant pour extension .winclone.
Donc ça, c'est fait. j'ai l'image disque .winclone de la partition Boot Camp de l'iMac.

Sur un autre Mac, il faut impérativement faire une réservation d'un taille strictement égale au moment de la sauvegarde. Dans ton cas de figure 168 Go, mais, mais, par sécurité il faut ajouter 1 Go de plus, soit 169 Go (ce que conseille l'éditeur). Lors de la réservation de Windows, il faudra donc faire un formatage impérativement en MS-DOS (FAT32), puis Winclone lors de la restauration fera à la volée la conversion dans le format NTFS. Attention, en pensant que ça sera la même chose, il ne faut jamais faire une réservation de la partition en NTFS, ce sera un échec cuisant.
OK donc je suis ta procédure pour le nouveau SSD de mon MBP comme en #10 en réservant au moins 99 Go (et d'ailleurs pourquoi pas 100 Go ou plus ?) au format FAT32 et ça devrait être bon.
à suivre donc.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
OK donc je suis ta procédure pour le nouveau SSD de mon MBP comme en #10 en réservant au moins 99 Go (et d'ailleurs pourquoi pas 100 Go ou plus ?) au format FAT32 et ça devrait être bon.
à suivre donc.
Non, non, et non, dans ta réponse #32, la taille de ta partition Windows est de 168 Go, donc il te faudra impérativement redéfinir cette même taille en mettant 1 Go de plus, soit 169 GO, par sécurité ! Ne tiens pas compte de la taille de sauvegarde du fichier .winclone, il est compressé, alors tiens-en toi à ce que préconise l'éditeur, car ça fait un moment que tu tournes en rond.
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
Non, non, et non, dans ta réponse #32, la taille de ta partition Windows est de 168 Go, donc il te faudra impérativement redéfinir cette même taille en mettant 1 Go de plus, soit 169 GO, par sécurité ! Ne tiens pas compte de la taille de sauvegarde du fichier .winclone, il est compressé, alors tiens-en toi à ce que préconise l'éditeur, car ça fait un moment que tu tournes en rond.
Mais il ne s'agit pas de la même partition ! Sur mon MBP la partition qui ne fonctionne plus fait bien 168 Go, mais celle dont j'ai fait la sauvegarde avec Winclone est celle de mon iMac, et celle-ci est plus petite, elle ne fait que 98 Go. C'est cette partition-là que je veux placer dans le nouveau SSD de mon MBP, puisque celle d'origine ne fonctionne plus ! D'autre part, est-ce important de ne prévoir qu' 1 Go de plus ? qu'est-ce qui empêche de prévoir une partition beaucoup plus grande ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
Je suis resté focalisé sur ta réponse #32 ensuite je me suis perdu. :shy:
C'est cette partition-là que je veux placer dans le nouveau SSD de mon MBP, puisque celle d'origine ne fonctionne plus ! D'autre part, est-ce important de ne prévoir qu' 1 Go de plus ? qu'est-ce qui empêche de prévoir une partition beaucoup plus grande ?
Pour le coup, tu ne devrais pas avoir de problème. Eh oui, il faut impérativement par sécurité ajouter 1 Go, soit 99 Go, mais par contre libre à toi de réserver une taille bien supérieure, voire 500 Go, le tout est que cette partition ne soit pas inférieure à 98 Go.
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
OK merci. Dans ton petit tuto #10, tu conseilles, pour récupérer mes applications, de les réinstaller manuellement ce qui peut s'avérer fastidieux, et qui nécessite de retrouver les fichiers d'installation et les clés d'activation éventuelles. Peux-tu expliquer pour quelle raison tu me déconseilles Time Machine ? il ne permet pas de récupérer automatiquement les applications ? et Assistant Migration non-plus ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
Peux-tu expliquer pour quelle raison tu me déconseilles Time Machine ? il ne permet pas de récupérer automatiquement les applications ? et Assistant Migration non-plus ?
Libre à toi de le faire, mais il faudra en mesurer les éventuelles conséquences. J'entends par là que ce serait ballot de corrompre une installation propre dans un SSD tout neuf en lui réinjectant via Time Machine ou Assistant migration des fichiers qui peuvent être corrompus ! Bien sûr que c'est plus long, mais au moins il n'y aura pas de dysfonctionnements et la première chose à faire après installation de tous tes logiciels et de faire de nouvelles sauvegardes en repartant de zéro.
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
Bon, j'ai avancé : clé de démarrage Mojave, partition Boot Camp sauvegardée avec Winclone, installation du SSD 500 Go, réinstallation de Mac OS Mojave, partition 200 Go pour Windows en MAS DOS (FAT), puis... impossible de restaurer la partition Windows : message : désactiver SIP, en redémarrant avec recovery depuis le terminal, taper csrutil disable... et là : command not found. je suis allé voir ici mais maintenant je bloque...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
message : désactiver SIP, en redémarrant avec recovery depuis le terminal, taper csrutil disable... et là : command not found.
Et pourtant en démarrant depuis la partition de récupération, c'est bien cette commande...
Bloc de code:
csrutil disable
...si tu tapes cette commande...
Bloc de code:
csrutil status
...quel est le résultat ? A chaque fois, dans tes réponses il faut faire un Copier/Coller du résultat et les mettre entre des balises </> Bloc de code. Ne pas oublier que pour cela soit effectif, qu'il faut redémarrer. Si tu as une erreur...
Bloc de code:
command not found
...c'est que tu as fait une erreur de frappe.
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
Si tu as une erreur...
Bloc de code:
command not found
...c'est que tu as fait une erreur de frappe.
sauf qu'ici, https://apple.stackovernet.com/fr/q/54459, il est dit : "Si vous voyez un globe animé après avoir appuyé sur cmdR votre Mac n'a probablement pas de récupération HD." Or en effet, je vois le globe au démarrage et je n'ai pas de récupération locale. Pourtant je l'avais avant, je le voyais en tenant la touche alt au démarrage, ce n'est plus le cas. Comment récupérer cette récupération ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
sauf qu'ici, https://apple.stackovernet.com/fr/q/54459, il est dit : "Si vous voyez un globe animé après avoir appuyé sur cmdR votre Mac n'a probablement pas de récupération HD." Or en effet, je vois le globe au démarrage et je n'ai pas de récupération locale. Pourtant je l'avais avant, je le voyais en tenant la touche alt au démarrage, ce n'est plus le cas. Comment récupérer cette récupération ?
Sauf que tu n'as compris que cette option de démarrage alt+cmd+R affichant un globe tournant indique une connexion sur les serveurs d'Apple et est là pour pallier à l'absence de la partition de récupération. Au final, la connexion sur les serveurs d'Apple créera exactement la même chose que la partition de récupération et la commande via le Terminal...
Bloc de code:
csrutil disable
...fera la même chose. Eh non, maintenant le maintien de la touche alt ne peut faire qu'apparaître que la présence de supports USB comme un disque ou une clé USB.

Officiellement chez Apple...
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
Sauf que tu n'as compris que cette option de démarrage alt+cmd+R affichant un globe tournant indique une connexion sur les serveurs d'Apple et est là pour pallier à l'absence de la partition de récupération.
si j'ai très bien compris. j'ai fait exactement ce qui était indiqué et j'ai bien lu l'article de Stackovernet qui dit que si le globe apparaît, c'est bien qu'il n'y a pas de récup en local. ça confirme ce que je constate. Mais ça laisse entendre qu'en effet la connexion aux serveurs d'Apple devrait pallier. Or, il semble que non.
Au final, la connexion sur les serveurs d'Apple créera exactement la même chose que la partition de récupération et la commande via le Terminal...

Bloc de code:
csrutil disable
...fera la même chose.
alors pourquoi ça ne le fait pas ?
Eh non, maintenant le maintien de la touche alt ne peut faire qu'apparaître que la présence de supports USB comme un disque ou une clé USB.
mais oui je sais bien, ça fait des années que je fais ça régulièrement pour démarrer sous Windows. Ce que je disais c'est qu'en faisant alt au démarrage, avant (sous High Sierra) je voyais la partition recovery, et là je ne la vois plus. mais pouir revenir à mon problème : comment désactiver SIP ? en démarrant depuis une clé de démarrage ?
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
Allez, j'arrête de répondre ici, car on joue au ping-pong avec ton autre message !
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
OK parfait. En tout cas merci beaucoup pour ta patience et tes précieux conseils sur ce sujet.
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
En fait, c'est pas fini !!
j'ai eu un message en fin d'installation de Winclone me disant que ça avait bien fonctionné, mais que je n'avais pas de driver pour le SSD et donc que Windows ne démarrera pas. Winclone ne conseille d'installer ce driver depuis l'assistant Boot Camp, mais ne trouve pas ce driver dans l'assistant... voir PJ
 

Fichiers joints

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
Ton Mac à une puce T2 qui est une protection empêchant tout démarrage depuis un support externe... https://support.apple.com/fr-fr/HT208330 ...il te faut donc désactiver temporairement ces options...

Puce T2.png

...il n'y a pas besoin d'installer un driver quelconque pour ton SSD.
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
je ne crois pas que mon Mac ait une puce T2, c'est un MBP de 2012.
 

Fichiers joints

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
Le temps de téléchargement de ce fameux pilote était prévu pour 543 minutes (!) j'ai donc arrêté au bout de 2 heures j'en avais marre d'attendre. j'ai redémarré sur la partition Windows provenant de mon iMac et récupérée depuis Winclone... et ça marche !
Un grand ouf ! de soulagement, j'ai enfin un MacBook Pro opérationnel sous Mojave et Windows 10.
Merci encore pour ton assistance pratiquement en temps réel depuis le début de ce sujet (10 mai !)
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
34 744
4 034
Je suis très étonné du message d'erreur de la copie écran de Winclone dans ta réponse #55 ! Pourquoi un tel message pour un SSD en indiquant la sécurité T2, c'est pour moi un grand mystère ?
 

bibiche

Membre confirmé
9 Juillet 2004
367
5
60
oui c'est aussi un mystère pour moi...
autre mystère : après 4 heures de téléchargement du "logiciel de prise en charge de WIndows", pour la troisième tentative, j'obtiens un message d'erreur (PJ). Je précise que je n'ai pas de problème de connexion, même si je n'ai qu'à peine 3 Mbps.
 

Fichiers joints