Selon ClarisWork 0,08 + 0,08 = 1,55 !!

iVan

Membre confirmé
3 Février 2001
120
0
J'y perds mon latin.
Dans la feuille de calcul de Clariswork ou Applework l'addition de 1,576 et 1,875 = 3,451. C'est bon.
S'agissant d'une TVA en EUR il ne faut que 2 décimales (calculée automatiquement au moyen d'une petite formule enfantine). Solution: dans Menu Format, choisir Numérique et introduire le chiffre 2 dans la case de "précision"... soit 2 chiffres après la virgule.
Résultat ?
1,576 devient 1,58... c'est bon
1,875 devient 1,88... c'est bon
Et l'addition ?
1,58 + 1,88 selon Clariswork = 3,45 !
On devine pourquoi: Claris additionne en réalité encore et toujours 1,576 et 1,875 même si 1,58 et 1,88 sont affichés dans leur case respective... Evidemment, avec une feuille de calcul bourrée de chiffres et d'additions on ne s'apperçoit pas que le résultat est faux... puisqu'on fait confiance à Claris.

Alors, je pose la question:
comment obliger Claris a faire 1,58 +1,88 = 3,46 ??
Ca fait des heures que je cherche
 

-anonyme-

Légende
26 Février 2001
66 286
2 667
Il faut utiliser la formule =ARRONDI(Référence_Cellule;2), pour convertir 1,576 en 1,58 & 1,875 en 1,88.
Le 2 détermine ton nombre de décimales.
Ensuite la somme des 2 donne 3,46.

Normalement ça colle.

Cordialement
 

al02

Membre d’élite
15 Octobre 2000
2 032
429
Bonjour,

Voici ce que j'ai essayé pour vous :

Sur Appleworks 5.04 :

Nota : les valeurs entre crochets correspondent au contenu des cellules.

en A1 : [1,576] en B1: [=ARRONDI(A1;2)]

en A2 : [1,875] en B2: [=ARRONDI(A2;2)]

en A3 : [=SOMME(A1..A2)] en B3 : [=SOMME(B1..B2)]

le résultat en B3 sera : 3,46

Cordialement,
al02
 

LCT

Membre émérite
14 Juillet 2001
644
0
À ce niveau très simple, aucun tableur ne fait d’erreur.
Vous pouvez certainement arrondir vos chiffres, comme le suggèrent Thierry44 et alo2.
Mais attention, votre résultat sera faux si vous avez de nombreuses cases à calculer.
Le mieux, pour éviter cela, est de n’arrondir que le résultat.
 

iVan

Membre confirmé
3 Février 2001
120
0
Les 3 réponses se complètent toutes, super. Cela fonctionne correctement avec la formule indiquée. Les cases à arrondir sont peu nombreuses puisqu'il s'agit de la TVA (à arrondir) uniquement.
Merci à vous tous