10.13 High Sierra Session Admin : toutes applications inactives

Fol

Membre junior
4 Juillet 2018
26
2
51
Bonjour,

Je suis nouveau et ici parce que je rencontre un problème sur mon Mac.
Je me présente:
iMac 21,5" - fin 2013 - High Sierra 10.13.5 (17F77)
Process : 2,7 Ghz - Intel Core i5
Mém. : 8 Go 1600 MHz DDR3
DD : 500G SSD avec 120G disponibles
Une session Admin et deux sessions utilisateurs.
Sauvegarde Time Machine sur DD externe.

SYMPTOMES:
Les deux sessions utilisateurs fonctionnent correctement.

La session Admin s'ouvre normalement mais absolument aucune application (Dock, dashboard, ...) ni actions ne sont quasiment possibles. Ex. : cliquer sur le menu "Pomme" / Préférences système ne donne rien. Pour chaque App, le même message apparaît : "Impossible d’ouvrir l’application «xxx.app», car elle est peut-être endommagée ou incomplète."
Le bureau comportait l'icône du Mac, celui du DD externe servant pour Time Machine et quatre screenshots en .png, autrement dit presque rien sur le bureau. (Je rappelle : 120G dispos sur un HDD de 500G SSD).

J'ai envisagé de réinstaller ma session Admin avec l'option de "migration" mais je ne disposais alors que d'une seule sauvegarde dont la date était postérieure à mon problème (en allant jusqu'au bout de la procédure, seule la taille de la session utilisateur sur laquelle j'étais s'affichait, toutes les autres lignes n'arrivaient pas à calculer la taille et la roue tournait indéfiniment ; il y avait d'ailleurs un message en-dessous du tableau qui disait qu'il y avait un problème). Donc, pas de migration de ma session Admin.

Avec Time Machine, j'ai réinstallé une version antérieure au problème. La seule modification qui s'est opérée fut sur ma session Admin où les icônes de toutes les applications ont été remplacées par des points d'interrogation (leurs noms sont toujours présents sous les "?"), hormis l'icône du Finder et celle du calendrier. Les miniatures des quatre screenshots ont également disparues.

J'ai vu un PB similaire signalé par Gus42 le 10/08/2017 et commencé à être traité par Macomaniac, mais Gus42 a résolu son affaire avec l'assistance Apple (en 2h42 de téléphone !) sans donner la procédure détaillée : "...pbm résolu en créant une nouvelle session et en transférant toute la session malade sur la nouvelle...".

Je me présente donc sur ce forum à partir de l'une des sessions utilisateurs (pas d'accès à mes mails sur ce Mac, j'utilise mes appareils mobiles iPad et iPhone) afin de trouver une solution pour réparer/recréer ma session Admin.

Enfin, je ne peux me connecter sur le Mac que le soir, mais je devrais pouvoir répondre à des demandes de précisions dans la journée (si j'ai le temps de venir sur le forum avec mon pad...).

En vous remerciant par avance pour la prise en compte de ma requête et l'aide que vous voudrez bien m'apporter.

PS : désolé si je ne suis pas drôle et pour l'absence d'émoticônes, mais j'ai essayé d'être le plus précis possible dans ma description.

Fol.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 250
24 228
Forêt de Fontainebleau
Bonjour Fol


Est-ce que tu disposes d'un second compte d'utilisateur à statut Admin (indépendant donc de celui à problème) ? -->
  • si les autres utilisateurs n'ont qu'un statut Standard --> est-ce que dans ta session Admin à problème > tu peux aller au Menu  > Préférences Système > Utilisateurs et groupes > déverrouiller le cadenas d'administration > sélectionner un autre utilisateur (Standard) > et cocher la case : "Autorisation à administrer cet ordinateur" ? - ou bien est-ce que ce n'est pas possible ?
 

Fol

Membre junior
4 Juillet 2018
26
2
51
Bonjour Macomaniac et merci de prendre en compte mon PB.

Je me doutais et j’espérais que ce soit toi qui réponde car tu as une approche très pédago et ça m’intéresse de comprendre ce qui se passe (origine du problème), ce que je fais comme action et pourquoi.

Pour répondre à tes deux questions, LA réponse est NON dans les deux cas (mais tu vas confirmer).

Pour les deux sessions User, je ne pense pas qu’elles soient avec droits Admin dans la mesure où à chaque fois qu’il y a une MAJ à effectuer (MAJ de Firefox par exemple), une fenêtre de dialogue s’ouvre (identifiant et mot de passe) et on me demande de me connecter Avec des droits d’administrateur. Je l’ai fait mardi et mercredi sur chacune des deux sessions utilisateurs avec les identifiants de mon compte principal Admin et j’ai pu mettre à jour Firefox.

Pour la seconde question, comme je l’ai cité en exemple dans mon premier post, en cliquant sur la Pomme (désolé, je n’ai pas l’icone Apple), le menu se déroule et puis plus rien, cliquer sur les titres, dont Préférences système, ne donne rien, ça reste muet.

Je me retrouve donc avec deux sessions User et plus d’accès Admin ( c’est un PB que tu avais évoqué dans un post avec KiriMixer en novembre 2017, mais elle avait été plus prudente que moi et possédait un second compte avec droits Admin : là tu expliquais que c’était possible d’en créer un mais que ça allait être un peu plus long...).

Voilà, voilà.

Je quitte les ondes et je me reconnecte ce soir at home.

Bbl
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 250
24 228
Forêt de Fontainebleau
D'après ta description > le plus simple est que tu crées un 3è compte d'utilisateur > à vocation purement auxiliaire > lequel sera Admin. Il existe un procédé spécial de dépannage qui permet d'effectuer cette création.

Auparavant > j'ai besoin de connaître 2 informations qui vont te faire utiliser le Terminal (aucun statut Admin n'est requis pour passer les commandes correspondantes). Donc dans une de tes sessions qui fonctionne > tu vas à : Applications > Utilitaires > tu lance le Terminal.

Dans la fenêtre ouverte > saisis (l'une après l'autre) les 2 commandes informatives :
Bloc de code:
diskutil list
fdesetup status

et ↩︎ (presse la touche "Entrée" du clavier après chaque commande saisie pour l'exécuter)

  • la 1ère affiche le tableau des disques > avec tables de partitions > et partitions --> elle fera connaître le nom du volume de démarrage
  • la 2è retourne le statut de FileVault (le logiciel de chiffrement) --> elle fera savoir si le volume de démarrage sera ou non verrouillé > quand tu démarreras sur l'OS de secours pour effectuer la manipulation permettant de créer un nouveau compte Admin

Poste ces 2 tableaux en copier-coller dans une fenêtre de code (pas de capture) > par le procédé suivant -->

  • dans la page de ce fil de MacGé > presse le bouton http://chebmann.free.fr/jpg's chat/MacGe/InsererCodeMcGe.jpg (carré avec un + inscrit - juste au milieu de la largeur de la fenêtre totale) dans la barre de menus au-dessus du champ de saisie d'un message > menu  : </> Code > par ⌘V colle dans la fenêtre Code > presse le bouton Insérer (ce procédé permet un affichage fenêtré qui économise l'espace de page en respectant la mise en forme des tableaux du «Terminal» --> d'où une plus grande lisibilité)

Note : si le dysfonctionnement de tes sessions t'empêche d'utiliser le Terminal ou de poster ses tableaux --> sache qu'il y aura moyen de pallier cet inconvénient.
 

Fol

Membre junior
4 Juillet 2018
26
2
51
(Dans le train)
Normalement ça devrait être bon pour l’acces au terminal, car j’ai dû essayer mardi une de tes commandes d’un ancien de tes posts et j’y avais accès.

J’essaie ce soir.

je pense que c'est ça qui t'intéresse :

FileVault is Off.

Bloc de code:
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         500.1 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.1 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            377.3 GB   disk1s1
   2:                APFS Volume Preboot                 51.3 MB    disk1s2
   3:                APFS Volume Recovery                1.0 GB     disk1s3
   4:                APFS Volume VM                      3.2 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:          Apple_CoreStorage TOSHIBA EXT             999.9 GB   disk2s2
   3:                 Apple_Boot Boot OS X               134.2 MB   disk2s3

/dev/disk3 (external, virtual):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS TOSHIBA EXT            +999.5 GB   disk3
                                 Logical Volume on disk2s2
                                 4D6F6C2A-4543-4160-8234-61327AA6B766
                                 Unlocked Encrypted

C'est mieux comme ça, pas compris pq ça n'a pas fonctionné la 1ère fois.

Je repasserai dans 2h.

Je suis désolé si c'est un peu haché comme conversation, mais j'ai qq petites contraintes et la SNCF ne m'aide pas à rentrer tôt depuis trois jours.

Le disque Toshiba 1To est ma sauvegarde Time Machine connecté en permanence.
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 250
24 228
Forêt de Fontainebleau
Donc le volume s'appelle Macintosh HD (et est membre d'un Conteneur apfs) & FileVault n'est pas activé : voici le tuto adapté à ton cas de figure -->

- redémarre > et presse les 2 touches ⌘R (cmd R) de l'écran noir à l'affichage d'une  = démarrage en mode récupération. Tu atteins un écran affichant une fenêtre de 4 Utilitaires macOS.

Va à la barre de menus supérieure de l'écran > menu : Utilitaires > sous-menu : Terminal.

Dans la fenêtre ouverte > saisis la commande (avec la plus grande exactitude) -->
Bloc de code:
rm /Volumes/"Macintosh HD"/var/db/.AppleSetupDone
(un espace entre rm et /Volumes--- ; mets "Macintosh HD" avc des "" ; pas d'espace entre HD" et la / qui suit ; pas d'espace entre db/ et .AppleSetupDone)
  • cette commande supprime un fichier de finalisation vide dans le volume Macintosh HD --> ce qui va te permettre de ré-obtenir les panneaux de paramétrage du Mac / création d'un compte admin comme à la fin d'une 1ère installation
  • re-démarre normalement --> à la fin du chargement de l'OS > au lieu d'ouvrir ta session > tu vas toucher la série des panneaux de paramétrage du Mac. Renseigne tout avec exactitude.
  • le dernier panneau te permet de créer un compte admin : ne reprends surtout pas les identifiants de ton compte > choisis : Nom complet = toto > nom de compte = toto > mot-de-passe = toto.

Tu ouvres une session toto (Admin) --> tu n'as qu'à le signaler alors.
 

Fol

Membre junior
4 Juillet 2018
26
2
51
Job is done, c’est fait.

On se retrouve demain.

Les deux sessions User sont-elles accessibles pendant ce temps-là ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 250
24 228
Forêt de Fontainebleau
Les deux sessions User sont-elles accessibles pendant ce temps-là ?

  • tu peux bien sûr quitter la session toto (Menu  > Fermer la session toto) --> ce qui réaffiche l'écran d'ouverture de session (LoginWindow) > et te permet de te reloger dans la session d'un de tes 2 autres utilisateurs.

Tu n'auras qu'à faire signe quand tu es disponible.
 

Fol

Membre junior
4 Juillet 2018
26
2
51
(Dans le train)

OK, avant de fermer hier soir j’a cliqué sur le nom Toto et j’ai effectivement vu que les trois autres sessions étaient toujours dispo.

Deux choses : à combien de temps estimés-tu la durée de l’operation ?
D’apres toi, qu’stclé qui a provoqué ce problème (mauvaise manip, manque d’entretien de la machine, mauvaise gestion de certaines données, malveillance Internet, virus, la faute à pas d’chance, ...) ?

En fonction de la durée, je te dis si on fait ça ce soir ou plutôt demain.

Je te souhaite une très bonne journée.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
36 490
4 566
D’apres toi, qu’stclé qui a provoqué ce problème (mauvaise manip, manque d’entretien de la machine, mauvaise gestion de certaines données, malveillance Internet, virus, la faute à pas d’chance, ...) ?
C'est très souvent le cas. ;)
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
79 250
24 228
Forêt de Fontainebleau
Disons que la session toto permet d'agir avec des droits Admin --> pour tenter de régler le problème des 2 autres comptes.

Dont je ne sais pas actuellement en quoi consiste le problème.

Pour te donner une idée : un compte est constitué de l'association de 2 facteurs : une identité d'utilisateur & un dossier-domicile -->

  • l'identité d'utilisateur est un fichier plist > dans lequel sont consignés les paramètres de l'utilisateur (son Nom Long > son nomcourt etc.) > et qui réside dans la base de données users du Service d'Annuaire (une adresse planquée)
  • le dossier-domicile est un dossier au nomcourt de l'utilisateur > sub-divisé en sous-dossiers (Bureau > Bibliothèque > Documents > Images ...) > dans lesquels sont stockés les fichiers et les préférences d'un utilisateur déterminé > et qui réside dans le répertoire Users (Utilisateurs)
  • l'association des 2 facteurs est réalisée par une adresse au dossier-domicile > inscrite dans le fichier identitaire de l'utilisateur > de type : /Users/machin (si machin est le nom de son dossier-domicile identique à son nomcourt) --> ce qui fait qu'à la lecture du fichier plist > le Système déterminera une ouverture de session sur l'espace du Bureau du dossier correspondant

Ce tableau brossé > on peut conjecturer : soit que ton fichier identitaire est corrompu dans ses écritures > soit que des éléments de ton dossier-domicile compromettent le fonctionnement de la session = préférences stockées dans la Bibliothèque personnelle (préférences du Finder > de lancement d'applications en ouverture de session...) ou excès de fichiers stockés sur le Bureau ou encore processus suspendu (de copie ou autre).
 
  • J’aime
Réactions: Fol

Fol

Membre junior
4 Juillet 2018
26
2
51
OK, j’avais lue ta description du fonctionnement d’un compte.

Ce qui m’interesse est que cela ne se reproduise pas, donc d’avoir les bonnes pratiques (...ou éviter les mauvaises) si ça vient de moi. J’utilise mon Mac uniquement pour des choses basiques et légales ; seule petite originalité, un jeu MMO en ligne.

Donc, à suivre.

Encore merci Macomaniac pour tes réponses avisées (= diagnostic et analyse pour comprendre et conclure).

PS 1 : @macomaniac : une petite idée de la durée de la manip’ ? Doit-elle se faire ensemble (tous les deux en ligne au même moment, je ne voudrais pas te faire perdre ton temps) ?

PS 2 : @ Locke, j’apprecierais d’être éclairé sur la potentielle « mauvaise manip » afin de ne pas la reproduire.
 

Fol

Membre junior
4 Juillet 2018
26
2
51
Bonsoir Mac,

La seule session qui a des problèmes est ma session perso Admin.

Les deux sessions utilisateurs et la nouvelle session toto/Admin que nous avons créée fonctionnent correctement.
 

Fol

Membre junior
4 Juillet 2018
26
2
51
La session s’ouvre. Le fonds d’écran personnalisé est le bon.

Et c’est tout. Aucune application ne fonctionne (après une réinstallation par Time Machine, les icônes des applications ont été remplacées par des points d’interrogation, mais les noms sont toujours inscrits dessous).
Le message est le suivant : « Impossible d’ouvrir L’application xxx.app car celles-ci est peut être endommagée ou incomplète ».

Le menu Pomme s’ouvre mais aucune fonctionnalité n’est accessible : Cliquer sur « Préférences systématique » ne donne rien comme je te l’avais dit.

En gros, ma session reste inactive. J’arrive à accéder au DD de ma sauvegarde Time Machine dont l’icône est sur le bureau, c’est tout.

Pour rappel, mon bureau est quasiment vide : le DD du Mac, le DD de sauvegarde et quatre screenshots (les miniatures ont disparu après la MAJ Time Machine, mais les noms sont toujours visibles).