Suppression de Soundflower dans Son ?

Olivier B

Membre confirmé
20 Avril 2009
142
0
50
Bonjour,

Petite question pratique, j'ai utilisé Soundflower et si j'ai bien supprimé le programme, il reste dans Préférences Systèmes/Sons le choix, dans Entrée et Sortie, des Soundflowers (2ch) et (64ch)...
Comment les supprimer ?

De plus, est il possible de créer un raccourci, dans le dock, du "niveau" Son et non pas être obligé de passer par Préférences Système ?
J'utilise souvent Son pour passer de mon apple TV à la sortie intégrée selon mes besoins...

Merci d'avance
Olivier
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
396
Paris
Comment as-tu supprimé le programme ? Il n'avait pas un désinstallateur ?

Sinon, pour avoir /Son dans le dock, il faut aller dans /Système/Bibliothèque/PreferencePanes et glisser/déposer Sound.prefPane dans le dock (attention, considéré comme fichier/lien, donc pas du côté des apps)...
Pour accéder à /Système, vu qu'en général, c'est « caché », Finder, Aller à, et mettre /System.
 
  • J’aime
Réactions: Olivier B

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
67 446
20 990
Forêt de Fontainebleau
Olivier,

normalement tu as un script de désinstallation dans le dossier «Soundflower» de tes Applications. Tu ne l'as pas utilisé [cf. la question de Larme <:coucou:>]?


Sinon, si tu as déjà supprimé le dossier ci-dessus, tu peux aller voir à :

- HD/Bibliothèque/Receipts/Soundflower.pkg
- Mountain Lion/private/var/db/receipts <il s'agit de dossiers invisibles de ton ordinateur> : benner tous les fichiers commençant par : com.cycling74.soundflower (environ 14) - Warning! pas d'erreur de sélection, n'est-ce pas?
- System/Bibliothèque/Extensions/Soundflower.kext
- ~/Bibliothèque/Preferences/ : com.cycling74.soundflowerbed.plist et com.cycling74.soundflowerbed.plist.lockfile

Re-démarrer.

[La désinstallation à la main est un de mes exercices favoris, mais sache que cette façon de procéder demande un doigté de pianiste si tu ne veux pas te les mordre ensuite (les doigts, j'entends :D) - par conséquent ce n'est pas publiquement encouragé.]
 

Olivier B

Membre confirmé
20 Avril 2009
142
0
50
Comment as-tu supprimé le programme ? Il n'avait pas un désinstallateur ?

Je ne sais plus...

Sinon, pour avoir /Son dans le dock, il faut aller dans /Système/Bibliothèque/PreferencePanes et glisser/déposer Sound.prefPane dans le dock (attention, considéré comme fichier/lien, donc pas du côté des apps)...
Pour accéder à /Système, vu qu'en général, c'est « caché », Finder, Aller à, et mettre /System.


Parfait !

Sinon, si tu as déjà supprimé le dossier ci-dessus, tu peux aller voir à :

- HD/Bibliothèque/Receipts/Soundflower.pkg
- Mountain Lion/private/var/db/receipts <il s'agit de dossiers invisibles de ton ordinateur> : benner tous les fichiers commençant par : com.cycling74.soundflower (environ 14) - Warning! pas d'erreur de sélection, n'est-ce pas?
- System/Bibliothèque/Extensions/Soundflower.kext
- ~/Bibliothèque/Preferences/ : com.cycling74.soundflowerbed.plist et com.cycling74.soundflowerbed.plist.lockfile


Le sous dossier Receipts, Extensions ne semblent pas exister
Je ne sais pas voir les invisibles
Et les com.cycling74.soundflower n'apparaissent pas dans Preferences...
Normal ? Du coup toujours Soundflower dans Sons !?

Comment faire mieux ?
Merci
Olivier B
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
396
Paris
Dans l'doute, tu peux essayer de le réinstaller, et désinstalle-le proprement avec son désinstallateur.
 

Olivier B

Membre confirmé
20 Avril 2009
142
0
50
Même en le "désinstallant" avec le script spécifique, reste dans Sons le choix des Soundlowers 2ch et 64ch alors que le programme n'existe plus !?

Je vois dans /Bibliothèque/Preferences/Audio, un 'fichier" : com.apple.audio.SystemSettings.plist où plusieurs lignes <string>SoundflowerEngine:0</string> sont inscrites encore !?

A l'aide...
Olivier B
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
67 446
20 990
Forêt de Fontainebleau
Olivier,

les 4 lignes que j'ai données indiquent le chemin à suivre, dans l'arborescence de l'OS, jusqu'à l'adresse du/des fichiers requis. [Dans ce qui suit, tu y vas Zen, d'accord? - Calme & Exact :D]



- HD/Bibliothèque/Receipts/Soundflower.pkg : par 'HD/Bibliothèque', j'entends la Bibliothèque Générale de l'OS. Quand tu ouvres une fenêtre-Finder, c'est celle qui saute aux yeux (en mode graphique), à droite du dossier 'Applications' = le dossier 'Bibliothèque'. Tu l'ouvres, tu vas au sous-dossier 'Receipts', tu l'ouvres, tu vas au paquet 'Soundflower.pkg' et tu bennes <ce paquet unique, n'est-ce pas?> [peu nécessaire, c'est par souci d'exhaustivité :D]

&#10057;

- System/Bibliothèque/Extensions/Soundflower.kext : par System/Bibliothèque, j'entends la Bibliothèque-Système nommément, qui regroupe les fichiers-core de l'OS. Quand tu ouvres encore une fenêtre-Finder, en mode graphique, tu avises un dossier intitulé 'Système'. Tu l'ouvres et tu tombes sur un dossier 'Bibliothèque' : c'est le répertoire de la 'Bibliothèque-Système' évoquée dans ce §. Tu l'ouvres, tu vas au sous-dossier 'Extensions' que tu ouvres encore. Tu tombes sur une série de fichiers .kext qui sont les kernel_extensions (ou extensions du noyau). WARNING : ne pas bidouiller là-dedans! Va strictement et exclusivement à la kernel_extension «Soudflower.kext» et benne. J'espère que tu es dans une session-admin, car il faut un mot-de-passe admin ici.

&#10057;

- ~/Bibliothèque/Preferences/com.cycling74.soundflowerbed.plist et com.cycling74.soundflowerbed.plist.lockfile : par ~/Bibliothèque, j'entends la Bibliothèque Personnelle de l'usager que tu es, càd. TA Bibliothèque. Elle est invisible par défaut sous «Mountain Lion». Afin d'y accéder, dans la barre de menus du Finder, clique sur Aller, sous-menu : 'Aller au dossier...'. Dans la fenêtre de renseignement qui s'affiche, fais un copier-coller de :

Bloc de code:
~/Library
ou

Bloc de code:
~/Bibliothèque
(au choix) et clique le bouton 'Aller'. Le Finder t'affiche les sous-dossiers de ton dossier 'Bibliothèque' perso. Tu vas au sous-dossier 'Preferences' que tu ouvres, tu repères les fichiers com.cycling74.soundflowerbed.plist & com.cycling74.soundflowerbed.plist.lockfile, tu les sélectionnes et tu bennes (pas d'erreur, n'est-ce pas?).

&#10057;

- Mountain Lion/private/var/db/receipts/com.cycling74.soundflower---. «Private» est un répertoire résolument invisible de ton OS (et pour d'excellentes raisons). Comme pour TA Bibliothèque, dans le § précédent, va au menu 'Aller' de la barre de menus du Finder, sous-menu 'Aller au dossier...', et dans la fenêtre de renseignement fais un copier-coller de :

Bloc de code:
/private/var/db/receipts
Une fenêtre t'affiche les fichiers du dossier 'receipts'. Tu vas aux fichiers qui commencent par : com.cycling74.soundflower--- (j'en ai 14 dans mon propre dossier 'receipts'), tu les sélectionnes tous (WARNING! pas d'erreur hein?) et tu bennes.



Tu re-démarres ton Mac. Normalemement, tous les fichiers-système d'installation de «Soundflower» ont disparu de ton OS. Espérons que l'affichage qui t'ennuie tant dans les 'PreferencesPanes/Son' aura disparu lui aussi.

&#10057;

[NB. Comme tu t'en seras rendu compte, il y a toujours au moins 3 Bibliothèques sous Mac OS X : Système, Générale et Usagère (celle de l'Utilisateur-admin par défaut). Mais pour tout compte d'utilisateur supplémentaire qui se crée, y compris celui du Super-User 'root', tu dois ajouter une Bibliothèque correspondante aux 3 de base.

Le statut d'invisibilité par défaut d'une série de répertoires sous Mac OS X répond à d'excellentes raisons, tant esthétiques (il est plus agréable de ne pas avoir sous les yeux en permanence l'architecture de coulisses d'un OS) que sécuritaires (cela évite la tentation du bidouillage, quand ce n'est pas carrément du bennage, de répertoires-racine sous prétexte qu'ils ne servent pas à l'usager <sic>, ou qu'ils encombrent le paysage en gâchant la vue. Il est plus sage de laisser les 'habitants' de l'invisible ...à leur dimension d'invisible.
]
 
Dernière édition:
  • J’aime
Réactions: Olivier B

Olivier B

Membre confirmé
20 Avril 2009
142
0
50
Super, le raccourci de Larme est nickel et les explications très didactiques de macomaniac ont fait disparaître les lignes Soundfower dans les choix d'entrée et de sorties de Sons...
Merci
Olivier B
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
396
Paris
Si c'est résolu, n'oublies pas de le mettre dans le fil de conversation, ça doit être dans Outils de la discussion en haut du premier post ;)
 

Valoufifa

Membre junior
15 Juin 2012
17
0
Bonjour,

J'ai depuis peu un problème similaire : dans les sorties sons, j'ai Soundflower (2ch) qui est par défaut alors qu'avant c'était les Hauts-parleurs intégrés et ça m'allait très bien !

Comment dois-je procéder pour remettre les hauts-parleurs intégrés par défaut ?
(Je suis sous Mac OS 10.9 Mavericks)

Merci !
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
67 446
20 990
Forêt de Fontainebleau
Bonjour Valoufifa.

Tu as 2 options : diplomatique ou drastique.

1° diplomatique (= la méthode polie)

Tu vas à : /Applications/Utilitaires/ et tu lances l'application «Configuration audio et MIDI». Dans la fenêtre qui s'ouvre, opère comme montré par ce visuel :


La petite icône noire en forme d'entonnoir (haut-parleur sortie_son) devrait venir étiqueter la ligne 'sortie intégrée'. Re-démarre par acquis de conscience au cas où l'étiquetage n'apparaîtrait pas illico. Va dans les Préférences Système/Son/Sortie et vérifie si la ligne : 'Haut-Parleurs internes' est bien surlignée et garde la sélection. Si oui, c'est réglé.

[NB. Reste prudente quand tu interviens dans la fenêtre de l'application : «Configuration audio et MIDI», car il y a plein de choix et de réglages abstrus qu'il vaut mieux pratiquer en connaissance de cause. Fais simple, comme montré.]

&#9828;

2° drastique (la méthode forte)

Un terme un tantinet sophistiqué pour dire : arracher le chiendent AVEC ses racines :D. J'avais donné dans mon message #3 adressé à Olivier l'adresse desdites racines (avec, à me relire, un luxe de détail dans les descriptifs topographiques). Eh bien! Tu vas voir aux adresses indiquées, tu repères chaque fois le fichier incriminé et tu le mets à la corbeille.

Ce procédé supprime exhaustivement «SoundFlower» et donc règle le problème 'radicalement'. À toi de voir si c'est ce que tu préfères.

&#9831;
 

Valoufifa

Membre junior
15 Juin 2012
17
0
Merci pour ton aide !

La première méthode me plaît beaucoup sauf que "Utiliser ce périphérique pour la sortie audio" est grisé et je ne peux donc pas cliquer dessus...

Sais-tu si il est possible de le "dé-griser" ou dois-je passer à la méthode brutale ? :)

Merci encore !
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
67 446
20 990
Forêt de Fontainebleau
"Utiliser ce périphérique pour la sortie audio" est grisé et je ne peux donc pas cliquer dessus...
Bouffre! Pour demeurer sur les sentiers de la 'diplomatie' [Parle poliment à ton Mac - il t'écoutera peut-être... :D], tu pourrais essayer d'agir sur «Soundflower» lui-même. Normalement, lorsque l'installateur du paquet téléchargé est activé, il installe pour l'essentiel : d'une part «Soundflower» sous forme de kext (kernel extension) = 'Soundflower.kext' (in : System/Library/Extensions) ; d'autre part, dans le repertoire 'Applications', un dossier 'Soundflower' dans lequel réside une application de pilotage de «Soundflower» = «Soundflowerbed».

Va à la susdite adresse, et lance «Soundflowerbed». En réponse, l'icône d'une fleur octo-foliaire s'affiche dans la barre de menus supérieure du Finder. En cliquant sur l'icône, une fenêtre déroulante propose des options respectivement pour «Soundflower (2ch)» et «Soundflower (64ch)». Est-ce qu'à la rubrique «Soundflower (2ch)», l'option : 'Built-in Output' ne serait pas cochée par hasard? Si c'était le cas, coche la 1ère option au contraire = 'None (OFF)'. Vérifie au passage que la même option = 'None (OFF)' est aussi cochée pour la rubrique «Soundflower (64ch)».

Est-ce que ce procédé ne règle pas le problème en virant la sortie-son sur les 'Haut-Parleurs internes'? Peut-être re-démarrer entre temps pour activer le choix. Si oui, tu peux t'en tenir-là et quitter «Soundflowerbed» (fenêtre déroulante, dernière opton). Ce qui signifie que les ressources de «Soundflower» demeurent installées, mais sont pour l'heure neutralisées.

Si la méthode douce [Parle poliment etc.] revenait à causer Latin à un sourd :D (parce que par exemple tu n'aurais plus de dossier «Soundflower» dans tes applications, et donc aucune application_pilote «Soundflowerbed» utilisable) - alors il serait temps d'extraire le mal par la racine (comme s'écrie le dentiste du 'Sapeur Camembert' en brandissant une paire de tenailles qui n'ont rien à voir avec le délicat procédé d'extraction des racines mathématiques). À défaut du désinstallateur de «Soundflower» normalement présent dans le dossier du même nom des Applications, va jardiner aux emplacements indiqués par mon ancien message, puis re-démarre. Plus de kext, plus de «Soundflower»...
 

Valoufifa

Membre junior
15 Juin 2012
17
0
[/QUOTE]Si la méthode douce [Parle poliment etc.] revenait à causer Latin à un sourd :D (parce que par exemple tu n'aurais plus de dossier «Soundflower» dans tes applications, et donc aucune application_pilote «Soundflowerbed» utilisable) - alors il serait temps d'extraire le mal par la racine (comme s'écrie le dentiste du 'Sapeur Camembert' en brandissant une paire de tenailles qui n'ont rien à voir avec le délicat procédé d'extraction des racines mathématiques). À défaut du désinstallateur de «Soundflower» normalement présent dans le dossier du même nom des Applications, va jardiner aux emplacements indiqués par mon ancien message, puis re-démarre. Plus de kext, plus de «Soundflower»...[/QUOTE]

Magnifique ! La "méthode douce" ne marchant pas, du moins n'ayant pas les dossiers et fichiers Soundflower dans 'Applications', j'ai foutu à la benne ce satané Soundflower.kest et après redémarrage, tout est rentré dans l'ordre !

Un grand merci à toi pour ton aide et tes compétences ! :up: Je dis chapeau l'artiste ! :D

À bientôt peut-être et merci encore de m'avoir enlevé ce petit caillou de ma chaussure, pas douloureux mais assez chiant à la longue ;)
 

saintdenizotpalacio

Nouveau membre
24 Mai 2019
1
0
26
Bonjour Olivier,

je fais remonter une ancienne question, mais j'ai le même problème, cependant la désinstallation a bien été effectuée avec redémarrage et je ne trouve plus trace de soundflower dans les fichiers système, cependant les icônes restent présents dans les préférences sons,

avez-vous une autre idée pour les supprimer ?

merci

steven

Olivier,

les 4 lignes que j'ai données indiquent le chemin à suivre, dans l'arborescence de l'OS, jusqu'à l'adresse du/des fichiers requis. [Dans ce qui suit, tu y vas Zen, d'accord? - Calme & Exact :D]



- HD/Bibliothèque/Receipts/Soundflower.pkg : par 'HD/Bibliothèque', j'entends la Bibliothèque Générale de l'OS. Quand tu ouvres une fenêtre-Finder, c'est celle qui saute aux yeux (en mode graphique), à droite du dossier 'Applications' = le dossier 'Bibliothèque'. Tu l'ouvres, tu vas au sous-dossier 'Receipts', tu l'ouvres, tu vas au paquet 'Soundflower.pkg' et tu bennes <ce paquet unique, n'est-ce pas?> [peu nécessaire, c'est par souci d'exhaustivité :D]

&#10057;

- System/Bibliothèque/Extensions/Soundflower.kext : par System/Bibliothèque, j'entends la Bibliothèque-Système nommément, qui regroupe les fichiers-core de l'OS. Quand tu ouvres encore une fenêtre-Finder, en mode graphique, tu avises un dossier intitulé 'Système'. Tu l'ouvres et tu tombes sur un dossier 'Bibliothèque' : c'est le répertoire de la 'Bibliothèque-Système' évoquée dans ce §. Tu l'ouvres, tu vas au sous-dossier 'Extensions' que tu ouvres encore. Tu tombes sur une série de fichiers .kext qui sont les kernel_extensions (ou extensions du noyau). WARNING : ne pas bidouiller là-dedans! Va strictement et exclusivement à la kernel_extension «Soudflower.kext» et benne. J'espère que tu es dans une session-admin, car il faut un mot-de-passe admin ici.

&#10057;

- ~/Bibliothèque/Preferences/com.cycling74.soundflowerbed.plist et com.cycling74.soundflowerbed.plist.lockfile : par ~/Bibliothèque, j'entends la Bibliothèque Personnelle de l'usager que tu es, càd. TA Bibliothèque. Elle est invisible par défaut sous «Mountain Lion». Afin d'y accéder, dans la barre de menus du Finder, clique sur Aller, sous-menu : 'Aller au dossier...'. Dans la fenêtre de renseignement qui s'affiche, fais un copier-coller de :

Bloc de code:
~/Library
ou

Bloc de code:
~/Bibliothèque
(au choix) et clique le bouton 'Aller'. Le Finder t'affiche les sous-dossiers de ton dossier 'Bibliothèque' perso. Tu vas au sous-dossier 'Preferences' que tu ouvres, tu repères les fichiers com.cycling74.soundflowerbed.plist & com.cycling74.soundflowerbed.plist.lockfile, tu les sélectionnes et tu bennes (pas d'erreur, n'est-ce pas?).

&#10057;

- Mountain Lion/private/var/db/receipts/com.cycling74.soundflower---. «Private» est un répertoire résolument invisible de ton OS (et pour d'excellentes raisons). Comme pour TA Bibliothèque, dans le § précédent, va au menu 'Aller' de la barre de menus du Finder, sous-menu 'Aller au dossier...', et dans la fenêtre de renseignement fais un copier-coller de :

Bloc de code:
/private/var/db/receipts
 

Steeveoriley

Nouveau membre
3 Novembre 2019
1
0
40
Bonjour
J’ai installer soundflower (la version de Matt ingals), l’instalation C’est bien passé.
Je retrouve bien les ch2 et ch64 dans mes paramètres audio. Par contre je ne trouve aucune icône dans ma barre du haut, ni même de fichier dossier ou icône dans mes applications. Même pas de possibilité de le désinstaller et le pire c’est que ça ne fonctionne pas. Je suis pas très doué en informatique, quelqu’un pourrait me venir en aide svp ?
Merci
Steeve