• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

[Tuto] iPhone avec SIP Freephonie et SipPhone

gibey

Membre confirmé
26 Mai 2007
495
4
Lot et Garonne
S.O.S je bloque entre l'étape 4 et 5.
Je suis arrivé à faire la fusion des 3 certificats, le soucis est le transfert du certificat obtenu sur mon iphone (je n'ai pas l'option mail chez orange...). Quelle autre procédure utiliser pour transférer ce certificat sur mon iphone 3G sous 3.0 (suis sous Mac léopard)
D'avance merci :rose:

---------- Nouveau message ajouté à 18h56 ---------- Le message précédent a été envoyé à 18h42 ----------

Oups, désolé, en réfléchissant un peu j'ai trouvé la solution : surfer en wifi et télécharger mes mails via mon wifi et non la 3G :siffle:
 

rammstein

Membre confirmé
1 Août 2004
147
0
32
J'ai une petite question : J'ai un iphone 3GS et j'ai installer Nimbuzz dessus et j'ai rentré mon identifiant et mot de passe Free dans Autre serveur VoIp. Et là j'ai essayé d'appeler une ligne fixe et le son était vraiment nikel!! :)

Par contre j'ai refait un essai depuis un autre réseau Wifi (ni freephonie ni free) et là pareil ça fonctionne impeccablement!! :)

Par contre est-ce que quand j'utilise justement un autre réseau Wifi mes communication vers fixe sont gratuites comme sur ma ligne Free??:confused:
 

fbi92120

Nouveau membre
25 Novembre 2008
2
0
Bonjour,

le message d'erreur "unable to load private key" m'est retourné par la console.
Si c'est un problème de format, à quoi correspond le format ANSI, je ne l'ai pas trouvé dans les différents type de format texte de textedit. J'en ai essayé plusieur mais cela n'a toujours pas fonctionné. Lequel format .txt choisir ?

Merci
 

discolan

Membre confirmé
7 Février 2008
385
73
Pour ceux qui utiliseraient Textedit, il faut aller dans le menu Format -> Convertir au format texte avant d'enregistrer.

Sinon, sous Word, enregistrer sous -> format texte brut txt
 

stygien

Nouveau membre
24 Juin 2009
3
0
paris
j'ai suivi le tutoial et j'ai bien généré le certificat dans la fenetre terminal
il m'a bien demandé un mot de passe

je me le suis envoyé par mail user.pfx
je l'ai bien telechargé dans mon iphone mais on m'a pas demandé de mot de passe
mais quand je vais dans réglages réseau il n'y a pas de " profil

iphone 3gs jailbreaké et isip légalement achetée

que faire
merci
 

discolan

Membre confirmé
7 Février 2008
385
73
Téléchargé par email ou via SSH (puisque jailbreaké) ?
Parce que normalement après un envoi par email, il suffit de cliquer sur le fichier user.pfx pour que cela commence l'installation et demande le mot de passe.

Le profil ne se trouve dans le menu réglages que si le mot de passe est renseigné et donc installation complète.

Sinon, je ne vois pas.
 

freezet

Membre junior
1 Septembre 2006
58
4
Merci à Discolan pour son tuto et sa patience.
Jusqu'au point 7 no problema : certificats installés, acceptés, profil OK, freephonie activé sur l'iphone.
Après cela tourne en eau de boudin : sur sipPhone et freephonie activé, new account/ freephonie private ip ( version 3.3 de SipPhone, Iphone 3G en 3.1.2)/identifiant, password, proxy

Quel est l'identifiant ?
le n° freebox 09 ? l'identifiant freewifi en chiffres ? l'identifiant généré par SipPhone ?
et le password
celui de la freebox ? du freewifi ? celui du certificat ?
que doit-on mettre pour Freephonie (public ip) Quelle est la différence ?

Proxy ?

pour le freewifi activé : même difficulté Account/ freenet/ identifiant et mdp non acceptés je suis renvoyée à la page précédente.
ça dure depuis 2 jours

suivant les combinaisons, je reçois : timeout ou forbidden ou encore too many blabla, unable : rienque des message pourris.
a l'aide, je craque :mad:
 

discolan

Membre confirmé
7 Février 2008
385
73
Freephonie public ip et freephonie private ip, aucune idée !
Je viens de voir que cela avait changer dans iSIP.
Avant il y avait bien la différence entre Free et Freephonie.

D'après mes infos sur mes comptes :
Free (pour les wifi libres ou les wifis dont vous avez les mdp, le votre ou celui comme freewifi)
Domaine : freephonie.net
identifiant : num de télélphone free
mot de passe : celui de votre compte
serveur proxy : rien
délai enregistrement : 1800
N° de messagerie vocale : rien
N° de téléphone : rien
Détection NAT : activé
Activer APNS : activé

Par contre, pour freewifi, il faut se connecter sur freewifi (via safari) avant de lancer iSIP si je me rappelle bien. Un peu galère.

Freephonie (réseau freephonie, celui avec les certificats)
Domaine : 172.17.20.241
identifiant : num de télélphone free
mot de passe : celui de votre compte
serveur proxy : 172.17.20.241
délai enregistrement : 1800
N° de messagerie vocale : rien
N° de téléphone : rien
Détection NAT : activé
Activer APNS : activé
 

stygien

Nouveau membre
24 Juin 2009
3
0
paris
Téléchargé par email ou via SSH (puisque jailbreaké) ?
Parce que normalement après un envoi par email, il suffit de cliquer sur le fichier user.pfx pour que cela commence l'installation et demande le mot de passe.

Le profil ne se trouve dans le menu réglages que si le mot de passe est renseigné et donc installation complète.

Sinon, je ne vois pas.
oui telechargé par email puis la fenetre reglage s'ouvre toute seule mais profil n'apparait pas :-(
 

stygien

Nouveau membre
24 Juin 2009
3
0
paris
salut
j'ai restauré mon iphone et installé mon certificat
à l'étape 6 il est dit se connecter à un reseau freephonie ok

et choisir eap-tls ok
le champ nom d'utulisateur reste vide et le champ identité se remplit puis je fais rejoindre et rien ne se passe
au bout d'un temps " impossible de rejoindre freephonie"
 

discolan

Membre confirmé
7 Février 2008
385
73
Un truc qui est tout con mais le certificat créé sur le site de free n'est valable que 2 mois.
Donc cela peut empêcher la connexion au réseau freephonie si le certificat est trop vieux.
Je crois qu'on peut voir la validité du certificat directement dans l'iPhone.

Ton erreur vient surement de là. Moi cela me donnait cela quand le certificat était trop vieux.
 

freezet

Membre junior
1 Septembre 2006
58
4
Merci encore à discolan pour toutes ses precisions.
J'ai enfin reussi a configurer le compte freephonie qui marche nickel.
Peut-etre mon expérience peut-elle servir à Stygien qui a aussi des problèmes.

Pour ce compte Freephonie où on me repondait " timeout" ou forbidden"

1.j'ai changé mon mot de passe SIP en allant sur
cette adresse/
de ma propre Freebosx obligatoirement, en faisant attention à n'inclure que des chiffres et des lettres (aucun signe cabalistique).
2. j'ai refait mes certificats comme indiqué en donnant dès le terminal le même mot de passe SIP.

tout a marché tout de suite. C'était donc une des deux erreurs que javais faites, peut-être le deux d'ailleurs:confused:

Quant au compte SIP sur freewifi, je suis toujours en rade : "number of retries excceded"
je cherche et je tiens au courant...

PS. Au fait, j'ai appris qu'il était dorénavant impossible de téléphonie en SIP ou VoIP à l'étranger : Free a supprimé le service à cause d'indélicatesses présumées de son personnel qui avait accès aux mots de pass Sip non codés, certains clients s'étant retrouvés avec des factures de 800 euros en fin de mois sans avoir utilisé leur tel...
 

discolan

Membre confirmé
7 Février 2008
385
73
Content que cela marche :up:

Pour le freeWifi, tu es bien connecté ? Tu as lancé Safari sur l'iPhone, rentré tes identifiants et testé une page au hazard avant de lancer iSip (en activant bien le compte Free dans iSip et pas le compte Freephonie) ?

PS. Au fait, j'ai appris qu'il était dorénavant impossible de téléphonie en SIP ou VoIP à l'étranger : Free a supprimé le service à cause d'indélicatesses présumées de son personnel qui avait accès aux mots de pass Sip non codés, certains clients s'étant retrouvés avec des factures de 800 euros en fin de mois sans avoir utilisé leur tel...
Je crois qu'en fait les appels vers l'étranger en SIP sont (ou étaient) bloqués, pour les raisons expliquées au dessus.
Par contre, l'appel vers les fixes en France depuis l'étranger en SIP est toujours possible, sauf si j'ai loupé un épisode. Donc on peut toujours se servir de son iPhone et d'un wifi à l'étranger pour appeler gratuitement les fixes en France.
 

freezet

Membre junior
1 Septembre 2006
58
4
Voilà tout est au vert.
Oui Discolan le freewifi était activé. Safari envoyait "connexion réussie"

En fait le problème venait de la non compréhension de la nouvelle configuration mise en place pour la version 3.3
Freephonie.net (public ip) doit être choisi pour la config SIP
freephonie.net (private ip) pour la config Freephonie (VoiP)
C'était la réponse du service technique de SipPhone qui donnait ces indications ss explications superflues !

Voila donc comment comment j'ai bidouillé au feeling :
1. j'ai activé le Isip (celui qui est présent en natif) avec l'adresse email et ensuite clic sur "activez-moi')
2. ensuite j'ai créé deux comptes ( gràca à l'option "modifier"):
a. compte Freephonie en choisissant Freephonie.net (Prvate ip), puis n° de tel 0950.... et Password Sip
b. compte Sip en choisissant Freephonie (public ip), le numéro donné par free (je pense que le numéro 0950 marche aussi bien).
En activant ds réglages Freephonie, le compte a. marche , en activant freewifi et identifiant et mdp ds safari, ça marchepour le compte b.

Si c'est la bonne manip, c'est une simplification, il suffisait de le savoir.....:)
 

xavax

Membre émérite
13 Octobre 2003
708
4
super le tuto!! MErci! Moi il y a juste un truc qui ne fonctionne pas c'est le push... Et vous?
 

xbuz

Nouveau membre
10 Novembre 2006
11
0
Bonjour à tous
Je reviens sur ce sujet
J'ai un problème en tapant la commande sur le terminal:
"Error opening input file public
public: No such file or directory":nailbiting: