iMac Admin inconnu sur iMac

Gilrod

Membre confirmé
9 Septembre 2011
21
1
Salut à tous !

N'étant pas un cador en informatique et ne parvenant pas à trouver une solution avec la fonction recherche, je fais appel aux plus connaisseurs d'entre vous.

Une amie vient de me donner un iMac G5 qu'un de ses potes fraichement divorcé avait stocké chez elle depuis plusieurs années... le gars a finalement quitté la région en lui laissant le bestiau...
C'est un 10.3.9 avec powerPc 1,8 Ghz, de 2004 d'après mes recherches (?).
Quand je l'ai récupéré il s'allumait avec écran noir, j'ai fait alt/pomme/P/R et il est parti nickel.
Seulement voilà, j'aimerais l'utiliser en y installant un vieux Logic audio (je suis compositeur et régisseur, et j'ai une cinquantaine de morceaux récupérés de mon G4 d'une autre époque) mais impossible d'y rentrer quoi que ce soit, vu qu'il me demande un nom d'administrateur et un mot de passe... :(
J'ai déja un MacbookPro et un Macmini at home, mais ce genre de cas ne s'est jamais présenté à moi...

Quelqu'un pourrait-il m'aider, parce que là, je pense avoir fait le tour et ça commence un tantinet à m'asticoter...

Un grand merci d'avance ! :(
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
87 429
26 630
Forêt de Fontainebleau
Salut Gilrod

Démarre le Mac les 2 touches ⌘S (cmd S) tenues pressées = démarrage en Single User (utilisateur unique = root).

Tu accèdes à un écran noir où défilent des lignes blanches de logs d'initialisation. Tu es dans un Terminal de root > en clavier QWERTY logique > et le volume de l'OS n'est disponible qu'en lecture seule.

Attends d'avoir l'invite de commade :
Bloc de code:
root#
pour commencer (si les lignes s'immobilisent sans que tu aies une invite de commande terminée par un # --> presse une fois la touche "Entrée" du clavier pour forcer son affichage.

Je vais te donner les commandes --> d'abord comme tu dois les voir affichées à l'écran > ensuite comment tu dois les taper sur ton AZERTY physique pour qu'elles correspondent au QWERTY logique.

Tape la commande qui s'affiche comme :
Bloc de code:
mount -uw /
et que tu tapes ainsi :
Bloc de code:
,ount )uz =
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)
  • cette commande remonte le volume en lecture et écriture > ce qui permet d'agir.

Tape la commande qui s'affiche comme :
Bloc de code:
rm /var/db/.AppleSetupDone
et que tu rapes ainsi :
Bloc de code:
r, =vqr=db=:QppleSetupDone
et ↩︎
  • cette commande supprime un fichier vide de finalisation --> ce qui va faire ré-afficher au re-démarrage les panneaux de paramétrage du Mac comme à la fin d'une installation propre

Tape la commande (identique dans les 2 claviers) :
Bloc de code:
reboot
et ↩︎
  • ton ordinateur re-démarre > l'OS se charge > mais à la fin tu devrais obtenir un panneau avec une animation musicale (Bienvenue etc. en diverses langues).

Remplis la succession des panneaux avec exactitude comme si tu paramétrais un Mac neuf (Pays, Clavier etc).

Le dernier panneau te propose de paramétrer un compte administrateur comme si c'était le premier. Tu as 2 possibilités -->

- a) tu veux garder la session de l'ancien utilisateur --> tu crées un compte admin bidon avec : Nom de compte = toto > Nom complet = toto > mot-de-passe toto. Ce qui te fais ouvrir une session admin toto. Tu vas à Menu  > Préférences Système > Comptes > tu sélectionnes le nom de l'ancien utilisateur et tu coches la case : "Autorisation à administrer cet ordinateur" (ou quelle que soit le libellé). Tu vérifies à Options --> qu'une préférence d'ouverture automatique de session ne s'est pas inscrite au bénéfice de toto. Tu te délogges de la session toto > tu te loges dans l'autre et tu y es admin désormais.

- b) tu veux créer une session avec des identifiants à toi (je pense dans le contexte que ce serait le bon choix) --> tu renseignes des identifiants personnels à ta guise - pourquoi pas les mêmes que tu emploies pour ton compte sur tes autres Mac (éviter les variations inutiles) ? --> une session neuve s'ouvre - la tienne > que tu pourras personnaliser à ta guise étant admin.
 
  • J’aime
Réactions: baron

Gilrod

Membre confirmé
9 Septembre 2011
21
1
Salut Maco' :)

Wow !! Merci beaucoup pour ta réponse, rapide et précise !

Je pars pour le réveillon ce matin et n'ai pas le temps d'essayer avant, mais je tente dès mon retour lundi et te tiens au courant.

MERCI
encore !! ;)

G.



Salut Gilrod

Démarre le Mac les 2 touches ⌘S (cmd S) tenues pressées = démarrage en Single User (utilisateur unique = root).

Tu accèdes à un écran noir où défilent des lignes blanches de logs d'initialisation. Tu es dans un Terminal de root > en clavier QWERTY logique > et le volume de l'OS n'est disponible qu'en lecture seule.

Attends d'avoir l'invite de commade :
Bloc de code:
root#
pour commencer (si les lignes s'immobilisent sans que tu aies une invite de commande terminée par un # --> presse une fois la touche "Entrée" du clavier pour forcer son affichage.

Je vais te donner les commandes --> d'abord comme tu dois les voir affichées à l'écran > ensuite comment tu dois les taper sur ton AZERTY physique pour qu'elles correspondent au QWERTY logique.

Tape la commande qui s'affiche comme :
Bloc de code:
mount -uw /
et que tu tapes ainsi :
Bloc de code:
,ount )uz =
et ↩︎ (presse la touche "Entrée" du clavier pour exécuter la commande)
  • cette commande remonte le volume en lecture et écriture > ce qui permet d'agir.

Tape la commande qui s'affiche comme :
Bloc de code:
rm /var/db/.AppleSetupDone
et que tu rapes ainsi :
Bloc de code:
r, =vqr=db=:QppleSetupDone
et ↩︎
  • cette commande supprime un fichier vide de finalisation --> ce qui va faire ré-afficher au re-démarrage les panneaux de paramétrage du Mac comme à la fin d'une installation propre

Tape la commande (identique dans les 2 claviers) :
Bloc de code:
reboot
et ↩︎
  • ton ordinateur re-démarre > l'OS se charge > mais à la fin tu devrais obtenir un panneau avec une animation musicale (Bienvenue etc. en diverses langues).

Remplis la succession des panneaux avec exactitude comme si tu paramétrais un Mac neuf (Pays, Clavier etc).

Le dernier panneau te propose de paramétrer un compte administrateur comme si c'était le premier. Tu as 2 possibilités -->

- a) tu veux garder la session de l'ancien utilisateur --> tu crées un compte admin bidon avec : Nom de compte = toto > Nom complet = toto > mot-de-passe toto. Ce qui te fais ouvrir une session admin toto. Tu vas à Menu  > Préférences Système > Comptes > tu sélectionnes le nom de l'ancien utilisateur et tu coches la case : "Autorisation à administrer cet ordinateur" (ou quelle que soit le libellé). Tu vérifies à Options --> qu'une préférence d'ouverture automatique de session ne s'est pas inscrite au bénéfice de toto. Tu te délogges de la session toto > tu te loges dans l'autre et tu y es admin désormais.

- b) tu veux créer une session avec des identifiants à toi (je pense dans le contexte que ce serait le bon choix) --> tu renseignes des identifiants personnels à ta guise - pourquoi pas les mêmes que tu emploies pour ton compte sur tes autres Mac (éviter les variations inutiles) ? --> une session neuve s'ouvre - la tienne > que tu pourras personnaliser à ta guise étant admin.
 

Gilrod

Membre confirmé
9 Septembre 2011
21
1
Salut Macomaniac,

Alors j'ai tout fait comme tu m'as écrit...tout s'est bien passé jusqu'au redémarrage...là il redémarre et affiche le bureau comme s'il ne s'était rien passé.... je n'ai donc pas la succession de panneaux que tu évoques....
Que pasa, por favor ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
87 429
26 630
Forêt de Fontainebleau
Ta session ouverte > va à : Applications > Utilitaires > lance le «Terminal».

Dans la fenêtre ouverte > fais un copier-coller de la commande :
Bloc de code:
ls -al /private/var/db/.AppleSetupDone
et exécute la par une pression sur la touche "Entrée" du clavier

  • si le fichier .AppleSetupDone est présent à la localisation attendue --> tu vas voir s'afficher une ligne de permissions sur le fichier

=> qu'est-ce qui est retourné ?
 

Gilrod

Membre confirmé
9 Septembre 2011
21
1
Ta session ouverte > va à : Applications > Utilitaires > lance le «Terminal».

Dans la fenêtre ouverte > fais un copier-coller de la commande :
Bloc de code:
ls -al /private/var/db/.AppleSetupDone
et exécute la par une pression sur la touche "Entrée" du clavier

  • si le fichier .AppleSetupDone est présent à la localisation attendue --> tu vas voir s'afficher une ligne de permissions sur le fichier

=> qu'est-ce qui est retourné ?
Quand j'ouvre le terminal, dans la fenêtre il y a ça :

"Last login: Mon Jan 1 18:46:50 on ttyp1
Welcome to Darwin!
Ordinateur-de-stephanie:~gilou78$ "

Donc là je dois taper la commande que tu m'indiques ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
87 429
26 630
Forêt de Fontainebleau
Bloc de code:
Ordinateur-de-stephanie:~gilou78$

  • est l'invite de commande du Terminal.

Tu tapes à partir de là la commande indiquée (ou tu en fais un copier-coller direct) et tu l'exécutes avec la touche "Entrée" du clavier.
 

Gilrod

Membre confirmé
9 Septembre 2011
21
1
Ok
J'ai plein de lignes qui se sont affichées...je ne peux pas te faire de capture d'écran car je t'écris depuis mon MacBookPro...
S'il faut je te prends une photo ?
 

Gilrod

Membre confirmé
9 Septembre 2011
21
1
26238391_10215069342829828_1474944811_o.jpg
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
87 429
26 630
Forêt de Fontainebleau
:coucou: Gilrod

Le fichier .AppleSetupDone est bien toujours présent at: /private/var/db. Donc...

... donc tu t'es loupé - sans doute lorsque tu as passé la commande rm en Single User. Tu es bon pour recommencer.

Arpès re-démarrage en Single User > les 3 commandes à passer (l'une après l'autre) sont (telles qu'elles doivent s'afficher à l'écran) -->
Bloc de code:
mount -uw /
rm /var/db/.AppleSetupDone
reboot

et telles que tu dois les taper au clavier AZERTY :
Bloc de code:
,ount )uz =
r, =vqr=db=:QppleSetupDone
reboot

Je pense que tu as dû faire une erreur de caractère ou d'espace dans une de tes saisies. Tu noteras qu'il y a 2 espaces libres dans le 1ère commande > et un seul dans la 2è (il n'y a pas d'espace entre db/ et .AppleSetupDone --> c'est peut-être l'illusion visuelle dont tu as été victime du fait de la présentation dans une fenêtre de code > où le caractère qui suit une barre oblique / en paraît détaché : il ne l'est pas). Essaie cette fois de taper avec exactitude. Si tu supprimes le fichier > tu auras droit à ton animation musicale en fin de re-démarrage.
 

Gilrod

Membre confirmé
9 Septembre 2011
21
1
Ok
Tu sais, je ne savais pas que les espaces comptaient, désolé... j'ai donc du effectivement faire des erreurs...
Je recommence la manip depuis le début...
Donc, 2 espaces dans la 1ère commande :
- entre "t" et ")" et entre "z" et "="
Et un seul dans la 2ème :
- entre "," et "="
That's right ?
 

Gilrod

Membre confirmé
9 Septembre 2011
21
1
AAAARRRRRRRRRRRRGHHHHHH !!!!!
Génial !!!! ça a marché !!!!!!!
Je ne te remercierais jamais assez, MACOMANIAC !!!! T'assures comme une bête !!!
Merci, merci, merci, moustache gracias, et encore MERCI !!!!
(et aussi au passage merci à Baron d'avoir "pris le relais"....)

A bientôt !
 
  • J’aime
Réactions: baron

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
87 429
26 630
Forêt de Fontainebleau
Content pour toi que tu aies réussi.

Sans DVD d'installation de «Panther 10.3» > tu n'avais d'autre solution que le Single User. Toujours pénible pour des utilisateurs qui ne sont pas en clavier QWERTY : Anglais ou Américain.

Bonne Année !
 
  • J’aime
Réactions: litobar71