Anciennes versions d'app

Kenny31

Membre confirmé
27 Avril 2012
161
2
Bonjour,

Depuis la sortie de watchOS 7, certaines applications mentionnent cette version d'OS dans les prérequis en tête de page sur l'app store.
Jusque là rien d'étonnant. Sauf que ces applications existaient déjà sous watchOS 6 voir inférieurs…

Je sais qu'il est possible de télécharger la dernière version compatible avec son OS (si le dev le propose) et ça marche très bien sur mon iPad vieillissant.

Sur watchOS il m'est impossible de télécharger Lumy, Watchsmith, Yahoo météo, et bien d'autres, alors que je les utilisaient avant leur mise à jour (et que j'arrive à télécharger une ancienne version de Lumy sur mon iPad sous iOS 12 ainsi que la toute dernière version sur mon iPhone sous iOS 14). J'ai eu le malheur de désinstaller ces applications et maintenant elle sont impossible à retélécharger… Lorsque je clique sur l'icône, un petit chargement apparait quelques secondes et un message m'invitant à réessayer plus tard apparait.
A terme les anciennes watch vont-elles devenir parfaitement inutilisables au fil des mises à jour d'application ? Ou s'agit-il de ma watch qui ne parvient pas à trouver la dernière version compatible (ce dont je doute) ?

Quelqu'un à t-il une info à ce sujet ? Sachant que la méthode fonctionne sur iOS, pourquoi pas sur watchOS ?

Merci :)
 

Fichiers joints

  • IMG_0065.PNG
    IMG_0065.PNG
    43,1 KB · Affichages: 27
  • IMG_0064.PNG
    IMG_0064.PNG
    17,9 KB · Affichages: 26
Dernière édition:

Kenny31

Membre confirmé
27 Avril 2012
161
2
Bonjour,

J'ai posté hier sur le sujet Application Apple Watch mais je viens de faire une constatation bien pire… Hélas ! Pour ceux que ça intéresse c'est ici.

Comme je le disais, depuis la sortie de watchOS 7, certaines applications mentionnent cette version d'OS en tant que pré-requis en tête de page sur l'app store. C'est déjà le cas sous iOS et macOS mais il est toujours possible de télécharger la dernière version compatible avec son système (si le dev le permet). Sauf sur watchOS… Et c'est là que ça commence à devenir inquiétant.

En effet il est aujourd'hui impossible de télécharger une application dans sa version fonctionnant sous watchOS 6 et inférieur.
Pire ! Si l'application a été mise à jour et que la dernière version nécessite watchOS 7, l'application disparait de votre watch !

Résultat dans quelque temps à part les applications natives, plus rien ne pourra se lancer sur une watch qui ne prend pas la dernière version de l'OS. Et c'est tout simplement scandaleux…

Ne pas avoir accès aux nouveautés n'est pas dérangeant. Ne plus avoir accès à ce qui fonctionnait le jour où je l'ai achetée (ou pas plus tard que ce matin avant la mise à jour de l'app) me met hors de moi. Et cela s'appelle bien de l'obsolescence programmée (et c'est un délit).

Je pense que l'app watch s'appuie toujours sur le binaire présent sur l'iPhone - malgré l'émancipation déguisée de la watch depuis qu'elle dispose de son propre store. Or ayant un iPhone sous iOS 14, je dispose également des mises à jours d'app qui impose watchOS 7. Impossible de rendre la watch autonome avec ses propres applications dans leurs propres versions (comme je le fais avec mon iPad bloqué sous iOS 12), elle est condamnée.

Bravo et merci Apple.

Note de la modération : il était inutile de créer un nouveau message, donc regroupement.
 
Dernière édition par un modérateur: