apache - mysql - php -

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Salut, je travaille sur un IMC acheté y'a un mois, Os 10.4.10.

Je dois créer un site pour le boulot en DMw MX.
Jusqu'à présent, je ne faisais que de la mise à jour ( http://www.healthandfood.be/html/fr/home.htm )

j'ai déjà crée un site de quelques pages,cette fois je dois inclure une identification sur la page après mon index.

Je suis super largué, car novice en MAC...

J'ai fait des recherches depuis hier, un peu partout, mais la foule d'infos à ce sujet est grave fouillis, ou trop compliquée pour moi. (http://forums.macg.co/vbulletin/showthread.php?t=184060&highlight=php )

-------------------------------------------------------------------------------------------------

En gros, hier, avec le terminal ,,'ai été amené à enlever des # .... puis sauvegardé.
J'ai été dans le partage de mes fichiers et j'ai démarré le partage web personnel...
Je suis sur le point d'installer PHPmyAdmin // ou MySQL //

---------------------------------------------------------------------------------------------------

Puis y'a aussi un test qui t'invite a créer une page .PHP, de la tester en local, et ça ça foire grave, j'ai chaque fois ce **** de message404 not found, en gros, si j'ai bien sais, cel veut dire que le fichier n'est pas à la bonne place... et pourtant...

Enfin soit, je nage grave... Mais j'ai envie de capter, et je ne sais pas par quoi commencer.....

J'ai lu tellement de tutos de ces deux jours, puis fait des recherches sur ce site, que j'en suis gavé...

Alors euh, ...:siffle:

Merci d'avance... ....
 

Anabys

Membre expert
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Je te propose deux solutions.

1) Si tu veux comprendre, tu peux lire cet article, ça fera un de plus :) Mais d'après les retours, ceux qui le lisent arrivent en général à faire fonctionner PHP/MySQL.

2) Tu peux éviter de te casser la tête et télécharger MAMP qui installe un environnement Apache/PHP+MySQL pré-configuré et prêt à être utilisé.
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Hello Anabys:

Je te remercie pour ces deux soluces.

Entre temps j'ai installé effectivement MAMP, je vais tester cela en fin de WE, parce que là, c'est écoeurage, grave...


Sympa de ta part.:) :up:
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Voilà, je suis sur le tuto renseigné ci-haut...

En gros, cela marche bien, mais je calle à une étape en fait...

En gros j'ai un message, de dreamweaver qui dit ceci-->

2002 Can't connect to local MySql serveur Through socket'/var/mysql/mysql.sock('2)

J'ai ce message lors de la sélection dde la base de données.

Quand je fais une recherche google à ce sujet, voici ce que je lis

----------------------------------------
A.2.2. Erreur Can't connect to [local] MySQL server
Un client MySQL sous Unix peut se connecter au serveur mysqld de deux fa¸ons différentes : sockets Unix, qui se connectent via un fichier du système de fichiers (/tmp/mysqld.sock par défaut) ou TCP/IP, qui se connecte via un port. Les sockets Unix sont plus rapides que TCP/IP mais ne peuvent être utilisée que pour des connexions locales. Les sockets sont utilisées si vous ne spécifiez pas de nom d'hôte ou si vous spécifiez le nom d'hôte spécial localhost.

Sur Windows, si le serveur mysqld tourne sur 9x/Me, vous ne pouvez vous connecter qu'avec TCP/IP. Si le serveur tourne sur NT/2000/XP et que mysqld a été démarré avec l'option --enable-named-pipe, vous pouvez aussi vous connectez avec un tunnel nommé. Son nom est MySQL. Si vous ne spécifiez pas un nom d'hôte lors de la connexion à mysqld, un client MySQL essayera d'abord de se connecter au tunnel nommé, et si cela ne marche pas il se connectera au port TCP/IP. Vous pouvez forcer l'utilisation des tunnels nommés sous Windows en utilisant . en tant que nom d'hôte.

L'erreur (2002) Can't connect to ... signifie généralement qu'il n'y a aucun serveur MySQL qui tourne sur la machine ou que vous utiliser un mauvais fichier de socket ou un port erroné quand vous essayez de vous connecter au serveur mysqld.

Commencez par vérifier (en utilisant ps ou le gestionnaire de tâches sous Windows) qu'il y a un processus nommé mysqld sur votre serveur ! S'il n'y en a aucun, vous devrez en démarrer un. See Section 2.5.2.3, « Problèmes de démarrage du serveur MySQL ».

Si un processus mysqld est actif, vous pouvez tester le serveur avec l'une des connexions suivantes (le port et le chemin vers la socket peuvent être différents chez vous, bien sûr) :

shell> mysqladmin version
shell> mysqladmin variables
shell> mysqladmin -h `hostname` version variables
shell> mysqladmin -h `hostname` --port=3306 version
shell> mysqladmin -h 'ip de votre hôte' version
shell> mysqladmin --socket=/tmp/mysql.sock version
Notez l'utilisation des guillemets obliques plutôt que les simples avec la commande hostname; cela provoque la substitution de hostname par la valeur courante du nom d'hôte de la machine dans la commande mysqladmin.

-------------------


Oulaaaa... Si il y a de la soluce dans l'air.. ( 1 h 08 ?...):p :p :p :p
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Et ceci ausssi dans la console:
:D :D :D :D :D :D :D :D :D :D :D

chown: /Applications/MAMP/logs/mysql_error_log: Operation not permitted
Starting mysqld daemon with databases from /Applications/MAMP/db/mysql
Using Dreamweaver MX

:nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting: :nailbiting:
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Le dernier message d'erreur...

2013 Lost conection to Mysql server during query
 

Anabys

Membre expert
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Oulaoulaoula, moins vite :p

Déjà, avec MAMP, utilise MAMP et non MAMP PRO. C'est important. MAMP lance MySQL sur ton compte alors que MAMP Pro préfère le compte www/mysql. Or, les deux comptes n'ont pas les mêmes autorisations. Donc MAMP dans un premier temps pour se familiariser, MAMP Pro par la suite si le besoin s'en fait sentir.

Ensuite, toujours avec MAMP, vérifie les ports utilisés (dans les préférences de MAMP) ! MAMP n'utilise pas les ports par défaut ! Si tu décides de conserver les ports fixés par MAMP, tu devras modifier tes adresses, par exemple taper "http://127.0.0.1:8080/" au lieu de "http://127.0.0.1/". Pour MySQL c'est pareil (port à renseigner dans le script PHP).

Finalement, dans la configuration de Dreamweaver : si tu as utilisé l'adresse "http://localhost/MonDossier/MonFichier.php", remplace la par "http://127.0.0.1/MonDossier/MonFichier.php" ou "http://127.0.0.1:8080/MonDossier/MonFichier.php" en utilisant les ports MAMP.
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Woop Anabys !

Je laissse béton pour ce soir...

On verra cela demain...

Merci pour:style: :up: :up: :afraid: ton post
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Hello, voici les ports qui sont renseignés dans le préférences de MAMP:

Port apache 8888
Port MSQL 8889

Ce ne sont pas les ports par défaut.

Je n'utilise pas MAMP pro.

Je nage à grands Flots, et pourtant !

Je recommence le tout..... depuis 0.

C'est parti !
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Voici donc les configurations que j'ai faites et introduites, pour faire mon site, en local...

Téléchargement de MAMP placé dans Applications:

Préférences:

Statut serveur Apache et serveur Mysql ok (vert)

Port apache: 8888
Port MSQL: 8889
Apache : Document Root dans --> / Applications/MAMP/htdocs

----------------------------
Mon site se trouve dans: DD, francoisbrun, Sites, FU
----------------------------

Configuration de Dreamweaver MX:

Nom site: FU

Infos locales:
Dossier racine du site local :DD:Users:francoisbrun:Sites:FU:
Dossier des images: DD:Users:francoisbrun:Sites:FU:images
Adresse HTTP: http://localhost/DD/Users/francoisbrun/Sites/FU/

Infos distantes:
Accès= local / Réseau
Répertoire distant : DD:Users:francoisbrun:Sites:FU:

Serveur d'évaluation:

Modèle de serveur: PHP MysQL
Accès: Local/ Réseau
Dossier du serveur d'évaluation : DD:Users:francoisbrun:Sites:FU:
Préfixe de l'URL : http://localhost/~francoisbrun/Sites/FU/

--------------------------------
Je crée ma base de données, selon un tuto, je la place ou exactement? _db_.sql
Je l'ai placée dans divers endroits ( dans ma racine FU, dans Dreamweaver, samples, database )
--------------------------------

Je suis donc Dreamweaver, et selon le tuto, je vais dans applications, je sélectionne la base de données avec MySQL,

je rentre les données, à savoir
Nom de connection: Membre
Serveur MSQL: localhost
Nom d'utilisateur: root
Mot de passe
Base de données _bd_

J'essaye de voir ce que cela donne, donc, bouton tester, et la, j'ai message qui me dit:

Code erreur 404 non trouvé
Aucun serveur d'évaluation ne s'exécute sur la machine serveur...

-----------------------------------

Donc, en résumé, j'ai testé pas mal de choses, pour voir ou se trouvait ma faute, genre, j'ai essayé de renseigner d'autres adresses HTTP, mais rien n'y fait.....

JE GALère .... Une idée ????????????????

Merci d'avance !

Si ce n'est pas clair, je peux faire des copies d'écran ! (...)( )
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Ensuite, je vais dans Liaisons, et la, malgré que je renseigne ce qu'il faut, j'ai le message suivant--> Pas de table dans ma base de données.

La copie de mon PHP est

<?php
# FileName="Connection_php_mysql.htm"
# Type="MYSQL"
# HTTP="true"
$hostname_Membre = "localhost";
$database_Membre = "_bd_";
$username_Membre = "root";
$password_Membre = "";
$Membre = mysql_pconnect($hostname_Membre, $username_Membre, $password_Membre) or die(mysql_error());
?>

(si cela aide..)
 

Anabys

Membre expert
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Re-oulalalala :p

Bon lol :)

1) Il y a un probl&#232;me &#224; ce niveau :

Apache : Document Root dans --> / Applications/MAMP/htdocs
Mon site se trouve dans: DD, francoisbrun, Sites, FU

Il faut que les deux chemins co&#239;ncident. Tu as donc le choix entre deux options:
- d&#233;placer le contenu de "Sites" dans MAMP/htdocs
- modifier le fichier httpd.conf (quelque part dans le r&#233;pertoire MAMP) en lui indiquant que le nouveau Document Root est "Sites".

2) Tu pourras ensuite acc&#233;der &#224; ton dossier FU en tapant l'adresse suivante :
http://127.0.0.1:8888/FU/

3) Ensuite, tu dois configurer le port du serveur et son adresse dans ton script PHP :
mysql_connect("127.0.0.1:8889", "user", "pass");

(=> je te conseille de tester d'abord avec mysql_connect avant d'essayer mysql_pconnect ; les connexions persistantes ne sont pas autoris&#233;es par tous les serveurs).

Par d&#233;faut, avec MAMP, si je me souviens bien, user = root et pass est vide. Ta configuration est donc correcte sur ce point.

4) On continue avec cela:
Je cr&#233;e ma base de donn&#233;es, selon un tuto, je la place ou exactement? _db_.sql
Je l'ai plac&#233;e dans divers endroits ( dans ma racine FU, dans Dreamweaver, samples, database )

Contrairement &#224; SQLite, les bases de donn&#233;es MySQL ne sont pas stock&#233;es dans des fichiers librement accessibles sur le disque (les donn&#233;es sont bien dans des fichiers, mais il faut passer par le serveur MySQL pour y acc&#233;der).

Le fichier .sql contient des instructions &#224; envoyer au serveur, mais il ne contient pas de donn&#233;e directement exploitable (=> dans le cas d'un dump, il contient bien les donn&#233;es, mais il faut les ins&#233;rer dans les tables en passant par le serveur avant de pouvoir les exploiter).

Bref, tout &#231;a pour dire que tu dois d'abord cr&#233;er une base, avant de pouvoir l'utiliser. Pour cela, tu as 2 possibilit&#233;s:
- cr&#233;er la base en ligne de commande (je ne d&#233;taille pas, tu n'utiliseras pas cette m&#233;thode de toute fa&#231;on ^^)
- cr&#233;er la base avec phpMyAdmin.

Tu peux acc&#233;der &#224; phpMyAdmin &#224; partir de MAMP (je ne sais plus exactement o&#249; c'est, cherche dans le logiciel lui-m&#234;me ou sur la page d'accueil http://127.0.0.1/ )

5) Apr&#232;s avoir fait tout cela, ta connexion devrait fonctionner. Un peu de lecture pour la suite :D
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Hellow !!!

Je fais cela maintenant, j'ai déjà déplacé mon fichier vers htdocs..

Je te tiens informé, c'est ajd ou jamais !

woop et Merci !
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
1 // Waw,.. alors, j'ai suivi tes conseils, mon dossier FU se
trouve bien dans htdocs.

Rem --> Lorsque je tappe http://127.0.0.1:8888/FU/ il ne se passe rien.


2// Tu parles de connect, et de P connect... Euh, pour ces données, obtenues en double cliquant sur le fichier Membre.php, créé automatiquement lors de l'exportation de ma base de données.

(FU // Connections // )

il suffit juste de supprimer le p de pconnect?

3 // Je ne connais tjs pas la place de mon fichier .sql !!!

Ps-> La base de données est faite, 4 champs, mais c'est dreamweaver qui ne la reonnait pas !
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Et losque j'eesaie ceci, en gros, un message de dreamweaver me dit que le préfixe n'est pas ok...
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Le point positif, dans l'histoire c'est que lorque je rentre "http://127.0.0.1:8888/FU/"
dans le paramétrage Dwr, le test est acepté...

Mais maintenant, quand j'essaie de connecter la base de doonées, un message apparait
---> Une erreur indéterminée s'est produite...

Alala , un positif pour un négatif... Tsssss:( :( :) :) :rateau: :rateau: :sleep: :sleep: :eek: :D
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
Ma console me crie:

chown: /Applications/MAMP/logs/mysql_error_log: Operation not permitted
Starting mysqld daemon with databases from /Applications/MAMP/db/mysql
Aug 26 21:19:47 FranZz crashdump[9900]: Dreamweaver MX crashed
Aug 26 21:19:47 FranZz crashdump[9900]: crash report written to: /Users/francoisbrun/Library/Logs/CrashReporter/Dreamweaver MX.crash.log
 

FranZz

Membre actif
19 Juillet 2007
403
9
Namur
J'ai lu ceci, je l'ai fait, mais j'ai tjs mon message d'erreur....

Et oui en faite, et je dis ça pour tout ceux qui ont ou aurons un jour ce soucis, il faut donc supprimer les fichiers du répertoire "_mmServerScripts".
Ce répertoire ce trouve à la racine du répertoire de votre site configurer dans DW. Vous suivez toujours ?

Ce sont normalement 3 fichier qui s'y trouvent :

ADODB.php
MMHTTPDB.php
mysql.php

Ces trois fichiers servent à DW pour tester la connection à la bdd comme dis sur ce lien donné déjà précèdement : http://www.macromedia.com/support/dreamwea...error_mysql.htm

Donc, revenons en à nos moutons : une fois ces trois fichiers supprimés, DW va tout simplement les recréer et ainsi vous vous retrouver avec 3 fichiers sains.

Voilà c'est tout simple ! enfin ça a marché pour moi mais il semblerais qu'il existe d'autres solutions sur le site de Macromédia (voir tjrs le mm lien ci-dessus) au cas où.

M'enfin...je suis un peu dégoutter quand même parce que ce soucis je l'avais déjà rencontrer et c'est en copiant ces trois fichiers d'un autres sites sain et en écrassant ceux du sites qui ne fonctionnait pas que j'avais résolu mon problème. Sauf que là, j'ai déjà fais ça hier soir sans résultat ! je pensais donc que ça provenais d'ailleur ! mais non il suffisais de les supprimer...