Applet Java sous Mountain Lion

Rem64

Membre confirmé
8 Avril 2011
123
0
Bonjour à tous,

mon problème est a la fois simple et pénalisant.

Disons pour faire simple que je vais sur un site qui a besoin d'un applet Java pour fonctionner. Sauf qu'avec cette s....rie de Mountain Lion (eh oui désolé mais je préférais l'animal avec la crinière) les sécurités empêche l'execution des applets alors que l'on pouvait accepter de les lancer auparavant. Maintenant la fenetre de sécurité empeche l'activation de l'applet. Il y a une fenetre qui apparait entre temps pour autoriser mais pas le temps de quitter que tout se bloque.

Merci pour votre aide. Ca sent le truc pour verouiller des formats et langages a la sauce apple. J'aodre leurs produits mais il y a des fois ils sont pas clairs!!
 

otgl

Membre émérite
20 Février 2012
879
18
Bonjour à tous,

mon problème est a la fois simple et pénalisant.

Disons pour faire simple que je vais sur un site qui a besoin d'un applet Java pour fonctionner. Sauf qu'avec cette s....rie de Mountain Lion (eh oui désolé mais je préférais l'animal avec la crinière) les sécurités empêche l'execution des applets alors que l'on pouvait accepter de les lancer auparavant. Maintenant la fenetre de sécurité empeche l'activation de l'applet. Il y a une fenetre qui apparait entre temps pour autoriser mais pas le temps de quitter que tout se bloque.

Merci pour votre aide. Ca sent le truc pour verouiller des formats et langages a la sauce apple. J'aodre leurs produits mais il y a des fois ils sont pas clairs!!

Il faut:
  1. Aller dans Applications > Utilitaires > Préférences Java.
  2. Cliquer sur l'onglet Options avancées.
  3. Sous "Vérifier la sécurité", choisir "exécution avec des protections, pas d'avertissement".
 

Rem64

Membre confirmé
8 Avril 2011
123
0
Il faut:
  1. Aller dans Applications > Utilitaires > Préférences Java.
  2. Cliquer sur l'onglet Options avancées.
  3. Sous "Vérifier la sécurité", choisir "exécution avec des protections, pas d'avertissement".

Non ca ne marche pas, j'ai toujours la fenêtre qui apparait puis un message de Java qui m'interdit l'accès a l'applet alors que j'ai fait ce que tu as indiqué et que j'ai approuvé le certificat (c'est un site que je connaissais avant et qui n'a jamais posé de probleme)

Bref je sais pas ce qu'ils ont foutu mais trop de sécurité tue la sécurité

quelqu'un aurait une autre solution?
 

otgl

Membre émérite
20 Février 2012
879
18
que j'ai approuvé le certificat

Vu qu'il y a certificat, peut-être que Mountain Lion considère ton applet Java comme une application à part entière. Essaie ceci:
  1. Aller dans  > Préférences Système > Sécurité et confidentialité.
  2. En bas à gauche de la fenêtre, cliquer sur le cadenas.
  3. Entrer le mot de passe.
  4. Sous "Autoriser les applications téléchargées", choisir "N'importe où".
Si le problème n'est toujours pas résolu, donne-nous le message exact qui s'affiche à l'écran, ou envoie-nous une capture d'écran.
 

Rem64

Membre confirmé
8 Avril 2011
123
0
Merci pour le truc, j'ai fini par faire fonctionner en essayant d'installer une nouvelle application.

Avouez franchement que rajouter des sécurité pour que l'on passe 3 plombes a se demander ce qu'il se passe c'est pas très cool de la part d'Apple. je sais que le but est d'être user friendly au max mais de la a verrouiller les Macs faudrait qu'ils se calment!
 

werthers

Nouveau membre
26 Août 2011
4
0
Vu qu'il y a certificat, peut-être que Mountain Lion considère ton applet Java comme une application à part entière. Essaie ceci:
  1. Aller dans  > Préférences Système > Sécurité et confidentialité.
  2. En bas à gauche de la fenêtre, cliquer sur le cadenas.
  3. Entrer le mot de passe.
  4. Sous "Autoriser les applications téléchargées", choisir "N'importe où".
Si le problème n'est toujours pas résolu, donne-nous le message exact qui s'affiche à l'écran, ou envoie-nous une capture d'écran.

Merci ! On peut donc installer ce dont on a besoin et remettre ensuite les options par défaut.