MacBook Air Aucune caméra disponible

llaber

Membre junior
11 Juillet 2020
22
0
37
Bonsoir,

Je me permets de remonter ce post plutôt que d'en créer un nouveau étant donné que je suis dans la même situation.

Dans mon cas, j'ai un MBP 15 unibody de mi-2012 qui fonctionnait jusqu'à la semaine dernière sur Mojave, et que j'ai finalement mis à jour sous Catalina la semaine dernière, cédant aux nombreuses notifications de mise à jour système...

J'ai essayé aujourd'hui de passer un appel skype et me suis rendu compte que ma webcam ne fonctionnait pas. Après une recherche sur Internet, j'ai vu que ce n'était pas vraiment un cas isolé suite à la mise à jour Catalina...

Dans toutes les applis nécessitant une caméra, j'ai un message d'erreur, et dans le rapport système, aucune camera n'est detectée, que ce soit dans la rubrique USB ou Appareil Photo...
facetime.png

rapport appareil photo.png

rapport USB.png


Voici ce que j'ai fait jusqu'à maintenant :
  • reset SMC / NVRAM
  • essai de création d'un nouveau compte utilisateur
  • vérification dans "temps d'écran" que la camera n'était pas désactivée
  • démarrage en mode sans echec
  • formatage et downgrade sous Mojave, puis re-mise à jour sous Catalina
  • démarrage depuis un disque externe sous High Sierra
  • débranchement / rebranchement de la nappe de webcam
...

Je n'ai à aucune de ces étapes réussi à obtenir un fonctionnement de la caméra, et je commence à être à cours d'idées :(

Je suis passé chez un réparateur Mac près de chez moi aujourd'hui qui m'a dit que selon lui c'était un problème matériel, opinion partagée par le service de support Apple, joint aujourd'hui par téléphone...

Je trouve quand même étonnant que la mise à jour vers Catalina ait pu provoquer un tel problème (alors qu'encore une fois, ma webcam fonctionnait parfaitement sous Mojave) et que je ne suis pas un cas isolé (notamment plusieurs topics sur discussions.apple.com).

Par chance, j'ai encore la possibilité de brancher une webcam externe, qui elle est reconnue, mais franchement, c'est une galère de devoir en passer par là alors que tout fonctionnait parfaitement jusqu'à la semaine dernière !

Mes options sont donc les suivantes :
  • réparation "magique" de la caméra... :troll:
  • utilisation permanente d'une camera externe :banghead:
  • désossage de l'écran pour remplacer la camera en espérant que le problème vienne bien d'elle :eek:
  • remplacement total de l'écran (y compris la caméra) en espérant à nouveau que le problème vienne vraiment de là :dead:

Merci à vous pour vos suggestions qui pourront peut être m'aider à explorer de nouvelles pistes !
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
48 850
8 890
Nancy___
Je trouve quand même étonnant que la mise à jour vers Catalina ait pu provoquer un tel problème (alors qu'encore une fois, ma webcam fonctionnait parfaitement sous Mojave)
Ou alors il s'agit d'une coïncidence, la webcam tombe en panne au moment de la màj de ton OS…
Je ne vois pas quoi faire d'autre en plus de tout ce que tu as fait, surtout que tu as testé le démarrage sur un disque externe avec High Sierra (c'est ce que je voulais te suggérer en lisant le début de ton post).

Le problème peut provenir de la caméra ou bien de la nappe (celle que tu as débranchée - rebranchée).
 

llaber

Membre junior
11 Juillet 2020
22
0
37
Penses tu que pour verifier le diagnostic, je pourrais essayer de brancher (sans forcement tout démonter) la nappe de ma cam sur la carte mère du MBP de mon épouse et voir si celui ci la détecte, ou inversement, la nappe de sa cam sur ma carte mère ?
J'espère ne pas lui griller SA cam en faisant ça, sinon je suis bon pour dormir sur le canapé !!!

son MBP est un 13 pouces de mi-2013 également, je ne suis pas absolument sur que la connectique soit la même, il faut que je vérifie...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
48 850
8 890
Nancy___
Penses tu que pour verifier le diagnostic, je pourrais essayer de brancher (sans forcement tout démonter) la nappe de ma cam sur la carte mère du MBP de mon épouse et voir si celui ci la détecte, ou inversement, la nappe de sa cam sur ma carte mère ?
Sur le principe, ça m'apparait intelligent comme test :up:


J'espère ne pas lui griller SA cam en faisant ça, sinon je suis bon pour dormir sur le canapé !!!
Ma femme serait plutôt à m'envoyer dormir sur le paillasson :eek::hilarious:


son MBP est un 13 pouces de mi-2013 également, je ne suis pas absolument sur que la connectique soit la même, il faut que je vérifie...
Regarde les tutos de démontage sur iFixit.com pour voir si les nappes ont l'air d'être identiques.
 

llaber

Membre junior
11 Juillet 2020
22
0
37
Bon, j'ai profité que Madame dormait pour venir lui subtiliser son Macbook, et après quelques sueurs froides (bah oui, elle est quand même toute fine la nappe de camera, un éternuement est si vite arrivé ! o_O), en démarrant MON macbook branché à SA caméra (les connecteurs étaient identiques...), je n'ai toujours pas de retour vidéo, ni de peripherique video détecté dans le rapport système.

Je me dis que c'est peut être comme j'ai installé le système sans caméra, qu'il ne la détecte pas maintenant que j'en branche une, mais d'un autre côté, il détecte quand je branche une webcam USB...

Bref, je ne sais pas trop quoi penser de cette expérience, le problème viendrait il de la carte mère ? du connecteur ? (j'ai vérifié, la cam fonctionne sur sa machine après remontage.... ouf ! :D)
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
48 850
8 890
Nancy___
je n'ai toujours pas de retour vidéo, ni de peripherique video détecté dans le rapport système.
Aie, ça devient embêtant.
EN même tu viens de démontrer qu'il n'est pas nécessaire que tu achètes une nouvelle nappe ou webcam.


Je me dis que c'est peut être comme j'ai installé le système sans caméra, qu'il ne la détecte pas maintenant que j'en branche une,
Non, MacOS ne fait pas ce genre de chose.


le problème viendrait il de la carte mère ? du connecteur ?
Du coup, oui ça pointe clairement vers un souci de carte mère, d'autant que tu as déjà testé d'autres OS sur un disque externe.