10.8 Mountain Lion Bloquée sur "Mac OS X Base System" à la réinstallation

Videal9

Membre junior
12 Octobre 2020
50
1
28
Bonjour @macomaniac, j'ai réussi à réinstaller une session Mountain lion mais sur une clé usb et non pas sur le disque dur externe. Sais tu comment mettre l'installation de Mountain Lion sur le disque dur pour que je puisse ensuite faire les mises à jour jusqu'à High Sierra ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 174
23 735
Forêt de Fontainebleau
Content déjà pour toi !

- tu trouves un Terminal dans la session de ta clé at: Applications > Utilitaires > Terminal. Passe une commande :​
Bloc de code:
diskutil list
  • qui affiche le tableau des disques

Poste le retour en copier-coller (via Safari) > en faisant le coller dans un Bloc de code (c'est plus lisible !) par le procédé suivant -->

- en bas de cette page des forums MacGé => utilise le menu (le 16è depuis la gauche = vers le milieu de la barre) dans la barre de menus au-dessus du champ de saisie d'un message > sous-menu : </> (= Bloc de code) => tu fais ton coller dans la fenêtre de code et Continuer.​

=> ces informations montreront la situation générale.
 

Videal9

Membre junior
12 Octobre 2020
50
1
28
Bloc de code:
Last login: Sun Oct 18 11:28:12 on console
macbook-pro-de-de:~ Virginie$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2: 7C3457EF-0000-11AA-AA11-00306543ECAC               499.9 GB   disk0s2
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *30.8 GB    disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                  Apple_HFS CLE                     29.9 GB    disk1s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk1s3
macbook-pro-de-de:~ Virginie$
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 174
23 735
Forêt de Fontainebleau
Je vois qu'une partition de secours avec un volume Recovery HD a bien été créée sur le disque de la clé > en accompagnement du volume de l'OS CLE. Quant à la partition principale du disque interne > elle porte la mention :
Bloc de code:
7C3457EF-0000-11AA-AA11-00306543ECAC
  • qui est l'UUID désignant universellement le type de partition "Apple_APFS". Cet UUID n'est mentionné dans un tableau de diskutil => que quand l'OS démarré ne reconnaît pas le format apfs > lui étant antérieur. C'est le cas ici avec l'OS Mountain Lion démarré du volume CLE.

Passe la commande (copier-coller) :
Bloc de code:
diskutil eraseVolume jhfs+ "Macintosh HD" disk0s2 ; diskutil list disk0
  • qui reformate la partition interne en jhfs+ > et reforme un volume Macintosh HD standard > puis affiche la configuration du disque interne seul

Poste le retour.
 

Videal9

Membre junior
12 Octobre 2020
50
1
28
Bloc de code:
Last login: Sun Oct 18 11:28:38 on ttys000
macbook-pro-de-de:~ Virginie$ diskutil eraseVolume jhfs+ "Macintosh HD" disk0s2 ; diskutil list disk0
Started erase on disk0s2
Unmounting disk
Erasing
Initialized /dev/rdisk0s2 as a 465 GB HFS Plus volume with a 40960k journal
Mounting disk
Finished erase on disk0s2 Macintosh HD
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            499.8 GB   disk0s2
macbook-pro-de-de:~ Virginie$

--------------------------------
Note du modérateur de service (ici Aliboron) :

Merci de mettre les copies de compte-rendus de Terminal entre des balises de "Bloc de code". On les trouve dans la barre d'outils, en dessous du deuxième bouton avec trois petits points :

Bloc de code.png
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 174
23 735
Forêt de Fontainebleau
Volume Macintosh HD disponible.

----------

Utilise ce lien : ☞Télécharger Carbon Copy Cloner☜ > descends dans la page > et utilise le bouton vert : Download CCC 4 pour télécharger une version de Carbon Copy Cloner supportée par Mountain Lion. Il s'agit d'un logiciel de clonage qui te permet une démo gratuite pleinement fonctionnelle. Déplace le logiciel dans les Applications.

----------

Lance-le et définis les options suivantes : source = CLE > destination = Macintosh HD => lance le clonage.

- à la fin > le logiciel devrait te demander si tu veux qu'il crée une partition de secours Recovery HD sur le disque de destination => tu valides bien sûr.​

----------

Quand tout est fini et s'il n'y a pas eu de problème > redémarre > la touche "alt" pressée pour obtenir l'écran de choix du volume de démarrage. Choisis : Macintosh HD > démarre dessus -->

- tu n'auras qu'à dire si tu as pu ouvrir une session dans le volume interne cloné d'après le volume CLE.​
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 174
23 735
Forêt de Fontainebleau
Bien sûr : le Mac démarre sur Macintosh HD.

- si tu veux un démarrage automatique sur ce volume > va à : Menu  > Préférences Système > Disque de démarrage. Sélectionne Macintosh HD > puis referme le panneau des Préférences Système. Cette sélection aura inscrit en NVRAM une préférence de démarrage automatique sur le volume pour l'EFI (le programme interne de boot primaire de la carte-mère).​
 

Videal9

Membre junior
12 Octobre 2020
50
1
28
J'ai sélectionné Macintosh HD dans "préférences système" mais quand j'ai redémarré ensuite (sans appuyer de touche) et sans la clé, le dossier point d'interrogation est revenu.. Ou un écran blanc. J'ai l'impression que ça fonctionne que si la clé est branchée

Je n'arrive qu'à l'allumer sur Macintosh HD en appuyant sur alt au démarrage sinon ça ne marche pas. Même pour la clé j'ai l'impression
 
Dernière édition:

Videal9

Membre junior
12 Octobre 2020
50
1
28
Oui je fais redémarrer et ça rouvre la session. Mais depuis ça marche plus dès que je veux ouvrir sans appuyer sur une touche au démarrage. Là j'ai relancé un clonage je me dis que c'est peut être ça qui s'est mal passé. J'ai mal fait ?
 
Dernière édition par un modérateur:

Videal9

Membre junior
12 Octobre 2020
50
1
28
MacBook Pro mi 2012 13pouces.
J'ai relancé le clonage, ça s'est bien passé. J'ai redémarré avec alt et choisi Macintosh HD, ça m'a affiché un rond barré puis ça a quand même ouvert ma session. J'ai éteint puis redémarré sans rien appuyer et en enlevant la clé mais là, ça m'affiche un dossier avec un point d'interrogation et ne me donne pas accès à ma session.
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
77 174
23 735
Forêt de Fontainebleau
D'accord -->

- ton modèle de Mac spécifique : MacBook Pro 13" mi-2012 => a un talon d'Achille : la défaillance de la nappe SATA qui relie le disque à la carte-mère en assurant l'alimentation et le transfert des données au processeur en 2 filières séparées. Je conjecture que c'est ce qui t'arrive. Il est facile de commander une nappe spécifique à ce modèle de Mac chez MacWay (dans les 20€) et de la changer soi-même en s'aidant d'un tuto d'iFixit (trivial).​
- ton modèle de Mac est également affligé d'un HDD (disque rotatif à plateaux) qui tourne à la vitesse anémique de 5400 tr/mn. Autant dire que la vitesse de fonctionnement en session décroît avec l'installation des OS les plus récents - surtout s'ils forcent le format apfs sur le disque. Si tu avais quelques sous à dépenser en sus de la nappe SATA => remplacer le HDD par un SSD (marque Crucial par exemple - gabarit 2,5") transfigurerait la vitesse de fonctionnement. En gros tu passerais d'un débit de 50 Mo/s environ en lecture / écriture => à près de 500 Mo/s : soit un x10. Remplacement de disque aussi trivial que celui de la nappe (voir tuto iFixit encore).​
 

Videal9

Membre junior
12 Octobre 2020
50
1
28
D'accord... Mais j'ai déjà changé le disque dur en février (mais pas en ssd) et la nappe en juin. C'est possible que ce soit encore ça ?
 
Dernière édition par un modérateur:

Videal9

Membre junior
12 Octobre 2020
50
1
28
Ça a l'air d'être la nappe SATA car, branché en externe, le Mac démarre. Mais je l'ai déjà changé il y a 4 mois...
 
Dernière édition par un modérateur: