Buzz sortie son MacBook

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Bonjour, j'ai un souci avec la sortie son de mon MacBook. J'ai bien cherché et il semble que personne n'a encore signalé un problème similaire. :(

Lorsqu'il est sur mon bureau, mon MacBook est en permanence relié à ma chaîne hi-fi via un jack stéréo branché sur la sortie son. Je peux donc écouter le contenu d'iTunes sur ma chaîne hi-fi. J'avais remarqué que lorsque le mac fonctionnait sur la batterie, et non sur le secteur, un buzz se faisait entendre dans les enceintes de la chaîne après exactement 30 secondes d'inactivté de la carte son de l'ordinateur. J'avais attribué cela à quelque chose comme une "mise en veille" de la carte son pour économiser la batterie. Jusque là, ça n'avait aucune importance.

Depuis cet après midi, le problème apparaît également lorsque mon MacBook est branché sur le secteur, ce qui est le cas 90% du temps quand je suis chez moi. Donc, là, ça devient franchement gênant, :mad: car 30 secondes après le dernier son émis par l'ordi (ex: le "bip" du réglage du son, ou encore iTunes), le buzz se fait entendre dans les enceintes. Pour l'arrêter, il faut obliger le mac à émettre un son à nouveau. Puis le problème revient, après 30 secondes, à chaque fois.

Que faire ? J'ai essayé de rédemarer le mac, de réparer les autorisations du disque. Je ne sais pas quoi essayer d'autre. :rose:

J'espère que mon explication est claire et que quelqu'un aura une idée concernant mon problème. Merci d'avance. :)
 

Fractal

Membre confirmé
8 Juillet 2006
152
6
41
Bruxelles, BE
Etrange !

Soit le son est effectivement généré par la "carte son" du MacBook, soit il s'agit d'un rayonnement que le Macbook émet et qui est capté par ton cable.

Tu devrais peut-être faire un essai avec un cable de meilleure qualité (blindage) pour être sur que le problème ne vient pas de la.

Assure toi aussi que le volume est bien réglé (évite le 5% sur Macbook et ta chaine hifi à fond!, mets plutot ton macbook à fond, et règle le volume avec ta chaine)
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Oui, j'avais envisagé que le problème vienne du cable. Il s'agit d'un jack stéréo 3,5 de 10 mètres de long, donc forcément c'est pas l'idéal en terme de qualité. J'avais eu précédement un autre problème (reglé) avec ce cable, car il captait une interférence venant d'une prise électrique. :hein:

Mais maintenant, il semble que le Mac y soit aussi pour quelque chose, puisque qu'en entend très clairement le buzz s'arrêter avant que l'ordi émette un son, puis reprendre systématiquement après une durée fixe.

Etrange, c'est le mot.
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
C'est presque rassurant de savoir que le problème existe aussi ailleurs. (Mais je compatis à ton problème, miz_ici).

Et c'est vrai que ce problème peut être très gênant: j'envisage par exemple d'utiliser mon MacBook sur scène avec mon groupe lors de concerts, et s'il doit envoyer un buzz dans la sono dès qu'il est inactif, ça va devenir très problématique !

Dernier détail troublant : le problème n'apparaît pas au casque. Je ne comprends pas. :mouais:
 

Fractal

Membre confirmé
8 Juillet 2006
152
6
41
Bruxelles, BE
Si ca n'apparait pas au casque alors il reste 2 solutions :

- Soit le cable de 10mètres est vraiment pourri. (De toute facon, 10m c'est trop pour du Jack/Cinch)
- Soit c'est lié à l'impédance de la chaine hifi/casque (Vu du Macbook, la charge n'est pas la même que ce soit une chaine hifi ou un casque)

Quand tu branches ta chaine hifi, il affiche quoi dans Préférences/Son/Sortie/Port ?

Moi même j'ai eu un problème à ce niveau là: quand je branche mon macbook en direct sur mon home cinema, il ne sort aucun son... Je suis obligé de passer par la TV (Macbook => TV => Home cinema)
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Alors, dans Préférences/Son/Sortie/Port, lorsque je branche mon jack, il m'indique "écouteurs".

J'ai essayé de relier mon MacBook à ma chaîne hi-fi avec un cable plus court (1,5m), et le buzz devient quasi imperceptible (il est toujours là, mais on le devine tout juste). Ce n'est donc sans doute pas une bonne idée d'utiliser un cable si long ; mais, bon, à moins de déplacer les meubles, je n'ai pas le choix. :nailbiting:

Ce qui est tout de même bizarre dans cette histoire, c'est que ce buzz s'est déclaré subitement après 5 mois d'utilisation de mon Mac dans des conditions rigoureusement indentiques. :mouais:

La solution de fortune consiste à mettre le volume de la source (mac) au maximum et de régler le volume avec la télécommande de la chaîne. C'est dommage, parce que jusqu'ici, c'était bien pratique de pouvoir régler le volume de la musique depuis OSX ou même avec l'apple remote. :(

Aaaaah, Airtunes, si j'avais des sous :rolleyes:
 

cameleone

Membre d’élite
Club MacG
22 Mars 2005
1 834
119
50
Nice
Ce qui est tout de même bizarre dans cette histoire, c'est que ce buzz s'est déclaré subitement après 5 mois d'utilisation de mon Mac dans des conditions rigoureusement indentiques. :mouais:
As-tu fait la mise à jour en 10.4.10 récemment ?
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
As-tu fait la mise à jour en 10.4.10 récemment ?
Oui. Mon problème a commencé l'après-midi où j'ai fait la mise à jour (jeudi). Seulement voilà, je n'arrive pas à me souvenir si le problème a commencé juste avant ou juste après que j'aie fait la mise à jour. Je pencherais pour après.... :hein: Est-il possible qu'il y ait une relation ?
 

cameleone

Membre d’élite
Club MacG
22 Mars 2005
1 834
119
50
Nice
Oui. Mon problème a commencé l'après-midi où j'ai fait la mise à jour (jeudi). Seulement voilà, je n'arrive pas à me souvenir si le problème a commencé juste avant ou juste après que j'aie fait la mise à jour. Je pencherais pour après.... :hein: Est-il possible qu'il y ait une relation ?
Plus que probable. Regarde mes messages dans le fil consacré à la mise à jour 10.4.10
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Plus que probable. Regarde mes messages dans le fil consacré à la mise à jour 10.4.10
Cameleone, nous avons exactement le même problème ! Et il semblerait effectivement que ce problème soit apparu suite à la mise à jour 10.4.10, si on en croit les post que tu cites dans l'autre fil. Les symptômes décrits sont exactement les miens (ce "pop" sourd lorsque la "carte son" semble entrer et sortir de veille).

Quelqu'un propose une solution qui consiste à faire tourner un mp3 vide en boucle en tâche de fond afin d'enrayer le problème. Je n'aime pas beaucoup cette solution.

Que faire ? attendre 10.4.11 ? :mad:

Cameleone, pour ma part, je n'utilise pas la sortie du MacBook en optique mais en analogique. Le problème est donc commun aux deux.

This used to happen only on battery, now it's happening on AC as well.
C'est pareil chez moi.

Et voici un résumé du problème qui me semble pertinent :
I have the same issue and am on a MacBook Core Duo 2.0Ghz. Just so you know what the sound is:

The sound is the sound of the audio chip going into power save mode. If you play a sound after it goes into power save mode, the audio system will make the same thump sound (if you have big speakers like mine) and the sound will play.

This is expected behavior when you are running a laptop and on battery power. It is not supposed to do this on AC power. So Apple really screwed something up as now it does it all the time. Can't have this. Apple, please fix this mess pronto!
 

cameleone

Membre d’élite
Club MacG
22 Mars 2005
1 834
119
50
Nice
Attendre Léopard ? :D Ou bien une Security update intermédiaire...
A moins que quelqu'un ne trouve comment régler la mise en ville sur plus de 20 secondes, ou bien comment la désactiver sur alimentation AC.
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Mmmh, oui, c'est sans doute pour faire passer tout le monde à Léopard qu'Apple nous colle un bug sur une des dernières mises à jour de Tiger. Jusqu'ici il ronronnait tranquillement... :siffle: ;)

En tout cas, si solution il y a, elle viendra peut-être de ce fil sur le forum Apple.

En attendant, on a le choix entre écouter de la musique tout le temps ou pas du tout. :D
 

cameleone

Membre d’élite
Club MacG
22 Mars 2005
1 834
119
50
Nice
Il y a également une solution donnée sur ce fil du forum Macbidouille (utilisation du soft LineIn). Je viens d'essayer, ça marche. Mais bon, ça reste j'espère temporaire...:rolleyes:
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Il y a également une solution donnée sur ce fil du forum Macbidouille (utilisation du soft LineIn). Je viens d'essayer, ça marche. Mais bon, ça reste j'espère temporaire...:rolleyes:
Merci, je vais aller voir. En espérant aussi que ce soit temporaire. En attendant, je découvre les joies de la section "Mac OSX Feedback" du site d'Apple. :p

Edit : En effet, ça marche. C'est mieux que rien pour l'instant.
 

gwena

Membre émérite
8 Novembre 2002
636
6
36
nancy
www.speeddesign2003.com
c'est quoi exactement comme son?
parce que j'entend une sorte de sifflement aigue et perso, j'ai plutot l'impression que ça vient de l'alim...
j'ai deja remarqué ça avec le macmini de mon père et mon g4 quand j'active un mod spécial d'économie des proce
 

Jellybass

Membre émérite
31 Mai 2006
933
52
Manchester
benguilbaud.com
Gwena, je pense que ton problème est celui souvent appelé "whine". Je ne veux pas m'étendre sur ce sujet ici, car il existe de très nombreux fils sur ce sujet. Essaie la fonction recherche. :)

En attendant, toujours pas de correctif pour le problème de la sortie son sur les Mac Intel. :(