10.12 Sierra Clé USB non détectée lors du démarrage avec ALT

dufossezmicka

Membre junior
6 Juillet 2019
36
2
30
voici le diskutil list depuis l'iMac en question :

Bloc de code:
-bash-3.2# diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *1.0 TB     disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS MACINTOSH HD            999.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        +2.1 GB     disk1
   1:                  Apple_HFS OS X Base System        2.0 GB     disk1s1
/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *160.0 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS CLE                     53.9 GB    disk2s2
   3:                  Apple_HFS Install OS X Yosemite   105.7 GB   disk2s3
/dev/disk3 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +5.2 MB     disk3
/dev/disk4 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk4
/dev/disk5 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk5
/dev/disk6 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk6
/dev/disk7 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk7
/dev/disk8 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk8
/dev/disk9 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +6.3 MB     disk9
/dev/disk10 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +2.1 MB     disk10
/dev/disk11 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +1.0 MB     disk11
/dev/disk12 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk12
/dev/disk13 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +524.3 KB   disk13
/dev/disk14 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +1.0 MB     disk14
/dev/disk15 (disk image):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                            untitled               +6.3 MB     disk15
-bash-3.2#
Que se passe-t-il si tu laisses le Mac démarrer sur l'installation d'El Capitan ?
ça commence comme si ca installait puis j'ai le message d'erreur aucun paquet n'a pu être installé... même en mettant la date à plusieurs date car j'ai cru comprendre que ca pouvait poser problème mais rien n'y fait
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 704
21 519
Forêt de Fontainebleau
Passe les commandes (séparément) :
Bloc de code:
ls /Vol*/MAC*
bless --info /Vol*/MAC*
  • qui affichent : les objets de 1er rang de MACINTOSH HD > puis son chemin de démarrage actuel

Poste les retours.
 

dufossezmicka

Membre junior
6 Juillet 2019
36
2
30
voici la reponse aux deux commandes bless et info :::


sur l'imac en panne evidement

Bloc de code:
-bash-3.2# ls /Vol*/MAC*
.IAProductInfo        .Trashes        private
.OSInstallerMessages    macOS Install Data
-bash-3.2# bless -- /Vol*/MAC*
No volume specified
-bash-3.2# bless --info /Vol*/MAC*
finderinfo[0]:     44 => Blessed System Folder is <missing>
finderinfo[1]:     48 => Blessed System File is <missing>
finderinfo[2]:      0 => Open-folder linked list empty
finderinfo[3]:      0 => No alternate OS blessed file/folder
finderinfo[4]:      0 => Unused field unset
finderinfo[5]:     44 => OS X blessed folder is <missing>
64-bit VSDB volume id:  0x770E99B31EBDC2E4
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 704
21 519
Forêt de Fontainebleau
Il y a dans le volume un dossier macOS Install Data dédié à la réception des ressources d'une installation. Classiquement ce dossier s'institule OS X Install Data (pour les OS jusqu'à High Sierra compris). Un dossier macOS Install Data provient d'une tentative d'installation d'un OS apfs plus récent comme Mojave.

- aucun chemin de démarrage n'est incrit sur l'en-tête du volume.​

Passe la commande :
Bloc de code:
bless --info /Vol*/Install*
  • qui affiche le chemin de démarrage du volume d'installation Install OS X Yosemite

Poste le retour.
 

dufossezmicka

Membre junior
6 Juillet 2019
36
2
30
Bloc de code:
-bash-3.2# bless --info /Vol*/Install*
finderinfo[0]:    532 => Blessed System Folder is /Volumes/Install OS X Yosemite/.IABootFiles
finderinfo[1]:    550 => Blessed System File is /Volumes/Install OS X Yosemite/.IABootFiles/boot.efi
finderinfo[2]:      0 => Open-folder linked list empty
finderinfo[3]:      0 => No alternate OS blessed file/folder
finderinfo[4]:      0 => Unused field unset
finderinfo[5]:    532 => OS X blessed folder is /Volumes/Install OS X Yosemite/.IABootFiles
64-bit VSDB volume id:  0xB9C47FBDABFD31CB
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 704
21 519
Forêt de Fontainebleau
Le chemin de démarrage du volume Install OS X Yosemite pointe > dans un dossier de démarrage .IABootFiles => au lanceur boot.efi de l'OS d'installation.

- voici la commande que je te propose de passer :​
Bloc de code:
bless --folder /Vol*/Install*/.IABootFiles --file /Vol*/Install*/.IABootFiles/boot.efi --setBoot
  • tu la passes en copier-coller à rebours : tu la copies ici d'abord avec Safari (jusqu'au --setBoot final) > tu la colles dans le terminal > tu l'exécutes
  • la commande réécrit à l'identique le chemin de démarrage de l'en-tête du volume > mais adresse en plus la NVRAM via l'option : --setBoot => qui inscrit un chemin de démarrage automatique pour l'EFI (le programme de boot primaire du Mac) au volume Install OS X Yosemite (où le chemin de démarrage de l'en-tête prendra le relais)

Commande muette si elle passe (retour direct de -bash-3.2#) : est-ce que ça a été le cas ?
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 704
21 519
Forêt de Fontainebleau
Passe la commande de vérification :
Bloc de code:
nvram efi-boot-device
  • qui affiche la valeur actuelle de la variable de la NVRAM : efi-boot-device (appareil de démarrage automatique de l'EFI)

Poste le retour.
 

dufossezmicka

Membre junior
6 Juillet 2019
36
2
30
voici le retour

Bloc de code:
-bash-3.2# bless --folder /Vol*/Install*/.IABootFiles --file /Vol*/Install*/.IABootFiles/boot.efi --setBoot
-bash-3.2# nvram efi-boot-device
efi-boot-device    <array><dict><key>IOMatch</key><dict><key>IOProviderClass</key><string>IOMedia</string><key>IOPropertyMatch</key><dict><key>UUID</key><string>E0AD9C0F-EA5A-41C6-9989-55BE0E8441FD</string></dict></dict><key>BLLastBSDName</key><string>disk2s3</string></dict></array>
-bash-3.2#
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
71 704
21 519
Forêt de Fontainebleau
Voici l'argument essentiel -->
Bloc de code:
<string>disk2s3</string>
  • c'est disk2s3 l'appareil démarrable automatiquement par l'EFI > or voici ce que montre le tableau des disques -->
Bloc de code:
   3:                  Apple_HFS Install OS X Yosemite   105.7 GB   disk2s3
  • disk2s3 = le volume Install OS X Yosemite d'installation de Yosemite. Ce volume est donc logiquement démarrable par l'EFI en mode automatique.

Redémarre (Menu  > Redémarrer) => et laisse surtout le Mac redémarrer tout seul sans presser aucune touche au clavier -->

- obtiens-tu après une temps de chargement un écran affichant une fenêtre de 4 Utilitaires OS X > où l'option : "Installer OS X" => te propose d'installer directement Yosemite ?​

Note : je fais une pause. Je reviendrai plus tard dans le fil aux nouvelles.
 

dufossezmicka

Membre junior
6 Juillet 2019
36
2
30
Voici l'argument essentiel -->
Bloc de code:
<string>disk2s3</string>
  • c'est disk2s3 l'appareil démarrable automatiquement par l'EFI > or voici ce que montre le tableau des disques -->
Bloc de code:
   3:                  Apple_HFS Install OS X Yosemite   105.7 GB   disk2s3
  • disk2s3 = le volume Install OS X Yosemite d'installation de Yosemite. Ce volume est donc logiquement démarrable par l'EFI en mode automatique.

Redémarre (Menu  > Redémarrer) => et laisse surtout le Mac redémarrer tout seul sans presser aucune touche au clavier -->

- obtiens-tu après une temps de chargement un écran affichant une fenêtre de 4 Utilitaires OS X > où l'option : "Installer OS X" => te propose d'installer directement Yosemite ?​

Note : je fais une pause. Je reviendrai plus tard dans le fil aux nouvelles.
pas de problèmes en même temps ta pause elle est bien méritée

alors au final c'est mon clavier qui foutait le bazar aussi du coup j'ai démarré en débranchant le clavier ton système s'est installe sur le disque interne normal j'ai rentre mes identifiants apple et tout et la ca fait une heure que c'est sur le dernier écran de configuration le rond tourne mais je sais pas si ca charge vraiment ou si c'est mort

au pire des cas , je peux forcer l'extinction et redémarrer ? ou ca va être encore pire?

en tout cas déjà je te remercie infiniment de m'avoir emmené jusque la. tu es un génie.

--------------------------------------------

il est reparti.... wooooooooowwoooowwoooooo je tourne sur yosemite je vais voir pour le monter sur high sierra et hop

je te remercierais jamais assez.
ps je suis electrochenicien programmateur, si jamais un jour je peux t'aider mais j'imagine que tu es cale

merci infiniment

on se reverra sans doute lors de mon prochain problème :kiss:
 
Dernière édition par un modérateur: