• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Commande console dans Doom 3

Dark_Fragor

Membre junior
6 Avril 2008
60
5
32
Nancy
Salut à tous !

J'aimerai accéder à la console de Doom 3 pour entrer qq commandes ...
le truc c'est que le seul raccourci clavier que je trouve pour activer la console c'est ctrl + ~ mais en faisant la commande rien ne se passe. J'ai essayé toute les combinaisons (ctrl alt maj pomme fn et tartinant le clavier ligne par ligne) J'ai un powerbook G4 (si çà peut aider, desfois que le fait que ce soit un portable peut jouer ...)

Et au fait la commande est elle activable seulement dans le jeu ou aussi quand on est dans le menu ?

merci de vos réponses
 

gKatarn

Modoblaster
Modérateur
Club MacG
27 Février 2001
16 606
2 466
En garnison sur Tatooine
Le tilde, c'est ALT-n mais souvent, sur un clavier FR c'est '<' ou SHIFT < :D

Mais çà suffit pas... dans un vieux post de Slug :
Il faut d'abord activer la console : dans ~/Library/Applications Support/Doom 3/base/ , créer un fichier texte nomme autoexec.cfg qui contient ces lignes

com_allowConsole "1"
com_showFPS "1"


Vala, çà devrait aller mieux :)
 

Dark_Fragor

Membre junior
6 Avril 2008
60
5
32
Nancy
j'ai déjà vu ce genre de post sur le net, le autoexec.cfg (çà pue le MS-DOS ce nom de fichier)
mais désolé çà ne marche pas, le nombre de fps s'affiche, preuve que le fichier a bien été pris en compte mais impossible d'accéder à la console ... malgré que j'ai essayé plein de commande de touche différente

???

+++
j'ai remarqué un bug sur Doom 3, il est incapable d'utiliser le 2 de mon powerbook comme un bouton dans le jeu, quand je veux changer une commande et que j'appuie sur le 2, rien ne se passe. Cà le fait avec d'autres touches aussi, mais c'est la seule appli qui merde avec mon clavier ... aussi , certaines touche ne s'appelle pas avec le caractère qu'il y a dessus, mais plutot avec un code de 4 caractère en hexa ... (par exemple quand je met 3 pour le fusil à pompe, çà me met 0D78 ou un truc genre ...)
 

mocmoc

Membre d’élite
Club MacG
8 Mars 2008
1 056
102
Je crois que quake 4 et doom 3 utilisent le mème moteur graphique non ?
Donc éssaye ctrl+alt+£
:)
 

Dark_Fragor

Membre junior
6 Avril 2008
60
5
32
Nancy
toujours pas

alors là j'ai essayé tte les commandes de touche possible et imaginable (avec maj fn ctrl alt option et pomme ...).
Bon qq saurai t-il ce qu'il faut farcir dans le fichier config de doom (voir lien) sur une touche pour déclencher la console ???

le chemin est:
user/~/Library/Application support/Doom3/base/DoomConfig.cfg

(quand on l'ouvre avec text edit bien sur)

merci :)
 

Daumier

Membre confirmé
27 Novembre 2001
159
1
Villers-les-Nancy
Bonsoir,

Je possède ce jeu et moi aussi j'ai galéré pour trouver la bonne commande. Voilà comment ça marche chez moi !

Après avoir cliquer sur l'icône de DOOM 3, et après l'intro, il faut tapper la combinaison de touches suivantes ;

ctrl + alt + <
La dernière touche c'est celle qui se trouve au dessus du alt de gauche elle combine < et >

Voilà je te souhaite que ça fonctionne.
 

Dark_Fragor

Membre junior
6 Avril 2008
60
5
32
Nancy
Bonsoir,

Je possède ce jeu et moi aussi j'ai galéré pour trouver la bonne commande. Voilà comment ça marche chez moi !

Après avoir cliquer sur l'icône de DOOM 3, et après l'intro, il faut tapper la combinaison de touches suivantes ;

ctrl + alt + <
La dernière touche c'est celle qui se trouve au dessus du alt de gauche elle combine < et >
.
Merci sur les précisions attendue sur quand est ce que je peux attendre que çà fonctionne ou pas, malheureusement cette commande de touche je l'ai déjà essayée ... marche pas

Il te faut mettre les lignes citées plus haut dans le ficher autoexec.cfg. ENSUITE seulement, tu peux ouvrir la console ;)
Comme dit plus haut, j'ai déjà réalisé cette manip et j'ai la preuve qu'elle a bien fonctionné, mais si je suis encore la à faire chier :siffle: c'est que çà ne marche tjrs pas ...

PS: Au fait daumier ... j'ai remarqué que tu étais sur villers, jsuis étudiant là haut, qu'est ce que tu y fait de beau ???
 

Daumier

Membre confirmé
27 Novembre 2001
159
1
Villers-les-Nancy
Je suis désolé que cela ne fonctionne pas.

A tout hazard as tu fais les deux mises à jours disponibles ;

http://www.ludomac.com/jeux.php?id=249

C'est sur cette page, dans la liste bleu, j'ai fais les 2 premiers.

J'ai aussi constaté des choses bizares sur ce jeux qui fonctionne parfaitement bien ici. des que je l'installe chez une cousine pour lui faire une démo avec un imac alu (les premier) moi j'ai un blanc, donc sans la même carte vidéo je n'arrive pas à avoir le son !

moi je suis sur Clairlieu à Villers et je suis retraité

Bon courage
 

Patrickkcirtap

Nouveau membre
22 Juillet 2008
2
0
Ouvrir le dossier "Applications". Dans le dossier "Utilitaires", lancer l'application

"Configuration audio et MIDI"

Choisir l'onglet : "Périphériques audio"

Sur le côté droit inférieur, se trouve le paramétrage de la "Sortie audio"

Sur le côté gauche au milieu, se trouve un menu "Propriétés de", qui offre trois choix :
"Microphone intégré"
"Entrée intégrée"
"Sortie intégrée"

Sélectionner l'option "Sortie intégrée"

Sur le côté droit inférieur, le paramétrage de la "Sortie audio" s'active alors

Le format est alors paramétrable. Il indique alors :

44100,0 Hz 2ca-24 bit

Ne pas toucher "44100,0 Hz", mais au lieu de "2ca-24 bit", sélectionner "2ca-16 bit"
 

Dark_Fragor

Membre junior
6 Avril 2008
60
5
32
Nancy
Ouvrir le dossier "Applications". Dans le dossier "Utilitaires", lancer l'application

"Configuration audio et MIDI"

Choisir l'onglet : "Périphériques audio"

Sur le côté droit inférieur, se trouve le paramétrage de la "Sortie audio"

Sur le côté gauche au milieu, se trouve un menu "Propriétés de", qui offre trois choix :
"Microphone intégré"
"Entrée intégrée"
"Sortie intégrée"

Sélectionner l'option "Sortie intégrée"

Sur le côté droit inférieur, le paramétrage de la "Sortie audio" s'active alors

Le format est alors paramétrable. Il indique alors :

44100,0 Hz 2ca-24 bit

Ne pas toucher "44100,0 Hz", mais au lieu de "2ca-24 bit", sélectionner "2ca-16 bit"
C'est très gentil mais çà n'a aucun rapport avec mon problème ...:mouais:
À se demander si tu as lu le début du post, ou s'agirait-il d'une erreur.:confused:
Toujours est-il qu'après avoir vainement abandonné l'idée de lancer la console, je me suis retrouvé un beau jour avec un Doom 3 qui ne marchait pas, j'ai donc du le réinstaller et j'ai fait les dernières mise à jour, et en en reparlant avec un ami récemment, qui lui arrivait lancer la console grâce à la commande : ctrl + alt + < , j'ai réussi à la lancer moi aussi!

Il semblerai donc que ce soit un problème de màj...

Merci à Daumier ;)