Compilateur pose souci dans Code::Blocks

Tutti Body

Membre enregistré
23 Août 2012
2
0
Bonjour tout le monde, je suis nouveau sur ce site et voilà j'ai un problème qui me casse la tête depuis ce matin.
Voilà, j'ai un Mac Os X 10.4.11
J'ai téléchargé la dernière version de Code::Blocks en suivant le tutoriel de M@teo du "siteduzero" mais apparemment le compilateur n'est pas intégré à la version Mac. (du coup je reste coincé à l'exercice du "Hello World")
J'ai alors essayé de télécharger "Xcode 2.5 Developer" sur le site d'Apple mais il y a plein de package et je ne sais pas où le fichier que j'ai besoin (le compilateur) est et où il a pu se mettre. J'ai essayé l'Auto-Detect, rien n'y fait, j'ai essayé de spécifier le chemin d'accès à un fichier "usr" ou "bin" (lequel choisir, de plus je ne suis pas sur de choisir le bon "usr" ou "bin" car il y en a plusieurs sur mon mac), non plus.
Chaque fois que j'appuie sur le bouton "Build & Run", ça me met soit un message avec "skippin" et que ça marche pas ou soit, un texte de plus ou moins 5 lignes s'écrit dans le Build Log et ensuite le Terminal apparait en 2 fenêtres.

Voilà mon cas, je remercie d'avance celui qui pourra m'apporter la lumière :)
 
Dernière édition:

ntx

Membre vénérable
Club MacG
15 Octobre 2004
12 128
376
92
Avec les vieilles versions de Xcode, il faut installer tout le package pour avoir le compilateur en ligne de commande. Ce n'est que récemment qu'Apple a fini par proposer une package spécifique avec uniquement les outils en ligne de commande.
 

Tutti Body

Membre enregistré
23 Août 2012
2
0
Merci beaucoup pour votre aide mais je crois que finalement le mieux, c'est quand même d'employer Xcode, avec Code::Blocks, on se tape 100 fois plus de souci, j'ai l'impression ><
Sinon, maintenant j'ai un autre problème : quand j'entre ce code dans Xcode, le Terminal ne s'ouvre pas alors qu'il devrait :

#include <iostream>
#include <string>

string demanderNom()
{
cout << "Entrez votre nom : ";
string nom;
cin >> nom;
return nom;
}

(il est copié-collé du siteduzéro avec le tuto de M@teo sur le langage C++)
 

ntx

Membre vénérable
Club MacG
15 Octobre 2004
12 128
376
92
A la lecture d'un précédent fil, il semble que le terminal (qui est plutôt une console à vrai dire) qui s'ouvre dans Xcode 4 au lancement de l'application ne permette pas la saisie de données. Il faut lancer cette appli dans un vrai terminal.