10.14 Mojave Connexion iCloud impossible

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Bonjour à tous !

Suite à une nouvelle installation de Mojave sur un iMac 2012 (i7 3 To FD) acheté récemment, et une importation de mes données via l'assistant migration, j'ai connu quelques misères qui sont en voie de résolution, mais il reste un gros point noir :
un problème de connexion avec iCloud. Dès la finalisation du paramétrage du compte, puis maintenant à chaque reboot, iCloud me demande le MdP pour (re)finir de paramétrer le compte.

Il l'accepte (double authentification sur les autres appareils), mais une fois booté j'ai de nouveau le message "saisissez votre mot de passe pour continuer à utiliser iCloud. Une fois saisi, Bim : "une erreur inconnue est survenue". D'autres fois il me disait que le MdP était erroné…

Quand je reboote, j'ai de nouveau (!) l'écran de paramétrage de compte qui s'ouvre (choisissez votre style, Configuration de votre compte), puis "ce Mac ne peut pas se connecter à iCloud en raison d'un problème lié à (mon adresse email) : ouvrez prefs, et rebelotte…

C'est d'autant plus pénalisant que mes contacts étant synchronisés dans iCloud, ils n'apparaissent même plus en local dans mon Carnet d'Adresses, malgré plusieurs manips (détails ici vers la fin pour ceux que ça intéressent : https://forums.macg.co/threads/carnet-dadresses-disparu.301871/page-2 ).

Je précise que j'ai déjà supprimé tous les éléments iCloud du Trousseau d'accès ainsi que les Prefs, mais rien n'y fait !

Si quelqu'un a une idée, je suis donc preneur : )
Merci d'avance !
 
Dernière édition par un modérateur:

Ahiqar

Membre junior
18 Juillet 2011
51
15
Bonjour,

as-tu déclaré ton nouvel iMac dans ton compte AppleID ou iTune et retiré ton ancien de ce même compte ?
 

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Bonjour,

as-tu déclaré ton nouvel iMac dans ton compte AppleID ou iTune et retiré ton ancien de ce même compte ?
Bonjour,
L'achat de cet iMac (d'occasion) fait suite à un vol du (des) précédents) :
je n'ai pas retiré l(es) ancien(s) de mon compte car je m'en suis fais voler 3 (…) que j'ai demandé à bloquer et à localiser, sans succès pour le moment…
Et si je les supprime d'iCloud, plus de géoloc, plus d'alerte etc, donc pas pressé pour l'instant : )

Quand tu dis "déclaré ton nouvel iMac dans ton compte AppleID ou iTunes", par quel biais ?

Je précise que j'ai installé il y a peu un autre iMac (i5 2012 HDD à plateau et High Sierra) que l'on m'a donné, ainsi qu'un 3ème (i7 2017) sans problème de ce type et en simplement renseignant toujours les mêmes infos pour iCloud.
 

Ahiqar

Membre junior
18 Juillet 2011
51
15
Par "déclaré" c'est "autorisé" l'appareil au compte iTunes ou Musique qui ne tolère que 5 ordinateurs.

Après relecture je te propose lors de la configuration du compte d'inactiver iCloud et iTunes afin de le faire plus tard dans préférences système, cela validera ton compte et ta session et tu pourras redémarrer sans être obligé de refaire la configuration du compte.
 
Dernière édition par un modérateur:

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Par "déclaré" c'est "autorisé" l'appareil au compte iTune ou Musique qui ne tolère que 5 ordinateurs.
Ha… Ça pourrait être une piste, mais je n'ai pas le souvenir d'avoir jamais déclaré quoi que ce soit…
En même temps, si c'était juste une boite de dialogue demandant à la volée si j'acceptais l'accès de ce Mac à iTunes, c'est possible !
Et si c'est ça, ça viendrait pas à l'idée des développeurs de mettre une petite boite de dialogue prévenant que le compte n'accepte que 5 ordinateurs max ?!

Donc concrètement, si je veux virer l'un des iMacs volés sans perdre la possibilité de les repérer, je fais comment ?
Sinon, je peux essayer de virer l'iMac i5 que j'ai, pour voir, mais ça se passe où ?
 

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Bon, j'avance TRÈÈÈÈS doucement, si on peut appeler ça avancer…

En fait je ne pense pas que ce soit la limitation qui bloque, dixit Apple :
"Vous pouvez associer simultanément jusqu’à dix appareils (parmi lesquels cinq ordinateurs) à votre identifiant Apple pour les achats".

J'ai un peu du mal à me repérer entre d'ID iTunes, Apple et iCloud et qui fait quoi (je trouve que c'est un bordel innommable !) mais sauf erreur de ma part j'ai :
  • sur iTunes : uniquement 2 iPhone
  • sur Appleid : 5 iMac (les 3 que l'on m'a volé, l'iMac i5 sur lequel j'écris et un iMac 2017 acheté et installé récemment), plus 1 MacBook Air et les 2 mêmes iPhone
Je précise que quand je vais sur "Localiser", il semble voir (dur à dire car ils ont tous le même nom et pas de N° de série…) : 5 iMac (mais pas certain que ce soit les mêmes !). Je dirais qu'il n'y a que 2 des 3 iMac volés, mais qu'il y a aussi celui qui ne veut pas se connecter (l'objet du post) déclaré "Hors ligne", plus le MBA et les 2 iPhone…

- sur iCloud : 3 iMac (l'iMac 27 2012 qui me pose problème (soit-disant pas connecté !), l'iMac i5 sur lequel j'écris, et l'iMac 2017 :
ceux que l'on m'a volés n'y figurent pas), le Macbook Air et 1 seul iPhone

Je viens également de me rendre compte que toutes ma musique dans iTunes a également disparu (elle était pourtant installée "en dur" et complète hier !), à part l'album gratos Songs of innocence de U2, le seul téléchargé à l'origine depuis iTunes (tout le reste ayant d'autres provenances et souvent gravés par mes soins depuis des CD !)
Et le plus beau dans tout ça c'est que dans iTunes, je me connecte à mon compte sans problème…

Je dois dire que j'ai beaucoup de mal à suivre la logique de tout ça et ça me fait penser à la grande époque Windaube…

Si ça inspire quelqu'un de plus compétent que moi (même pour une explication du pourquoi du comment de tout ça), je suis preneur !
 
Dernière édition par un modérateur:
  • Wow
Réactions: Beauchadiniou

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Tant que j'y suis, un détail mais TRÈÈÈÈS énervant, surtout quand on fait des tests sur plusieurs ordi :
la double authentification !
A chaque connexion des mêmes appareils par les mêmes biais elle se déclenche à nouveau !
Pas moyen de limiter ça au moins à une fois par session (j'ai déjà indiqué 12 fois tous ces appareils comme étant "de confiance" !).
Merci !!!

-------------------------------------------------------

Bon, j'ai ± résolu le problème iTunes (musique disparue) : ayant déporté ma biblio iTunes sur le HDD plutôt que sur le trop petit SDD où est installé le système, les applis et le User, il semble ne pas prendre en compte cette modif quand il se lance.
Pourtant dans les Prefs iTunes (avancées), il est bien spécifié le bon endroit…
 
Dernière édition par un modérateur:

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Après avoir quitté et relancé iTunes, ma musique a de nouveau disparu car il ne va pas chercher la bonne biblio alors qu'elle est bien spécifiée dans les prefs iTunes : une idée pour ne pas être obligé de le lancer à chaque fois avec "alt" puis retourner la chercher ?

Sinon, toujours impossible de me connecter à iCloud alors que l'iMac fait bien partie des appareils connectés dans "Apple ID"…
Si une bonne âme avait une idée, ça me ferai me sentir moins seul : )
 
Dernière édition par un modérateur:

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Une piste (?) : En créant une seconde session Admin, aucun problème pour me connecter à iCloud, et j'ai au passage récupéré mes contacts. Ça ne change rien pour l'autre session.

Encore un autre souci : j'ai un trackpad et une souris connectés et, après redémarrage, si le trackpad fonctionne normalement la souris "bug" dans les 2 sessions : le curseur avance à 2 à l'heure en saccadant et impossible de corriger ça dans les prefs…

Pour le trackpad, il semble toutefois que le paramétrage ne tienne pas au reboot : ça fait plusieurs fois que je suis obligé de re-cocher "Toucher pour cliquer".

Jamais vu autant de trucs qui zonent après une install…
 
Dernière édition par un modérateur:

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
@macomaniac
Bonjour !
Je me permets de faire à nouveau appel à tes compétences car je ne me sors pas de mon problème iCloud (voir ci-dessus).
Je sais que ça n'est pas ton domaine, mais je me demande si le plus "simple" ne serait finalement pas de créer une autre session puisque ma session "Admin" se connecte à iCloud sans problème ?

Dans ce cas de figure, je souhaiterais si possible (mais je crois que pour changer c'est compliqué !) conserver le même nom pour ma session et pouvoir tout réimporter depuis la première (celle qui ne parvient pas à se connecter) sans avoir à tout re-paramétrer.
Puis évidemment effacer l'ancienne.

Penses-tu que ce soit une bonne idée, et si oui as-tu une idée de la meilleure façon de procéder ?
Merci d'avance !
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
81 372
24 646
Forêt de Fontainebleau
Dans ta session Admin > tu peux ouvrir le panneau des Utilisateurs et groupes (dans les Préférences Système) et déverrouiller le cadenas d'administration. Je vais supposer que ton utilisateur s'intitule Gag (nom complet) alias gag (nom du compte) -->

- sélectionne Gag > presse le bouton - pour supprimer l'utilisateur. Tu obtiens un panneau affichant des options de suppression. Choisis : "Enregistrer le dossier de départ dans une image-disque" => Supprimer l'utilisateur. L'identité d'utilisateur Gag va être supprimée > tandis que le dossier de compte gag des Utilisateurs va être encapsulé dans une image-disque gag.dmg à l'intérieur d'un dossier intitulé : Utilisateurs (supprimés) dans le répertoire des Utilisateurs. L'affichage de Gag, Admin va disparaître de la colonne de gauche du panneau.​
- presse maintenant le bouton + pour créer un nouvel utilisateur. Choisis les mêmes identifiants de noms et de mot de passe que pour Gag. Un utilisateur Gag, Admin se trouve de nouveau affiché dans la colonne de gauche.​

Déloge-toi de la session Admin > loge-toi dans la session de l'utiisateur (néo) Gag. Tu ouvres une session vide (de données et de préférences). Est-ce que tu parviens à te connecter à iCloud dans cette session ?
 

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Merci, je vais tenter ça.
Par contre, pour des raisons de manque d'espace sur mon SSD de 121 Go (tu te souviens ?), j'ai du déporter certains dossiers sur le HDD, notamment mes dossiers "Images" et Musique".
Ça ne risque pas de poser de problème pour qu'il s'y retrouve ?
Sinon au pire je pourrai recommencer la manip…
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
81 372
24 646
Forêt de Fontainebleau
Quand tu dis "déporter" => veux-tu dire que tu as copié ces dossiers dans le volume HDD > puis que tu as supprimé les originaux de ton dossier de compte actuel > enfin que tu les as remplacés par des liens symboliques ? - ou pas ?
 

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Non, j'ai créé des dossiers sur HDD, puis fait pointer "Photos" et iTunes sur les bibliothèques du HDD.
Ça marche bien pour Photos, mais pour iTunes il ne va pas chercher la bonne biblio alors qu'elle est bien spécifiée dans les prefs iTunes : obligé de le lancer à chaque fois avec "alt" pour retourner la chercher…

En fait, j'ai fini par me dire que je devrais peut-être déporter tout mon dossier User sur le HDD, mais je ne maitrise pas la manip.
Tu en penses quoi ?
 
Dernière édition:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
81 372
24 646
Forêt de Fontainebleau
Pour cela > il faut copier le dossier User => HDD. Puis dans le panneau des Utiilsateurs et groupes > déverrouiller le cadenas > cliquer User avec la touche ctrl pressée => ce qui affiche les Options avancées.

- dans le bas du panneau > tu as une rubrique : Répertoire de départ avec comme adresse : /Users/User (répertoire des Utilisateurs du volume démarré => dossier User). Il faut à la place : /Volumes/HDD/User (volume HDD > dossier copié User). Tu peux modifier l'adresse à la main > ou tu utilises le bouton Choisir pour naviguer au dossier copié User de HDD et presser le bouton : Ouvrir pour modifier le chemin d'ouverture de session. Puis OK. Redémarrer une fois après avant de ré-ouvrir la session User.​

Ta problématique me paraît compliquée - quand même. Réfléchis bien à ce que tu veux faire.
 

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Ma problématique ne devrait pourtant pas être si compliquée : je cherche seulement à avoir un Mac fonctionnel : )

Mais comme tu as pu le constater depuis le début, c'est l'enchaînement des choses qui complique tout, avec comme point de départ l'obligation d'installer Mojave en APFS, même sur un Fusion Drive.

Du coup, séparation du FD, mais SSD finalement trop juste pour contenir le Système, les Applis et le dossier User complet, donc obligé d'en "déporter" une partie, et au passage ce problème iCloud qui semble ne pas passionner grand-monde…

Bref, je "m'ouroboros" ;-)

Du coup, sachant que mon dossier User (disons "Gag", même si en vrai je ne m'appelle pas comme ça :)) est "complet" sur le SSD (simplement avec les dossier Images et Musique vides puisque déportés) je peux :
  • commencer par ta procédure du post #11,
  • puis vérifier que cette session se connecte à iCloud (c'est le but ma pauv' Lucette)
  • puis si c'est bon déporter le dossier User sur le HDD
  • puis remettre "à la pogne" mes images et musiques dans les "bons dossiers" qui seront probablement vides à ce moment

J'ai bon ?
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
81 372
24 646
Forêt de Fontainebleau
Oui : tu peux suivre ce scénario.

- je persiste à penser que si tu avais laissé le Fusion Drive > ce qui l'aurait converti au type apfs avec l'installation de Mojave => tu n'aurais pas eu toutes ces complications. Car tu aurais disposé d'un espace considérable.​
 

Gag

Membre confirmé
8 Février 2009
194
13
Boulogne-Billancourt
Bonjour macomaniac,
Désolé du silence mais occupé sur d'autres galères (une imprimante cette fois !)

Bon, ça continue :
après le début de la procédure ci-dessus, j'ai une alerte qui m'indique « Impossible de supprimer le compte utilisateur de "Gag".
Une erreur est survenue lors de la sauvegarde du dossier départ de cet utilisateur »
.

Une idée ?

Edit :
j'ai bien un dossier "Utilisateurs supprimé" qui est apparu, mais vide.
 
Dernière édition: