Connexion impossible par ftp

shub2

Membre confirmé
6 Novembre 2007
280
17
Paris
J'essaie d'envoyer des fichiers ou des images par ftp sur ma page Web sur le serveur Noos: impossible !!

J'ai essayé par 2 logiciels, Transmit et Adobe Contribute.
Pour les deux logiciels c'est le même protocole: il faut donner le nom de serveur, l'identifiant et le mot de passe, et ça ne marche pourtant pas. Pourtant ma hotline me certifie que ses informations sont bonnes et me disent que c'est un problème de Mac ou de logiciels. Je finis par être connu comme le loup blanc chez Noos !!
Je n'y comprends rien.
Vous avez une idée ?:hein:
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Bonsoir,

Dans les logiciels de transfert, pour l'hôte, c'est un nom ou une adresse IP qui est utilisé?
Autrement, il n'y a que le n° de port (21), le login et le mot de passe à renseigner.
Je n'utilise pas Transmit, mais il doit bien y avoir un log quelque part qui donne le code erreur?

Peut-être aussi passer en mode passif.
 
Dernière édition:

shub2

Membre confirmé
6 Novembre 2007
280
17
Paris
Bonsoir,

Dans les logiciels de transfert, pour l'hôte, c'est un nom ou une adresse IP qui est utilisé?
Autrement, il n'y a que le n° de port (21), le login et le mot de passe à renseigner.
Je n'utilise pas Transmit, mais il doit bien y avoir un log quelque part qui donne le code erreur?

Peut-être aussi passer en mode passif.
Dans l'Utilitaire Console j'obtiens ce message suite à l'échec de connexion:
01/11/11 08:53:39,756 login: DEAD_PROCESS: 347 ttys000

Il faut absolument renseigner les 3 champs, serveur, login et MDP dans les 2 logiciels cités au-dessus sinon le bouton "connecter" reste grisé et inaccessible.
Quant à utiliser Terminal, ça doit être possible via les commandes relatives à Internet genre curl et ftp mais je les ai jamais utilisées ! Je me servais de Transmit précisément pour transférer des fichiers et chez eux, ils ne savent pas expliquer non plus: ils me conseillent de tout recommencer depuis scratch.
Nouvelle fenêtre, remplir les champs etc. mais rien à faire ! Ça ne se connecte pas ... Il doit y avoir une option qu'ils m'ont pas précisé chez Noos.

J'ai essayé de remplacer le nom du serveur ftp -mapage.noos.fr- par son IP obtenu via la commande host sous Unix, 82.216.111.10, mais ça marche pas non plus.
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
398
Paris
Sous le Terminal, essaye :
$>ftp login@host
Après il te demande ton mdp...

Regarde également si tu n'es pas en sftp ou s'il faut passer par du sftp ;)
 

shub2

Membre confirmé
6 Novembre 2007
280
17
Paris
J'ai essayé par sftp et à ce moment il choisi automatiquement son port qui reste en grisé: dans mon cas le port 990 mais il arrive pas mieux à se connecter. Temps d'attente dépassé ou connexion impossible, dit-il ...
Vraiment je comprends pas !!

J'y étais arrivé sur mon ancien ordinateur, et heureusement j'avais exporté les bookmarks favoris de Transmit sur une clé USB. Je les ai importés dans mon MacBook Pro via Transmit et ça marche (!) mais ces "bookmarks" de Transmit sont illisibles et indéchiffrables, par un quelconque logiciel genre bbedit, ce qui fait que je comprends toujours pas !

J'ai essayé par ftp et voici ce que j'obtiens:


$ ftp stehub@noos
ftp: Can't lookup `noos': nodename nor servname provided, or not known
ftp>


On dirait qu'il connaît pas noos !! Étrange ...

Pourtant il reconnaît noos comme hôte:

$ host noos.fr
noos.fr has address 82.216.111.15
noos.fr mail is handled by 10 mx.noos.fr.
 
Dernière édition:

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Dans le Terminal, lance un ftp, comme ci-dessous.
On voit bien qu'on se connecte à noos avec mapage.noos.fr comme nom d'hôte.
A la question login, bien sûr, je ne confirme pas le mien, mais je renseigne le tien (stehub).
Après, il me demande le mot de passe.... Tu es donc connu chez eux.
Fais le test chez toi pour voir si tu vas au bout...

imac:~ polo$ ftp
ftp> open mapage.noos.fr
Connected to mapage.noos.fr.
220-FTP server ready.
220 This is a private system - No anonymous login
Name (mapage.noos.fr:polo): stehub
331 User stehub OK. Password required
Password:

Le smiley n'est pas de moi, c'est l'interprétation de : p (le p de polo...)
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
398
Paris
Idem :
Larme$ ftp tonlogin[arobase]mapage.noos.fr
Connected to mapage.noos.fr.
220-FTP server ready.
220 This is a private system - No anonymous login
331 User tonlogin OK. Password required
Password:


Édit : J'ai légèrement modifié les infos (@, et tonlogin)
 

shub2

Membre confirmé
6 Novembre 2007
280
17
Paris
Merci ça me rassure d'être au moins connu chez Noos j'ai fait exactement les mêmes commandes que toi et j'obtiens toujours

ftp> open mapage.noos.fr
Connected to mapage.noos.fr.
220-FTP server ready.
220 This is a private system - No anonymous login
Name (mapage.noos.fr:stephanehubert): stehub
331 User stehub OK. Password required
Password:
530 Authentication failed, sorry
ftp: Login failed


Pourtant le mot de passe est bon je crois. On dirait un problème de port. C'est le port de l'angoisse cette histoire. :mad:
Ton port ftp serait pas le 220 par hasard ?
En tout cas ça a l'air de venir de chez eux. Les serveurs de réception pop et d'envoi smtp marchent , j'arrive à recevoir et envoyer des mails sans problème. Bon.

1/4 d'heure + tard: ça y est ils m'ont planté Mail chez Noos. Ils m'ont fait changer le mot de passe sur la connexion distante avec Dreamweaver et maintentant Mail n'arrive plus à se connecter.
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Pareil que Larme, pb login password...

Voir le lien ci-dessous:
http://assistance.numericable.fr/article203.html
Le login, c'est tt ce qui se trouve avant l'"@" dans l'adresse mail (du comte principal)
Le password, c'est celui du compte principal (sauf si le mot de passe de la page perso a été changé)

Sinon, le pb est chez Noos...
 

shub2

Membre confirmé
6 Novembre 2007
280
17
Paris
Pareil que Larme, pb login password...

Voir le lien ci-dessous:
http://assistance.numericable.fr/article203.html
Le login, c'est tt ce qui se trouve avant l'"@" dans l'adresse mail (du comte principal)
Le password, c'est celui du compte principal (sauf si le mot de passe de la page perso a été changé)

Sinon, le pb est chez Noos...
Merci : impossible de se connecter et de surfer sur le lien que tu m'as indiqué.

Ils tombent en panne de temps en temps leurs serveurs sur Noos, et évidemment ça arrive les jours de fête ou de congé, ou les lendemains !
Effectivement le problème semble venir de chez eux. Ce qu'il y a d'ennuyeux avec les hotline, c'est que certaines fois on tombe sur des techniciens sympas et compétents qui font ce qu'ils peuvent pour aider et dépanner, d'autres fois on tombe sur des gens qui vous disent "arrivez-vous à vous connecter sur notre site noos ? Si oui, le problème vient de chez vous et de vos logiciels, Mail et autres. Contactez chez un informaticien."

Bon il y'a qu'à attendre. D'autres gens ont eu le même problème avec leurs serveurs et les hotline ici ??? :eek:
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Curieux que le lien ne marche pas...
C'est bon chez moi en ce moment.
Pas de firewall, de LittleSnitch?
Peux-tu lister le ficher /etc/hosts pour voir ce qu'il y a dedans?
 

shub2

Membre confirmé
6 Novembre 2007
280
17
Paris
Curieux que le lien ne marche pas...
C'est bon chez moi en ce moment.
Pas de firewall, de LittleSnitch?
Peux-tu lister le ficher /etc/hosts pour voir ce qu'il y a dedans?
Pas de firewall mais un little snitch effectivement. Là j'arrive à me connecter sur la page en question... Merci

Vindieu: lorqu'on déconnecte Little snitch il arrive à trouver le ftp et Transmit marche. Quel idiot ! J'aurais dû y penser. Merci en tout cas ... Je crois que chez noos ils ont réussi à réparer quelque chose mais pas le serveur de réception pop qui marche toujours pas !
J'ai 2 ordis, unMacBook Pro et un Power G4Mac (une antiquité) et j'arrive pas à recevoir mes mails, donc ça doit pas marcher chez eux non ce serveur pop ?

Terminal gèle toujours sur la commande 'ftp' et l'option Gérer les sites ... sur Dreamweaver n'arrive pas à se connecter non plus sur noos via ftp.
Je comprends rien à ces histoires de protocoles File Transfer sinon QU'IL FAUT BIDOUILLER LE MOINS POSSIBLE SUR LES FICHIERS GENRE /etc/hosts , ça marche sur certains endroits et pas d'autres. Enfin, j'en ai tout de même un qui marche, Transmit ...
Merci :up:


ftp> open noos.fr
et puis il se passe rien ... Il gèle même avec Little Snitch déconnecté. Ça m'étonne, je crois que ftp sous Terminal c'est le protocole le + simple pour envoyer des fichiers. Sinon on recommande pas parce qu'on envoie son Mot de passe en clair et non-chiffré, et ça il faut pas paraît-il !!
Plutôt utiliser sftp je crois ...


Bon une panne de moins en tout cas :up:
 

Larme

Vétéran
Club MacG
11 Décembre 2007
6 491
398
Paris
ftp> open noos.fr[/FONT] et puis il se passe rien ... Il gèle même avec Little Snitch déconnecté. Ça m'étonne, je crois que ftp sous Terminal c'est le protocole le + simple pour envoyer des fichiers. Sinon on recommande pas parce qu'on envoie son Mot de passe en clair et non-chiffré, et ça il faut pas paraît-il !!
Plutôt utiliser sftp je crois ...
Et si tu tapais $>ftp mapage.noos.fr plutôt que $>ftp noos.fr ? :eek:
 

Polo35230

Membre d’élite
Club MacG
4 Janvier 2011
1 555
82
Larme à raison, le nom d'hôte est mapage.noos.fr

Maintenant, les logiciels de transfert ftp n'ont pas inventé la poudre, ce ne sont que des interfaces graphiques qui utilisent les commandes ftp du Terminal...
Le ftp du Terminal n'est pas si simple, fais un "man ftp" pour voir...:)
Dans le Terminal, tu as aussi un sftp (c'est un ftp sécurisé), mais de l'autre côté (chez Noos,) il faut qu'ils acceptent ce protocole de transfert.

Quant au fichier hosts, c'est vrai qu'il vaut mieux ne pas le bricoler, sauf que certains logiciels le font sans te demander ton avis, et peuvent semer la zone....
C'est pour ça qu'il faut le regarder quand on a des pbs d'accès à certains sites.

LittleSnitch, quant à lui devait peut-être interdire (par défaut), les connexions sortantes ftp (port 21).
Là aussi, il faudrait regarder les règles.