Connexion NAS Synology DS920 + sur Mac Mini Late 2014 en Ethernet

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
Bonjour à tous! :merci:

J'ai acquis récemment un NAS Synology DS920+ que j'utilise notamment avec 2 Macs Mini, dont le principal (utilisation la plus fréquente) est un Late 2014.

Les choses se passent plutôt bien (compte tenu que je ne suis qu'un Newbie en la matière...) sauf des déconnexions intempestives du Mini. Souvent brèves, mais quand je télécharge un fichier sur le NAS cela interrompt le processus... Egalement quand je dois transférer un fichier du NAS au Mini (ou vice versa) cela peut se faire très vite comme prendre un temps anormalement long.

En farfouillant sur le net, je me suis rendu compte que l'on pouvait connecter les deux en Ethernet, ce qui devrait apporter un débit plus important, mais aussi j'espère une plus grande stabilité. J'ai essayé de me conformer au maximum sur les instructions, en déclarant sur le NAS comme sur le Mini des adresses auto-assignées qui devraient être compatibles :

Capture d’écran 2021-08-16 à 17.48.14.png


Sauf que ça ne marche pas. L'état sur le Mini reste désespérément en jaune, et rien ne semble changer dans le dialogue entre les deux.

Avez-vous une idée de ce que j'ai oublié?

Merci d'avance pour votre aide! :up:
 

maxou56

Membre expert
Club MacG
14 Avril 2020
2 686
558
Lorient
je me suis rendu compte que l'on pouvait connecter les deux en Ethernet, ce qui devrait apporter un débit plus important, mais aussi j'espère une plus grande stabilité.
Bonjour,
Par rapport au 2 branchés en ethernet sur un switch ou box internet Gigabit et que l’ethernet est en premier dans l’ordre des connexions sur le Mac. Non pas d’avantage (Ou quelques Mo/s si tu mets les 2 en mtu 9000 par exemple, mais des inconvénients)

Sauf que ça ne marche pas. L'état sur le Mini reste désespérément en jaune,
En jaune c’est normal car le port ne permet pas l’accés à internet, et qu’il n’y a pas de serveur dns, passerelle.
(le NAS à aussi un serveur DHCP, par exemple le configurer pour le LAN2 puis mettre le Mac et le NAS en DHCP comme ça la connexion sera en vert)
Mais ça doit fonctionner en local par exemple, Finder > se connecter au serveur > smb://169.254.154.13
Attention si tu utilises « bonjour » ou 192.168.x.x c’est le wifi qui sera utilisé.


Maus la solution la plus propre c’est de connecter les 2 sur le même réseau en ethernet et par exemple dans le pare-feu du NAS bloquer l’IP wifi (il faudra des baux dhcp statiques) du Mac, pour forcer la connexion en ethernet entre les 2.
 
Dernière édition:

edenpulse

Membre expert
Club MacG
10 Août 2010
1 241
273
Bonjour à tous! :merci:

J'ai acquis récemment un NAS Synology DS920+ que j'utilise notamment avec 2 Macs Mini, dont le principal (utilisation la plus fréquente) est un Late 2014.

Les choses se passent plutôt bien (compte tenu que je ne suis qu'un Newbie en la matière...) sauf des déconnexions intempestives du Mini. Souvent brèves, mais quand je télécharge un fichier sur le NAS cela interrompt le processus... Egalement quand je dois transférer un fichier du NAS au Mini (ou vice versa) cela peut se faire très vite comme prendre un temps anormalement long.

En farfouillant sur le net, je me suis rendu compte que l'on pouvait connecter les deux en Ethernet, ce qui devrait apporter un débit plus important, mais aussi j'espère une plus grande stabilité. J'ai essayé de me conformer au maximum sur les instructions, en déclarant sur le NAS comme sur le Mini des adresses auto-assignées qui devraient être compatibles :

Voir la pièce jointe 235255

Sauf que ça ne marche pas. L'état sur le Mini reste désespérément en jaune, et rien ne semble changer dans le dialogue entre les deux.

Avez-vous une idée de ce que j'ai oublié?

Merci d'avance pour votre aide! :up:
Le NAS n'est pas censé être connecté directement à ton Mac mini, mais a ton routeur...
 

love_leeloo

Membre actif
Club MacG
25 Décembre 2004
985
324
dans la configuration où le NAS est relié seulement à ta box (ou ton routeur), comment y accèdes tu pour prendre des fichier dessus depuis tes Mac Mini ?

personnellement j'utilise le ftp (filezilla est gratuit et efficace) et ça marche plutôt bien. je tourne autour de 50/60Mo/s en transfert.
sans aucun coupure.

essaie les branchements les plus simple. c'est souvent le plus efficace ;)

bon courage
 

Polo35230

Membre expert
Club MacG
4 Janvier 2011
1 687
100
Salut,
J’ai beaucoup de mal à comprendre le fait de passer par des adresses auto-assignées pour faire communiquer deux machines…

Supposons que la Box soit sur un réseau 192.168.1.x masque 255.255.255.0
Le plus simple, c’est de laisser les Macs Mini en configuration DHCP auto. La box leur attribuera alors des adresses IP sur sa plage DHCP (supposons 192.168.1.10 à 192.168.1.50)

L’idéal est de configurer les interfaces ethernet du NAS en IP fixes (use DHCP: No), mais hors plages DHCP.
Par exemple:
192.168.1.51 Masque:255.255.255.0, DNS: 192.168.1.1 (si c’est l’adresse Lan de la box) routeur: 192.168.1.1
192.168.1.52 Masque:255.255.255.0, DNS: 192.168.1.1 (si c’est l’adresse Lan de la box) routeur: 192.168.1.1

Après, bien sûr, comme l’ont dit maxou et edenpulse, il faut que les matériels soient connectés en ethernet sur un switch ou sur la box.
 

love_leeloo

Membre actif
Club MacG
25 Décembre 2004
985
324
personnellement je mets des baux DHCP permanents sur ma box (routeur).

tous mes appareils ont donc des adresses IP fixes, mais je le fais sur le routeur.
ça se fait en 1 clic de souris
 

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
Bonjour à tous! Merci pour vos réponses... Désolé si je ne comprends pas tout...

Pour que ce soit plus clair, j'ai fait un schéma rapide des appareils connectés dans la pièce.

Bureau.jpg

Le réseau internet provient d'un TP-Link TL-WPAS8631P CPL Wifi AV 1300. J'ai du installer des CPL un peu partout chez moi, les murs étant particulièrement épais (demeure datant de 1912 sauf erreur de ma part). Le Wifi est connecté sur le TP-Link, et une connexion LAN est branchée pour le NAS. Le NAS est connecté en LAN du TP-Link, et avec le Mini principal. Toutes les autres connexions sont en Wifi, y compris le deuxième Mini (difficile à connecter en LAN) et le PC de travail (télétravail à 100% pour le moment). Les connexions LAN sont indiquées en rouge, la connexion USB en vert.

C'est pour suppléer une connexion un peu instable en WIfi du Mac principal avec le NAS que j'ai essayé de créer une seconde connexion en LAN.

J'espère que ma configuration est ainsi plus claire, désolé si je vous ai embrouillé dans mes explications initiales.

Pour répondre à vos remarques et questions, dans la mesure où je les comprends...
 

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
En jaune c’est normal car le port ne permet pas l’accés à internet, et qu’il n’y a pas de serveur dns, passerelle.
(le NAS à aussi un serveur DHCP, par exemple le configurer pour le LAN2 puis mettre le Mac et le NAS en DHCP comme ça la connexion sera en vert)
Mais ça doit fonctionner en local par exemple, Finder > se connecter au serveur > smb://169.254.154.13
Attention si tu utilises « bonjour » ou 192.168.x.x c’est le wifi qui sera utilisé.


Maus la solution la plus propre c’est de connecter les 2 sur le même réseau en ethernet et par exemple dans le pare-feu du NAS bloquer l’IP wifi (il faudra des baux dhcp statiques) du Mac, pour forcer la connexion en ethernet entre les 2.
Merci pour l'information sur le jaune. J'ai essayé de me connecter au serveur à partir du finder sans succès.

Le schéma montre que je ne peux faire que du filaire, car j'ai trop d'appareils qui sont en Wifi... D'où ma recherche d'une solution hybride.
 

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
dans la configuration où le NAS est relié seulement à ta box (ou ton routeur), comment y accèdes tu pour prendre des fichier dessus depuis tes Mac Mini ?

personnellement j'utilise le ftp (filezilla est gratuit et efficace) et ça marche plutôt bien. je tourne autour de 50/60Mo/s en transfert.
sans aucun coupure.

essaie les branchements les plus simple. c'est souvent le plus efficace ;)

bon courage
J'y accède par le finder, tout simplement; comme si c'était un disque dur externe en quelque sorte...

A noter que cette instabilité crée d'autres problèmes qui se manifestent même sans recourir à Finder: j'ai réglé les sauvegardes Time Machine sur le NAS; et les mêmes causes créant les mêmes effets, quelquefois la sauvegarde s'interrompt du fait de la perte momentanée de connexion...
 

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
Salut,
J’ai beaucoup de mal à comprendre le fait de passer par des adresses auto-assignées pour faire communiquer deux machines…

Supposons que la Box soit sur un réseau 192.168.1.x masque 255.255.255.0
Le plus simple, c’est de laisser les Macs Mini en configuration DHCP auto. La box leur attribuera alors des adresses IP sur sa plage DHCP (supposons 192.168.1.10 à 192.168.1.50)

L’idéal est de configurer les interfaces ethernet du NAS en IP fixes (use DHCP: No), mais hors plages DHCP.
Par exemple:
192.168.1.51 Masque:255.255.255.0, DNS: 192.168.1.1 (si c’est l’adresse Lan de la box) routeur: 192.168.1.1
192.168.1.52 Masque:255.255.255.0, DNS: 192.168.1.1 (si c’est l’adresse Lan de la box) routeur: 192.168.1.1

Après, bien sûr, comme l’ont dit maxou et edenpulse, il faut que les matériels soient connectés en ethernet sur un switch ou sur la box.

C'est le cas, il y a bien une connexion en DHCP automatique. C'est l'instabilité de cette connexion qui me pousse à chercher un palliatif.
 

love_leeloo

Membre actif
Club MacG
25 Décembre 2004
985
324
et pourquoi tu n'essaies pas de brancher ton NAS directement en Ethernet sur le routeur ?

ça permettrait de savoir si ça peut venir du WIFI
 

edenpulse

Membre expert
Club MacG
10 Août 2010
1 241
273
Oui je sais, et c'est le cas. Je cherche simplement une solution pour fiabiliser la connexion. Compte tenu du schéma, est-ce que tu as une autre solution à proposer, qui permettrait peut-être de simplifier les choses?
Peut-être simplement ton routeur opérateur est fautif. Ce qui est fortement possible si c'est une box classique opérateur comme orange ou SFR.
 

maxou56

Membre expert
Club MacG
14 Avril 2020
2 686
558
Lorient
J'ai essayé de me connecter au serveur à partir du finder sans succès.
Si le pare-feu du NAS est correctement configuré, c'est normale. les 169.254.xxx.xxx ne sont pas autorisés.

Mais sur ton schéma pourquoi ne pas mettre un switch basique gigabit entre le CPL, Mac mini et le NAS?
Ou si la prise CPL possède plusieurs prises Ethernet Gigabit comme sur la Photo.
En bloquant l'IP wifi du Mac dans le pare-feu du NAS (soit totalement, soit juste pour bonjour, afp, smb).
L'avantage, le Mac ce connectera prioritairement à internet et sur le réseau local en Ethernet (et CPL) si celui est en premier.

Sinon si tu souhaites connecter en direct les 2, oui c'est possible, mettre par exemple le NAS en 192.168.3.1 (255.255.255.0) et Mac en 192.168.3.2 (masque 255.225.225.0 et configurer le DNS et passerelle en 192.168.3.1, l'Ethernet n'aura pas besoin d'être en premier). Et ce connecterait via le Finder, soit via le navigateur avec l'IP 192.168.3.1
Par le Finder soi smb://IP soit afp://IP suivant ce que tu as configuré...
j'ai réglé les sauvegardes Time Machine sur le NAS
Pareil pour Time Machine dans cette configuration, il faudra supprimer la, les tâches, et sans réutiliser bonjour. Il faudra d'abord ce connecter dans le Finder manuellement via l'IP 192.168.3.1 monter les dossier partagé "Time Machine" puis aller dans Time Machine et ce reconnecter à la tache via le dossier "192.168.3.1" qui sera apparu et pas "xxxx.local". Sinon via bonjour ça risque d'utiliser le Wifi.
Capture d’écran 2021-08-17 à 14.49.00.png
 
Dernière édition:

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
Peut-être simplement ton routeur opérateur est fautif. Ce qui est fortement possible si c'est une box classique opérateur comme orange ou SFR.

On a peut-être une piste effectivement... Mais la LiveBox 4 est-elle vraiment en cause, sachant qu'à part alimenter le salon où elle est installée en WiFi, elle ne fait pas grand chose sauf pour la connexion LAN sur l'émetteur du CPL?
 

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
Si le pare-feu du NAS est correctement configuré, c'est normale. les 169.254.xxx.xxx ne sont pas autorisés.

OK, merci!
Mais sur ton schéma pourquoi ne pas mettre un switch basique gigabit entre le CPL, Mac mini et le NAS?
Ou si la prise CPL possède plusieurs prises Ethernet Gigabit comme sur la Photo.

C'est ce que j'avais fait initialement (brancher directement le LAN du Mini sur le CPL), mais je n'avais pas l'impression que c'était actif... Je me suis même demandé à un moment si le CPL ne fonctionnait pas en LAN ou en WiFi, mais pas les deux à la fois...

En bloquant l'IP wifi du Mac dans le pare-feu du NAS (soit totalement, soit juste pour bonjour, afp, smb).
L'avantage, le Mac ce connectera prioritairement à internet et sur le réseau local en Ethernet (et CPL) si celui est en premier.

Sinon si tu souhaites connecter en direct les 2, oui c'est possible, mettre par exemple le NAS en 192.168.3.1 (255.255.255.0) et Mac en 192.168.3.2 (masque 255.225.225.0 et configurer le DNS et passerelle en 192.168.3.1, l'Ethernet n'aura pas besoin d'être en premier). Et ce connecterait via le Finder, soit via le navigateur avec l'IP 192.168.3.1
Par le Finder soi smb://IP soit afp://IP suivant ce que tu as configuré...

Là ça dépasse (largement) mes compétences... :nailbiting:

Qu'est-ce que tu appelles le DNS et la passerelle? A quel endroit ça se configure?

Pareil pour Time Machine dans cette configuration, il faudra supprimer la, les tâches, et sans réutiliser bonjour. Il faudra d'abord ce connecter dans le Finder manuellement via l'IP 192.168.3.1 monter les dossier partagé "Time Machine" puis aller dans Time Machine et ce reconnecter à la tache via le dossier "192.168.3.1" qui sera apparu et pas "xxxx.local". Sinon via bonjour ça risque d'utiliser le Wifi.
Voir la pièce jointe 235345
Je pense que je saisis, mais il faut régler l'autre problème d'abord.

Comment s'assurer que "Bonjour" n'est pas activé?
 

Pat1763

Membre actif
11 Août 2008
591
26
La Rochelle (17)
Tout est possible.
Mais si c'est Mac/PC > wifi > Livebox > CPL > NAS.
Le fait que ça soit instable n'est pas forcément anormal suivant la qualité du réseau électrique, des débits wifi, CPL...

Les débits WiFi ont été mesurés quand j'ai déployé le réseau des CPL, mais pas de façon assez pro pour détecter des chûtes de connexion aléatoires. Le réseau électrique... on dira qu'il en est à sa première mouture (pas installé en 1912, mais il y a au moins 60 ans); le bureau où je suis ainsi que le tableau principal ont été rénovés il y a 2-3 ans, mais bon il y a tout le reste de la maison... Le CPL suit donc. Pour info, j'ai installé une liaison 32 ampères dans le garage (ce qui a amené à rénover aussi l'électricité de la cuisine et du garage) pour la recharge de mon VE. Lorsque je regarde les caractéristiques du réseau sur le chargeur, ça bouge pas mal (notamment pour le voltage et l'ampérage)...
 

maxou56

Membre expert
Club MacG
14 Avril 2020
2 686
558
Lorient
Comment s'assurer que "Bonjour" n'est pas activé?
Il faut mieux le laisser activé sur le NAS.

C'est ce que j'avais fait initialement (brancher directement le LAN du Mini sur le CPL), mais je n'avais pas l'impression que c'était actif...
C'est simple de vérifier, si la connexion reçois bien une IP de la livebox, quelle est bien en verte.
Après comme dit plus haut, il faut mettre la connexion ethernet en premier et idéalement bloquer l'IP du wifi sur le NAS pour être sur d'utiliser l'ethernet, ou ne pas ce connecter en wifi en même temps que l'ethernet.

Comme ça tous est automatique, pas besoin de ce prendre la tête.