Contour impossible à vectoriser

ccciolll

Membre expert
Club MacG
Bonjour,

me voici face à un phénomène incompréhensible.

C'est un fichier Illustrator que j'ai récupéré? Il comporte certains tracés avec des contours.

Je souhaite vectoriser ces contours.

Or cela m'est impossible, tout du moins le résultat ne convient pas.
Et puis difficile de vous décrire le problème sans image or je n'arrive plus à uploader de fichier sur macgé depuis là, quelques minutes…

Euh…

Bon, donc le tracé, c'est simple, c'est 2 points, reliés par un trait courbe. Quasiment le niveau 1 du tracé vectoriel, quoi.
Et quand je vectorise le contour (ou plutôt quand je fais "relief" car j'utilise illustrator 8 que je trouve plus pratique que le CS) au lieu d'avoir un genre de macaroni, j'obtiens des tracés qui se superposent et se coupent.

GGhhh, je vois pas comment décrire ça avec des mots… Disons qu'au lieu d'avoir une seule forme composée d'un tracé avec 4 points, je me retrouve avec 3 formes : 2 pleines de 4 points et une en transparence avec 3 points, ces 3 points étant superposés aux autres.

Ouais, incompréhensible, hein. Pourtant en image ça donne un truc vraiment tout bête.

Enfin bon, j'ai essayé d'isoler le tracé dans un nouveau docuement, de le copier dans photoshop pour le réimporter dans illustrator, de le copier dans illu CS, de l'enregistrer en Illustrator 3 et de le réouvrir, j'ai toujours le même résultat. Pourtant, si je fais un tracé similaire (2 points réliés par une courbe) je vectorise le contour sans problème.

Que faire que faire ?


Ils ont encore oublié d'aérer, dans le forum "Arts graphiques" ? :siffle:
 

ccciolll

Membre expert
Club MacG
Ils ont encore oublié d'aérer, dans le forum "Arts graphiques" ? :siffle:

Ce serait à cause de ça que je n'arrive pas à uploader une image ?

Je croyais que c'était lié à ma limite d'uploads à moi. J'ai fait un peu de ménage mais ça ne monte toujours pas.

Bon, je vais faire avec un lien et ça ira aussi bien

Donc voici mon problème illustré :

Image.gif


Comme vous voyez, le résultat "après" n'est pas celui escompté. Je souhaiterai obtenir qqchose qui ressemblât un peu plus au "avant".
Quand je crée des tracés de même style, ils se vectorisent le contour sans problème. Alors pourquoi celui-là fait le zinzin ?
 

PA5CAL

Membre expert
Club MacG
21 Juillet 2005
9 251
597
Île-de-France
Bonjour

Je n'ai pas la réponse, mais ce que je trouve étonnant c'est que la détection des éléments géométriques de la forme semble tout-à-fait correcte. Tous les éléments y sont, et bien placés. Il semble que seule l'interprétation du résultat vectoriel pose problème : les opérations de recomposition vectorielle ne sont pas appliquées comme il faudrait.

Bogue ? Dysfonctionnement d'un composant logiciel ? Incompatibilité de format vectoriel ?
 

ccciolll

Membre expert
Club MacG
Oui, je suis d'accord avec toi. Tu utilises juste des mots plus pertinents et descriptifs, mais c'est exactement ce que je ressens.

Il fait un truc qui à l'air correct, sauf que pas exactement. Il a une ogique qui n'est pas la bonne… Et seulement sur ce tracé d'origine. Si j'en fais un moi-même (de tracé) selon des paramètres APPAREMMENT identiques, il se comporte comme il faut.

Bon, je vais être bon pour refaire le logo à l'œil nu en mode pomme Y.
 

ccciolll

Membre expert
Club MacG
Ben écoute, merci, mais du coup, je viens de réessayer. Et là, dans mon fidèle Illustrator 8, en me contentant de copier le tracé et le "coller à la place" (pommeF) dans un calque vide et tout seul, le Objet>tracé>relief a marché comme il se doit.
Je suis pourtant persuadé d'avoir essayé cette méthode puisque c'est celle que j'utilise toujours dans ce genre de situation.
Bon, je devais être à la masse ce jour là.
 
  • J’aime
Réactions: zigouiman

ccciolll

Membre expert
Club MacG
Dans un souci d'exactitiude absolue, ça m'aurait tout de même pris une bonne minute. à multiplier par le nombre de petits vermicelles de ce type présents dans le fichier.

Et dans l'absolu, c'est quand même mieux de trouver la solution.
 

apenspel

Membre expert
Club MacG
23 Juin 2002
7 056
329
.be - BXL
C'est vrai que Illustrator 8 était bien buggué. Moi, ce qui me tuait, c'étaient les points noirs au beau milieu de mes dégradés circulaires.
 

ccciolll

Membre expert
Club MacG

apenspel

Membre expert
Club MacG
23 Juin 2002
7 056
329
.be - BXL
J'aime bien la CS2, ou la v. 10, aussi. Il semble qu'il faille éviter les impair(e)s. ;)
 

ccciolll

Membre expert
Club MacG
Bon, aucune raison de parler des KPT dans ce sujet, allez hop, je ferme !!!











(oups, je me suis pris pour un modo)
 
  • J’aime
Réactions: NED

Joconde

Membre enregistré
28 Juillet 2007
2
0
Ah, il n'y avait pas de décomposition des contours dans les KPT Vector trucs ?

Salut à tous,

je vois que ton problème n'est pas commun mais as-tu bien décortiqué ton problème.
Tu as du avoir un effet patfinder sur ces tracés. Essaie de les dissocier.

Pourquoi tu n'utilise pas ton tracé comme modèle et tu le reproduis ?;)

Bon courage !