des soucis avec mon macpro

pipi_room

Nouveau membre
31 Décembre 2007
7
1
36
bonsoir à tous,
Quelqu'un a-t'il fini par comprendre ces problèmes?! J'ai comme l'impression que pour le mien (décrit plus haut) la carte graphique n'est pas fautive (ou alors il faudrait que je tombé sur 2 CG 2600xt défaillantes dont une neuve fourni par le service apple.
J'ai pris un peu de temps pour me geeker à la bidouille mac et j'ai vraiment l'impression que c'est une défaillance de firmware EFI, un peu comme s'il l'extended firmware ne se lançait pas complétement.
Je m'explique, mais ce n'est peut être valable que pour mon cas
les led de diagnostic de la logic board ne présentent aucune erreur détectée (LEDS 3 4 5 6 ) restent éteintes en toutes circonstances.
leds 8 et 9 en vert continu, et la 2 en jaune continu seulement le hic vient de la une et la sept qui sont éteinte en toute circonstances alors qu'elles devraient rester allumées.
soit si on interprete ca selon le guide,

led 1--> off when computer is in sleep mode, ..... le macpro serait donc dans un mode veille qui l'empèche de booter.

LED 7 --> 1 GPU present ... off "EFI HAS CONFIGURED THE GRAPHICS CARD" en imaginant que la carte graphique soit neuve et testée sur 2 slot x 16 différent il y a peu de chance que le pb vienne de ce coté.

en continuant de fouiller sur la logic board j'ai vu que les early 2008 n'ont pas de reset smc comme les anciens sous forme d'un bouton, (j'ai cru voir un relicat de ce bouton sur le circuit imprimé, juste en dessous de l'arete droite du premier disque dur. Il y a là un emplacement à contact marqué SMC rst...)
Cependant les logic board 2008 ont un reset system afin de voir si le systeme reboot apreès un tour de chauffe....
Pour moi c'est un echec ce bouton ne sert à rien...

Enfin bref, j'aurais bien voulu essayer de flasher le firmware efi avec la version mars 2008 (que je ne suis d'aillleurs plus sur d'avoir mis à jour) seulement pour l'instant je n'ai pas trouver d'autre moyen que de lancer le boot jusqu'au bout avant de faire la manip?!

QQ un aurait une idée pour faire la manip sans lancer complétement la machine, genre en réseau ou autre?!

j'espère que les explications ne sont pas trop brouillons j'ai passé la journée le nez dans la bestiole et les pensées fusent....

Je précise au passage que le macpro ressort d'un applestore premium machintruc ou selon eux la seule solution c'est raquer un mois de salaire pour changer la carte mère.
Je le précise car le gars m'a tout de même avouer ne pas avoir compris le problème mais que changer la logic board allait le résoudre!!! quel farce:up:
 
Dernière édition:

pipi_room

Nouveau membre
31 Décembre 2007
7
1
36
re bonjour à tous,
Petit rapport concernant ces problèmes de macpro.
Pour l'instant plus personne ne réagit sur ce post, mais je tient à le continuer pour apporter ce que je test et peut etre bientot une solution.
Aujourd'hui, j'ai lancé une réécriture du firmware macpro, dans mon cas la version 1.5 early 2008 dispo ici http://support.apple.com/kb/DL94
La manip et plutot simple, burnez un cd avec le firmware dmg dessus, la page apple insiste sur le nom que vous donnez à ce cd
To restore your computer's firmware, you must first create a CD using the disk image named "FirmwareRestorationCD.dmg" by following these steps:
Dans le doute j'ai renommé le fichier pour que le mien colle à la lettre. Le hic c'est que pour cette manip il vous faut un autre mac, ou peut etre qu'il existe un utilitaire pc gravant des cd en format mac? en tout cas je n'en ai pas trouvé (et oui je suis hybride mac pc) donc le macpro du boulot fera l'affaire.
Avant la manip, une réinitialisation smc (la 98654687ème).
Par précaution et pour ne pas risquer de perdre un précieux essai j'ai inséré le cd manuellement dans le superdrive, la manip est plutot simple.
ouvrir la machine, sortir le bloc superdrive. pas besoin de le déconnecter normalement il y a un peut de longueur de nappe.
Sous la facade gauche à travers la fente du lecteur on distingue une roue dentée qui commande l'ouverture. avec un trombone faite la tourner dans le sens inverse des aiguille d'une montre (si on regarde par dessus) ou vers la droite (si vous regardez de face).
ça s'ouvre mettez votre cd recovery dedans puis fermez.

L'opération de lancement du firmware n'a pas fonctionné exactement comme mentionnée dans le apple support. Je n'ai pas eu d'étape de led flashing, mais j'ai qd meme maintenu le bouton pendant une bonne minute.
au bout d'un moment je lache le bouton, (j'entend que le cd travaille depuis le début) les ventilo graphique et mac sont à bon régime.
Puis tout se calme et la machine continue à bosser silencieusement, elle lit le disque.
Pendant toute cette étape je n'ai rien à l'écran, pas de pomme pas de barre, juste no signal.
je la surveille de loin pendant que je bricole d'autres trucs.
Au bout de 5 minutes le gong salvateur arrive.
IL BOOT !!!!!
tout repart comme si de rien était et semble stable silencieux etc...
Le temps de chercher la console pour trouver d'éventuel kp, l'écran coupe au noir, et la machine repart en mode sécu.
seulement le cd tourne tjrs dedans donc pour l'instant je laisse faire, cela fait 15 min maintenant, je vais retenter la manip.

---------- Nouveau message ajouté à 16h26 ---------- Le message précédent a été envoyé à 16h00 ----------

Petite précision durant le dernier test

lorsque le mac est reparti en mode sécu, j'ai jeté un oeil au led de diagnostics. la n°7 clignotait genre faux contact ou quellelque chose se lance mais se coupe tout de suite après.

Le second test que je viens de lancer à l'instant, (la meme manip, snc + firmware)
bouton appuyé, machine démarre puis ventilo puis cd elle cherche un truc.
J'entend un buzz genre bip de bios (que je n'avais jamais entendu auparavant) puis le gong de boot.
Et depuis lors (c'était il y a 3 minutes pas de pb ) j'installe techtool pour un check et harware chk. mais tout a l'air de rouler....
Quand je pense à mr truc qui voulais me faire payer 800€ de logic board! je lui ferai bien avaler sa logic board moi gros arnaqueur!
 
  • J’aime
Réactions: figaro

pipi_room

Nouveau membre
31 Décembre 2007
7
1
36
J'ai peut etre parlé trop vite,
mon macpro 3.1 à très bien tourné le temps que je lui ai demandé, j'ai fait l'entretien de base et poussé (authorisation disk, réparation disque os, mise à jour des firmware, sauvegarde time machine etc...) ça a tourné nickel jusqu'au soir. J'éteint la machine la pensant vraiment réssucitée!
Le lendemain, rebelotte pas de boot... et led 7 diagnostic éteinte, alors que 2 8 9 ok
donc, je relance la manip en me disant qu'une des écriture efi s'est mal passé. plus moyen de mettre à jour l'efi, la machine ne comprend pas la manip et la cg tourne à fond.

J'ai 2 théories, et je maintient que la logic board est intacte.
-la carte graphique 2600xt fout le dawa.
-mon disque dur osx à un pépin, ( la réparation avait trouvé des écart entre les tables de registre et les fichiers présents sur le disque, 3 fichiers et 3 répertoires en plus sur le disque)
et empèche le boot d'osx.

Mais pourquoi diable les manip firmware ne fonctionnent-elle plus?
 

pipi_room

Nouveau membre
31 Décembre 2007
7
1
36
De retour pour clore ce fil,
Cela m'a pris du temps mais j'ai pu trouver une logic board à un prix raisonnable un peu moins de 400€ et changer moi même la bestiole.
Rien d'insurmontable, et en dehors de quelques pièges le démontage et remontage est même facile. Cela m'a pris 4 heures en prenant le temps de faire des photos lire le guide et prendre des notes, ...bref pour les allumés de la vitesse il doit y avoir moyen de le faire en 1h30.
Pour conclure il remarche comme si rien n'avais eu lieu c'est la fin de cette mauvaise aventure,
la carte mère défectueuse ne présente pas de problème de condensateur visible, seul un encrassement assez significatif et même bizarre à des endroits précis; ainsi qu'une trace de vis qui a dû rater son trou et gratter la couche de surface.
Bref cela peut ou non être la cause de tout cela... pour moi le mystère plane toujours.
pour rappel la led diagnostic 7 restait éteinte, incompatibilité EFI vs GPU.

J'en retiens tout de meme une grande déception de apple en qui j'avais plutôt confiance en terme de fiabilité. Tout au long de cette (mé)saventure j'ai gardé en tête ces histoire d'ingénieurs qui fabriquent des produits pour qu'il tombent en panne et fassent plus de chiffre; la mort programmé. Ajoutez y le prix des pièces de rechange, le peu de revendeurs, la difficulté de trouver des fournisseurs parallèles... bref, vu d'ici apple ressemble plus à un dictat commerciale qu'a une marque fiable (le temps des G4 est révolu).
Alors peut-etre que les fan vont me traiter de menteur, mais je souhaite pour ma défense rappeler les mots de l'ingénieur technico commercial 3eme barrière hotline que j'ai eu l'honneur d'avoir au bout d'1h40 de patience,
"oh, vous savez 3 ans et demi c'est déjà un bel age !! " oser me dire ca, moi qui fait toujours tourner mon Nec workstation de 2000, oui 12 ans d'age!

Donc sauf "révolution" dans la politique apple, ce mac sera le premier et le dernier, dorénavant je me contenterai d'un bon vieux asus et d'un pot de peinture blanche.

Désolé d'avoir été si long, pour ceux qui en serait désireux n'hésitez pas a me contacter pour plus d'info sur le démontage,