MacBook Pro Disque dur principal écriture impossible

cedd79

Membre confirmé
5 Mai 2011
29
1
Salutation à tout le monde !

Déjà, mes excuses pour ce long texte. Si je viens à vous, c'est à cause d'un problème bien curieux que je rencontre avec mon vénérable Macbook pro donc voici la configuration :

Macbook pro mi-2010
2,66 GhZ Intel Core 2 Duo
RAM 8 Go DDR3
OS : El Capitan et Snow Leopard (sur deux disques séparés)

Tout d'abord, cet ordi était équipé d'un disque dur interne de 320 Go que je n'ai jamais uploadé plus que 10.6.8, puisque cela fonctionnait très bien. Puis, en décembre 2016, j'ai vraiment eu besoin de passer au SSD. J'ai donc fait installer chez MacWay un SSD de 500G sur lequel a été posé mon ancien système. Mon disque de 320 Go a pris la place de mon lecteur DVD qui ne fonctionnait plus. Et je suis resté sous Snow Leopard sur le nouveau.

J'ai continué de bosser tranquillement avec cette config jusqu'au mois dernier (octobre 2018) où n'ayant plus aucun logiciel à jour, la machine ramant à mort, j'ai enfin décidé de passer sous El Capitan. J'ai laissé le mac faire et magie, tout a bien fonctionné.

Enfin jusqu'à il y a quatre jours. Alors que j'utilisais Excel 2016 (license achetée), la machine s'est mise à ramer jusqu'à ce que le logiciel se ferme en me disant qu'il y a un problème de mémoire cache. J'ai relancé la machine et le drame. Impossible d'aller plus loin que la pomme d'allumage, avec un joli texte qui s'affichait me disant des trucs du genre "panic CPU" "user space panic : assertion failed", etc.

Je ne suis pas informaticien, ni je parle très bien anglais, mais a priori, ce n'était pas bon. L'ordi s'est mis à rebooter tout seul pour retomber systématique sur ce texte (je l'ai pris en photo si ça vous intéresse), jusqu'à ce que, après 5 ou 6 reboot, je force l'arrêt. Puis, j'ai tenté de redémarrer. La barre de chargement est montée lentement jusqu'au bout, mais le système n'a jamais réussi à se lancé.

Depuis j'ai tenté de :
- laisser en mode sans échec : échec
- faire une réinitialisation NVRAM
- passer par le monde recovery et réinstaller mon back up time machine : j'arrive bien sur l'utilitaire de recovery, j'arrive à l'utilitaire de disque, mais il me dit erreur si je tente une restauration
- passer par le monde recorvery et réinstaller El Capitan : idem que plus haut
- réparer le disque : idem que plus haut

Du coup, j'ai redémarré mon ordi en rebootant sur mon ancien système que je n'avais jamais pris le temps d'effacer, qui était resté sur mon ancien disque de 320 Go (celui qui avait pris la place du lecteur DVD). Miracle, mon ordi a redémarré comme si de rien n'était, en m'affichant même mon disque principal (le SSD qui plante donct), comme un simple disque internet de stockage.

Mais pas si simple que cela car si je peux sans problème y récupérer mes données, si celui est reconnu sans souci et monte tranquillement, il se comporte comme s'il était formaté en NTFS : impossible d'écrire dessus, de réparer ses autorisations. J'ai juste pu le reconstruire une fois avec mon utilitaire de disque et avec DiskWarrior, mais sans pouvoir quand même rebooter dessus. Si on ne peut rien écrire dessus (il est pourtant en "lecture et écriture), je comprends mieux pourquoi il n'était pas possible d'y restaurer mon time machine, El Capitan ou l'effacer.

Voilà ! J'espère n'avoir pas été clair, pas trop long, et de n'avoir pas trop oublié de truc. Si vous avez des idées sur ce qui se passe, je suis preneur ! Merci d'avoir pris le temps de me lire !

Ced
 
Dernière édition par un modérateur:

Fullcrum

OS Collector
Club MacG
5 Janvier 2016
4 182
1 060
Dole 39
Salut,

En première lecture, ça me fait penser à la NAPP SATA, ce petit bout de câble qui relie ton SSD à la carte mère. À savoir si Macway te l’avait remplacé en même temps que l’installation du SSD en lieu et place du disque à plateaux ?

Attends un peu d’avoir d’autres avis, mais je parierais presque que c’est la NAPP SATA.
 

cedd79

Membre confirmé
5 Mai 2011
29
1
Hello !

Merci beaucoup pour cette réponse ! :)

La NAPP SATA, c'est bien le câble qui relie le disque dur à la carte mère ?

J'y ai pensé, mais je croyais que lorsque la NAPP grillait, le disque dur ne montait plus du tout.

Aucune idée sur MacWay a changé la NAPP lors de l'installation du disque dur. Cela me paraitrait normal puisque les connexions doivent être un peu différentes d'un disque dur traditionnel. Mais comme ils ne m'ont pas facturé de NAPP, à moins que tout cela était compris dans le prix...
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 965
6 421
La NAPP SATA, c'est bien le câble qui relie le disque dur à la carte mère ?
Oui, la nappe SATA relie bien le disque dur à la carte mère. Et non, elle ne grille pas, tu as lu ça où ? Le problème est tout autre, le taux de transfert des données est à minima cinq fois supérieur à celui d'un disque dur à plateaux. Il faut impérativement une nappe SATA de qualité supérieure que tu pourras acheter chez MacWay en téléphonant et en donnant le modèle exact de ton MBP pour ne pas te tromper.
Du coup, j'ai redémarré mon ordi en rebootant sur mon ancien système que je n'avais jamais pris le temps d'effacer, qui était resté sur mon ancien disque de 320 Go (celui qui avait pris la place du lecteur DVD).

Miracle, mon ordi a redémarré comme si de rien n'était, en m'affichant même mon disque principal (le SSD qui plante donct), comme un simple disque internet de stockage.
Là tu confirmes que le problème est bien la nappe SATA puisque tu redémarres sans problème avec l'ancien disque dur. C'est un problème connu, qui survient sans prévenir du jour au lendemain. Certains utilisateurs ont ce problème tout de suite après le changement d'un disque dur, ou 1 jour, 1 semaine, 1 mois, 1 année, c'est imprévisible.

Ton MBP étant assez ancien, je te conseille d'installer le SSD en lieu et place du disque dur d'origine et placer l'ancien à la place du SuperDrive, histoire de bénéficier du taux de transfert le plus élevé.
 

cedd79

Membre confirmé
5 Mai 2011
29
1
Merci pour ta réponse ! :)

.Ton MBP étant assez ancien, je te conseille d'installer le SSD en lieu et place du disque dur d'origine et placer l'ancien à la place du SuperDrive, histoire de bénéficier du taux de transfert le plus élevé.

C'est ce que j'ai fait il y deux ans justement. Le SSD a remplacé le disque dur d'origine, et le disque dur d'origine le lecteur. Et c'est sur ce dernier que je reboot en ce moment, car c'est le SSD qui bugg. :-(
 

cedd79

Membre confirmé
5 Mai 2011
29
1
Je vais tester la nappe. On verra bien.

Mon SSD principal est toujours reconnu, je peux, à partir de l'ancien, récupéré ce que je veux, mais comme je ne peux rien écrire dessus (et donc lancer mon système à partir de celui-ci), en effet cela semble être mécanique.

Je fais une opération MacWay et je reviens vers vous ! :)

Encore merci !
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 965
6 421
Je vais tester la nappe. On verra bien.
Négatif, il n'y a rien à tester. Si ton SSD n'est pas/plus reconnu, il faut impérativement la changer par une neuve.

Et au fait, encore faut-il savoir de quelle nappe SATA on parle ? Celle du disque dur principal, ou celle du connecteur du SuperDrive ? Ou est connecté ton SSD, à la place du disque dur d'origine ?
 

cedd79

Membre confirmé
5 Mai 2011
29
1
Quand je disais "tester", je voulais dire "installer". :)

Mais le disque est bien reconnu, il tourne. C'est juste qu'on ne peut rien n'y inscrire. Et que le système ne se lance plus à partir de celui-ci. Mais il monte sans problème sur l'ordi. Vraiment singulier.
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 965
6 421
Quand je disais "tester", je voulais dire "installer". :)
OK.
Mais le disque est bien reconnu, il tourne. C'est juste qu'on ne peut rien n'y inscrire. Et que le système ne se lance plus à partir de celui-ci. Mais il monte sans problème sur l'ordi. Vraiment singulier.
Je me répète, où est connecté ton SSD, à la place du disque dur d'origine ?

Ou est connecté le disque dur qui pose problème en lecture/écriture ? Dans quel disque dur est installée ta version de macOS en cours ?
 
M

Membre supprimé 1138547

Invité
Bonjour,
C’est ce que te dit Locke, problème de débit. Rien de mystérieux
Ce qui l’est, c’est que ton SSD tourne[emoji56]
 

cedd79

Membre confirmé
5 Mai 2011
29
1
où est connecté ton SSD, à la place du disque dur d'origine ?

Yes. Le SSD de 500Go est à la place du disque d'origine.
Le disque d'origine de 320Go a été placé à la place du lecteur. Et me sert de stockage. Mais je n'ai jamais supprimé les fichiers systèmes.

Ou est connecté le disque dur qui pose problème en lecture/écriture ?

Le SSD 500Go (celui qui pose problème) est connecté à la place du disque d'origine. Il fonctionne tout à fait en lecture, mais plus en écriture. Et le système ne se lance plus à partir de celui-ci.
Il monte très bien, à la manière d'un disque interne, à partir du système en cours.

Dans quel disque dur est installée ta version de macOS en cours ?

La version de MacOS en cours est installée sur le vieux disque de 320Go que je n'ai jamais formaté et que je lance via la touche Alt au démarrage de l'ordi.

Désolé si je ne suis pas clair. Je ne suis pas vraiment pas pointu en informatique. :-(
 

Locke

What am I doing here?
Modérateur
Club MacG
20 Juillet 2011
40 965
6 421
Le SSD 500Go (celui qui pose problème) est connecté à la place du disque d'origine. Il fonctionne tout à fait en lecture, mais plus en écriture. Et le système ne se lance plus à partir de celui-ci.
Il monte très bien, à la manière d'un disque interne, à partir du système en cours.
Ça s'éclaircit, par curiosité, tu lances le Terminal, tu fais un copier de cette commande...
Bloc de code:
diskutil list
...en donnant le résultat.

Petit rappel...
Pour diffuser un rapport EtreCheck ou un retour de commandes via le Terminal dans les forums, dans votre réponse, un clic sur cette icône ⊞, sélectionnez les Balises </> Code, dans la fenêtre qui s’ouvrira faites un Copier/Coller du rapport et/ou du résultat du Terminal, un clic sur Insérer et validez votre réponse.
 

cedd79

Membre confirmé
5 Mai 2011
29
1
Ça s'éclaircit, par curiosité, tu lances le Terminal, tu fais un copier de cette commande...
diskutil list
...en donnant le résultat.

Petit rappel...


Bloc de code:
Last login: Mon Nov 26 08:31:02 on console
Ced:~ cedric$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *525.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            524.3 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *320.1 GB   disk1
   1:                        EFI                         209.7 MB   disk1s1
   2:                  Apple_HFS HD 320Go                319.7 GB   disk1s2
Ced:~ cedric$

Voilà ! :)
 

cedd79

Membre confirmé
5 Mai 2011
29
1
Et bien c'est plutôt une bonne nouvelle.

Merci pour ces expertises et pistes de réparation. Ce mercredi, je passe chez MacWay et je reviens ici pour le feedback.

Encore merci !