• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

DotClear - premiers pas

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Hello

Je suis sous Safari (normal quoi...), effectivement je n'ai pas eu le reflexe de tester avec IE, ce qui finit de prouver que je ne suis pas un vrai pro...
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
J'ai testé sous Safari(1.2), MSIE et Camino(0.7) et je n'ai pas réussi à reproduire ton problème : mes modifs dans les outils sont bien prises en compte. Le seule différence constatée est l'interface d'admin dans Safari qui est moins finie (pas d'onglets).
Même version de DC (1.2alpha), même hébergeur : Celeonet.fr, même manipulation (interdire les commentaires).

Je regarde le lien posté plus haut...

>Edit :
molgow a dit:
Ce message de sylver pourrait éventuellement vous intéresser.
Effectivement, vu que je n'ai pas réussi à reproduire le problème, je ne peux pas t'aider, le mieux c'est de continuer cette discussion sur http://www.dotclear.net/

>>Edit2 ... mais je vois que c'est déjà fait
 

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Bizarre, car ce problème est survenu les deux fois où j'ai installé DotClear (entre temps j'ai tout effacé...)

C'est vraiment très étrange par ma barbe...
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
peut-être un problème d'autorisations d'accès ftp qui serais survenu lors du chargement avec ton client FTP. vérifie si tu as bien toutes les autorisations ChMOD sur le fichier dont on t'a parlé sur le forum de DC : conf/dotclear.ini

(quel logiciel FTP utilises-tu ?)

Si tu vas dans ton Espace client Celeonet>Onglet FTP>WebFTP, tu peux chercher ton fichier dotclear/conf/dotclear.ini vérifier si tu as bien -rw-rw-rw- en autorisations ChMod. Si ce n'est pas le cas, clique sur l'engrenage, à droite pour cocher toutes les cases "lecture" et "écriture".

C'est très simple à faire. Normalement on ne devrait pas avoir à le faire mais il parait qu'il arrive que des autorisations soient modifiées par le client FTP au moment du transfert...
 

turnover

Membre d’élite
Club MacG
5 Décembre 2001
1 143
237
47
PACA
www.cedriclemoigne.com
Oui je vois que ça et moi non plus j'ai pas retrouvé ce bug. Tu devrais le poster sur le bugtrak du site de dotclear si tu trouves pas d'ici là.

Pour ce qui est du theme. Vous pouvez en créer un vous même en copiant le theme defaut de base. Nommer le différemment et changez bien les infos dans desc.xml. Ensuite il faut comprendre les boucles et les fonctions.
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
DotClear utilise de manière exhaustive les css. En fait il réponds totalement aux normes du W3C, ce qui fait qu'il suffit d'éditer le fichier style.css d'un thème pour complètement l'arranger à sa sauce (visuellement). C'est tellement bien fait que c'est très bien pour s'entraîner à manipuler les CSS.

Ensuite, s'il s'agit d'ajouter ou d'enlever un lien, c'est les fichier .php qu'il faut modifier (en particulier template.php).
 

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Merci je vais tester tout ça ce week end (ce soir, je fais une pause de DotClear, le médecin a dit que c'était important...).
 

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Bonjour

Je me suis ré-attaqué au problème aujourd'hui et il semblerait que le coupable soit Safari (1.2) puisque je parviens à modifier les champs depuis IE.

Suis-je le seul à avoir ce problème?
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
Je n'ai pas le problème mais il me semble vaguement me rappeler avoir un des pb similaires avec la version précédente. Tu as bien la toute dernière version ? 1.2.x ?
 

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Niconemo a dit:
Je n'ai pas le problème mais il me semble vaguement me rappeler avoir un des pb similaires avec la version précédente. Tu as bien la toute dernière version ? 1.2.x ?
Oui j'ai la toute dernière...
Bon pour l'instant je m'en sors, j'ai même réussi à modifier les templates et css, trop fort, moi...

Prochaine étape : arriver à agrandir la largeur de la page et mettre un favicon (j'en chie un peu).

http://vince.celeonet.fr

PS. Je continue à poster ici malgré l'existence du forum dotclear que je ne trouve pas très convivial et pas très pratique (quand je poste dans un vieux sujet, celui-ci ne remonte pas, du coup personne ne voit ma question).
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
Si tu es sur Celeonet, tu pourra poster aussi sur le forum de WebDynamit (en précisant que ton site est sur Celeonet si tu as un nom de domaine)


Ton favicon marche bien (c'est possible que Safari mette quelques temps à l'afficher chez toi : pb de cache).

Pour la largeur, édite la valeur "width" du style "#page" dans fichier style.css (/themes/default/style.css). Elle est définie à 728 pixels. Bienvenue dans le monde des feuilles de style en cascade


<font class="small">Code:</font><hr /><pre>/* Page
-------------------------------------------------------- */
#page {
width : 728px;
margin : 0 auto;
padding : 0 9px;
background: #FFF url(images/bg.png) repeat-y left;
voice-family: "\"}\"";
voice-family:inherit;
width: 710px;
}
</pre><hr />

&gt;Edit : Euh en regardant cet extrait, je vois des trucs bizarres : des entrées en double, ça n'est pas normal... tu y a déjà touché ?
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
Non. J'ai vérifié c'est aussi sur la version originale. Je vais poster un truc à ce sujet sur le forum DC.
 

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Merci pour tes réponses

Je m'étonne que mon favicon marche (tu as essayé ce matin?), moi je ne parviens pas à le voir, même après avoir utilisé safari icon manager...

Pour la largeur de la page j'ai déjà essayé de modifier ce paramètre mais ça m'a tout foutu en bordel.

Faudra que je creuse un peu...
 

la tortue

Membre confirmé
6 Novembre 2003
397
1
Niconemo a dit:
<font class="small">Code:</font><hr /><pre>/* Page
-------------------------------------------------------- */
#page {
width : 728px;
margin : 0 auto;
padding : 0 9px;
background: #FFF url(images/bg.png) repeat-y left;
voice-family: "\"}\"";
voice-family:inherit;
width: 710px;
}
</pre><hr />

&gt;Edit : Euh en regardant cet extrait, je vois des trucs bizarres : des entrées en double, ça n'est pas normal... tu y a déjà touché ?
Les trucs bizarres c'est un "hack" pour IE qui se plante sur les paddings:
Le parser de IE s'arrête quand il voit l'accolade '}' dans 'voice-family'.
Il mémorise donc largeur 728 .
Les autres navigateurs vont jusqu'au bout et mémorise largeur 710.
La différence 18 = 9 + 9 correspond au padding...


Personnellement j'aime pas trop ce genre de code.
 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
Ben moi je trouve ça génial au contraire
même si je préfèrerasi que MSIE interprète correctement le code CSS.

Donc pour modifier la largeur, pour rajouter 50px par exemple, il faut rajouter 50 aux deux width. Mais après il faudra encore éditer la largeur des colonnes intérieures...
 

donatello

Membre d’élite
Club MacG
14 Mars 2001
1 210
324
42
Carrément à l'ouest
Alors :

Quand je change "width" dans 'page' il ne se passe rien

Par contre quand je change "width" dans 'main' ça fait sortir le calendrier vers la droite.

Par contre je vois mon favicon
 

la tortue

Membre confirmé
6 Novembre 2003
397
1
Niconemo a dit:
Ben moi je trouve ça génial au contraire
Faut pas pousser non plus.

C'est de la maxi-bidouille de m
rde...
Si t'es un peu courageux, tu laisse tomber la compatibilité avec IE.

 

Niconemo

Modo (toujours vivant !)
Modérateur
Club MacG
26 Juin 2001
6 447
455
Rhône-Alpes
Que ce soit de la bidouille, je ne dis pas le contraire (mais ça ne mange pas de pain).
Mais je ne vois pas où est le courage à ne pas être compatible avec MSIE... Ça me gave de devoir le faire à cause d'un logiciel de m
rde, comme tu dis, mais si toi tu peux te permettre de ne pas être compatible avec 90 % des internautes mes clients ne sont pas du même avis.
 

la tortue

Membre confirmé
6 Novembre 2003
397
1
Niconemo a dit:
mais si toi tu peux te permettre de ne pas être compatible avec 90 % des internautes mes clients ne sont pas du même avis.
Il ne s'agit pas vraiment d'incompatibilité...
C'est pas parce qu'un DIV est un peu décalé sur IE que les visiteurs vont le remarquer...

Mais personnellement je préfère que l'affichage plantouille un petit peu sur IE, plutôt que d'écrire du code bidouille pour contourner un bug d'IE en s'appuyant sur un autre bug.

Difficile de prédire lequel des deux va être corrigé en premier.

Je pense qu'il vaut mieux suivre les recommandations W3C, parce que c'est sans doute dans cette direction que les navigateurs vont évoluer.