• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

Forum Iweb

Statut
Ce sujet est fermé.

romeo133

Membre junior
19 Décembre 2007
25
0
c'est exactement ca que je veux. Mais j'ai pas compris comment faut faire ? Tu peux m'expliquer en détail ? merci d'avance
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
si t'as iWeb'o8
- efface le contenu de ta page (les photos les textes) qui ne fera qu'alourdir ta page et ralentir ta redirection
-si possible change le theme de cette page par un blanc ou noir (les deux plus legers)
- tu colles dans un Widget HTML le code que je t'ai donné sur chacune des pages que tu veux "redirectionner" vers ton nouveau site, en modifiant l'adresse de destination de mon code

si tu as iWeb'06 tu peux utiliser iWebmore en l'absence du html Widget

autre possibilité avec un editeur de texte (type Smultron ou TextMate)
sur les pages concernées effacer tout ce qu'il ya comme code entre les balises
Bloc de code:
<body> et </body>
et y coller le code de redirection
 

romeo133

Membre junior
19 Décembre 2007
25
0
désolé d'etre si lourd, mais ca fonctionne pas comme sur ton site.

J'ai un site vierge. j'ai créé une seule page pour le test sur laquelle je place un élément HTML ? c ca ? la taille n'a pas d'importance ni l'endroit ou je le met ?

J'ai publié le site, mais quand je tape l'adresse du site, je reste sur mon site et y'a le site vers lequel je voulais etre redirectionné qui apparait au milieu de ma page.

J'ai du raté une étape.

merci d'avance
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
bon alors on va faire simple:
- tu ouvres textedit tu colles mon code avec l'adresse de redirection corrigée
- tu sauvegardes et tu nommes ta page index.html (si elle doit rester unique sur ce site ou lenomdemonchoix.html si ce site doit avoir d'autres pages)
- il te demande de choisir .txt ou .html, tu marques .html
- tu balances ta page sur ton serveur et basta.
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
euh c'est bien ce script là que t'as utilisé?
Bloc de code:
<script type="text/javascript">
<!-- 
  document.location.href="http://ladressedemonforuml"
-->
</script>
parce que là j'ai un doute
j'ai donné deux codesla page précédente:
l'un pour une iframe
l'autre pour une redirection
c'etait au choix, ce que tu me montres est une iframe mais pas une redirection...
 

romeo133

Membre junior
19 Décembre 2007
25
0
oui c'est bien celui la mais ca fonctionne pas. j'ai du faire une connerie

J'ai créé un site, sur lequel il n'y a qu'une seule page vide.

J'ai copié ton code dans textedit je l'ai nomé index.html et je l'ai copié dans le dossier de mon site.

dans mon dossier j'ai 2 éléments : 1 page index.html et un dossier qui porte le nom de mon site avec des dossier dedans.
La page que j'ai créé avec textedit, je dois la copié à quel endroit ? je dois effacé la premier index.html ki est à la racine et je le remplace par le mien ?
parcke ca na pa fonctionné. kan j'ai publié le site, y'avai juste une page blanche avec le code écrit.
 

romeo133

Membre junior
19 Décembre 2007
25
0
<script type="text/javascript">
<!--
document.location.href="http://www.google.fr"
-->
</script>


voila le code ke j'ai utilisé
 

romeo133

Membre junior
19 Décembre 2007
25
0
A bon ? Je suis pas devant mon mac, j'essairai à midi. Merci encore. Je te tiens au courant si ca marche.

A+
 

romeo133

Membre junior
19 Décembre 2007
25
0
je viens d'essayer mais ca fonctionne toujours pas :-(

Pourtant j'ai fait tout ce que tu m'a dis. J'ai copié le code dans textedit, dans les préférences, j'ai coché format texte et j'ai sauvegardé sous le nom : index.html. Ensuite j'ai copié cette page à la place de ma page index.html de mon dossier site.

regarde ce que ca fait :

http://redirection.scola.fr

a+
 

romeo133

Membre junior
19 Décembre 2007
25
0
mais c bizzare que ca fonctionne pas. Mon ordi est tout réssent, il a meme pas 1 mois.

ptite question, sur la page de mon site, je dois rien mettre ? Je dois pas mettre le code dans un élément html ?
 

romeo133

Membre junior
19 Décembre 2007
25
0
ca yest ca marche !!!!!

en fait, dans textedit, j'ai décoché la case "conserver les espaces".

et quand j'ai sauvegardé j'ai décoché la case "txt." à défaut d'extension.

Enfin voila, jte remercie. C'est vraiment sympa de ta part d'avoir pris sur ton temps pour m'aider.

Merci encore.

Salut à une prochaine.

Ciao
 

koeklin

Membre d’élite
Club MacG
17 Août 2007
2 366
249
Ton ordi marche bien rassure toi mais l'utilisation de textedit pour cet emploi n'est pas fréquent, on a tendance à préférer pour cela d'autres editeurs de texte comme Smultron ou TextMate (c'est ce dernier que j'utilise le plus) et je ne maitrise pas assez les fonctions de ce TextEdit pour t'expliquer pourquoi ça marche chez moi et pas chez toi , tout ce que je sais c'est que j'ai modifié un temps certaines préférences de ce logiciel (mais lesquels? je ne m'en souviens plus)

Edit: Pas vu ton message quand j'ai tapé celui ci, content que ça marche.... enfin... désolé de te conseiller d'utiliser des logiciels (ici texetedit ) que je ne maitrise pas assez
 

romeo133

Membre junior
19 Décembre 2007
25
0
T'inquiète pas, maintenant j'ai vu ce qui clochait. jtembetrai plu lol
Mais jte remercie vraiment beaucoup.
Ptete à une prochaine. Je dois retourner bosser.

A +. CIAO
 
Statut
Ce sujet est fermé.