10.6 Snow Leopard Impossibilité d'ouvrir un .pkg

Pulsar55000

Membre enregistré
18 Septembre 2011
2
0
29
Bonjour,

Je souhaiterais installer une version de Python pour mon mac (qui est un Mac OS X 10.6.7). Je souhaiterais installer le macOS 64-bit/32-bit installer

Que l'on trouve ici

https://www.python.org/downloads/mac-osx/

Cependant lorsque je veux exécuter le .pkg que je télécharge il refuse de s'exécuter et m'affiche un message d'erreur qui est le suivant ;

https://www.noelshack.com/2021-01-3-1609972919-capture-d-ecran-2021-01-07-a-00-05-53.png

Pourriez-vous m'aider s'il vous plait ? Est-ce que c'est parce que mon mac est trop vieux (2011) ?

Je suis une quiche en informatique...

Bonne soirée !
 

maxou56

Membre expert
Club MacG
14 Avril 2020
2 695
563
Lorient
Est-ce que c'est parce que mon mac est trop vieux (2011) ?
Bonsoir,
C'est vraiment l'âge du mac le problème (il n'est pas jeune non plus ;) )
Mais Snow Leopard est un veille OS.
pourquoi toujours Snow Leopard? (Ton mac supporte jusqu'a High Sierra 10.13)

Je souhaiterais installer le macOS 64-bit/32-bit installer
Quelle version? Il indique pourtant 10.6 pour le 64/32bit et 10.9 pour le 64bit.
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 710
5 220
Là-haut
La première chose à faire est de mettre le système à jour.

Donc 10.6.8 + mise à jour de sécurité + d’autres petites choses (dont une mise à jour du programme d’installation qui vraisemblablement est à l’origine des problèmes cités).

Menu de la pomme > Mise à jour de logiciels...


La question de l’upgrade du système.

Déjà, pourquoi être resté si longtemps avec un vieux système ? (c’est une vraie question qui appelle une réponse)



Pour macOS 10.13 High Sierra, il faudra impérativement 8 Go de RAM.

En attendant, Il est possible d’installer OS X 10.11 El Capitan.

Attention ! Nécessité de faire des sauvegardes avant d’entreprendre quoique ce soit. Vérifier que les logiciels et périphériques (imprimantes, scanners, etc.) utilisés sont bien compatibles avec cette version de macOS.
 

baron

Membre expert
Club MacG
22 Avril 2008
1 803
484
LLN
lorsque je veux exécuter le .pkg que je télécharge il refuse de s'exécuter et m'affiche un message d'erreur qui est le suivant ;

https://www.noelshack.com/2021-01-3-1609972919-capture-d-ecran-2021-01-07-a-00-05-53.png
Comme l'indique ta copie d'écran, c'est une version qui nécessite au moins Mavericks (Mac OSX 10.9).
As of 3.7.7, we provide one installer: 64-bit-only that works on macOS 10.9 (Mavericks) and later systems. The deprecated 64-bit/32-bit installer variant for macOS 10.6 (Snow Leopard) is no longer provided.

Soit, comme le recommandent les autres, tu upgrades ton système vers une version plus récente ; soit tu restes avec SnowLeopard, en faisant quand même les mises à jour vers 10.6.8 via menu Pomme > Mise à jour de logiciels… — comme moi avec un MBPro de 2010 — et tu prends la version 3.6.8 de Python, disponible ici (en dépit de ce qu'ils disent sur leur site…) :
https://www.python.org/ftp/python/3.6.8/python-3.6.8-macosx10.6.pkg
 
  • J’aime
Réactions: Moonwalker