LaTeX

Clarine

Membre confirmé
10 Janvier 2005
30
2
Région parisienne
Bonjour,

J'utilise TeXshop. J'avais un Powerbook et je viens d'acheter un macBook Pro. J'ai tout fait migrer de l'un à l'autre, et comme LaTeX ne fonctionnait plus bien, j'ai tout réinstallé avec MacTeX-2008 (c'est plus pratique que i-installer!). Après quelques galères (des caractères qui ne s'affichaient plus correctement après compil) et un petit coup d'Onyx, tout semble être à peu près rentré dans l'ordre... sauf un truc.
Pour redéfinir mes numérotations, j'utilise les commandes suivantes dans le préambule :
\renewcommand{\thechapter}{\Alph{chapter} -- }
\renewcommand{\thesection}{\Roman{section} -- }
\renewcommand{\thesubsection}{\Roman{section}.\arabic{subsection}}

Et bien pour la dernière, ça ne marche pas! Au lieu de mettre les numéros et le titre, il écrit par exemple "I. subsection Niveaux d'énergie"
Il écrit donc texto "subsection" et ne fait pas marcher le compteur. J'ai essayé de plein de manières, avec et sans {}, en enlevant le compteur de section avant etc. Le seul moyen de refaire marcher le compteur de sous-section est d'enlever le
\renewcommand{\thesubsection}{\Roman{section} -- \arabic{subsection}. }
mais évidemment, je ne numérote du coup plus comme je veux.

C'est un peu comme si c'était la commande \thesubsection qui ne marchait pas (alors que pour \thesection ça marche).

Bref, help, qui a une idée ? Que puis-je faire ?
 
A

Anonyme

Invité
bonjour,

mercredi dernier je suis aussi passé de powerbook G4 à macbook pro; j'y ai réinstallé texshop (j'avais gardé le .pkg que j'avais téléchargé ) et je n'ai pas eu de pb de migration.
Seulement, je ne suis pas un grand "connaisseur".
Je te conseille le forum spécialisé http://wiki.mathematex.net ;)

désolé de ne pas pouvoir faire plus pour toi
 

Clarine

Membre confirmé
10 Janvier 2005
30
2
Région parisienne
Merci. Je n'ai pas trouvé la réponse sur ce site, mais je me suis aperçue que j'avais en fait le même problème avec la numérotation des figures, où j'utilise aussi un \renewcommand avec \arabic... du coup j'ai essayé en remplaçant \arabic par \roman... et ça marche :eek:
Bref, quelqu'un saurait-il comment réinstaller la numérotation en chiffres arabes ? :mouais: Quel fichier dois-je changer ?:hein:
Si personne ne sait, je vais demander à un site spécialisé TeX, mais sil y a un pro de LaTeX par ici, ça serait plus simple.
 

othiare

Membre enregistré
7 Février 2010
2
0
Bonjour,

J'utilise TeXshop. J'avais un Powerbook et je viens d'acheter un macBook Pro. J'ai tout fait migrer de l'un à l'autre, et comme LaTeX ne fonctionnait plus bien, j'ai tout réinstallé avec MacTeX-2008 (c'est plus pratique que i-installer!). Après quelques galères (des caractères qui ne s'affichaient plus correctement après compil) et un petit coup d'Onyx, tout semble être à peu près rentré dans l'ordre... sauf un truc.
Pour redéfinir mes numérotations, j'utilise les commandes suivantes dans le préambule :
\renewcommand{\thechapter}{\Alph{chapter} -- }
\renewcommand{\thesection}{\Roman{section} -- }
\renewcommand{\thesubsection}{\Roman{section}.\arabic{subsection}}

Et bien pour la dernière, ça ne marche pas! Au lieu de mettre les numéros et le titre, il écrit par exemple "I. subsection Niveaux d'énergie"
Il écrit donc texto "subsection" et ne fait pas marcher le compteur. J'ai essayé de plein de manières, avec et sans {}, en enlevant le compteur de section avant etc. Le seul moyen de refaire marcher le compteur de sous-section est d'enlever le
\renewcommand{\thesubsection}{\Roman{section} -- \arabic{subsection}. }
mais évidemment, je ne numérote du coup plus comme je veux.

C'est un peu comme si c'était la commande \thesubsection qui ne marchait pas (alors que pour \thesection ça marche).

Bref, help, qui a une idée ? Que puis-je faire ?
Bonjour,
Je viens d'acheter un Macbook Pro, pouvez vous m'aider à installer latex dessus. Depuis trois jours jours, j'essaie avec le mactex2009 mais j'ai des problèmes avec le i-installer!
Merci