Mac OS met 10mn à stopper

Noyau34

Membre enregistré
18 Août 2007
5
1
Montpellier
Bonjour,

Ca y est, je suis résigné à demander un avis sur ce petit problème agaçant. J'ai pourtant cherché, mais bon...

J'ai deux mac reliés sur une borne Airport, le mini en fast-ethernet, le macbook en 802.11n. Sur cette même borne, un disque dur connecté en ethernet (LaCie EDMini) et un autre en USB grâce à la fonctionnalité Disque Airport.

J'en viens à ce qui motive le titre du post : si j'ai le malheur :siffle: d'oublier de démonter les volumes réseau avant de demander au mac d'arrêter le système, mac os mettra au moins dix minutes avant de stopper le hardware lorsque je déciderai de cliquer sur Eteindre.... :eek:

Mon mini flambant neuf, quant à lui, ne connaît pas ce problème. :mouais:

Voilàà, merci pour une 'tite réponse. Bonne soirée. :)
 

David_b

Membre expert
Club MacG
4 Décembre 2005
5 912
425
Jamais très loin de mon stylo
davidbosman.fr
l faut mieux démonter les disques réseau comme les dd externes avant d'éteindre.:)

Les disques externes également, pourquoi ?
Quand le Mac s'éteind il s'éteind, ensuite j'éteind les disques externes. c'est mauvais ?
 

apenspel

Membre expert
Club MacG
23 Juin 2002
7 056
329
.be - BXL
Ça met surtout plus de temps à s'éteindre.
Mais je fais presque comme toi : j'éteins l'ordi, puis je coupe l'alimentation générale de tous les périphériques, transfos y compris.
 

ceslinstinct

Membre expert
Club MacG
10 Août 2004
2 070
111
21
Bonsoir

J'ai un AppleScript dans le dock, un clic ferme les applications ouvertes, démonte tous les volumes externe et quitte sans m'afficher la fenêtre.

J'ai eue des problèmes de mauvaises fermetures de DD externe alors je ne prend plus de risques.

@+
 

Noyau34

Membre enregistré
18 Août 2007
5
1
Montpellier
Bonsoir,

Depuis que j'ai installé les disques en réseau (de chez LaCie), j'ai tout d'abord pensé que le comportement du macbook était devenu "malheureusement" normal et qu'il me fallait déconnecter proprement les partages avant d'éteindre : on va imaginer que LaCie a fait quelques boulettes dans ses produits, a ajouté des contraintes...

Ce n'est que depuis que j'ai acheté un mini, il y a quelques jours que je me suis rendu compte (en oubliant d'éjecter les disques avant d'éteindre) qu'il se fermait presque instantanément. Conclusion, ça ne vient pas des disques, ni de la borne Airport, mais bien d'un grain de sable dans le système de mon MacBook.

J'ai examiné la log qui indique de nombreuses tentatives (échouées) de reconnection aux disques pendant dix minutes. Après un "max reconnect time reach" il abandonne et poursuit la terminaison des quelques démons et process qui restent sur sa liste de choses à faire avant le vrai shutdown.

Bref, je ne vois pas pourquoi le mini est insensible au problème rencontré sur le MacBook, ça m'est d'autant plus intriguant.

J'ai l'extrait de log pour ceux qui sont intéressés. :D

Merci encore pour vos réponses.
Bonne soirée.
 

Noyau34

Membre enregistré
18 Août 2007
5
1
Montpellier
Bonjour,

Bon, ben personne n'a d'idée, alors ?

Ca sent la réinstallation...:(

Après quoi je trouverai bien ce qui a cloché, au fil des réinstallations des logiciels.

Mais je m'en doutais un peu : d'autres users sont dans le même cas que moi d'après d'autres posts dans des forums étrangers, et ils n'ont pas obtenu de réponse.

Tant pis.

A bientôt.
 

supermoquette

Membre vénérable
Club MacG
13 Mai 2002
29 434
3 495
Balance le log.

Et regarde si un de tes disque ne serait pas sollicité par un service automatique.
 

Noyau34

Membre enregistré
18 Août 2007
5
1
Montpellier
Ca roule.

Attention ça va pas faire très propre dans le post :nailbiting:

Bon d'abord, au cas où, la liste des process en cours (la log vient après) :


Processes: 67 total, 2 running, 65 sleeping... 210 threads 16:45:57
Load Avg: 0.19, 0.12, 0.12 CPU usage: 1.8% user, 7.6% sys, 90.7% idle
SharedLibs: num = 188, resident = 49.6M code, 6.66M data, 9.38M LinkEdit
MemRegions: num = 7619, resident = 216M + 21.6M private, 130M shared
PhysMem: 245M wired, 374M active, 603M inactive, 1.20G used, 823M free
VM: 9.95G + 127M 126750(1) pageins, 0(0) pageouts

PID COMMAND %CPU TIME #TH #PRTS #MREGS RPRVT RSHRD RSIZE VSIZE
501 top 11.0% 0:05.17 1 18 20 868K 828K 1.33M 27.0M
498 bash 0.0% 0:00.01 1 14 16 184K 1.21M 1.22M 27.1M
497 login 0.0% 0:00.01 1 16 40 172K 916K 1.84M 26.9M
495 Terminal 1.7% 0:00.79 4 90 158 1.87M+ 12.3M 17.9M+ 359M
487 mdimport 0.0% 0:00.38 4 65 60 1.75M 5.14M 4.70M 40.4M
476 AppleSpell 0.0% 0:00.11 1 44 34 756K 3.29M 2.04M 37.4M
475 TextEdit 0.0% 0:00.22 1 67 149 1.94M 9.36M 5.79M 355M
448 check_afp 0.0% 0:00.12 2 27 21 248K 1.20M 852K 27.1M
390 DashboardC 0.0% 0:00.85 3 97 246 5.09M 12.8M 23.8M 363M
389 DashboardC 0.0% 0:00.25 3 95 168 3.80M 6.97M 18.0M 352M
388 DashboardC 0.0% 0:01.19 3 93 177 4.04M 7.39M 18.2M 354M
387 DashboardC 0.0% 0:00.21 3 93 153 3.18M 7.23M 16.4M 353M
386 DashboardC 0.0% 0:00.35 4 102 173 4.52M 7.45M 19.5M 355M
384 DashboardC 0.0% 0:00.69 4 114 206 5.90M 8.42M 22.2M 358M
369 slpd 0.0% 0:00.03 6 30 31 248K 1.29M 1.00M 30.2M
367 lookupd 0.0% 0:00.44 2 34 39 696K 1.46M 1.46M 28.5M
322 Safari 0.0% 4:17.17 6 147 863 101M 38.6M 117M 498M
305 Mail 0.0% 0:15.81 6 154 368 22.6M 24.2M 29.6M 386M
302 dmnotifyd 0.0% 0:00.06 2 34 29 716K 3.06M 1.12M 36.7M
295 automount 0.0% 0:00.04 3 40 30 316K 1.34M 1.10M 28.7M
287 automount 0.0% 0:00.16 5 76 42 528K 1.38M 1.39M 29.8M
284 rpc.lockd 0.0% 0:00.00 1 10 16 100K 860K 216K 26.7M
273 nfsiod 0.0% 0:00.00 5 30 24 136K 760K 204K 28.6M
259 ntpd 0.0% 0:01.01 1 11 17 156K 1000K 436K 27.1M
254 usbmuxd 0.0% 0:00.00 2 21 22 188K 788K 596K 27.0M
236 UniversalA 0.6% 0:18.35 1 63 124 1.36M 5.49M 3.88M 347M
234 HPEventHan 0.0% 0:00.13 3 76 156 876K 4.61M 3.40M 341M
232 iTunesHelp 0.0% 0:00.08 2 62 122 644K 5.41M 2.18M 347M
231 MicrosoftM 0.0% 0:10.40 1 58 106 808K 3.81M 1.99M 338M
229 iCalAlarmS 0.0% 0:00.18 1 61 120 920K 5.78M 3.77M 343M
220 Finder 0.0% 0:24.57 3 118 255 5.35M 32.7M 22.4M 386M
219 SystemUISe 0.0% 0:03.27 4 230 384 8.59M 23.5M 16.0M 385M
218 Dock 0.0% 0:00.96 2 147 246 1.92M 15.8M 7.57M 362M
211 pbs 0.0% 0:00.19 2 53 44 744K 5.20M 2.07M 54.8M
185 pvsnatd 0.0% 0:01.26 3 22 24 192K 1.20M 576K 28.1M
169 HPIO Trap 0.0% 0:02.54 3 50 58 560K 3.66M 1.78M 38.5M
157 hpusbmond 0.0% 0:00.12 1 16 27 244K 1.30M 760K 27.3M
156 Mbox2CS 0.0% 0:00.01 1 18 22 208K 780K 828K 26.7M
149 RetroRun 0.0% 0:02.82 1 15 47 1.85M 9.64M 2.47M 120M
142 llipd 0.0% 0:05.17 1 8 18 1.21M 780K 1.31M 26.8M
122 AppleFileS 0.0% 0:00.62 2 54 39 1.02M 1.93M 1.34M 33.3M



Et la log (résumée parceque c'est long), dont la première ligne suit exactement l'instant ou j'ai cliqué sur "Eteindre" à 21h58 :



Aug 19 21:58:16 Nixie configd[37]: posting notification com.apple.system.config.network_change
Aug 19 21:58:16 Nixie configd[37]: rtmsg: error writing to routing socket
Aug 19 21:58:18 Nixie mDNSResponder: getifaddrs ifa_netmask for fw0(7) Flags 8863 Family 2 169.254.212.251 has different family: 0
Aug 19 21:58:18 Nixie mDNSResponder: SetupAddr invalid sa_family 0
Aug 19 21:58:28 Nixie diskarbitrationd[39]: coreaudiod [38]:26391 not responding.
Aug 19 21:58:28 Nixie diskarbitrationd[39]: mdimportserver [206]:10839 not responding.
Aug 19 21:58:28 Nixie diskarbitrationd[39]: mdimportserver [206]:20227 not responding.
Aug 19 21:58:28 Nixie diskarbitrationd[39]: mds [117]:15887 not responding.
Aug 19 21:58:28 Nixie diskarbitrationd[39]: ATSServer [65]:12291 not responding.
Aug 19 21:58:28 Nixie diskarbitrationd[39]: coreservicesd [63]:9731 not responding.
Aug 19 21:59:13 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: doing reconnect on /Volumes/LaCie
Aug 19 21:59:13 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect to the server /Volumes/LaCie
Aug 19 21:59:13 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect on /Volumes/LaCie failed 49.
Aug 19 21:59:18 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: posting to KEA retry for /Volumes/LaCie delayCnt 6
Aug 19 21:59:18 Nixie KernelEventAgent[31]: tid 00000000 received VQ_NOTRESP event (1)
Aug 19 21:59:18 Nixie KernelEventAgent[31]: tid 00000000 type 'afpfs', mounted on '/Volumes/LaCie', from 'afp_0TTnxu0W953Y14hWjw0Xizv2-1.2c000006', not responding
Aug 19 21:59:18 Nixie KernelEventAgent[31]: tid 00000000 found 1 filesystem(s) with problem(s)
Aug 19 21:59:23 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect to the server /Volumes/LaCie
Aug 19 21:59:23 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect on /Volumes/LaCie failed 49.
Aug 19 21:59:33 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect to the server /Volumes/LaCie
Aug 19 21:59:33 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect on /Volumes/LaCie failed 49.


Partie que j'ai supprimé (une trentaine de lignes identiques)


Volumes/LaCie
Aug 19 22:09:22 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect on /Volumes/LaCie failed 49.
Aug 19 22:09:22 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: max reconnect time reached 610 > 600 /Volumes/LaCie
Aug 19 22:09:22 Nixie KernelEventAgent[31]: tid 00000000 received VQ_DEAD event (32)
Aug 19 22:09:22 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: posting to KEA to unmount /Volumes/LaCie
Aug 19 22:09:22 Nixie KernelEventAgent[31]: tid 00000000 type 'afpfs', mounted on '/Volumes/LaCie', from 'afp_0TTnxu0W953Y14hWjw0Xizv2-1.2c000006', dead
Aug 19 22:09:22 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: doing reconnect on /Volumes/LaCie
Aug 19 22:09:22 Nixie KernelEventAgent[31]: tid 00000000 found 1 filesystem(s) with problem(s)
Aug 19 22:09:22 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect to the server /Volumes/LaCie
Aug 19 22:09:22 Nixie kernel[0]: AFP_VFS afpfs_Reconnect: connect on /Volumes/LaCie failed 49.
Aug 19 22:09:23 Nixie kernel[0]: AFP_VFS afpfs_unmount: /Volumes/LaCie, flags 524288, pid 31
Aug 19 22:09:23 Nixie lookupd[323]: lookupd (version 369.6) starting - Sun Aug 19 22:09:23 2007
Aug 19 22:09:23 Nixie kernel[0]: jnl: close: flushing the buffer cache (start 0x301e00 end 0x306000)
Aug 19 22:09:23 Nixie shutdown: halt by oL:
Aug 19 22:09:23 Nixie SystemStarter[329]: "/Library/StartupItems/Tablet" failed security check: permissions
Aug 19 22:09:24 Nixie Parallels: Stopping DHCP/NAT daemon...
Aug 19 22:09:24 Nixie SystemStarter[329]: authentication service (342) did not complete successfully
Aug 19 22:09:24 Nixie SystemStarter[329]: Digidesign Mbox 2 Configuration Service (347) did not complete successfully
Aug 19 22:09:25 Nixie Parallels: Unloading Network module...
Aug 19 22:09:25 Nixie Parallels: Unloading ConnectUSB module...
Aug 19 22:09:25 Nixie Parallels: Unloading Monitor module...
Aug 19 22:09:26 Nixie kernel[0]: [Parallels] Parallels VM observer thread stopped
Aug 19 22:09:26 Nixie Parallels: Unloading Hypervisor module...
Aug 19 22:09:26 Nixie kernel[0]: [Parallels] Parallels Hypervisor exited.
Aug 19 22:09:26 Nixie Parallels: Shutdown complete.
Aug 19 22:09:28 Nixie SystemStarter[329]: The following StartupItems failed to properly start:
Aug 19 22:09:28 Nixie SystemStarter[329]: /System/Library/StartupItems/AuthServer
Aug 19 22:09:28 Nixie SystemStarter[329]: - execution of Startup script failed





Voilà, en espérant que ça puisse éclairer...

Merci pour votre réponse.