Macintosh Plus Diesel

sartoo

Membre junior
20 Juillet 2011
15
1
43
www.sartoo.fr
Bonjour,

Je me présente rapidement (car il y a pas grand chose à dire), je suis tombé dans l'informatique en 86 (à l'âge de 9 ans) avec un ZX81 à l'école (je l'ai récupéré depuis), un MSX (que j'ai encore), j'ai faillit avoir un macintosh plus mais il aura fallu attendre l'iMac G3 pour que je sois macuser.
Je viens de remonter dans le temps et je me suis acheté il y a peu un Macintosh Plus. Le problème c'est qu'il ne s'allumait qu'en tapant sur l'appareil. J'ai ouvert (et découvert des signatures :up:) et j'ai vu une soudure louche. Je l'ai refaite et maintenant il démarre mais affiche l'écran que lorsqu'il est chaud. La soudure est entre un fil qui va au tube et un condensateur (désolé je suis pas trop calé en électronique), ça pourrait être lui qui déconne ? Quand l'ordi est "chaud" pas de problème.
Au passage si quelqu'un à une disquette system 6 en trop ...
Un grand merci d'avance
 

melaure

Chasseur de Bobos
Club MacG
24 Octobre 2001
24 847
1 736
50
Le Grand Lyon
Bienvenu et bravo pour ta collection. Ca fait plaisir de voir encore pas mal de gens sauver la vie de ces vieilles babasses.

Coté matos et OS pas de soucis pour t'aider, coté électronique on est un peu plus juste, mais tu peux aussi poster sur le forum de Silicium, une association dont je fais aussi partie (en plus des Gones du Mac).
 

sartoo

Membre junior
20 Juillet 2011
15
1
43
www.sartoo.fr
Bonjour,
belle découverte des signatures !
pour le system 6 tu trouveras peut être ton bonheur ici

Merci pour le lien mais mon problème pour l'OS :
- En mac avec disquette je n'ai que celui-ci (et ne connais personne avec mac et disquette)
- j'ai récupéré un lecteur disquette usb au boulot mais marche pas sur mon macbook air. Du coup j'ai aussi ramener mon portable pc du boulot.
- j'ai une disquette 800k (un seul trou) où il devait y avoir le système mais le mac n'en veut pas et met le ?
- ce que je voudrais si possible c'est un tuto qui m'explique comment formater cette disquette sur le pc et y copier le système (si c'est possible techniquement)

Bienvenu et bravo pour ta collection. Ca fait plaisir de voir encore pas mal de gens sauver la vie de ces vieilles babasses.
Coté matos et OS pas de soucis pour t'aider, coté électronique on est un peu plus juste, mais tu peux aussi poster sur le forum de Silicium, une association dont je fais aussi partie (en plus des Gones du Mac).

Merci pour l'info je m'inscrirais mais j'avoue ne pas être très assidus aux forum (mais je me soigne). Déjà si vous m'aidez côté logiciel ce sera top car pour le reste il tourne si on le laisse tranquillement chauffer.

Merci d'avance à tous !
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 527
3 548
68
Sous la limite KT
- ce que je voudrais si possible c'est un tuto qui m'explique comment formater cette disquette sur le pc et y copier le système (si c'est possible techniquement)

Là, il me semble que la version "PC" de Basilisk II permet ça, mais je n'en suis pas certain. à l'occasion je vérifierais.

pour le reste il tourne si on le laisse tranquillement chauffer.

Là, c'est plus inquiétant, ça sent "le tube à l'agonie", ça, à moins que ça ne vienne de la THT !


EDIT je confirme que dans le package complet de Basilisk II "Windows" figure l'utilitaire HFVExplorer, qui permet depuis le lecteur de disquettes d'un PC, de créer une image disque à partir d'une disquette Mac, et de créer une disquette Mac à partir d'une image disque de type DSK, HFV ou HFx. Reste à savoir comment convertir une image de type img dans un de ces formats.
 
Dernière édition:

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 527
3 548
68
Sous la limite KT
Bon je vais regarder Basilisk II dès que j'ai un peu de temps.



Alors là ce serait pas cool car je suppose que ce sont 2 organes que l'on ne répare pas ...
Je me dis que ça pourrais être un condo lié à la THT, non ?

Je ne dirais pas "impossible", mais ça me surprendrait, vu qu'il s'éclaire à la longue, je penche plus pour un problème de tube "au bout du rouleau", de par l'usure du filament de chauffage, ou, si ça n'est pas le tube, alors un problème dans le circuit électronique qui alimente le dit filament et a du mal à le faire chauffer suffisement !
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 657
277
60
... vu qu'il s'éclaire à la longue, je penche plus pour un problème de tube "au bout du rouleau", de par l'usure du filament de chauffage...
Dans un tube cathodique il n'y a pas d'usure du filament...

... en revanche à la longue la cathode (qui est chauffée par le filament) s'oxyde et cette oxydation gène l'émission des électrons... et comme le débit d'électron faiblit, alors la luminosité faiblit.

Mais c'est un phénomène qui est constant, c'est à dire qu'il ne varie pas en fonction du temps d'allumage et de "chauffe" : le tube est moins lumineux, et cette luminosité de change pas entre l'allumage et 10 ou 30 minutes plus tard.



... ou, si ça n'est pas le tube, alors un problème dans le circuit électronique qui alimente le dit filament et a du mal à le faire chauffer suffisement !
Ça c'est tout à fait possible !

Pour faire simple, grosso-modo la plupart des TV et moniteurs ont le chauffage du tube branché sur un enroulement du transfo THT... mais :
- certains sont branchés directement et fonctionnent alors en courant "alternatif" (mais pas sinusoïdal !)
- alors que d'autres fonctionnent en courant continu, avec une diode de redressement et un filtrage par condensateur électrochimique... dans ce cas, le vieillissement du condensateur diminue l'efficacité du filtrage et fait baisser la tension de chauffage, donc le tube devient moins lumineux...

... et le symptome de l'écran qui a besoin d'un temps de chauffe important pour s'allumer correspond bien à un condensateur chimique de filtrage fatigué.
 

sofizabel

Membre confirmé
3 Mai 2013
225
16
52
paris
bonjour
si je peux me permettre (je ne suis pas très technique).
mon copain a retapé plusieurs mac compacts (MacPlus, SE30), qui présentait ce genre de symptômes (écran ne s'allumant qu'après avoir chauffé).
sa méthode: après examen minutieux (à la loupe), il refaisait certaines soudures.
 

melaure

Chasseur de Bobos
Club MacG
24 Octobre 2001
24 847
1 736
50
Le Grand Lyon
bonjour
si je peux me permettre (je ne suis pas très technique).
mon copain a retapé plusieurs mac compacts (MacPlus, SE30), qui présentait ce genre de symptômes (écran ne s'allumant qu'après avoir chauffé).
sa méthode: après examen minutieux (à la loupe), il refaisait certaines soudures.

Bah voilà, il peut ouvrir un centre de réparation. On avait l'Amiga Repair Team, il peut créer la Old Mac Repair Team ;)
 

sartoo

Membre junior
20 Juillet 2011
15
1
43
www.sartoo.fr
bonjour
si je peux me permettre (je ne suis pas très technique).
mon copain a retapé plusieurs mac compacts (MacPlus, SE30), qui présentait ce genre de symptômes (écran ne s'allumant qu'après avoir chauffé).
sa méthode: après examen minutieux (à la loupe), il refaisait certaines soudures.

J'ai en effet repris une soudure suspecte. Au départ il ne s'allumait pas et après avoir refait cette soudure il s'allume avec un délais de chauffe. Peut être il y en a d'autres ... Je vais essayer de tester le condensateur (je sais pas encore trop comment) et après vérifier à nouveau les soudures. Merci pour tes précisions.
 

sartoo

Membre junior
20 Juillet 2011
15
1
43
www.sartoo.fr
Je reviens avec un peu de news ...
J'ai fait un teste :
- jour 1, test de démarrage "à froid", l'ordi affiche au bout de quelques minutes après un ou deux clignottements
- jour 2, je chauffe au sèche cheveux les deux condos sur le haut (dont celui que je soupçonne car près de la soudure qui avait lâché) et là j'appuie sur le bouton et le démarrage est instantané ! Donc ce serait peut être bien le condo.
Par contre j'ai installé basilisk II sur mon PC du boulot mais je ne comprend pas comment faire une disquette de boot. J'arrive à émuler le système 7. J'ai testé avec HFVExplorer de creer une disquette à partir du fichier system7.dsk mais sans succés j'ai un message d'erreur. La disquette 800k HS ? A mais en écrivant je pense à un truque ... La disquette est peut être tout simplement trop petite pour copier le system ! A suivre mais suis preneur de tout aide ...
 

sofizabel

Membre confirmé
3 Mai 2013
225
16
52
paris
bonsoir
je ne voudrais pas dire de bêtises, mais il me semble bien avoir donné un système 7 sur disquettes DD.
d'ailleurs notre MacPlus fonctionnait avec celui-ci (à partir d'un disque externe 20SC, si je me souviens bien).
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 657
277
60
- jour 2, je chauffe au sèche cheveux les deux condos sur le haut (dont celui que je soupçonne car près de la soudure qui avait lâché) et là j'appuie sur le bouton et le démarrage est instantané ! Donc ce serait peut être bien le condo.
Le coup du sèche-cheveux (ou plus exactement l'influence de la chaleur) est assez symptomatique du condensateur chimique sec !!!

Essaye de voir si l'un des deux ne serait pas par hasard branché aux bornes du filament ? ou entre le filament et la masse ?

Ils ont quelles capacités et quelles tensions de service ?

(le filament en général chauffe avec du 6,3 V, donc la tension de service des condos peut être un indicateur de leur relation ou non avec le chauffage du filament)
 

sartoo

Membre junior
20 Juillet 2011
15
1
43
www.sartoo.fr
Le coup du sèche-cheveux (ou plus exactement l'influence de la chaleur) est assez symptomatique du condensateur chimique sec !!!
Essaye de voir si l'un des deux ne serait pas par hasard branché aux bornes du filament ? ou entre le filament et la masse ?
Ils ont quelles capacités et quelles tensions de service ?
(le filament en général chauffe avec du 6,3 V, donc la tension de service des condos peut être un indicateur de leur relation ou non avec le chauffage du filament)

Bon alors j'ai pas eu le temps de trop y regarder par contre j'ai quelques photos. Voici la soudure qui était douteuse et que j'ai refaite :
http://www.flickr.com/photos/110220530@N03/11133080935/

La soudure correspond "au fil vert qui va vers le tube" (désolé je suis pas fort en électronique). Et cette soudure est reliée par une piste au condensateur C1, c'est là que j'ai chauffé (haut de la photo) :
http://www.flickr.com/photos/110220530@N03/11133212163/

Voilà !
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 657
277
60
Bon alors j'ai pas eu le temps de trop y regarder par contre j'ai quelques photos.
Oui, mais je ne peux rien voir sur ces photos... si tu veux que je t'aide il faudrait que tu rouvres ton Mac et que tu me donnes les capacités et tensions de service des deux condensateurs que tu soupçonnes, ainsi je pourrais (peut-être) te confirmer que l'un ou les deux est-sont dans le circuit de chauffage.



Voici la soudure qui était douteuse et que j'ai refaite :
image | Flickr : partage de photos !
Ça se n'est pas une soudure "douteuse", c'est carrément une soudure cramée !!! probablement sur un circuit de puissance... ça peut être le chauffage...
 

sartoo

Membre junior
20 Juillet 2011
15
1
43
www.sartoo.fr
Oui, mais je ne peux rien voir sur ces photos... si tu veux que je t'aide il faudrait que tu rouvres ton Mac et que tu me donnes les capacités et tensions de service des deux condensateurs que tu soupçonnes, ainsi je pourrais (peut-être) te confirmer que l'un ou les deux est-sont dans le circuit de chauffage.

Ça se n'est pas une soudure "douteuse", c'est carrément une soudure cramée !!! probablement sur un circuit de puissance... ça peut être le chauffage...

Le condensateur que je soupçonne est en C1 sur la même piste que la soudure cramée. Il y a d'inscrit dessus CE04P 3.9μF 85°C et apparemment 25V (difficile d'accès).
image | Flickr : partage de photos !

Je viens de lire en diagonal et en anglais ce lien qui parle justement d'un problème avec ce condensateur : http://68kmla.org/files/classicmac2.pdf

N'étant pas fort en électronique et pas trop en anglais ... Ce que je voudrais savoir :
- comment tester le condensateur ?
- est ce que je peux le dessouder sans risquer de prendre le jus ?
- dans le pdf ils parlent de le changer par un autre 50v non polar low ESR ??? Si quelqu'un pouvait me mettre un lien vers un condensateur du marché en achat en ligne ...
Merci d'avance
 

claude72

Membre d’élite
Club MacG
13 Février 2005
3 657
277
60
Le condensateur que je soupçonne est en C1 sur la même piste que la soudure cramée. Il y a d'inscrit dessus CE04P 3.9μF 85°C et apparemment 25V
Alors il n'est pas sur le circuit de chauffage du filament...

... mais vu la proximité du connecteur du déflecteur, et ce que le gus dit sur lui dans le PDF, il est plutôt dans le circuit de déviation horizontale.




- comment tester le condensateur ?
Tu le changes... et si ça marche mieux après, alors il était mort...
... mais si ça ne change rien c'est qu'il n'est pas mort !

(pour lever le doute simplement, les dépanneurs soudent un 2e condensateur identique en parallèle et côté soudures du circuit imprimé !)



- est ce que je peux le dessouder sans risquer de prendre le jus ?
Si le Mac est éteint, oui.



- dans le pdf ils parlent de le changer par un autre 50v non polar low ESR ??? Si quelqu'un pouvait me mettre un lien vers un condensateur du marché en achat en ligne...
Conrad, Sélectronic...

Mais dans le PDF le gus dit aussi que ce genre de condo chimique non-polarisé à faible résistance série n'est pas facile à trouver, et qu'il est possible de le remplacer par 4 condensateurs disque-céramique 1 microfarad 50 volts en parallèle... il dit aussi que ce "bricolage" bien que peu esthétique est très robuste et même meilleur que le composant original.



À la fin du PDF, il y a les schémas du Mac !!! alors :

- le chauffage du filament est en 12 V continu, à travers une self L5 : il faudrait que tu vérifies si tu as bien du 12 volts sur les 2 pins de cette self,

- la soudure cramée que tu as ressoudée est probablement une des pins de la self L2 qui alimente à travers C1 le déviateur ligne (horizontal),

- comme j'avais supposé, le condensateur C1 (3,9 microfarads / 25 V) est sur le circuit du déviateur ligne, donc sans relation avec le chauffage filament... (mais ça n'empêche pas qu'il est peut-être mort ???)

- si la soudure cramée n'est pas sur L2, alors est est sur la self L1, qui avec le condensateur C2 (4700 microfarads 16 V) assure le filtrage du 12 V alimentant le balayage ligne et le chauffage filament (et évite les retours parasites sur l'alim 12 V)... là aussi, une mesure de tension avant et après la self seraient bienvenues.

Pour ces deux mesures, il faudrait les faire tout de suite après la mise en route, donc avant que le tube s'allume...
... puis après la chauffe du diesel, quand le tube est enfin allumé... et comparer !
 
Dernière édition: