Macintosh SE/30 et mode32

jab2

Membre junior
21 Février 2007
42
0
Hello tous le monde. J’ai une petite question concernant mon mac et le mode32.
J’ai installé sur mon de/30 le système 7.5 ainsi que 20Mo de Ram. Jusqu’ici tour va bien, le mac se porte à merveille. Po ur pouvoir profiter pleinement de la ram, j’ai ensuite installé mode32 (v7.5), redemarré l’ordi et coché ladressage 32bit. Après un nouveau redémarrage, l’ordi s’est mis à planté très souvent (processeur arythmetique absent ou erreur Finder). Cependant, dans le menu Finder, la ram était bien exploité. Puis après un ultime redémarrage, j’ai eu droit à un sad Mac. Je n’ai pu réutiliser l’ordinateur qu’en le démarrant sur disquette. Est ce que cela vous est déjà arrivé ? Est ce que ça pourrait être un problème software ou hardware ?
 

Fichiers joints

  • AB5D30A4-AEC9-4688-9365-BB7197C0D1C4.jpeg
    AB5D30A4-AEC9-4688-9365-BB7197C0D1C4.jpeg
    42,7 KB · Affichages: 74

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 744
153
Paris
Je vais tenter de t'aider juste pour la démarche que je trouve honorable d'utiliser encore une telle machine. Je pense que l'erreur est software. Mais je ne sais pas si à l'epoque l'idée de passer un tel jeu d'instructions ne faisait pas chauffer le processeur au point de le faire cramer. Tout est possible.

Est-ce que la possibilité de remettre le jeu d'instructions d'origine avec l'utilisation de la RAM d'origine est possible et refait démarrer la machine.

Si c'était Hardware et en l'occurence le CPU qui à cramé je pense pas que la machine t'adresserai une erreur. Je pense donc plus à un probleme Software.
 

gpbonneau

Membre d’élite
Club MacG
12 Juillet 2005
1 077
442
65
Normandie
gpbmaccollection.online.fr
Le SE/30 d'origine supporte un adressage sur 24-bit. Il était vendu avec 1Mo de RAM (4x256Ko) ou 4Mo (4x1Mo), extensible jusqu'a 8Mo (8x1Mo), des barrettes 1Mo qui coutaient un bras à l"époque.
Tout ça pour dire que le patch de Connectix "MODE32", repris ensuite par Apple, lorsque les barrettes 4Mo sont devenus abordables, n'est qu'un sparadrap sur une jambe de bois (la ROM d'origine pas 32-bit clean, remplacée en partie par une autre chargé au démarrage de la machine). La machine n'était pas conçu pour fonctionner avec plus de 8Mo.

J'ai, malgré tout, plusieurs machines qui fonctionnent comme ça, sans problème, mais il est possible que ta configuration supporte mal l'adressage 32-bit...

Si en démarrant sur ta disquette et en retirant MODE32 de ton dossier Extensions dans le dossier Système, ça marche de nouveau en 24-bit sans problème, je pencherais plutôt pour un pb hardware.

Le problème peut venir de tes barrettes RAM : les 8 premiers Mo sont bien reconnu et la machine fonctionne bien sans MODE32, mais fonctionne mal quand il faut adresser les 20Mo à cause d'une barrette qui fonctionne mal...
-> Avec 20Mo tu as 4 barrettes de 1Mo + 4 barrettes de 4Mo. Essai de démarrer en changeant la combinaison et l'emplacement des barrettes, Bank A/B, si tu en as d'autres (8x1, 4x4, 8x4, etc...).
On trouve maintenant des barrettes 16Mo mais c'est encore pire pour trouver la bonne combinaison.

Le pb peut venir aussi du processeur, testé à l'origine dans ce Mac en adressage 24-bit seulement, il est peut-être défaillant en 32-bit. Malheureusement il est soudé sur la carte mère...

Il y a des utilitaires Apple de l'époque qui permettait de faire quelques tests RAM et autres :

https://www.macintoshrepository.org/425-apple-mactest-pro (version 68k)

Pour t'assurer que ce n'est pas un problème software, le plus simple est de faire une clean install dans un nouveau dossier système, idéalement sur un autre disque dur, externe par exemple...
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 427
3 520
68
Sous la limite KT
Bon, déjà un premier point : un "sad Mac", c'est obligatoirement un problème matériel. Si le problème ne survient qu'à la mise en œuvre de Mode32, qui fonctionnait parfaitement sur cette machine, alors, ça signifie qu'une ou plusieurs des barrettes au delà des 8 premiers Mo est ou sont défectueuse(s). Un sad Mac ne vient pas seul, il y a un code sous l'icône, tu peux te reporter ici pour en avoir la signification.

Ah, dernière chose : les barrettes "SIMM 30 broches" du SE30 sont des barrettes 8bits, il est donc absolument indispensable de monter 4 barrettes absolument identiques par banc pour que ça fonctionne (même capacité, of course, mais aussi autres caractéristiques semblables, notamment au niveau du temps de réponse (120 ns), donc des barrettes récupérées dans un SE ou un Mac+ ne conviennent pas forcément, car ces machines acceptent de fonctionner avec des barrettes à 150 ns.

Pour ce qui est du processeur, le 68030 est bien un processeur à adressage 32 bits, c'est juste la Rom qui n'est pas "32 bits Clean", l'extension "Mode32" sert précisément à remédier à ça. Preuve s'il en faut : au milieu des années 90, j'ai eu un SE30 pendant trois ans, avec 16 Mo de Ram, je n'ai jamais connu de problème avec l'utilisation de Mode 32, du système 7 jusqu'au 7.5.5 qui se sont succédé dessus.

EDIT : Put1, 16 Mo … Quand je pense que je me sens parfois à l'étroit avec les 16 Go de mon MBP ou les 8 de mon MBA ! o_O
 
Dernière édition:
  • J’aime
Réactions: melaure

gpbonneau

Membre d’élite
Club MacG
12 Juillet 2005
1 077
442
65
Normandie
gpbmaccollection.online.fr
Ce que je voulais dire, c'est que cette machine n'était pas prévu pour fonctionner avec plus de 8Mo, donc le code de boot qui fait le diagnostic, avant le chargement de la ROM, puis du patch sur le HD, peut détecter une erreur, mais le code SadMac ne va pas forcément bien informer sur l'erreur...
Je pense aussi que c'est un problème de RAM.
Donc s'assurer que tout fonctionne bien comme avant sans MODE32, en mode 24-bit.
Puis essayer avec les 4 barrettes de 4Mo seulement par exemple, avec MODE32 installé et activé...

4 barrettes identiques par banc, c'est le B.A. ba, et 120ns pas plus (des 4Mo c'est au moins 120ns forcément).

J'ai une machine qui fonctionne avec 8 barrettes 4Mo sans aucun problème et j'ai aussi essayé 4 barrettes 16Mo sur une autre qui devenait instable si je laissais des barrettes dans l'autre banc... Donc maintenant je met soit 8 barrettes identiques, soit 4 seulement avec un banc vide...
 

mandigo25

Membre junior
21 Novembre 2019
33
13
41
normal l'os 7.5.3 ne supporte pas Mode 32 et ne peut pas s'installer sur une Rom 24bits sinon il faut rester en 7.1 pour avoir toute la Ram dispo
Le mieux est de changer la ROM soit une Rom de IIsi ou IIfx soit une Rom achetée sur Ebay par exemple
Dans mon cas mon Se/30 tourne sous 7.61 avec 68 mo sans aucun soucis avec une clean Rom de 512 ko , par contre il faut hacker le fichier System avec resedit (tout est expliqué ici https://vintageapple.org/gamba2/os8_se30.html )



IMG_0801[1].JPG
 
  • J’aime
Réactions: jab2

gpbonneau

Membre d’élite
Club MacG
12 Juillet 2005
1 077
442
65
Normandie
gpbmaccollection.online.fr
normal l'os 7.5.3 ne supporte pas Mode 32 et ne peut pas s'installer sur une Rom 24bits sinon il faut rester en 7.1 pour avoir toute la Ram dispo
Le mieux est de changer la ROM soit une Rom de IIsi ou IIfx soit une Rom achetée sur Ebay par exemple
Dans mon cas mon Se/30 tourne sous 7.61 avec 68 mo sans aucun soucis avec une clean Rom de 512 ko , par contre il faut hacker le fichier System avec resedit (tout est expliqué ici https://vintageapple.org/gamba2/os8_se30.html )

J'ai 2 SE/30 avec 32Mo (8x4Mo) en 7.5.3 qui tourne parfaitement avec MODE32 (dont un transparent ;-)
IMG_6631-2.JPG

Le SE/30 supporte le 7.5.3 (et même 7.5.5) d'origine.
Pour adresser plus de 8Mo de RAM il faut MODE32, ou mettre une ROM de IIfx ou IIsi (plus rare vu que la plupart ont une ROM soudée). Changer la ROM c'est moins pratique, faut en trouver une...
J'ai essayé, ça ne change rien.

Ensuite si tu veux passer sur des systèmes non supportés d'origine, là d'accord, il faut bricoler dans les fichiers...
 
Dernière édition:

jab2

Membre junior
21 Février 2007
42
0
Merci pour vos retours. L'ordinateur redémarrant avec la disquette, j'ai réinstallé le système 7.5,
l'ordinateur a bien fonctionné. j'ai relancé l'installer Mode32. Et la, ça a l'air de fonctionner.
La première installation, je l'avais faite par disquette et je pense qu'elle était défectueuse, du coup l'installation à du être corrompu. On va espérer que c'était ça.
Autrement le sad mac affichait le code suivant :
0000000F
0000000A
 
Dernière édition:

jab2

Membre junior
21 Février 2007
42
0
Dernière question, j'ai fais l'acquisition de 4 barrettes de 16Mo :

Cependant, je n'ai pas fais attention aux "60ns", est ce que cela a une impact sur le fonctionnement des barrettes pour mon SE/30?
 

gpbonneau

Membre d’élite
Club MacG
12 Juillet 2005
1 077
442
65
Normandie
gpbmaccollection.online.fr
Dernière question, j'ai fais l'acquisition de 4 barrettes de 16Mo :

Cependant, je n'ai pas fais attention aux "60ns", est ce que cela a une impact sur le fonctionnement des barrettes pour mon SE/30?

60ns c'est la rapidité d'accès aux données.
Pour une SE/30, il faut qu'il soit inférieur à 120ns, donc c'est bon.
 
  • J’aime
Réactions: jab2

claude72

Membre d’élite
Club MacG
13 Février 2005
3 655
273
60
La première installation, je l'avais faite par disquette et je pense qu'elle était défectueuse, du coup l'installation à du être corrompu. On va espérer que c'était ça.

L'espoir fait vivre… mais Pascal77 te disais dans son message #4 :
Bon, déjà un premier point : un "sad Mac", c'est obligatoirement un problème matériel.
Donc ton problème ne venait pas une installation défectueuse faite à partir d'une disquette corrompue (ni même d'une installation corrompue faite à partir d'une disquette défectueuse).
 

jab2

Membre junior
21 Février 2007
42
0
L'espoir fait vivre… mais Pascal77 te disais dans son message #4 :

Donc ton problème ne venait pas une installation défectueuse faite à partir d'une disquette corrompue (ni même d'une installation corrompue faite à partir d'une disquette défectueuse).
Oui, c'est ça. Fait rare mais le sad mac venait d'une installation défectueuse du Mode32. Le SE/30 tourne à merveille actuellement.
 

jab2

Membre junior
21 Février 2007
42
0
normal l'os 7.5.3 ne supporte pas Mode 32 et ne peut pas s'installer sur une Rom 24bits sinon il faut rester en 7.1 pour avoir toute la Ram dispo
Le mieux est de changer la ROM soit une Rom de IIsi ou IIfx soit une Rom achetée sur Ebay par exemple
Dans mon cas mon Se/30 tourne sous 7.61 avec 68 mo sans aucun soucis avec une clean Rom de 512 ko , par contre il faut hacker le fichier System avec resedit (tout est expliqué ici https://vintageapple.org/gamba2/os8_se30.html )



Voir la pièce jointe 166677
merci pour cette info. Je m'y tenterai après avoir reçu mes barrettes de RAM ! J'ai un IIsi qui traine dans mes placards
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 427
3 520
68
Sous la limite KT
merci pour cette info. Je m'y tenterai après avoir reçu mes barrettes de RAM ! J'ai un IIsi qui traine dans mes placards

Ne sois pas trop déçu de la piètre performance du II si comparé au SE30, qui, malgré ses 4 Mhz de moins, était largement plus réactif que lui. Pour avoir bossé sur ces deux machines, je préférais de loin le SE30 malgré son écran limité.
 

jab2

Membre junior
21 Février 2007
42
0
Pour moi également c'est le SE/30 qui prime. Et puis, j'ai quelques IIsi qui trainent, alors ça ne me dérange pas d'en sacrifier un !
 

gpbonneau

Membre d’élite
Club MacG
12 Juillet 2005
1 077
442
65
Normandie
gpbmaccollection.online.fr
merci pour cette info. Je m'y tenterai après avoir reçu mes barrettes de RAM ! J'ai un IIsi qui traine dans mes placards

Ça m'est arrivé d'avoir des plantages en série à cause de fichiers système corrompu qui se finissent par un SadMac.
Un formatage et réinstallation du système avait réglé le problème.
Un SadMac n'est pas forcément dû à un problème matériel majeur, en redémarrant sur ta disquette ça fonctionnait bien.
Si ça recommence, ton disque dur a peut-être des soucis sur certaines pistes.

Pour moi également c'est le SE/30 qui prime. Et puis, j'ai quelques IIsi qui trainent, alors ça ne me dérange pas d'en sacrifier un !

La plupart des IIsi (en tout cas tous ceux que j'ai vu) ont une ROM soudée et le support pour la ROM est vide. Ceux avec ROM sur barrette sont plutôt rare (si c'est le cas, ne le sacrifie pas, ça m'intéresse ;-)
D'autres Mac (comme le IIcx), ont un support ROM vide et un jumper pour privilégier la ROM sur barrette si tu en mets une (Apple avait peut-être prévu de faire des upgrades de ROM ?).
Donc regardes bien le tiens pour voir s'il a une barrette ROM... ou pas.
J'avais essayé une barrette de IIfx (ils ont tous une barrette ROM amovible et j'en ai plusieurs) sur un de mes SE/30, franchement, je n'ai trouvé aucune différence avec MODE32.