Mail.app en a décidé autrement

-anonyme-

Légende
26 Février 2001
66 286
2 673
Bonjour à toutes et à tous,

Depuis quelques mois, ce cher Mail.app a décidé de n'en faire qu'à sa tête avec certains mails en HTML et pas d'autres.

Du jour au lendemain, certains mails se sont mis à être correctement affichés, et pas d'autres.

Exemple typique, les mails de l'ADC, passent en texte, comme si les graphiques n'étaient pas affichés. Comme une page HTML qui aurait perdu images et CSS.
Pas glop.

J'ai bien sûr vérfié les préférences auxquelles je n'avais pas touché. Niet.

Je me suis ensuite demandé si cela pouvait venir de la réception des providers, j'ai 1&1, GMail. Mais apparemment non.

Certains mails venant d'eBay reçus sur GMail ne s'affichent pas correctement, et uand j'y réponds, le coprs du message cité et affiche nickel !

Les mails de Materiel.net sont nickels, alors qu'aussi reçus sur GMail.

J'ai bien sûr procédé à la réparation des autorisations et tout le toutim.


Auriez-vous une quelconque idée ?

PS: je suis fan des mails en texte pur (leur vocation) mais les mails envoyés en HTML c'est sympa aussi :D
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Bonsoir

Je rencontre un problème équivalent avec certains en HTML que j'ai reçus (avec Mail.app). Ils apparaissent en blanc quand je tente de les visualiser. Pourtant, leur contenu n'est pas vide (on peut voir le code brut en faisant Alt+Pomme+U).

En ce qui me concerne, n'ayant pas utilisé mon Mac depuis un mois, et puisqu'il n'y avait pas de problème avant, je peux dire que la cause du problème est toute récente. La seule manip antérieure à la visualisation desdits messages a été la mise-à-jour de sécurité 2007-007 de Mac OS X... Cela pourrait-il avoir un rapport ? :nailbiting:
 

Anabys

Membre d’élite
Club MacG
2 Août 2004
1 099
67
Paris
www.valhalla.fr
Mail ne télécharge pas (sauf si on le demande explicitement) les images qui proviennent d'un lien "img src=..." dans le HTML de l'e-mail, pour des raisons de sécurité (anti-spam). Cela vient peut être de là ?
 

-anonyme-

Légende
26 Février 2001
66 286
2 673
@Anabys :

Tout à fait d'accord avec toi, l'option est dans les préférences dans l'onglet Viewing on a "Display remote images in HTML messages", cette option a toujours été cochée ;)

C'est pas grave, Leopard va sortir et je vais faire une clean install :D

@PA5CAL :

Peut-être, en effet. Je vais laisser courir, pour la gêne que ça occasionne...
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Bon, je pense que je viens peut-être de trouver l'origine du problème d'affichage de mes mails récalcitrants.

Il semble en effet que Mail ne soit pas en mesure (à tort ou raison) d'afficher correctement le texte dans le format décrit immédiatement après la première balise "multipart" des quelques messages concernés. En revanche, en choisissant un affichage alternatif (menu Présentation>Message) on arrive bien à afficher le message dans le format décrit après la seconde balise "multipart".

Mon problème vient donc soit d'un bug de Mail, soit de messages mal formés (à cause d'un bug dans le logiciel de messagerie de l'expéditeur, par exemple).


Mais je doute maintenant qu'il s'agisse du même problème que le tien. En effet, chez moi c'est tout le corps du message qui n'est pas affiché. Et ça ne semble pas être ton cas.

Comme le suggère Anabys, la disparition des images est peut-être due à un problème d'accès aux fichiers correspondants au travers d'Internet. En revanche, je ne pense pas que le problème d'affichage des styles puisse venir de là, les messages HTML de l'ADC ne faisant (généralement) pas appel à des feuilles CSS extérieures.
 
  • J’aime
Réactions: m4el

-anonyme-

Légende
26 Février 2001
66 286
2 673
@PA5CAL :

Chez moi aussi c'est tout le corps du message qui est mal affiché, c'est donc aussi mon cas.

Ça marche comme il faut quand je fais View -> Message -> Next Alternative. Raccourci Pomme+].

Merci !
 

-anonyme-

Légende
26 Février 2001
66 286
2 673
En fait, ça m'apprendra à cliquer n'importe où quand je nettoie le mac avec Onyx.

J'avais activé l'option "Afficher les mails en format text quand cela est possible".

Donc forcément que j'avais du texte avec l'HTML.

J'arrête le White Spirit.

Demain.