Mail plante avec une suite de chiffre

Statut
Ce sujet est fermé.

Anthony

Journaliste
MacGeneration
Administrateur
Club MacG
28 Octobre 2005
2 901
925
metrozendodo.fr

Aliboron

Chercheur de son
Modérateur
Club MacG
1 Janvier 2008
13 308
771
Toulouse.cong
faq.office.macintosh.free.fr
Ça donne le résultat attendu, au lieu de planter…
C'est ce qu'on appelle une "solution de contournement". Connue depuis belle lurette comme le rappelle Anthony ci-dessus. Mais ce n'est pas pour autant un bug résolu (tu parles d'ailleurs toi-même de "passer outre ce bug"). Il sera résolu lorsqu'on pourra saisir onze chiffres dans le champ de recherche ! ;)

Mais je crois que c'est surtout une interprétation excessive par Anthony du terme "résolu" qui figure dans le titre du fil. En fait, c'est la demande de l'utilisateur qui est résolue, pas le bug. Pour le reste, on est tous d'accord, me semble-t-il pour dire qu'il y a bien un bug, qu'il n'est pas résolu, mais qu'on peut assez facilement le contourner...

Supplément gratuit : c'est un bug qui semble ne concerner que la version française. En tout cas, je viens de faire l'essai en passant Catalina en anglais et hop ! plus de souci pour faire une recherche avec onze chiffres. Ce qui explique certainement pourquoi le bug n'est pas corrigé...
 
Dernière édition:

baron

Membre d’élite
22 Avril 2008
1 413
344
LLN
Mais je crois que c'est surtout une interprétation excessive par Anthony du terme "résolu" qui figure dans le titre du fil. En fait, c'est la demande de l'utilisateur qui est résolue, pas le bug.
:up:
Autre lieu, autres mœurs…

Dès le départ, on sait qu'il suffit de mettre autre chose que des chiffres pour contourner le bug. Mais ça ne résout pas le problème ¡…]
Si le problème est « Comment retrouver une série de plus de dix chiffres ? (p.ex. un code EAN ou un nº de bon de commande) », l'ajout de guillemets amène une solution (il suffit en pratique d'en placer un avant la série de chiffres), alors qu'avec d'autres caractères comme indiqué précédemment, la recherche n'aboutit pas.

Mon intention en postant était simplement de permettre à celui qui était coincé par ce bug de résoudre son problème pratique – ce que personne n'avait fait jusque là me semble-t-il – plutôt que de démontrer qu'il y a ou non un bug, en soi non contesté.
 
Dernière édition:

djamet

Nouveau membre
24 Septembre 2020
1
0
47
Sous Catalina, une recherche de type numérique fait planter le spotlight au delà de 10 chiffres. Ajouter le signe "+" devant la recherche permet de contourner cette difficulté. Le problème ne se pose pas avec les recherches de type Alphanumérique.
 
Statut
Ce sujet est fermé.