[MAILING] problème avec la balise <map>

senkou

Nouveau membre
4 Juin 2010
4
0
35
Bonjour,

je suis un développeur web qui rencontre un petit souci au niveau des mailings que j'envoie. J'essaye d'être le plus généraliste possible afin que tout mes contacts de mailings reçoivent correctement ma newsletter cependant je rencontre un problème avec les mac users.

J'utilise dans mon code la balise <map> qui sert à rendre une zone cliquable sur une image. Dans Safari aucuns problèmes tout fonctionne, cependant dans mail je n'ai aucun lien qui fonctionne !

Voici la structure de mon code :

Bloc de code:
<img src="mon_image.jpg" usemap="#map_mon_image" width="400" height="350" border="0">
    <map name="NL_2010_06_03">
        <area shape="rect" coords="15,44,215,355" href="http://lien1.fr" target="_blank" title="Lien 1">
        <area shape="rect" coords="15,44,215,355" href="http://lien2.fr" target="_blank" title="Lien 2">
            <area shape="default" href="http://www.lien.fr" target="_blank" title="http://www.lien.fr/">
    </map>

Même mon lien par défaut n'est pas pris en compte auriez vous une suggestion pour m'aider ?

Cordialement, Senkou.
 

senkou

Nouveau membre
4 Juin 2010
4
0
35
Personne n'a rencontré ce problème ? Mon message à déjà été vu plusieurs fois depuis que je l'ai déposé mais personne ne me réponds ? Petit UP :up:
 
A

Anonyme

Invité
Le nom de ton map ne fait pas référence à l'usemap de ton image. Un truc correct serait plutôt dans le genre :

Bloc de code:
<img src="photo.jpg" alt="capture d'écran de safari mobile" width="320" height="480" border="0" usemap="#[B]Map[/B]" />
    <map name="[B]Map[/B]" id="[B]Map[/B]">
        <area shape="rect" coords="247,4,281,308" href="#" alt="Barre d'adresse" />
        <area shape="rect" coords="249,314,278,470" href="#" alt="Recherche" />
    </map>
 

momo-fr

Ancien Aveyronnais
Club MacG
4 Octobre 2004
4 725
1 851
Bordeaux (33)
www.momofr.net
Personne n'a rencontré ce problème ? Mon message à déjà été vu plusieurs fois depuis que je l'ai déposé mais personne ne me réponds ? Petit UP :up:
Jamais je n'ai utilisé une <map> dans une newsletter… difficile de te répondre, pour moi : Newsletter = structure et utilisation simple = pour une facilité de lecture maximum. :rateau:
 

senkou

Nouveau membre
4 Juin 2010
4
0
35
Jamais je n'ai utilisé une <map> dans une newsletter… difficile de te répondre, pour moi : Newsletter = structure et utilisation simple = pour une facilité de lecture maximum. :rateau:

Je suis entièrement d'accord cependant ce sont des "directives" de ma boîte ils utilisent beaucoup de produits en images dans leur Newsletter résultat la balise <map> à tout son intérêt. Et excepté sur mail je n'ai pas rencontré de problème pour le moment.

Le nom de ton map ne fait pas référence à l'usemap de ton image. Un truc correct serait plutôt dans le genre :

Bloc de code:
<img src="photo.jpg" alt="capture d'écran de safari mobile" width="320" height="480" border="0" usemap="#[B]Map[/B]" />
    <map name="[B]Map[/B]" id="[B]Map[/B]">
        <area shape="rect" coords="247,4,281,308" href="#" alt="Barre d'adresse" />
        <area shape="rect" coords="249,314,278,470" href="#" alt="Recherche" />
    </map>

Je l'ai tapé rapidement mais j'utilise aussi le ID ça n'change rien =/
 
A

Anonyme

Invité
Alors il faut découper cette image en petits morceaux et donner un lien à ces morceaux.
 

jackseg

Nouveau membre
10 Septembre 2008
6
0
Bonsoir,
J'ai le même problème sur page que j'ai créé sur PC. Si je l'envoie sur un mac depuis un PC avec Explorer, Mail ne prend pas en compte les zones cliquables. Par contre si la page est envoyée depuis un serveur, le lien fonctionne.