MAMP et 403 Forbidden

studio5150

Membre junior
15 Juin 2009
32
0
Belgique
Bonjour à tous

je travail avec MAMP depuis plus d'un an, et depuis hier soir je crois que mon mac a fait une MAJ et du coup je n'ai plus accès à la page PHP de config de MAMP (http://localhost:8888/MAMP/?language=French où je peux logiquement accéder à phpMyAdmin)

Voila le message

Forbidden

You don't have permission to access /MAMP/ on this server.

Apache/2.0.59 (Unix) PHP/5.2.6 DAV/2 Server at localhost Port 8888


quelqu'un peux m'aider??? J'ai mes clients qui s'impatientent :) :)
 

studio5150

Membre junior
15 Juin 2009
32
0
Belgique
J'avais déjà testé ceci hier, :)
J'ai également changer tour à tour les droits d'accès de ce répertoire et rien n'y change... :(

Mais je pense que le réseau sur quoi est la machine n'y est pas pour rien...
Car la même config sur mon macbook (réseau domestique) et là tout va bien... :s
 

Jehutty

Membre junior
12 Août 2008
30
1
Bonjour, j'ai exactement le même soucis suite à une MAJ de MAMP. Cela fait maintenant plus de 6 mois que j'ai ce problème et il n'est toujours pas résolu chez moi !
J'ai essayé d'autre soft que MAMP comme XAMPP mais j'ai la même erreur, c'est donc bien cette mise à jour qui a foutu le boxon !

Je n'ai pas d'autre solution que le formatage et la réinstalation complète de léopard ne qui en m'enchante pas... D'autant plus que je ne peux réinstaller à partir de time machine vu que l'erreur est présente dessus...
bref si quelqu'un sait comment réinitialiser OSX ou au moins sa configuration réseau, sans tout reformater, je suis preneur !

Merci !

---------- Nouveau message ajouté à 15h00 ---------- Le message précédent a été envoyé à 14h44 ----------

OK j'ai trouvé la solution !!!

Cool ca me fais plaisir, vraiment !

donc je l'ai trouvé ici même

Pour les non anglophone :
1) il suffit d'ouvrir le fichier httpd.conf dans Applications/MAMP/conf/apache/ avec un soft type TextWrangler.

2) Ensuite allez à la ligne (lignes 378-381 pour moi) où il est écrit :

<Directory />
Options Indexes FollowSymLinks
AllowOverride All
</Directory>

3)
Changez "AllowOverride All" par "AllowOverride None".
4) Sauvez httpd.conf
5) Démarrez MAMP et votre page d'accueil devrait se charger !

Merci à lui pour sa solution qui fonctionne chez moi !

 
  • J’aime
Réactions: koeklin

tatouille

Vétéran
1 Juin 2004
5 174
494
Stanford CA

Merci à lui pour sa solution qui fonctionne chez moi !


donc principalement vous etes tous une bande de peigne cul qui ne veulent pas apprendre a se servir d'apache par faineantise je pense, parce que la (les caves ils reglent le probleme en desactivant les htaccess alors qu ils ont des htaccess mal configures sur leur arbo... bande de pigs)
AllowOverride ca veut dire qu il y a un htaccess non?

ps: le forum web c'est vraiment devenu in-interressant avec ce depotoir et invasion de sous-faux-newbs-
feingnant je pense que la moderation et les users clefs y sont pour quelque chose, please essayez d'elever un peu le niveau c'est Pathétique
:zen:

 

grumff

Membre d’élite
Club MacG
9 Novembre 2000
3 606
99
Grenoble, France
www.grumff.com
Le problème c'est surtout qu'on a de plus en plus de gens qui utilisent des logiciels en php sans avoir de notions de comment ça marche. La faute à mamp et aux cmf qui ont rendu ces logiciels un peu plus accessibles. Seulement déployer des outils en php, ça reste un peu plus compliqué que d'installer ilife. Donc ça demande un peu de curiosité et d'implication pour comprendre comment ça marche, et si on n'en est pas capables, c'est pas la peine d'utiliser ces outils là. Et effectivement on voit arriver de plus en plus de gens qui attendent qu'on leur mâche le travail parce qu'ils sont incapables de taper 3 mots clés dans google pour trouver les centaines de tutos qui expliquent tout ça très bien. Sans parler de ceux qui n'ont pas de compétences et qui répondent à côté de la plaque à des sujets où ils pigent rien de plus que celui qui pose la question.
Tout ça pour dire que je partage ton énervement Tatouille.
 

WoSarT

Membre junior
24 Juillet 2009
95
1
28
France - Paris
www.ImaGesHeberG.com
Excusez moi, mais moi je trouve vos deux comportement nul.

Apache et PHP sont deux choses différentes. C'est pas pour rien que parfois on trouve dans des entreprises deux postes différents pour ces deux éléments.
Qu'est ce qui vous fait dire qu'ils ne sont pas en plein apprentissage ? Vous bien sur, vous avez directement tout su. Hop en lisant vos cours PHP, vous avez directement lu en même temps les .htaccess, php.ini ...

En lisant ton message tatouille, on dirait que tu veux montrer que t'es d'un niveau supérieur et eux des sous-merde du PHP. T'es peut être bon, qui sait, mais t'es aussi passé par le statut de newbie comme tu dis.
 

FranZz

Membre confirmé
19 Juillet 2007
403
9
Namur
Et on fait tourner les serviettes....:rateau: