MAMP et localhost error: "Not found the requested URL....."

midiweb

Membre confirmé
23 Mars 2007
115
0
salut, j'ai l'erreur suivante sous MAMP quand je démarre mon serveur en local pour lire mon script form.php:

Not Found

The requested URL /form.php was not found on this server.
Apache/1.3.33 Server at ordinateur-de-****.local Port 80

Tout marchait bien encore avant hier.

Le port de Apache est 8888, celui de Mysql 8889. J'ai remis ceux par défaut, 80 et 3306.
Mais en vain. Mon script est bien dans /applications/MAMP/htdocs


Qui peut m'aider?

Merci
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
salut, j'ai l'erreur suivante sous MAMP quand je démarre mon serveur en local pour lire mon script form.php:

Not Found

The requested URL /form.php was not found on this server.
Apache/1.3.33 Server at ordinateur-de-****.local Port 80

Tout marchait bien encore avant hier.

Le port de Apache est 8888, celui de Mysql 8889. J'ai remis ceux par défaut, 80 et 3306.
Mais en vain. Mon script est bien dans /applications/MAMP/htdocs


Qui peut m'aider?

Merci
Est ce que le partage web perso est activer dans les préférences systèmes ? si oui il y a peut-être un conflit entre les deux Apache.

Sinon je ne sais pas d'où ça peut venir, mais pourquoi changer le port de MAMP puisqu'il n'est fait que pour le test ? (il est fortement déconseiller de ne pas l'utiliser en deploiment pour des raisons de sécurité) ;)
 

outsooncool

Membre junior
5 Avril 2007
50
1
Toulouse
je remonte le sujet car je bosse sous mac au travail.
Je voudrais creer des pages en PHP. J'ai donc desactivé le partage web, installé MAMP, redémarré , crée une page de test sous golive , enregistré celle ci en .Php dans le dossier htdocs du dossier MAMP.
Je tappe donc http://localhost:8888/MAMP/htdocs/nomdufichier.php et j'ai droit à :

Not Found

The requested URL /MAMP/htdocs/test.php was not found on this server.
Apache/2.0.59 (Unix) PHP/5.1.6 DAV/2 Server at localhost Port 8888


Là je ne sais plus quoi faire, j'ai redemarré l'OS, MAMP..rien à faire.

Ai je raté une étape, y a t il des parametres à configurer une fois MAMP téléchargé et démarré?

Je précise que lors de l'ouverture des serveurs, mamp s'ouvre et me confirme que ces derniers sont bien démarrés.
 

outsooncool

Membre junior
5 Avril 2007
50
1
Toulouse
MERCI, je viens de tester, ca m'affiche la page de code PHP ... a n'y rien comprendre!


EDIT

Je viens de tenter avec une nouvelle fonction, là j'ai page blanche!


RE EDIT

Ok, c est bon, ca fonctionne, la fonction ne devait pas etre bonne! MERCI BEAUCOUP!