10.9 Mavericks Mavericks, virtualBox et scanner

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
8 932
3 097
Bonjour,

Certains s'en souviennen peut-être, le passage de Mavericks à El Capitan avait rendu obsolete mon scanner Canon 4400F, Canon n'ayant pas cru bon de mettre à jour ses pilotes. Les différentes solutions n'ayant pas marché j'avais résolu l'affaire en gardant une partition en 10.9 et en bootant dessus chaque fois que le besoin s'en faisait sentir. avec le confinement et la nécessité pour le gamin d'envoyer son boulot à ses profs c'est devenu quotidien, j'ai donc repris mes recherche et ai trouvé un splendide tuto pour virtualiser Mavericks. Et ça marche !
Du coup j'ai récupéré la toolbox et le pilote, installé le tout, sauf que quand je lance un scan il me répond 'lancement du pilote impossible'. Je me demande si la VM arrive à joindre le scanner, pourtant il est bien dans la liste des matériels détectés.

Si quelqu'un a une idée de génie, il est le plus que bienvenu
 

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 681
139
Paris
Bonjour,

Certains s'en souviennen peut-être, le passage de Mavericks à El Capitan avait rendu obsolete mon scanner Canon 4400F, Canon n'ayant pas cru bon de mettre à jour ses pilotes. Les différentes solutions n'ayant pas marché j'avais résolu l'affaire en gardant une partition en 10.9 et en bootant dessus chaque fois que le besoin s'en faisait sentir. avec le confinement et la nécessité pour le gamin d'envoyer son boulot à ses profs c'est devenu quotidien, j'ai donc repris mes recherche et ai trouvé un splendide tuto pour virtualiser Mavericks. Et ça marche !
Du coup j'ai récupéré la toolbox et le pilote, installé le tout, sauf que quand je lance un scan il me répond 'lancement du pilote impossible'. Je me demande si la VM arrive à joindre le scanner, pourtant il est bien dans la liste des matériels détectés.

Si quelqu'un a une idée de génie, il est le plus que bienvenu
Est-ce que quand tu branches le scanner tu l’actives bien dans les paramètres de virtual box ?
 

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
8 932
3 097
Il est branché en permanence au Mac, et j'ai bidouillé un truc dans les dans les paramètres USB de virtualBox, mais plutôt au pif !
Sans titre.png
 

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 681
139
Paris

RubenF

Accélérateur
Club MacG
6 Octobre 2014
2 681
139
Paris
Tu peux le faire manuellement quand tu es sur la VM lancée dans périphériques - USB - Ton Scanner
 

Romuald

Bof...
Modérateur
Club MacG
14 Septembre 2006
8 932
3 097
C'est bizarre le fonctionnement des VMs. Hier je passe à la dernière version de virtualbox, je bidouille des trucs et des machins dans la configuration, je ne sais plus trop lesquels ni dans quel ordre (en gros activer l'USB3, revenir sur l'USB2, changer le branchement du scanner) et tout d'un coup, paf, ça semble marcher, le scanner est en ligne. Par contre ça coince comme si j'étais sur un OS plus récent : apparition de la fenêtre 'numérisation en cours', blocage et time-out.
Ce matin je relance la VM, je remarque que ça me coupe le bluetooth sur le host, donc j'essaie de le relancer et la impossible de faire sortir la souris de la fenêtre VM, et cmd-tab est inactif...
Par contre le scanner scanne via la VM !

L'informatique, j'vous jure :wacky: