Modifications données DD externe impossible

klamoux

Nouveau membre
25 Avril 2010
7
0
Bonjour,
J'ai récupéré un disque dur externe en USB 2.0 de 500go que j'utilisais jusqu'à présent sur un PC. Mon iMac le reconnait sans encombre, mais il se trouve que je ne peux apporter aucune modification sur celui-ci (que se soit un déplacement de fichier, renommer un document ou en supprimer un). Si j'étais sur Windows, je dirais qu'il y a un problème de "lecture seule".
Etant novice sur Mac, je solicite votre aide afin de savoir quelle serait la manip à effectuer pour rectifier ce soucis.

Merci à vous !
 

PA5CAL

Vétéran
Club MacG
21 Juillet 2005
9 228
597
Île-de-France
Bonjour

Je dirais qu'il est formaté en NTFS, le format propriétaire de Microsoft.

Mac OS X ne peut, par défaut, que le lire (et pas l'écrire), pour une raison de licence essentiellement.

Il existe des pilotes de tierce partie qui permettent d'écrire sur ce type de partition, tels que NTFS-3G (gratuit mais lent) ou Paragon NTFS (payant mais rapide).

Par ailleurs, une astuce valable sous Snow Leopard rend l'opération possible sans ajout de logiciel. Mais c'est du bidouillage.

Tous ces point ont été déjà très largement abordés sur le forum. Une recherche préalable à l'ouverture de cette discussion aurait été utile.
 

Laurent.68

Membre junior
16 Mars 2010
18
0
Alsace
Bonsoir All, :)

Je suis un switcheur tout frais...

J'ai également ce "souci".

J'ai eu le cas cet apres-midi avec une clée USB, Très bien en lecture, un peu moins en écriture...
Je ne me suis pas trop posé de question pour une clé de 8Go, je l'ai simplement formatée, enfin, je l'ai "Effacée" devrai-je plutot dire... :rateau:

Ce soir, j'ai le même souci mais avec un disque dur externe de 250Go et 1 autre de 500Go...

Je préfère poser la question plutot que commencer à essayer de transvaser tout sur l'un pour l'effacer pour ensuite transvaser sur l'autre et... Vous aurez compris je pense... ;)

La question est la suivante, pour ma clé usb, j'ai effacé en MS-DOS (FAT), Dois-je faire pareil pour mes 2 disques durs ou dois-je utiliser une des techniques citées plus haut?

Merci à vous.
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 527
3 548
68
Sous la limite KT
Bonsoir All, :)

Je suis un switcheur tout frais...

J'ai également ce "souci".

J'ai eu le cas cet apres-midi avec une clée USB, Très bien en lecture, un peu moins en écriture...
Je ne me suis pas trop posé de question pour une clé de 8Go, je l'ai simplement formatée, enfin, je l'ai "Effacée" devrai-je plutot dire... :rateau:

Ce soir, j'ai le même souci mais avec un disque dur externe de 250Go et 1 autre de 500Go...

Je préfère poser la question plutot que commencer à essayer de transvaser tout sur l'un pour l'effacer pour ensuite transvaser sur l'autre et... Vous aurez compris je pense... ;)

La question est la suivante, pour ma clé usb, j'ai effacé en MS-DOS (FAT), Dois-je faire pareil pour mes 2 disques durs ou dois-je utiliser une des techniques citées plus haut?

Merci à vous.

Tout dépend de ce que tu dois mettre sur tes disques : le format FAT (nommé MS-DOS sur Mac) limite la taille d'un fichier à 4 Go, donc, si tu es certain de ne jamais avoir un fichier dépassant cette taille, c'est bon, sinon, le mieux, c'est "Paragon NTFS", parce que la lenteur de NTFS 3G est à mon avis incompatible avec l'écriture de fichiers de cette taille, ça prendrait des heures.

A noter que Paragon, est certes payant, mais c'est quand même un prix abordable (une trentaine d'€ si mes souvenirs sont bons).
 

Laurent.68

Membre junior
16 Mars 2010
18
0
Alsace
Merci pour ta réponse Pascal. Rapide et efficace. :zen:

En effet, je préfère mettre un sou pour être tranquille plutôt que devoir me poser la question de la taille des fichiers.

Je viens d'installer "Paragon NTFS".

Une icône s'est ajoutée dans les "Preferences Système" : NTFS for Mac OSX.

J'ai inséré mon disque dur externe, cliqué sur cette nouvelle icône, sélectionné mon disque et pour finir, j'ai coché "Autorisations d'accès" et "Compresser des fichiers et des dossiers".

Ne sachant pas exactement ce à quoi cela correspondait, je n'ai pas coché "Désactiver la fonctionnalité d'heure du dernier accès".

J'ai juste, tout semble correct? Je n'ai rien oublié? :up: