Mon PC est-il compatible Hackintosh ?

HectorBertucat

Nouveau membre
11 Mars 2019
7
0
19
Salut à tous !

Je suis l'heureux possesseur d'un MacBook Pro 13" de 2018 depuis bientôt 8 mois et le plaisir de travailler sous macOS est vraiment incroyable, j'ai en plus de ça un iPhone + AirPods enfin bref j'apprécie vraiment l'écosystème. J'ai également une tour (un PC fixe) sous Windows 10 qui me sert principalement à jouer et pour tout ce qui est du montage photo/vidéo mais j'ai vraiment envie de passer sur un Hackintosh et éventuellement de boot sur W10 avec un autre disque si je veux jouer.
Ma question est en fait de savoir si selon vous mes specs sont compatibles avec un Hackintosh, d'après mes recherches tout semble bon mais je vous avoue qu'une confirmation serait top !

Liste des specs du PC :
  • i7 4970K @4,00
  • 2 x 8 Go RAM DDR3
  • NVIDIA GTX 970
  • AsRock Z97 Pro4
  • SSD de 256 Go
  • DD de 2 To

Voilà, je pense avoir listé tout les composants qui peuvent éventuellement poser un problème pour le jailbreak.
Et aussi, petite information qui est je pense important : j'ai 3 écrans, 2 sont branchés sur la carte graphique et le 3ème sur la carte mère (donc sur la carte graphique intégrée à la carte mère), merci d'avance pour vos réponses !
 

HectorBertucat

Nouveau membre
11 Mars 2019
7
0
19
A priori c'est hackintoshable oui.
Tu ne pourras pas installer Mojave par contre. Il n'y a pas de nvidia webdrivers de disponibles pour Mojave.
Je viens de voir ça oui.. j'ai vu par contre que certains avaient réussis à installer les drivers de High Sierra sur Mojave, aucune idée de si c'est stable ou pas par contre.. Je vais partir sur High Sierra et éventuellement upgrade vers Mojave que cela sera possible.
Merci en tout cas de ta réponse !
 

edenpulse

Membre émérite
10 Août 2010
687
142
Tu peux installer les drivers de HS sur Mojave, mais tu n'auras aucune accélération graphique. Le résultat sera extrèmement frustrant, toute l'interface "laggant" violement. Rien de fluide du coup.
 

HectorBertucat

Nouveau membre
11 Mars 2019
7
0
19
Tu peux installer les drivers de HS sur Mojave, mais tu n'auras aucune accélération graphique. Le résultat sera extrèmement frustrant, toute l'interface "laggant" violement. Rien de fluide du coup.
Ok donc ça vaut clairement pas le coup étant donner que je vais faire du FCPX, Photoshop et tout ça, merci du conseil !
 

polyzargone

Membre émérite
13 Décembre 2010
597
59
Ok donc ça vaut clairement pas le coup étant donner que je vais faire du FCPX, Photoshop et tout ça, merci du conseil !

Ben si pourquoi ?

Rien ne t'oblige à passer à Mojave et si tu veux vraiment y passer, tu pourras attendre sur High Sierra le temps d'économiser et de revendre ta GTX pour une AMD :p (de toute manière, FCPX sera plus à l'aise avec les Radeon) !

Sinon pour l'install, ta config ne posera aucun problème : Guide d'installation
 
  • J’aime
Réactions: HectorBertucat

HectorBertucat

Nouveau membre
11 Mars 2019
7
0
19
J'ai une question également, j'espère que vous pourrez m'aider je trouve pas de réponse.. Comme je vous l'ai dit j'ai 3 écrans (2 branchés sur le GPU) - je sais pas si ça change quelque chose à mon problème mais - quand je boot sur la clé USB ou j'ai mis macOS (avec les kexts qui me paraissent associés à ma config et avec le config.plist qui est je pense bon), j'ai le chargement avec le logo de la pomme et sur 5 essais, à chaque fois mon ordi reboot et ne termine pas l'installation. J'ai essayé de mettre plusieurs arguments au boot comme "nv_disable=1" et "cpus=1" mais j'ai toujours le même problème.
Concernant les paramètres du BIOS j'ai mis ceux indiqués ici.
Merci d'avance de votre aide !
 

HectorBertucat

Nouveau membre
11 Mars 2019
7
0
19
Et aussi, petite info qui est peut être importante, lorsque j'ai essayé de télécharge High Sierra depuis mon MBP sous Mojave je ne peux pas, je suis donc passé par une machine virtuelle sous High Sierra pour pouvoir télécharger l'installer via l'App Store mais là encore j'ai eu un problème : le fichier téléchargé ne faisait que 15 Mo. Après plusieurs recherches j'ai lancé l'installer et j'ai quitté ce dernier juste avant le redémarrage de la VM (en fait, l'installer de 15 Mo télécharge les fichiers nécessaires pendant l'exécution de ce dernier, j'ai donc récupérer les fichiers téléchargés (présents à la racine de l'OS), j'ai créé un dossier "SharedSupport" et j'ai glissé les fichiers téléchargés dans ce dossier). La suite s'est bien passée (mettre l'installer sur l'USB, installer Clover...).
Je ne sais pas si c'est la cause de mon problème, je vous donne le maximum d'informations parce que je suis vraiment perdu là..
 

polyzargone

Membre émérite
13 Décembre 2010
597
59
@HectorBertucat

Je ne sais pas où est passée ta dernière réponse mais voici ce que j'ai reçu comme mail de notification :

J'ai une question également, j'espère que vous pourrez m'aider je trouve pas de réponse.. Comme je vous l'ai dit j'ai 3 écrans (2 branchés sur le GPU) - je sais pas si ça change quelque chose à mon problème mais - quand je boot sur la clé USB ou j'ai mis macOS (avec les kexts qui me paraissent associés à ma config et avec le config.plist qui est je pense bon), j'ai le chargement avec le logo de la pomme et sur 5 essais, à chaque fois mon ordi reboot et ne termine pas l'installation. J'ai essayé de mettre plusieurs arguments au boot comme "nv_disable=1" et "cpus=1" mais j'ai toujours le même problème.
Concernant les paramètres du BIOS j'ai mis ceux indiqués ici.
Merci d'avance de votre aide !

Donc premièrement, assures-toi que l'un des écrans branché sur l'IGPU (celui sur la carte mère) n'utilise pas la sortie VGA. Il faut utiliser les sorties DVI/HDMI uniquement.

Pour l'installation, je te conseille de n'utiliser qu'un seul écran puisque de toute manière, ton GPU ne sera pas complètement fonctionnel (pas de webdrivers). Soit tu débranches physiquement le GPU et tu n'utilises que l'IGPU, soit tu désactives l'IGPU dans le Bios et tu n'utilises qu'un seul écran (de préférence en HDMI/Display Port) sur le GPU.

L'activation des 3 écrans simultanément ne sera possible qu'une fois que tout sera OK côté GPU/IGPU.

Et deuxièmement, le mieux serait que tu reprennes l'installation de Clover en suivant notre Tuto d'installation de macOS 10.13/10.14 en utilisant le Clover_Generic.zip fourni.

cpus=1 ne sert à rien dans ton cas. En fait, il ne sert à rien pour 99,9 % des cas :p !

Après plusieurs recherches j'ai lancé l'installer et j'ai quitté ce dernier juste avant le redémarrage de la VM (en fait, l'installer de 15 Mo télécharge les fichiers nécessaires pendant l'exécution de ce dernier, j'ai donc récupérer les fichiers téléchargés (présents à la racine de l'OS), j'ai créé un dossier "SharedSupport" et j'ai glissé les fichiers téléchargés dans ce dossier).

Oulah ! C'est du bricolage tout ça :D.

As-tu essayé ça : Si vous n'avez pas eu le temps de Télécharger El Capitan, macOS Sierra ou High Sierra ou ça Comment récupérer quelques anciens Mac OS X (bis) ?
 

HectorBertucat

Nouveau membre
11 Mars 2019
7
0
19
Le tuto pour télécharger les anciennes version de macOS ne fonctionne pas pour moi malheureusement.. je n'ai pas téléchargé macOS High Sierra (j'avais direct Mojave) du coup impossible de le télécharger...
Et aussi je suis tombé sur le Tuto mais quand je veux m'inscrire sur le site pour télécharger Clover, je ne reçois pas de mail de confirmation pour finaliser l'inscription (décidément j'ai que des couilles...)
 
Dernière édition: