Mon scanner PIXMA MG7750

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Bonjour à tous,

J'ai une imprimante multifonctions CANON MG7750 depuis la fin de l'année dernière.
Mon ordi : iMac 2015 reconditionné acheté il y a un mois sur l'Apple Store (sur Sierra 10.12.5).

Tout fonctionnait parfaitement jusqu'à ce que j'essaie ce matin de scanner depuis l'écran d'accueil. A chaque fois, l'écran d'accueil indique "traitement en cours, veuillez patienter", puis rien ne se passe ! Par contre, je peux scanner sans problème depuis le logiciel "Canon Quick Menu (!). En réalité, c'est beaucoup plus long que d'appuyer sur un bouton de l'écran d'accueil... et puisque cela marchait avant, j'aimerais bien savoir ce qui cause ce dysfonctionnement.
Je précise que je n'ai aucun problème - depuis l'écran d'accueil - pour copier (donc la numération fonctionne) ou pour imprimer.
J'ai contacté CANON. Le technicien m'a demandé de débrancher/rebrancher, changer de port usb (je l'avais déjà fait avant...), supprimer les pilotes puis les réinstaller : cela n'a rien changé. Puis il m'a dit qu'il ne connaissait pas les Mac....

Je me demande si cela ne viendrait pas de la dernière mise à jour Sierra(10.12.6) que j'ai installée récemment.

Peut-être certains d'entre vous ont-ils rencontré ce souci après la MAJ, ou pourraient-ils avoir une idée pour solutionner mon problème.

Merci de votre aide.
Cordialement et bon week-end.
 
D

Deleted member 1099514

Invité
Salut

Tu peux tenter ceci :
Tu vas dans menu /préférences systèmes/Imprimantes Scanner puis clic droit dans la fenêtre de gauche et là tu fais "Réinitialiser le système d'impression".
Tu débranches ensuite l'imprimante et tu redémarres le Mac.
Tu rebranches ensuite l'imprimante et tu ré-essaies
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Bonsoir jeanjd63,

Tu m'a souvent aidée et je t'en remercie.
En l'occurence, j'ai déjà tenté cette manip. mais cela n'a rien réglé.
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Je vais tout de même tenter de l'installer tout à l'heure.
Comme je dois sortir, je reprendrai le fil pous tard.
Je te remercie.
A+

Hélas : c'est celui que j'ai installé ce matin :(
Merci quand même...
A+
 
Dernière édition par un modérateur:

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Bonjour,

suite de mes peregrinations....

Pour en avoir le coeur net, j'ai raccordé mon scanner à mon MacBookPro encore sous Yosemite : et bien, ça marche !!!
Donc, le problème vient bien de Sierra.
Bizarre, puisque j'ai téléchargé les pilotes pour Sierra sur le site de CANON.
Avez-vous une idée ?
Je précise que Sierra (10.12.5) était déjà installé quand j'ai acheté mon iMac. Malheureusement, je ne me rappelle pas si j'ai utilisé le scanner avant de passer à la dernière mise à jour (10.12.6)...
 
D

Deleted member 18124

Invité
J'ai réinstallé les derniers pilotes depuis le site de CANON FRANCE.
Celui-ci est-il différent ?

Voici la méthode pour une réinstallation propre (source : assistance Canon) :

Aller dans pomme / préférence système / imprimantes et fax

Sélectionnez votre MG puis cliquez sur le signe –

Confirmer la suppression

Fermez la fenêtre


Allez sur votre disque dur c :

Choisissez comme type affichage colonnes (le 3eme type d’affichage)

Allez sur bibliothèque / printer

Mettez le répertoire Canon à la poubelle (attention cela supprime toutes imprimantes canon installé)


Allez sur bibliothèque / image capture / twain data source / et supprimer les répertoires du MGxxxx


Allez sur pomme / préférence système / imprimante et scanner


Sur le colonne de droite ou apparait les imprimantes installé faite un clic droit ou un ctrl + clic

Et sélectionner réinitialiser le gestionnaire d’impression (cela supprime les imprimantes présente)


Videz la corbeille. Si vous ne pouvez pas vider la poubelle, redémarrer le mac et videz la poubelle

au redémarrage du mac


Aller dans votre disque dur / utilitaire / l’utilitaire gestionnaire de disque


Onglet SOS sélectionner votre disque dur et faite une vérification puis une réparation des autorisations de disque


Redémarrez le mac

Après quoi, il faut télécharger et installer les dernières versions des pilotes disponibles sur le site de Canon.


As-tu procédé ainsi ?
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Bonjour Himeji,

En fait, j'avais tout fait sauf aller dans Bibliothèque et supprimer le répertoire.
J'avais aussi passé Onyx.
Aujourd'hui, je ne suis pas chez moi et n'ai donc pas accès à mon iMac.(je poste depuis mon MacBook).Je tenterai ce soir à mon retour. Ce qui m'étonne, c'est que je peux scanner depuis Quick Menu, mais pas depuis l'écran d'accueil.

Par contre, puisque tu a l'air de bien connaître les imprimantes/scanner CANON, sais-tu comment se débarrasser de "My image Garden" ? J'ai eu le tort de l'installer sur mon MacBook quand j'ai acheté l'imprimante et maintenant à chaque utilisation (depuis l'écran d'accueil qui marche très bien !), je ne peux plus enregistrer doc., photo, etc... tout simplement sur le bureau... ou ailleurs :(

Je reviens ici quand j'aurai essayé ta manip.
Bon dimanche.Merci.
 
D

Deleted member 18124

Invité
Bonjour Himeji,

En fait, j'avais tout fait sauf aller dans Bibliothèque et supprimer le répertoire.
J'avais aussi passé Onyx.
Aujourd'hui, je ne suis pas chez moi et n'ai donc pas accès à mon iMac.(je poste depuis mon MacBook).Je tenterai ce soir à mon retour. Ce qui m'étonne, c'est que je peux scanner depuis Quick Menu, mais pas depuis l'écran d'accueil.

Par contre, puisque tu a l'air de bien connaître les imprimantes/scanner CANON, sais-tu comment se débarrasser de "My image Garden" ? J'ai eu le tort de l'installer sur mon MacBook quand j'ai acheté l'imprimante et maintenant à chaque utilisation (depuis l'écran d'accueil qui marche très bien !), je ne peux plus enregistrer doc., photo, etc... tout simplement sur le bureau... ou ailleurs :(

Je reviens ici quand j'aurai essayé ta manip.
Bon dimanche.Merci.

Je l'ai aussi installé quand j'ai acheté mon imprimante mais je ne m'en sers pas (j'utilise Transfert d'images). Et je n'ai jamais cherché à le désinstaller.

Pour une désinstallation garantie 100% propre, je ne sais pas. Sinon, c'est comme pour n'importe quelle application : tu mets l'application à la corbeille et tu parcours le dossier Bibliothèque de ton compte utilisateur à la recherche de fichiers ou dossiers liés à l'application.
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Je l'ai aussi installé quand j'ai acheté mon imprimante mais je ne m'en sers pas (j'utilise Transfert d'images). Et je n'ai jamais cherché à le désinstaller.

Pour une désinstallation garantie 100% propre, je ne sais pas. Sinon, c'est comme pour n'importe quelle application : tu mets l'application à la corbeille et tu parcours le dossier Bibliothèque de ton compte utilisateur à la recherche de fichiers ou dossiers liés à l'application.

OK. : la bonne vieille méthode.. J'essaieraI quand j'aurai réglé mon problème sur l'iMac.

A suivre...
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Me revoilà !
J'ai effectué toutes les manifs indiquées par Himeji, excepté : "Allez sur bibliothèque / image capture / twain data source / et supprimer les répertoires du MGxxxx" , car je n'ai pas trouvé "twain data source". Par contre, dans Bibliothèque- Printers, j'ai supprimé l'imprimante. Puis dans "Préf." j'ai supprimé les préférences imprimante.
Ensuite, j'ai re-téléchargé les pilotes sur le site CANON, mais le problème reste le même.
Je peux imprimer et copier depuis l'écran d'accueil, mais scanner seulement à partir de Quick Menu (heureusement !), impossible de le faire depuis l'écran d'accueil.

Puisque je peux scanner depuis l'écran d'accueil avec mon MBPro sur Yosemite, je pense que le problème vient de la dernière MAJ Sierra avec laquelle les pilotes CANON ne sont pas encore compatibles.

Ras le bol de me prendre la tête depuis 2 jours !!!
Je vais patienter en attendant une solution miraculeuse.

Encore merci à jeanjd63 et à Himeji des efforts déployés pour essayer de m'aider.

Bonne fin de WE.
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
Bonjour à tous,

Suite de mon aventure.....

Après ma demande d'aide faite sur le site de CANON il y a 2 semaines, je viens de recevoir (seulement !) une réponse.
Cela paraît tellement invraisemblable que je vous la retransmets telle quelle :

"Cher Client,

Nous vous remercions d’avoir contacté le Service Clientèle Canon.

Sous Mac OS X 10.11/10.12, les commandes de numérisation effectuées depuis l'imprimantes connectée en USB ne peut fonctionner.
Il est en effet nécessaire de démarrer la numérisation depuis votre système Mac OS.

Cordialement".

Ainsi, moi qui avais acheté cette imprimante récente pour sa supposée comptabilité avec SIERRA, je dois admettre qu'il n'est pas possible de l'utiliser "tout bêtement" depuis l'écran d'accueil:(

Si cela peut être utile à certains d'entre vous....
En ce qui me concerne, la prochaine fois que j'achèterai une imprimante, je choisirai une marque vraiment compatible avec Apple.

Cordialement.
 
  • J’aime
Réactions: Moonwalker

Moonwalker

Dark Star
Club MacG
22 Avril 2006
22 660
5 104
Là-haut
Mouai. Je ne suis même pas étonné. Typiquement Canon. Néanmoins, à 180 € l'imprimante, on pouvait s'attendre à autre chose concernant le support macOS.

Il précisent "en USB" donc sous-entendu que cela fonctionne en WiFi ou autre ?

En regardant le Test de Les Numériques, je m'aperçois que cette machine est dotée d'un port Ethernet.

T'as pensé à la brancher derrière un routeur ? Si ça coince en USB ça passera peut-être en Ethernet.
 

kerala48

Membre actif
1 Juillet 2012
148
10
Paris
En fait, je n'ai tenté qu'en USB.
C'est vrai que ça marche "peut-être" en Wifi ou Ethernet, mais j'ai passé tellement de temps à chercher (supprimer les pilotes, les réinstaller, etc...), qu'à dire vrai, du fait que je ne scanne pas tous les jours et que l'imprimante marche très bien via l'écran tactile (bizarre, non ?), j'ai décidé de faire avec pour l'instant. Mais je tenterai peut-être à moment perdu, rien que pour en avoir le coeur net !!!
Quant au support Canon par téléphone, ils ne semblent pas connaître le fonctionnement des Mac.
Comme tu le dis très justement : à ce prix là, sans compter le prix des cartouches d'encre, j'étais en droit d'espérer une machine au Top.
Bonne journée.
 

aymar18

Membre enregistré
6 Mai 2021
1
0
32
Bonjour à tous,

J'ai une imprimante multifonctions CANON MG7750 depuis la fin de l'année dernière.
Mon ordi : iMac 2015 reconditionné acheté il y a un mois sur l'Apple Store (sur Sierra 10.12.5).

Tout fonctionnait parfaitement jusqu'à ce que j'essaie ce matin de scanner depuis l'écran d'accueil. A chaque fois, l'écran d'accueil indique "traitement en cours, veuillez patienter", puis rien ne se passe ! Par contre, je peux scanner sans problème depuis le logiciel "Canon Quick Menu (!). En réalité, c'est beaucoup plus long que d'appuyer sur un bouton de l'écran d'accueil... et puisque cela marchait avant, j'aimerais bien savoir ce qui cause ce dysfonctionnement.
Je précise que je n'ai aucun problème - depuis l'écran d'accueil - pour copier (donc la numération fonctionne) ou pour imprimer.
J'ai contacté CANON. Le technicien m'a demandé de débrancher/rebrancher, changer de port usb (je l'avais déjà fait avant...), supprimer les pilotes puis les réinstaller : cela n'a rien changé. Puis il m'a dit qu'il ne connaissait pas les Mac....

Je me demande si cela ne viendrait pas de la dernière mise à jour Sierra(10.12.6) que j'ai installée récemment.

Peut-être certains d'entre vous ont-ils rencontré ce souci après la MAJ, ou pourraient-ils avoir une idée pour solutionner mon problème.

Merci de votre aide.
Cordialement et bon week-end.
Bonjour à tous,

J'ai une imprimante multifonctions CANON MG7750 depuis la fin de l'année dernière.
Mon ordi : iMac 2015 reconditionné acheté il y a un mois sur l'Apple Store (sur Sierra 10.12.5).

Tout fonctionnait parfaitement jusqu'à ce que j'essaie ce matin de scanner depuis l'écran d'accueil. A chaque fois, l'écran d'accueil indique "traitement en cours, veuillez patienter", puis rien ne se passe ! Par contre, je peux scanner sans problème depuis le logiciel "Canon Quick Menu (!). En réalité, c'est beaucoup plus long que d'appuyer sur un bouton de l'écran d'accueil... et puisque cela marchait avant, j'aimerais bien savoir ce qui cause ce dysfonctionnement.
Je précise que je n'ai aucun problème - depuis l'écran d'accueil - pour copier (donc la numération fonctionne) ou pour imprimer.
J'ai contacté CANON. Le technicien m'a demandé de débrancher/rebrancher, changer de port usb (je l'avais déjà fait avant...), supprimer les pilotes puis les réinstaller : cela n'a rien changé. Puis il m'a dit qu'il ne connaissait pas les Mac....

Je me demande si cela ne viendrait pas de la dernière mise à jour Sierra(10.12.6) que j'ai installée récemment.

Peut-être certains d'entre vous ont-ils rencontré ce souci après la MAJ, ou pourraient-ils avoir une idée pour solutionner mon problème.

Merci de votre aide.
Cordialement et bon week-end.
salut

J'ai aussi eu un incident comme toi, j'ai réinstallé le pilote, j'ai pris le pilote à ce lien
https://www.canonprinterdriver.org/2021/01/canon-pixma-mg7750-printer-driver.html
Continuez d'essayer et bonne chance