Mot de passe admin perdu

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
72 447
21 732
Forêt de Fontainebleau
Concernant le MacBook Pro mi-2010 : Mactracker signale qu'il a été livré soit avec la version d'usine Snow Léopard 10.6.3 > soit avec la version 10.6.4. Selon la date d'achat de ce même modèle de Mac.

- je ne suis pas sûr qu'en cas de livraison avec la version 10.6.4 préinstallée > ton Mac démarre sur le DVD d'install 10.6.3. As-tu des précisions sur la version exacte installée à l'origine ?​
 

Zoum21

Membre junior
23 Mai 2020
17
0
21
Mon Mac n'est pas un MacBook Pro mi-2010 , mais un MacBook mi-2010 (et non pro): mais je ne sais pas où trouver plus d'informations sur la version exacte installée à l'origine, voici ce qui est marqué sur la fiche technique :

Logiciels préinstallés
  • Mac OS X 10.6 Leopard (inclut Time Machine, Coup d'œil, Spaces, Spotlight, Dashboard, Mail, iChat, Safari, Carnet d'adresses, QuickTime, iCal, Lecteur DVD, Photo Booth, Front Row, Xcode Developer Tools)
  • iLife (inclut iPhoto, iMovie, GarageBand, iWeb et iDVD)
Je ne sais pas si cela peut être utile ? Où trouver les informations nécessaire ?

PS : Est t'il normal que sur les site de vente de DVD d'installation Snow léopard, il n'y est pas de version 10.6.4 mais seulement des versions 10.6 (où parfois 10.6.3 mais qui semblent identiques aux 10.6 )
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 760
3 720
Là-haut
C'est le problème. Les spécificités générales du modèle ne précisent pas la build installée d'usine et c'est cela qui est important.

J'ai un iMac mi 2010 et il est venu avec 10.6.4. D'où le gros doute que le DVD 10.6.3 puisse convenir.

Voyons chez EveryMac :

Pre-Installed MacOS:X 10.6.3 (10D2162)Maximum MacOS:X 10.13.x*

Outch ! C'est le numéro de build qui va coincer. Le DVD n'ira donc pas car sa build est 10D575.
 
Dernière édition:

Zoum21

Membre junior
23 Mai 2020
17
0
21
D'accord, est-il donc possible de trouver un DVD adéquat ? (comment savoir le build des DVD snow leopard ?)
 

Moonwalker

Dark Star
Club MacG
22 Avril 2006
21 760
3 720
Là-haut
D'accord, est-il donc possible de trouver un DVD adéquat ? (comment savoir le build des DVD snow leopard ?)
Nope. Il faudrait les DVD gris correspondant exactement à ta machine.

Comme tu peux le voir, cette machine est compatible jusqu'à macOS 10.13 High Sierra.

Tu peux donc créer un programme d'installation amorçable de High Sierra ou de El Capitan (préférable vue la configuration) à l'aide d'un autre Mac.



Sinon, concernant Snow Leopard, la stratégie consisterait à trouver un Mac disposant de celui-ci et de son DVD d'installation ou d'un DVD compatible.

On relie les deux machines par FW et on démarre le MacBook en mode Target. On utilise le deuxième Mac pour installer Snow Leopard sur le DD interne du MacBook comme s'il s'agissait d'un DD externe. On monte ce Snow Leopard en 10.6.8.

On sépare les deux machines et on redémarre le MacBook sur ce 10.6.8. Il faudra bien sûr refaire quelques réglages.


Et je viens de me rappeler que le mi 2010 n'a pas de port FireWire. :banghead:

Alors, il faut sortir le disque et le mettre dans un boiter extérieur pour y installer 10.6.8.
 

Zoum21

Membre junior
23 Mai 2020
17
0
21
D'accord merci, il n'est pas possible de trouver des DVD gris correspondant exactement à ma machine ?

Je vais donc me concentrer sur la deuxième option, merci de votre aide !
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
41 886
5 963
Nancy___
il n'est pas possible de trouver des DVD gris correspondant exactement à ma machine ?
Le mieux est de téléphoner à Apple pour savoir… La probabilité m'apparait faible, on parle de DVD qui ont 10 ans !
 

Zoum21

Membre junior
23 Mai 2020
17
0
21
D'accord je comprend ! Je vais voir ce que je peux faire.
Merci beaucoup super forum !
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 537
1 556
Angoulême
Tu as bien saisi la commande qui comportait des minuscules de "L" et pas des chiffres "1".

- et la réponse est sans appel : l'utilitaire rm manque dans son répertoire natif de résidence (/bin). Je ne sais pas d'où vient qu'il en a été supprimé. Mais c'est la raison qui fait que la commande rm ne passe pas en Single User.​

Il faut donc abandonner ce plan. Voici les possibilités qui te restent pour te dépanner -->

- réussir à te rappeler le mot-de-passe de session que tu avais choisi (essaie de te remémorer le moment où tu as installé Snow Léopard et où tu as dû configurer ton compte d'utilisateur).​
- ré-acheter un DVD universel d'installation de Snow Léopard (occasion sur eBay) > l'Apple Store ne le vendant plus.​
- te faire faire une clé d'installation démarrable d'un OS compatible avec ton Mac par un autre possesseur de Mac.​
Si le binaire rm n'est plus là, peut-être que le binaire mv est présent ?!
Il serait intéressant de tenter la commande avec un mv ;)
Bloc de code:
/bin/mv /var/db/.AppleSetupDone /var/db/.NotAppleSetupDone
 
  • J’aime
Réactions: macomaniac

Zoum21

Membre junior
23 Mai 2020
17
0
21
J'ai essayé ta commande en Single User et dans le Terminal, mais je n'ai pas très bien compris comment l'écrire. J'ai tous essayé, je m'excuse des erreurs possibles mais voici les résultats :

IMG_20200526_003236.jpg IMG_20200526_003524.jpg IMG_20200526_005729.jpg
 
Dernière édition par un modérateur:

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 537
1 556
Angoulême
c'est la commande complète qu'il faut taper.
Refais la manip sur la session Single User (celle sur fond noir) avec cette commande complète (une seule ligne) :
Bloc de code:
/bin/mv /var/db/.AppleSetupDone /var/db/.NotAppleSetupDone
Cette commande consiste à renommer le fichier qu'on n'arrive pas à supprimer.
 

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
72 447
21 732
Forêt de Fontainebleau
:coucou: daffyb

Mon intervention consiste en une glose. Ta substitution de mv à rm est une idée brillante. Mais voici le doute que j'émets (réflexion faite) -->

- je pense que mv n'est pas une commande "intrinsèque" > mais un "wrapper" (un enveloppeur de sous-commandes). Précisément des 2 commandes : cp & rm. Dans la fonction "déplacement" de la commande mv --> je me figure que : a) la source est copiée à la destination (cp) > puis b) la source est supprimée (rm). Dans la fonction "renommage" de la commande mv --> je me figure que : a) un clone renommé est exécuté à côté de la source (cp) > puis b) la source est supprimée (rm).​

- s'il en est ainsi y compris pour la fonction "renommage" (pour la fonction "déplacement" --> je suis certain du binôme opératoire : cp => rm ; pour la fonction "renommage" --> je le conjecture seulement) > en l'absence de l'exécutable rm dans le dossier /bin => la commande mv devrait échouer. Sinon à créer un clone renommé à côté de la source (dans le cas ici présent un fichier .NotAppleSetupDone) > du moins à supprimer la source (le fichier .AppleSetupDone).​
 

Zoum21

Membre junior
23 Mai 2020
17
0
21
J'ai réalisé la commande en Single User et je n'ai obtenu aucun message d'erreur :

IMG_20200526_112802.jpg
 
Dernière édition par un modérateur:

Zoum21

Membre junior
23 Mai 2020
17
0
21
INCROYABLE !!! ça a marché !! j'ai relancé le MacBook et j'ai eu la cinématique de lancement, l'ordi est réinitialisé et j'ai pu recréer un compte avec un nouveau mot de passe ! Super MERCI BEAUCOUP VOUS ETES GÉNIAL !!!
Une petite dernière question, il est bien possible de télécharger une mise à jour de logiciel plus récente (ici jusqu'à macOS 10.13 High Sierra ) sans le fameux DVD ? car lorsque je lance une recherche de nouveaux logiciel, il ne détecte rien.
 

Zoum21

Membre junior
23 Mai 2020
17
0
21
D'accord merci, mais mon MacBook m'indique que mon logiciel est à jour (dans l'onglet pomme / mise à jour du logiciel) alors que je suit à macOS 10.6.8, alors que normalement je peux donc au maximum être à macOS 10.13.6 avec ce type de MacBook. Je ne comprend pas, même dans l'app store il m'indique :" Aucune mise à jour disponible"...
 

Sly54

Acrobate de l'espace
Modérateur
Club MacG
31 Janvier 2005
41 886
5 963
Nancy___
(dans l'onglet pomme / mise à jour du logiciel) alors que je suit à macOS 10.6.8, alors que normalement je peux donc au maximum être à macOS 10.13.6 avec ce type de MacBook
Parce que High Sierra ne t'est pas proposé en mise à jour.

Lien pour High Sierra : https://forums.macg.co/threads/comment-telecharger-les-anciens-macos.1307498/
Mais tu ne peux pas passer directement de SL à HS, il te faut un intermédiaire (El Capitan ?)

Regarde le post de Moonwalker : #125
 

Zoum21

Membre junior
23 Mai 2020
17
0
21
J'ai pu essayer, à l'aide de la Procédure de mise à niveau vers OS X El Capitan, mais rien à faire : je peux télécharger le logiciel mais lorsque je continue, un premier message d'erreur intervient.

IMG_20200528_003004.jpg

Je peux quand même retrouver le second logiciel dans mes téléchargements dans l'onglet Finder, mais un second message d'erreur apparaît lorsque je souhaite exécuter et installer cette nouvelle version, qui m'indique de télécharger une nouvelle copie via l'App Store, alors que ce fichier n'existe pas (ou plus), sur l'App Store...

IMG_20200528_003209.jpg IMG_20200528_002327[1].jpg

Aucune mise à jour ne m'est proposée, comment faire ?
 
Dernière édition par un modérateur: