Myst sur Tiger

ArkSeth

Membre junior
12 Juin 2007
15
1
33
Salut à tous.

J'essaye d'installer Myst III: Exile sur mon ibook G4 avec MacOS X Tiger, et le "Myst3 Installer" refuse de se lancer parce qu'il ne trouve pas "Classic", et me demande si j'ai bien une version de MacOS 9.1 ou ultérieure...
J'ai cherché un peu sur ce forum, mais sans rien trouver. Quelqu'un peut m'aider ?
 

grumff

Membre d’élite
Club MacG
9 Novembre 2000
3 606
99
Grenoble, France
www.grumff.com
Bah le message a l'air clair, ça tourne pas sous os x. Donc il te faut os 9, si t'as de la chance il se lance via classique, qui émule mac os 9 (ce qui nécessite malgré tout d'installer ce dernier), et si t'as pas de chance et que ton ibook ne boot pas nativement sous os 9 (ce qui est probable), t'es foutu. ;) Sauf si l'éditeur a fournit un patch depuis.
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
En clair, il te faut installer l'environnement Classic, qui doit se trouver sur les CD/DVD fournis avec ton iBook.

Ceci dit, je ne suis pas sûr que Myst III va fonctionner correctement via l'environnement Classic. Mais tu peux essayer.


N.B.: Les iBook G4 ne peuvent pas démarrer directement sur OS 9. Environnement Classic obligatoire...
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
Des ibooks y'en a eu 50... Il me semble que les premiers bootent sous os 9, même s'il doit pas en rester beaucoup.
Tous les iBook G4 sont incapables de démarrer en natif sur MacOS 9. Seuls les iBook G3 peuvent le faire.
 

ArkSeth

Membre junior
12 Juin 2007
15
1
33
En clair, il te faut installer l'environnement Classic, qui doit se trouver sur les CD/DVD fournis avec ton iBook.

Ceci dit, je ne suis pas sûr que Myst III va fonctionner correctement via l'environnement Classic. Mais tu peux essayer.


N.B.: Les iBook G4 ne peuvent pas démarrer directement sur OS 9. Environnement Classic obligatoire...
Problème étant que je ne trouves pas cet environnement sur mon DVD d'installation... C'est sans espoir ? :-/
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
Problème étant que je ne trouves pas cet environnement sur mon DVD d'installation... C'est sans espoir ? :-/
A ma connaissance, l'environnement Classic a été fourni avec tous les iBook G4. Je pense que tu as mal cherché.

Sur les DVD d'installation de mon PowerBook G4, l'installateur de l'environnement Classic OS 9 se trouve sur le DVD n°2.
------> Install MacOS 9 system support


Il est clair que l'on parle des DVD d'installation fournis à l'origine à l'achat d'un Mac (DVD de couleur grise)...

Sinon regarde sur tous les CD/DVD fournis avec ton Mac; peut-être que dans ton cas l'installateur de l'environnement Classic se trouve sur un CD nommé "Applications complémentaires".
 

ArkSeth

Membre junior
12 Juin 2007
15
1
33
Je l'ai acheté d'occasion, et le propriétaire d'origine ne m'a fourni qu'un seul DVD...
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
Le souci vient peut-être de là. S'il ne t'a pas donné tous les DVD, ou un DVD qui n'est pas d'origine... Si c'est le cas, il va te falloir acheter une CD de MacOS 9.1 ou 9.2 que l'on peut trouver d'occasion, que tu pourras installer comme environnement Classic.


Peux-tu de me dire:

-Quel est l'OS qui est sur ce DVD ? Le DVD est de quelle couleur ? Qu'est-ce qui est marqué dessus ?
-Quelle est le modèle exact de ton iBook G4 ?
 

ArkSeth

Membre junior
12 Juin 2007
15
1
33
iBook G4 avec un dualboot MacOS X v10.4.9 'Tiger' / Ubuntu v7.04 'Feisty Fawn'
L'outil "information système" indique 'PowerBook6,7', et à vrai dire, je n'en sais pas vraiment plus.

Le DVD est noir avec un grand X en gris légèrement dégradé, le logo d'Apple en haut, les informations de copyright sur la droite et le nom de l'OS précité sur la gauche, avec aussi la mention "Includes Xcode 2". Au dire de son précédent propriétaire et d'apparence, il s'agit du DVD d'installation original.

Et je précise à toute fin utile que c'est mon premier mac, et donc, par voie de conséquence, mon premier DVD d'installation de MacOS.
 

grumff

Membre d’élite
Club MacG
9 Novembre 2000
3 606
99
Grenoble, France
www.grumff.com
Pour mac os 9 de toutes façons il suffit de récupérer le "dossier système" et de le mettre n'importe où sur ton disque. Trouve un ami qu'a ça sous la main... ;)
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
Tu as un iBookG4 de dernière génération. Si tu cliques sur la pomme bleue en haut à gauche, et que tu sélectionnes "A propos de ce Mac", tu dois voir marqué processeur 1,33 ou 1.42 Ghz.

Par contre, les DVD noirs ne sont pas fournis avec les Mac neufs. Ce sont des DVD vendus en boite qui ne contiennent pas l'environnement Classic.

Les DVD fournis à l'origine avec les Mac sont gris. Manifestement, on ne te l'a pas donné. Ce n'est pas correct.

Je me souviens avoir aidé une personne à installer l'OS sur un iBook de dernière génération. Et je suis certain d'avoir installé l'environnement Classic.

Je vais lui demander des infos dès que possible...
 

ArkSeth

Membre junior
12 Juin 2007
15
1
33
Merci pour le lien, je télécharge ça... Un .sit, ça marche comment, au juste?

Ah, et pour le processeur, j'avais effectivement oublié, c'est un 1.33Ghz (évidemment ppc).
Et pour la petite histoire, la personne qui me l'a vendu l'avait elle-même achetée d'occasion, et je crois que le fautif était le premier propriétaire. J'ai été obligé d'ouvrir la bête après un crash de disque dur, et apparemment, celui-ci avait déjà fait la même chose, mais beaucoup moins délicatement que moi...
 
A

Anonyme

Invité
Le .sit, c'est le .zip du mac. Normalement ça se décompresse tout seul. Sinon… faut aller sur www.versiontracker.com pour télécharger stuffit expander.
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
[MGZ] BackCat;4299635 a dit:
Au lieu de vous tirer la nouille sur les noms de code des ibooks, proposez lui la mise à jour en 1.22 qui permet de jouer sous mac OS X…

http://www.macgamefiles.com/detail.php?item=16922

;) :p
Tu as déjà essayé cette solution ?

Parce que d'après ce que je comprend, c'est un patch qui permet simplement de lancer le jeu installé sur une partition OS 9 depuis une partition OS X.

Le patch date de 2001, de l'époque où il était recommandé d'installer OS 9 et OS X sur 2 partitions distinctes.

Je ne vois pas comment installer ce patch (en fait 2 patch successifs) si celui-ci nécessite OS 9 comme je viens de le constater, après l'avoir télécharger...
 

divoli

Vénérable sage
Club MacG
13 Août 2005
15 862
1 420
J'ai trouvé les patch en français.

J'ai l'impression qu'il y a eu plusieurs versions (Mac) de Myst:Exile; une sur un CD pour OS 9, et une sur un CD pour OS X.


Mais on ne peut pas rendre un jeu prévu pour OS 9, compatible OS X (hors environnement Classic) par un simple patch. Ca, j'ai du mal à le croire...