• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

NUMBERS - Formule de Calcul

Wolf_51

Membre junior
14 Mars 2016
94
1
45
Bonjour à tous,

Je fais actuellement un tableau sur Numbers pour mon travail qui va me servir au quotidien et j'aimerais y faire des statistiques, cependant je coince sur une formule.

Je voudrais à partir d’une colonne contenant des codes produits (13 différents) faire un camembert qui détaille le nombre de fois ou ces codes ont été utilisés dans cette même colonne.
Ces codes sont des abréviations faites de lettres.

Exemple : dans ma colonne j’ai 18 fois le code « MC », 25 fois le code « DOC » etc …

Je n'arrive pas à trouver la combinaison gagnante.
Pourriez-vous m'aider ?

Merci et bonne soirée.
 

Lauange

Membre d’élite
Club MacG
22 Février 2012
1 395
55
48
Pas loin de la mer
Salut, en utilisant la fonction NB.SI :

=NB.SI(A2:A50;"MC")
 

zeltron54

Membre d’élite
29 Mars 2008
1 437
211
Lorraine
Bonjour,

Tu te fais un petit tableau de récapitulation de 13 lignes (une par code produit).

Exemple: supposons que ta colonne à analyser soit la B.
En colonne X tu mets le nom du produit (exemple M...C...)
En colonne Y tu mets le nombre d'utilisation du code produit de la colonne B avec la formule =NB.SI(B;"=MC") pour le produit dont le code est MC.

Puis tu fais ton graphe sur les 13 lignes et 2 colonnes X et Y.

J'espère avoir été clair ! Pas sur !

Bonne journée

Edit: grillé par Lauange...
 
  • J’aime
Réactions: Lauange

Wolf_51

Membre junior
14 Mars 2016
94
1
45
Ça fonctionne !
Merci beaucoup pour votre réactivité et efficacité :)

Si je peux abuser ... :p
J'ai à côté une colonne "quantité" on peut l'associer ?
Sachant que la quantité est associée au code produit d'une même ligne ...
 
Dernière édition:

baron

Membre d’élite
22 Avril 2008
1 051
177
LLN
Bien sûr ! Essaie… ;)

Le résultat d'une formule est manipulable comme le contenu d'une cellule. Le type d'opération dépendant de la nature du résultat.
Si le résultat d'une formule est un nombre, tu peux faire toutes les opérations mathématiques sur ce nombre (multiplier, etc.) ; si c'est une date, tu peux calculer une autre date ; si c'est un texte, tu peux le concaténer, etc.
 

Wolf_51

Membre junior
14 Mars 2016
94
1
45
Oui ça en fait des infos ... :)

Mais la ça en devient trop compliqué pour la petite expérience.

Je vais en rester là pour le moment


Sent from my iPhone using Forums iGeneration mobile app
 

Wolf_51

Membre junior
14 Mars 2016
94
1
45
Bonjour again.

J'ai finalisé mon tableau et mes formules fonctionnent cette fois (merci encore).

C'est un tableau qui contient 32 onglets, un pour chaque jour du mois et le dernier pour le recap mensuel.

Question confort de navigation c'est un peu moyen pour se déplacer à travers tous ces onglets ...

Je me demande donc si il existe un moyen d'avoir un accès plus rapide à ces différents onglets ?

Merci d'avance


Sent from my iPhone using Forums iGeneration mobile app