• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

pb importation pyplot python 2.7

TB18

Nouveau membre
16 Septembre 2018
2
0
45
Bonjour,
recemment passé à Python 2.7, "import numpy as np" passe sans aucun souci, un "import matplotlib' ne pose pas de pb, mais lorsque j'essaie d'importer pyplot:
"import matplotlib.pyplot as plt" j'ai le déluge d'erreur suivant, et rien trouvé dans les divers forum de comparable:
"Traceback (most recent call last):
File "/Users/CARPE/Desktop/Prgm_Python/testgraph2.py", line 5, in <module>
import matplotlib.pyplot as plt
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/pyplot.py", line 24, in <module>
import matplotlib.colorbar
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/colorbar.py", line 29, in <module>
import matplotlib.collections as collections
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/collections.py", line 23, in <module>
import matplotlib.backend_bases as backend_bases
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/backend_bases.py", line 50, in <module>
import matplotlib.textpath as textpath
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/textpath.py", line 11, in <module>
import matplotlib.font_manager as font_manager
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/font_manager.py", line 1356, in <module>
_rebuild()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/font_manager.py", line 1341, in _rebuild
fontManager = FontManager()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/font_manager.py", line 989, in __init__
self.ttffiles = findSystemFonts(paths) + findSystemFonts()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/font_manager.py", line 318, in findSystemFonts
for f in get_fontconfig_fonts(fontext):
File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/matplotlib/font_manager.py", line 274, in get_fontconfig_fonts
pipe = subprocess.Popen(['fc-list', '', 'file'], stdout=subprocess.PIPE)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 710, in __init__
errread, errwrite)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/subprocess.py", line 1334, in _execute_child
child_exception = pickle.loads(data)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py", line 1382, in loads
return Unpickler(file).load()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py", line 858, in load
dispatch[key](self)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/pickle.py", line 966, in load_string
raise ValueError, "insecure string pickle"
ValueError: insecure string pickle"


Toute aide bienvenue pour me dire comme pouvoir utiliser pyplot...

merci !
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 826
3 121
On ne sait pas quel est le contexte de ton ordinateur.
Personnellement, je ne fais pas beaucoup confiance aux outils qui viennent avec le système, car leurs mises à jour sont assez aléatoires.

Donc j'utilise Anaconda et je n'ai pas de problème à importer les bibliothèques et modules.

Il s'agit d'une question de développement donc je déplace.
 

TB18

Nouveau membre
16 Septembre 2018
2
0
45
merci beaucoup pour votre réponse rapide.
Anaconda installé et... effectivement tout tourne impec.
merci !
 

bompi

El Moderador
Modérateur
Club MacG
12 Février 2004
41 826
3 121
merci beaucoup pour votre réponse rapide.
Anaconda installé et... effectivement tout tourne impec.
merci !
Tant mieux.

Il est certes un peu dommage de ne pas comprendre pourquoi ça ne marche pas (si ça se trouve, c'est simple à réparer) mais ma petite expérience me dit que ça ne vaut pas la peine de se fatiguer. Il vaut bien mieux utiliser des outils standards et à jour.

Donc, pour tous les langages autres que ce dont on a besoin spécifiquement sur macOS (ou iOS), par exemple Objective-C ou Swift, il vaut mieux prendre des distributions robustes et avec un bon support ou une bonne communauté en ligne.

Je t'ai indiqué Anaconda parce que je subodore que tu travailles plutôt du côté big data, machine learning etc. et Anaconda t'offre tout clef en main, y compris Spyder, Jupyter et iPython ; très pratique et fonctionnel.

Si tu as des besoins plus limités, n'oublie pas de regarder ce que propose Homebrew, un gestionnaire de paquetages très pratique et qui te permettra d'installer pratiquement tout ce que tu veux dans un espace à part. Là, tu auras vraiment de quoi te dépanner.