10.14 Mojave Perdu mot de passe de programme interne

Bohdi

Membre junior
27 Juin 2017
14
5
31
Bonjour à tous,

J'ai installé Windows 10 via Bootcamp sur mon MBP 2018. Le Mac ne fait plus que de booter sur Windows. Lorsque j'appuis sur la touche "alt" pour choisir mon disque de démarrage au lancement, le Mac me demande un mot de passe de programme interne. J'ai souvenir d'avoir configuré ça à l'installation, mais l'ordinateur refuse en block tous mes mots de passes.

J'ai essayé de les taper en clavier qwerty, idem. J'ai essayé toutes les combinaisons clavier proposées par Apple au boot, rien ne fonctionne. Soit je tombe sur Windows, soit sur la demande du mot de passe du programme interne. Même CMD+R ne fonctionne pas.

Je suis complètement bloqué sur Windows et c'est problématique. Tout mon boulot est sur le Mac. J'ai un backup CCC (Carbon Copy Cloner) sur DD externe, mais vu que je ne peux pas booter dessus... toujours coincé. Quelqu'un aurait une astuce pour me sauver la vie svp ?

Merci beaucoup,

Paul
 
Dernière édition par un modérateur:

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 792
25 485
Forêt de Fontainebleau
Bonsoir Paul

Le programme interne du Mac : c'est l'EFI - un logiciel lancé par une pression sur le bouton d'alimentation du Mac ou qui prend la main dès qu'il s'agit de booter un OS (après redémarrage ou choix à l'écran du gestionnaire de démarrage via le bouton "alt").

Quand un mot-de-passe est défini pour l'EFI > aucun démarrage alternatif n'est possible à part celui sur le volume désigné comme volume interne de démarrage. Il semble que ton installation de Windows ait défini le volume BOOTCAMP comme ce volume de démarrage automatique.

Il faut renseigner le mot-de-passe de l'EFI pour déverrouiller ce programme et accéder à un démarrage sur un autre Système. C'est à l'écran affichant un cadenas que cette authentification s'effectue. Le clavier logique pour cet écran est exclusivement l'Américain QWERTY.

Pour activer ce mot-de-passe de l'EFI > tu n'as pu le faire qu'en ouvrant une session de secours (⌘R) = écran des 4 Utilitaires macOS > en allant au menu Utilitaires de la barre de menus supérieure de l'écran > et en lançant l'application : Utilitaire sécurité au démarrage.

Comme ton Mac est ultra-récent > cet acte ne remonte pas à loin. Essaie de te revoir en train de faire cette opération. Tu étais alors, dans la session de secours, avec un clavier logique normalement Français AZERTY -->

  • qu'est-ce qui t'est venu à l'esprit comme mot-de-passe pour l'EFI ? - la même chose que ton mot-de-passe de session d'utilisateur ? - si ce n'est pas le même > tu as bien dû te dire qu'une association d'idées te permettrait de le retrouver : la même chose que le nom du super-administrateur = root ? - que ton chien familier = Médor ? - que ton chat favori = Grominet ? - que ta bonne amie = Cunégonde ? - que le mot-de-passe passe-partout des forums MacGé = toto ?

=> est-ce que tu retrouves ton choix d'alors du mot-de-passe ?
 

Bohdi

Membre junior
27 Juin 2017
14
5
31
Hello macomaniac,

Merci pour cette top réponse. J'ai réussi à m'en sortir, il s'agissait d'un décalage entre le clavier AZERTY et le QWERTY. En effet, le QWERTY tape les chiffres sans devoir maintenir la majuscules. C'était le détail qui tue. Ouf, je suis sauvé... sinon quelle galère d'aller dans un App Store pour ça.

La sécurité à un prix. Eh oui.

Merci à vous,

Paul
 
Dernière édition par un modérateur:
  • J’aime
Réactions: jmpas et macomaniac

macomaniac

Ouroboros
Club MacG
20 Septembre 2012
84 792
25 485
Forêt de Fontainebleau
Ravi pour toi que tu t'en sois tiré !

----------

Si tu voulais désactiver le mot-de-passe de l'EFI -->

  • ouvre la session de secours (redémarrage et ⌘R) > à l'écran des 4 Utilitaires macOS > va au menu : Utilitaires de la barres supérieure de menus > lance l'option : Utilitaire sécurité au démarrage. Dans le panneau qui s'ouvre > tu peux saisir le mot-de-passe antérieur de l'EFI (en clavier Français AZERTY si tu as bien le drapeau du clavier Français dans l'angle droit supérieur de l'écran - sinon tu peux le choisir dans la liste déroulante des langues) > puis presser le bouton permettant de le désactiver.
----------

Bonne Fêtes !
 

jmpas

Membre junior
9 Mai 2010
33
1
nantes
Hello macomaniac,

Merci pour cette top réponse. J'ai réussi à m'en sortir, il s'agissait d'un décalage entre le clavier AZERTY et le QWERTY. En effet, le QWERTY tape les chiffres sans devoir maintenir la majuscules. C'était le détail qui tue. Ouf, je suis sauvé... sinon quelle galère d'aller dans un App Store pour ça.

La sécurité à un prix. Eh oui.

Merci à vous,

Paul
Merci, j'étais dans la meme merde, et grace à vous , j'ai réussi à débloquer ma situation !