.php5

mac4921

Membre junior
7 Février 2004
68
1
Ici & Là
Bonjour,

Voilà, j'utilise MAMP pour développer en PHP/MySQL des petits sites.

Mon hébergeur web propose le support de PHP5 mais les fichiers doivent prendre l'extension ".php5". Jusque là tout va bien, ça se gâte quand j'essaye d'ouvrir les fichiers en local, avec MAMP, qui ne reconnaît plus les fichiers.
Ma question : Y-a-t'il un moyen pour permettre à MAMP de servir ces fichiers ".php5" correctement.

Merci.
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
Dans /Applications/MAMP/conf/apache/

ouvre httpd.conf avec textedit :

pomme-F tu cherche : "AddType application/x-httpd-php"
normalement, tu as une ligne qui ressemble à :
"AddType application/x-httpd-php .php .phtml .php3"

ben tu rajoute .php5 ^^

tu auras donc : "AddType application/x-httpd-php .php .phtml .php3 .php5"


et voilà !!




P.S.: il faut redémarrer apache pour que ce soit prit en compte ;)
 

mac4921

Membre junior
7 Février 2004
68
1
Ici & Là
ENORME :up:

Un superMerci ... ça marche "au poil" !!!

Une petite remarque, pour moi le chemin pour atteindre le fichier httpd.conf était le suivant :

/Applications/MAMP/conf/

(pas : /Applications/MAMP/conf/apache/) j'espère que je ne me suis pas planté de fichier.

P.S : merci aussi pour le pomme F, j'connaissais même pas.:up:
 

.Steff

Membre d’élite
Club MacG
6 Septembre 2005
1 294
104
EN plus la derniere version de MAMP ne prend en compte que le PHP4 et le PHP5...Et moi j'ai justement des probleme pour faire marcher du PHP3...bizarre
 

p4bl0

Membre d’élite
Club MacG
12 Juillet 2004
4 772
425
31
$PWD
p4bl0.net
fredmac75 a dit:
il y à tout de même une limite à ta solution. Les nouvelles fonctions de PHP5 ne pourront être prisent en considération... donc attention au codage. Si ce n'est pour utiliser de nouvelles fonctions de PHP5, je ne vois pas l'intérêt de la chose ?;)
c'est vrai...



:mad: truk2oof, t'as encore posté sans réfléchir !!!! au piquet ====> |
 

mac4921

Membre junior
7 Février 2004
68
1
Ici & Là
Effectivement je n'ai pas la toute dernière version de MAMP.

Je suis sous MAMP 1.0.

Mais comme tu dis le principal c'est que ça marche.

Encore merci.
 

bruno2502

Nouveau membre
25 Janvier 2006
3
0
As tu réussi à faire marcher le php3 avec la dernière version de MAMP, même avec l'ajout de :
### Ajouts pour SPIP
# PHP4 & PHP3 configuration
AddType application/x-httpd-php .php3
DirectoryIndex index.html index.htm index.html.var index.php index.php3
moi toujours pas !!!