• Bonjour Visiteur. Bienvenue sur les nouveaux forums de MacGeneration. La peinture est encore fraiche, quelques boulons doivent être resserrés, plus d’informations demain !

10.8 Mountain Lion Port Série introuvable

HImac in touch

Membre d’élite
Club MacG
26 Juillet 2005
2 184
117
34
at Macland
Bonjour à vous tous et joyeuse fête nationale en passant !

Je vous écris car je suis confronté à un problème auquel Google ne semble pas très bavard.

Voilà, je fais de la programmation électronique à l'aide d'une carte de développement Arduino. Pour pouvoir transférer le code (C++) sur la carte, j'utilise un cable USB (celui pour les imprimantes) que je branche sur mon Mac Book Air (2012) et je dois désigner le port que j'utilise pour transférer les données sur la carte.

Je suis censé trouver un port Série (enfin, celui qui sera émulé), du genre usbserial, mais je n'ai accès qu'à 4 connexions bluetooth (Modem, PDA Sync, Serial 1, Serial 2). Je les ai tous testés mais aucun ne marche... Ce qui est un peu normal vu qu'il n'y a que du bluetooth de proposé :meh:.

J'ai donc fait une recherche de mes différents ports à l'aide du terminal avec ls dev/cu.* et ls dev/tty.* et je n'ai que le bluetooth qui s'affiche... j'ai essayé d'installer de nouveaux drivers, mais rien ne change du coup, je suis totalement à sec niveau idées... j'espère que l'un de vous saura m'apporter la lumière dont j'ai besoin car j'en ai vraiment besoin pour mon projet ... Je vais pas m'acheter un PC pour faire fonctionner ça :shifty:...


A votre dispo si vous avez besoin d'infos !
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 024
365
92
Avec une Arduino Uno équipée d'un port USB A (le carré des imprimantes) pas besoin de pilote, elle doit être connue nativement.
Es-tu sûr de ton câble ? de ta carte ?
 

HImac in touch

Membre d’élite
Club MacG
26 Juillet 2005
2 184
117
34
at Macland
Désolé pour le retard, j'ai été bien occupé.

Je pense que ma carte ne sert à rien en l'état (c'est une version "chinoise" que j'ai acheté sur le net pour pas cher...). J'ai racheté l'officielle on verra bien, je vous dirai ça.

Pour le câble, les leds de la carte s'allume bien donc c'est qu'il marche non ?
 

ntx

Vénérable sage
Club MacG
15 Octobre 2004
12 024
365
92
J'ai acheté sur la baie une Pro Mini chinoise à 2,50€ qui marche très bien. Au pire quand tu auras une autre Arduino tu pourras essayer de reflasher ta UNO chinoise pour repartir sur de bonnes bases.
Pour le câble il faudrait être sûr qu'il n'y a pas de faux contacts à force d'être entortillé. La LED verte signifie que l'alimentation 5V du l'USB passe, pas forcement les data.
 

HImac in touch

Membre d’élite
Club MacG
26 Juillet 2005
2 184
117
34
at Macland
J'ai acheté sur la baie une Pro Mini chinoise à 2,50€ qui marche très bien. Au pire quand tu auras une autre Arduino tu pourras essayer de reflasher ta UNO chinoise pour repartir sur de bonnes bases.
Pour le câble il faudrait être sûr qu'il n'y a pas de faux contacts à force d'être entortillé. La LED verte signifie que l'alimentation 5V du l'USB passe, pas forcement les data.
Aah ok, donc ça peut être aussi le câble. Vu que mes montages (sans programmation) avec des leds s'allumaient, je me suis dis que si le courant passait, les datas aussi, mais c'est bon à savoir. Je te dirai ça, merci !
 

daffyb

-Duck Warrior-
Modérateur
Club MacG
18 Octobre 2001
13 478
1 534
Angoulême
Je suis censé trouver un port Série (enfin, celui qui sera émulé), du genre usbserial, mais je n'ai accès qu'à 4 connexions bluetooth (Modem, PDA Sync, Serial 1, Serial 2). Je les ai tous testés mais aucun ne marche... Ce qui est un peu normal vu qu'il n'y a que du bluetooth de proposé :meh:.
tu regardes où ?
 

HImac in touch

Membre d’élite
Club MacG
26 Juillet 2005
2 184
117
34
at Macland