PowerBook Wallstreet ou PDQ sous Panther

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Je cherche des renseignements sur la compatibilité de mon PowerBook G3 modèle M4753 (dit Wallstreet et PDQ d'après Mactracker)

Ne pouvant pour le moment pas le démarrer cas il ne dispose pas de disque dur à l'intérieur car il m'est difficilement utilisable. L'écran à tendance à se couper peu de temps après que le système est démarré et cela à la suite de l'installation de Jaguar :(
Je dois installer au mieux Panther afin de palier à ce problème assez épineux car inexistant sous Os 9 sans Jaguar :siffle: .

J'aurai besoin de quelques conseils, lumières etc…… afin de réussi au mieux mon intervention ;)

Mon but est comme je ne peux même pas utiliser de CD bootable, (cause =>écran) bref je vais cloner une partition de mon iBook Palourde sous Os X.3.9 réalisé il y a 2 jours.
Je vais utiliser le disque dur de l'iBook palourde en mode target connecté à mon iBook G4 afin de cloner la partition Panther puis la restaurer sur un disque dur USB dans lequel sera connecté un disque dur potentiel pour le PowerBook.
étant donné que je manque de temps en ce moment je n'ai pas voulu m'élancer dans la bidouille sans être sur du résultat auparavant.
Je suis venu chercher de l'aide :up: pour réussir le plus vite possible, en gros poser les bases, faire de la théorie pour ensuite passer à la pratique ! :cool:
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
Ben c'est mal barré, ton histoire. Va falloir impérativement installer OS 9 avec Panther sur ton disque dur (9.1 minimum, 9.2.2 recommandé) ainsi que XPostFacto.

La procédure : tu démarres le PDQ sous OS 9, tu lances XPostFacto, et depuis XPostFacto, tu lances Mac OS X 10.3.9. XPostFacto installe les compléments pour que ce système accepte de fonctionner sur le PDQ, et Mac OS X se lance. Par la suite, normalement, plus besoin d'XPostFacto, mais pour mon PDQ, je trouve plus sûr de le laisser sur son disque, ainsi qu'OS 9.2.2, juste au cas où :siffle:

Par contre : Si ton PowerBook est un Wallstreet 233*, ça va ramer un max. Tout autre WallStreet ou un PDQ, même 233 le fera tourner suffisamment bien pour une utilisation raisonnablement modeste, sous réserve qu'il soit correctement pourvu en mémoire (384 Mo mini, mais 512 Mo, c'est mieux).

(*) On reconnais un WallStreet 233 d'un PDQ 233 de deux façons si c'est un écran 12 pouces, de la seconde seulement pour un 14 pouces :

1) Le WallStreet 12" à un écran "matrice passive", alors que le PDQ 12" à un écran matrice active

2) dans tous les cas (12 ou 14"), le PDQ 233 à 512 Ko de cache L2, alors que le WallStreet 233 en est totalement dépourvu (ce qui fait qu'il y a environ 35% de différence au niveau perf globale, d'où la galère pour faire tourner OS X sur le WallStreet 233. Les autres WallStreet (250 et 292 Mhz) ont de la cache L2).

EDIT : Ah oui, au fait, si c'est un 13 pouces, c'est forcément un WallStreet !
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Alors merci pour tous ces renseignements :) je me sens déjà plus à l'aise même si c'est mon deuxième cours que je reçois de ta parts (le même en plus!)
Bref je n'en ai jamais trop ;)

Alors je ne l'ai pas encore démarré. Je peux d'or et déjà dire que c'est une version 266Mhz car il dispose d'origine un disque dur de 4Go, 14' (cache 1Mo de L2 => PDQ) et de 320Mo de ram :)
Sans le démarrer ^^

Bref assez parlé, en ce moment même je duplique ma partition Panther sur le disque dur du Wallstreet à l'aide de l'utilitaire de disque.
Je vais de ce pas telecharger "XPostFacto" afin de réaliser au mieux l'installation :).
J'ai déjà passé le système en Os X.3.9 sans les autre mises à jours sécurité etc……

En tout cas il est magnifique c'est une belle, très belle bête ! il faut que je m'en trouve un comme cela, c'est pas possible ^^:love:

Je viens d'essayer de le démarrer même sans disque dur pour voir s'il fonctionne, il ne se passe rien……
L'adaptateur secteur est en très mauvaise état (bricolé pour tout dire) est-il possible d'utiliser l'adaptateur sercteur de mon iBook palourde en bien meilleur état.La source du problème pourrait être du à l'alimentation… un mauvais entretient de celui-ci peut endommager l'ordinateur !
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
L'adaptateur secteur est en très mauvaise état (bricolé pour tout dire) est-il possible d'utiliser l'adaptateur sercteur de mon iBook palourde en bien meilleur état.La source du problème pourrait être du à l'alimentation… un mauvais entretient de celui-ci peut endommager l'ordinateur !

Depuis le temps que le Palourde de ma fille est alimenté par des alims de WallStreet, je pense pouvoir affirmer que la compatibilité est avérée. Toutefois, reste à savoir si l'alim du Palourde est en mesure de fournir une puissance suffisante pour le PDQ, qui a besoin de 45 watts.

Ah, un coup d'œil rapide à MacTracker me dit que oui, donc tu peux y aller !

Par contre, le problème pourrait aussi venir de la carte d'alim (qui fait aussi carte son, d'ailleurs). C'est un des points faibles de cette machine, et les sites qui en vendent encore ne les font pas bon marché (autour de 150 €, j'étais content de pouvoir disposer d'une épave de WallStreet quand j'ai du en changer une :siffle:).
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
l'adapateur fonction parfaitement en effet (je dirai même mieux que celui d'origine qui est très fatigué).

J'ai remarqué dès lors du branchement de l'ordinateur sur la prise d'alim celui-ci se mettait à souffler assez fort (comme si le ventilateur s'initialisait …) Puis après se bref instant j'appuie sur le bouton de démarrage, le dong céran noir pendant 3 secondes puis le disque dur se met à tourner.

Je voudrai souligné que mon clonage ne fonctionne pas à partir du palourde… (Os 9 et Os X)

Pour qu'il face quelque chose j'ai effectué plusieurs tentative de reset (3 fois) rien…
je démonte la carte processeur retire la barrette mémoire nettoie un peu, remonte le tout. Et il démarre enfin!

Impossible de lui dire de booter sur un Os à partir de la touche alt, il m'affiche désespérément une disquette avec le point d'interrogation (recherche système).

J'ai donc redémonté le tout, pour insérer le disque dur dit maudit … (Os X.2 et Os 9.2.2) et il démarre……:eek: Mon disque dur avec deux Os ne fonctionne pas mais ce-dernier oui (comprends pas trop mais bon) :rolleyes: :rolleyes:
Bref il démarre sous jaguar, je m'empresse de modifier le système de démarrage dans les préférence système afin de booter sur Os 9 (j'ai pas envie qu'il ne me plante entre les doigts :zen:
Bref je réussi et le voila depuis 5 minutes sur Os 9 :) (une première réussite) je me félicite ;):up:
Je dois encore installer Os X.3.9

Pour information c'est un Wallstreet cadencé à 250Mhz disposant donc de 1Mo de cache L2 d'un bus à 83Mhz. Cela m'a tout l'air d'un écran 14'1 (1024x768)
Une brave bête ;)
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
l'adapateur fonction parfaitement en effet (je dirai même mieux que celui d'origine qui est très fatigué).

J'ai remarqué dès lors du branchement de l'ordinateur sur la prise d'alim celui-ci se mettait à souffler assez fort (comme si le ventilateur s'initialisait …) Puis après se bref instant j'appuie sur le bouton de démarrage, le dong céran noir pendant 3 secondes puis le disque dur se met à tourner.

Je voudrai souligné que mon clonage ne fonctionne pas à partir du palourde… (Os 9 et Os X)

Pour qu'il face quelque chose j'ai effectué plusieurs tentative de reset (3 fois) rien…
je démonte la carte processeur retire la barrette mémoire nettoie un peu, remonte le tout. Et il démarre enfin!

Impossible de lui dire de booter sur un Os à partir de la touche alt, il m'affiche désespérément une disquette avec le point d'interrogation (recherche système).

J'ai donc redémonté le tout, pour insérer le disque dur dit maudit … (Os X.2 et Os 9.2.2) et il démarre……:eek: Mon disque dur avec deux Os ne fonctionne pas mais ce-dernier oui (comprends pas trop mais bon) :rolleyes: :rolleyes:
Bref il démarre sous jaguar, je m'empresse de modifier le système de démarrage dans les préférence système afin de booter sur Os 9 (j'ai pas envie qu'il ne me plante entre les doigts :zen:
Bref je réussi et le voila depuis 5 minutes sur Os 9 :) (une première réussite) je me félicite ;):up:
Je dois encore installer Os X.3.9

Pour information c'est un Wallstreet cadencé à 250Mhz disposant donc de 1Mo de cache L2 d'un bus à 83Mhz. Cela m'a tout l'air d'un écran 14'1 (1024x768)
Une brave bête ;)

Ok, alors quelques précisions :

1) Le démarrage "touche alt" ne concerne que les Mac dotés d'un open firmware en eprom, celui du WallStreet est en Rom, ce système de démarrage à la volée ne fonctionne donc pas. Pour forcer le démarrage sous OS 9, il faut réinitialiser la PMU (Mac éteint, maj+fn+ctrl+démarrage, le ventilo ronfle un coup, la lumière verte s'allume brièvement, tu attends au moins dix secondes avant d'allumer le Mac ensuite).

2) A propos de l'install de Panther : Les routines d'installation de XPostFacto sont incompatibles avec le lecteur de CD (trop ancien d'après la doc) de ce Mac, donc, pour installer ton système, si tu n'as pas le lecteur de DVD optionnel, le mieux est de sortir le disque dur, le mettre dans un boîtier externe Firewire, et installer le système depuis un autre Mac supportant Panther (moi, j'ai fais ça depuis un PM G4/733 de 2001). Je ne pense pas qu'un lecteur ou graveur SCSI fasse l'affaire, car je pense qu'OS X pourrait refuser de démarrer depuis un tel périphérique (Le SCSI "built in" n'est pas reconnu par OS X, même s'il reste partiellement utilisable. Dans la pratique, mon vieux graveur de CD SCSI était utilisable, mais Infos système Apple le détectait comme périphérique de baie d'extension, et pas comme périphérique SCSI. Mon scanner, lui, n'était carrément pas détecté). XPostFacto n'est ensuite utilisé que pour faire démarrer (la première fois) le WallStreet sous OS X.

3) Selon la taille du disque dur, ne perds pas de vue qu'OS X doit impérativement être installé dans une partition entièrement située dans les 8 premiers Go du disque (en théorie, XPostFacto permet de se dégager de cette obligation, mais en pratique, ça ne marche pas ou très mal, sur mon PDQ, ça a fonctionné deux jours, puis XPostFacto à ensuite refusé de faire redémarrer le Mac en invoquant cette raison, j'ai du tout recommencer en partitionnant). A noter que faire une partition de 8 Go tout rond ne va pas, il faut la tailler à 7,99 Go.

Bon, là, c'est tout ce que je vois à dire sur le sujet, à part que mon PDQ (un 266 Mhz 14,1 pouces) tourne comme une horloge sous Panther depuis fin août dernier (et il y est nettement plus réactif que sous Jaguar).

Ah si, pour te permettre d'être sûr, la partie visible de la dalle du 14,1 pouces fait exactement 285 mm de large, et le 13,1 pouces affichait aussi en 1024x768, seul les 12 pouces (matrice active ou passive) étaient limités au 800x600.

Si tu as d'autres questions, n'hésite pas.
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
en effet la touche alt ne fonctionne pas du tout ;)
En faissant le reset (touche shift+fn+crtl+power) 30s je rebranche le cordon d'alim à l'ordi, les ventilateur souffle + led vert. (ok) mais à chaque fois que je branche l'alimentation il me fait ça !

Je vais créer une partition de 7,99 Go max (panther et Os 9 déjà installé dessus).
Je dispose malheureusement que d'un boîtier en USB :( et démonter la palourde m'embêterai plus qu'autre chose (c'est trop long et je n'ai pas forcement le temps en ce moment).

C'est exact, Panther à quelque difficulté à Booter sur le lecteur de CD interne. Je dispose pas ici mais chez mes parents d'un lecteur/graveur externe SCSI (je pourrai toujours essayé si je n'y arrive pas).

C'est bien du 14.1" ;).
Je suis persuadé qu'il doit aussi bien tourner que ma palourde à 300Mhz ^^
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
je viens de réinstaller le disque restauré dans une partition inférieur à 8Go, il me fait la même scène ! (disquette dès le démarrage)
j'ai effectué un reset de la PMU, pareil…
je vais cloner le disque qui fonctionne puis le restaurer dans le plus gros disque dur :)
on verra ensuite ;)
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
je viens de réinstaller le disque restauré dans une partition inférieur à 8Go, il me fait la même scène ! (disquette dès le démarrage)
j'ai effectué un reset de la PMU, pareil…
je vais cloner le disque qui fonctionne puis le restaurer dans le plus gros disque dur :)
on verra ensuite ;)

Ote moi d'un doute, tu essaies bien de démarrer sous OS 9, là ?
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Oui j'essaye de booter sur Os 9.
Mais sur la même partition il y a à la fois Os 9 et Os X.3.9
La même partition sur ma palourde fonctionne que ce soit sous classic (Os 9) ou panther.

C'est quand même bizarre que le disque d'origine fonctionne et pas le mien.

Je me souviens qu'avec Os 9, il était facile de créer un système bootable. J'ai alors copier le dossier système Os 9 du disque dur qui fonctionne sur le Wallstreet pour le remplacer sur ma partition…… et cela ne fonctionne quand même pas.
J'ai un doute…… le problème proviendrai peut-être de la superposition des Os? Car panther es déjà installé dessus.
J'essayerai ce soir l'un avec juste Os 9 puis Os X après (toujours en passant par la restauration.
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
De retour :)

Bon je n'avance pas du tout :(
je crains que le problème soit directement lié au boîtier externe en USB2.
Toutes mes tentatives de clonage de disque dur à l'aide de l'utilitaire de disque échou. Le Wallstreet ne veut pas boote sur un Os même en ayant fait une copie du disque qui fonctionne.
Faut que j'ai un boîtier en FireWire! (ha je l'ai donnée à mon frère…… rr)
Je pense que le problème vient de là car c'est pas possible ^^:eek:
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
De retour :)

Bon je n'avance pas du tout :(
je crains que le problème soit directement lié au boîtier externe en USB2.
Toutes mes tentatives de clonage de disque dur à l'aide de l'utilitaire de disque échou. Le Wallstreet ne veut pas boote sur un Os même en ayant fait une copie du disque qui fonctionne.
Faut que j'ai un boîtier en FireWire! (ha je l'ai donnée à mon frère…… rr)
Je pense que le problème vient de là car c'est pas possible ^^:eek:

Bon, ça devient compliqué ton histoire, t'es dans quel coin (des fois qu'on puisse se voir pour un diagnostic avance de tes misères) ?
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Et bien je suis toujours en Corse pas bougé ;)

Seul le disque dur d'origine fonctionne :( 6Go
Faut que je trouve une parade
pour rappel :

Je dispose de 3 disques dur :
- Un de 6Go d'origine
- Un de 4Go d'un autre Mac
- Un de 20 Go provenant d'un PC formater en volume Mac ;)
- Boîtier externe USB2

Je tente à la fois de résoudre un soucis lié exclusivement à Jaguar, l'écran s'éteint au bout de quelque minutes si j'en crois mon collège et impossible de le réactiver, seul solution reboot.
Je me résous donc à installer Os 9 & Os X.3 à partir de mon iBook palourde. Pour cela je dispose d'un boîtier externe en USB2.

Ce que je tente depuis quelques jours est de restaurer depuis l'iBook une de mes partitions comprenant à la fois déjà Os 9 & Os X.3.9 (appelé Panther)

Pour cela j'ai crée :
- une partition de moins de 8Go avec les deux Os dedans / Marche pas
- Deux partitions l'une pour cloner le disque dur d'origine qui fonctionne normalement sur une partition de 7Go et l'autre pour juste panther. J'ai entre temps effacé la partition nommée Panther de ma palourde qui contenant Os 9 & Os X.3.9 pour réinstaller juste Os x.3). Avant d'effectuer la deuxième restauration sur l'autre partition, j'ai testé ma restauration sur la première partition provenant du disque dur fonctionnel sur le WS / Marche pas
- j'ai essayé d'autres combines, en échangeant les disques dur mais sans jamais toucher à celui d'origine qui lui fonctionne, le WS boote sous Os 9 et Os X.2. / Marche pas

Encore à trouver :
Un boîtier externe 2,5" en FireWire
Installer Os 9 puis Panther.
Tester :)

Comme je n'ai ni le boîtier FireWire, ni Os 9 sur moi mais à un autre endroit qui me sera accessible dès vendredi je verrai.

D'accessible ce week-end:
- Je peux toujours installer Os 9 à l'aide d'un câble ethernet. Pour panther d'après Pascal 77 j'ai besoin d'un lecteur externe reconnu et bootable !
- Un graveur SCSI
- Disque 3,5" SCSI
- ZIP
Bref toute une panoplie de produits compatibles avec le portable.

Voila où j'en suis:up:
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Oui je pense qu'il n'y a pas de soucis mais c'est dommage pour le disque de 20Go. :(

Sinon pour installer Panther je ne sais pas encore si je démonte l'iBook palourde pour insérer le petit disque dur / ou me prendre un boitier en Firewire pour effectuer la manipulation / ou connecter un lecteur/graveur de CD sur le WS en SCSI.
J'ai également une carte PCMCIA USB2 Cardbus 32Bit de SDK (comme par hasard :rolleyes: :D ) modèle MA-103. je ne sais pas si elle est compatible, je cherche des renseignements sur internet

Compatible :) (sauf pour le modèle Kanga, mais comme c'est le Wallstreet c'est ok!:) )

je vais tenter le diable!
je copie XPostFacto4 sur le disque dur qui fonctionne, réinstalle ce disque dans le WS, il démarre sous Os 9 :)
Je lance l'application je sélectionne le disque Os 9 puis redémarre. Puis une fois rebooter je me dis pourquoi ne pas tenter de booter sur Panther!
J'insères le CD, il est reconnu ! Je démarre même dessus! Mais au moment de passer à l'installation, j'ai un message d'erreur m'indiquant que mon ordinateur n'est pas compatible avec cette Os… ai-je raté une étape avec XPostFacto4?
je pense qu'il est possible de s'en sortir!
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
je me dis pourquoi ne pas tenter de booter sur Panther!
J'insères le CD, il est reconnu ! Je démarre même dessus! Mais au moment de passer à l'installation, j'ai un message d'erreur m'indiquant que mon ordinateur n'est pas compatible avec cette Os… ai-je raté une étape avec XPostFacto4?

Ben oui, tu ne peux pas démarrer le WallStreet sur le CD de Panther, car XPostFacto ne permet pas de gérer l'installation depuis le lecteur de CD d'origine (il le permettrait peut-être avec le lecteur de DVD optionnel qu'on pouvait avoir avec cette machine, mais encore faut-il en trouver un :sick:).

Ce qui m'a sauvé, c'est que j'ai eu, avec un boîtier externe 3,5" mixte Fw/USB2, un adaptateur permettant de monter un disque 2,5" sur une connectique pour 3,5", j'ai donc pu faire l'install de Panther sur mon PM G4, puis, une fois le disque remis dans le WallStreet, utiliser XPostFacto uniquement pour lancer Mac OS X.
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Je démarre sur le CD…… de panther :)
Mais sa bloque lors du lancement de l'installation vu qu'en théorie ce portable n'est pas supporté.
Alors puis me servir du logiciel XPostFacto ou il faut que j'installe autrement l'Os?
 

Pascal 77

ex modéraptor
Club MacG
28 Octobre 2004
44 471
3 529
68
Sous la limite KT
Je démarre sur le CD…… de panther :)
Mais sa bloque lors du lancement de l'installation vu qu'en théorie ce portable n'est pas supporté.
Alors puis me servir du logiciel XPostFacto ou il faut que j'installe autrement l'Os?

Non, tu ne peux pas installer avec XPostFacto, en raison d'un problème de compatibilité avec le lecteur de CD du WallStreet, sauf à y parvenir depuis un lecteur externe, si le SCSI est supporté (les cartes Firewire PCMCIA ne sont pas bootables). Sinon, la seule solution passe par une méthode similaire à celle que j'ai utilisé, et t'ai décrite plus haut dans le topic : installer Panther depuis un autre ordi, puis utiliser XPostFacto pour le lancer sur le WallStreet (je précise un peu : tu démarres le WallStreet sous OS 9, tu lances XPostFacto, et dans la fenêtre de l'appli, tu demandes le démarrage de Panther. XPostFacto installe les fichiers nécessaire pour pallier à l'incompatibilité avec le firmware, redémarre le Mac, et ça marche (choisir l'option la plus modeste pour la carte vidéo, les autres posent problème). Ensuite, en théorie : plus besoin ni d'OS 9 ni d'XPostFacto, mais perso, je préfère les garder sous la main !
 

Superparati

Membre confirmé
26 Mai 2005
371
10
33
Londres
macibook.yourmac.fr
Bon je vais re par FireWire des que j'aurai cela sous la main.
Normalement ce week-end je dois récupérer un PM G4 et un POwerMac G3 desktop.
Ce dernier dispose de connectique SCSI, je peux faire quelque chose entre les deux. Mais avant tout il faudra que j'ai installer Panther sur le PM :) pour ensuite faire une installation en mettant le WS en mode target :)

Je vais y arriver