macOS Big Sur Problème de lecture H264 et H265 macbook pro 16'' 2019

le_s

Membre junior
21 Mars 2015
26
4
47
Bonjour,

Je possède un macbook pro 16 pouces 2019 et j'ai de gros problèmes pour le décodage dy H264, le H265 je n'en parle même pas. Il y a du lag, de la pixellisation pour rattraper le retard, etc.
Plusieurs lecteurs ont été testés, VLC, MPV, IINA
Il est sous Big Sur, fresh install, initialement 11.0.5 mise à jour vers 11.1 hier mais j'avais déjà le problème avant.
Quand j'étais sous Catalina je ne pourrais pas dire si le problème existait ou pas je ne lisais pas de vidéos et je m'en suis peu servi.
J'ai lancé etrecheck mais a priori rien d'anormal, c'est à n'y rien comprendre.
Quelqu'un aurait une piste ?

Stéphane.
 

MrTom

Membre d’élite
Club MacG
6 Août 2019
2 010
473
38
Hello,

Est-ce que tu peux nous fournir le rapport en question en le mettant sur Pastebin.com ?
Aussi, est-ce que tu as un exemple de video, que j'essaie sur le mien ?
 

le_s

Membre junior
21 Mars 2015
26
4
47
Bonjour,

Merci pour ta réponse :)
Voici le pastebin.
Un extrait il faut que je me débrouille pour en couper un bout. Au pire je peux te donner un lien (vers mon serveur privé donc sans risque mais en MP) pour aller downloader la vidéo en entier. Je t'avouerai que ça a ma préférence, autant sur Windows ça ne me poserais pas de souci, autant sur le mac je dois avouer être un newbie :-/

Merci encore :)
 

MrTom

Membre d’élite
Club MacG
6 Août 2019
2 010
473
38
Hello,

Tu peux faire un partage de fichier sur iCloud aussi.
En effet rien de concluant dans ton rapport.

Est-ce que tu lis ces vidéos depuis le SSD interne de ton Mac ou depuis un serveur externe ?
 

le_s

Membre junior
21 Mars 2015
26
4
47
Je suis un pro de l'IT mais pas du mac, si ça peut t'aider dans tes questions ;)
Oui j'ai essayé à partir des deux supports, en lecture directe sur l'écran du laptop ou HDMI, même problème, que je n'ai pas sur mon vieil ultrabook qui rame par contre sur le H265, normal il est de 2012.
Mon problème c'est de pousser une tel volume de données sur icloud, je n'ai qu'un ADSL et 5GB c'est pas gagné en upload, par contre je peux l'envoyer sur un google drive, j'ai une connexion entre mon serveur et mon drive si ça te satisfait :)
J'en profite pour signaler que j'ai homebrew installé sur le machine au cas où
 

MrTom

Membre d’élite
Club MacG
6 Août 2019
2 010
473
38
yes on fait comme ça t'arrange.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 638
535
Bonjour,

Avec la fonction élagage de QuickTime (Menu Edition/Elaguer, sans ré-encodage), tu peux aussi ne laisser que quelques secondes de vidéo que tu peux uploader facilement…

Quel est le container de tes vidéos et quelle en est l'origine ?

Pourrais-tu simplement en ouvrir une avec QuickTime, faire Cmd-I et donner une capture d'écran des 3 rubriques déployées ?

Encore mieux, passer ta vidéo sur MediaInfo, onglet texte, et nous mettre une capture d'écran de l'analyse ?

Comment se passe la lecture QuickTime sur une cession invité ?
 

le_s

Membre junior
21 Mars 2015
26
4
47
Voici la sortie mediainfo :)

En fait la pixellisation n'est pas permanente, la lecture d'un extrait pour moi n'est pas suffisante. J'ai une pixellisation systématique tout au début dans les 20 premières secondes, ensuite régulièrement, comme si ça prenait du retard, ça pixellise, la son reste ok puis hop ça saute et ça redevient bien. Quand je cherche à sauter plus loin dans le film ça plante carrément. Sur mon ultrabook aucun souci.
Par contre je ne mettrai pas le lien drive directement dans le topic j'imagine que vous comprendrez pourquoi :)
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 638
535
A part la définition peu courante (2,4/1 soit deux 16:9 côte à côte), ta vidéo n'a rien de problématique pour la lecture avec ses 29,97 ips, en 4:2:0 8 bits MPEG4.
Il est donc anormal que ton MBP de 2019 ne le lise pas quel que soit le lecteur lisant le mkv utilisé, y.c VLC.
De quelle carte graphique disposes-tu ?
As-tu essayé de lire depuis une cession invité ?
 

le_s

Membre junior
21 Mars 2015
26
4
47
Session invité pareil.
Du coup j'ai retesté sur mon ultrabook j'ai eu aussi de la pixellisation cette fois, ça me rend dingue surtout que j'ai eu le problème sur plein de vidéos. Je vais tout reprendre à zéro et revenir, pas envie de vous faire perdre du temps.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 638
535
Il y a quand même un problème dans cette vidéo, c'est la faiblesse du débit vidéo. 5,48 Mbps en mpeg4 pour du 1280*536, c'est extrêmement faible, et c'est peut-être la cause de la pixellisation observée et des dérèglements en lecture.
Est-ce toi qui l'a compressée à ce point ?
 

le_s

Membre junior
21 Mars 2015
26
4
47
Est-ce toi qui l'a compressée à ce point ?
Non du tout, c'est du DL, mais ce qui me paraît bizarre que ça n'est pas la seule avec j'ai des soucis et c'est bien la première fois surtout qu'aucun des autres utilisateur ne s'en plaint. C'est extrêmement curieux, je vais creuser avec d'autres vidéos, notamment H265 où là malheureusement je vais avoir du mal à avoir un point de comparaison chez moi car mon ultrabook ne peut pas lire. Je testerai demain au travail :)
 
Dernière édition par un modérateur:

le_s

Membre junior
21 Mars 2015
26
4
47
Absolument extraordinaire, j'en prends une autre en MPEG2 en me disant je vais regarder ça tranquillement et penser à autre chose, toutes les 30 secondes gros lag, le son reste ok mais la vidéo s'arrête 2 à 3 secondes et repart en accéléré pour rattraper son retard.
Voici le NFO
Si vous ne voyez aucune explication et vu ce qu'il y a dessus je vais réinstaller l'OS à partir d'un support externe, immédiatement installer un lecteur et re-tester :rolleyes:
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 638
535
Tout cela n'est évidemment pas normal.
Pourrais-tu avec Avidemux sélectionner quelques minutes de l'une de tes vidéos en enregistrant sortie video 'Copy' et sortie audio 'Copy' de façon à ne pas ré-encoder.
Puis uploader sur WeTransfer (pas nécessaire de s'enregistrer) et nous donner le lien de téléchargement.
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 638
535
Evidemment, ça se lit sans aucune difficulté chez moi…

Tu dois avoir un sacré problème puisque ça ne fonctionne chez toi ni sur ton compte utilisateur ni sur une cession invité.

Quand même surprenant avec une installation Big Sur depuis hier ! Tu sais désormais ce qu'il te reste à faire…:)

J'ai un iMac puissant mais ce genre de vidéo doit se lire sur la plus faible des machines, surtout en mpeg2. Ce pourrait être différent en HEVC mais avec une machine comme la tienne, cela ne devrait pas poser plus de problème…

Capture d’écran 2021-01-03 à 17.44.38.jpg
 
Dernière édition par un modérateur:

le_s

Membre junior
21 Mars 2015
26
4
47
Nous sommes bien d'accord, à aucun moment ça ne devrait poser de souci, si un macbook pro de 2019 ne sait pas lire des vidéos même HEVC 4k Apple doit changer de métier xD
Je réinstalle, le DL est en cours et je reviens dire comment ça se passe

Merci :)
 

JLB21

Vétéran
Club MacG
22 Novembre 2007
5 638
535
Apple doit changer de métier…:D:D:D

Surtout quand on voit que les iPhone enregistrent par défaut en UHD HEVC à 60 ips, voir pour les derniers en RAW…
 

MrTom

Membre d’élite
Club MacG
6 Août 2019
2 010
473
38
Hello,

Non chez moi (sur l'iMac) ça saute au bout d'une minute (j'ai de la micro coupure), le son coupe en même temps également.
Je n'ose même pas sortir le MBP...

EDIT : saute toujours au même moment. N'y aurait-il pas un problème aussi avec le fichier ?